16:08:05 <jgriffith> #startmeeting cinder
16:08:05 <openstack> Meeting started Wed Sep 12 16:08:05 2012 UTC. The chair is jgriffith. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:08:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:08:07 <openstack> The meeting name has been set to 'cinder'
16:08:11 <jgriffith> Hey winston-d
16:08:19 <jgriffith> Sorry I'm a bit late folks
16:08:25 <clayg> hey boss!
16:08:29 <jgriffith> Lost track of time this morning
16:08:36 <clayg> it's been one of those mornings...
16:08:48 <jgriffith> *boss* makes me chuckle every time
16:08:56 <DuncanT> Hey
16:09:02 <jgriffith> DuncanT: Hello!!!!
16:09:11 <jgriffith> Alright, let's get started...
16:09:17 <jgriffith> #topic RC1 status
16:09:37 <jgriffith> We're shooting for tomorrow or Friday to cut cinder RC1
16:09:58 <jgriffith> I'm thinking it's going to be closer to Friday morning, but I'm hopeful Fri morning at latest
16:10:20 <jgriffith> Most everything that's in the pipeline now should make it if you guys can help out with reviews
16:10:40 <jgriffith> The only one that I don't think is going to go is:
16:10:54 * clayg mumbles something about it better not be mine
16:10:55 <jgriffith> the rename option clayg submitted
16:10:59 <clayg> damnit!
16:11:01 * jgriffith runs and hides
16:11:11 <jgriffith> clayg: Sorry clayg!
16:11:18 <clayg> well so nova marked the bug as importance medium when I tagged it to that project?
16:11:39 <clayg> and since it's an additive change I *really* don't see why this can't be something that works in cinder but not in nova volumes?
16:12:05 <jgriffith> clayg: well, that's a whole seperate topic and I don't necessarily disagree with you
16:12:12 <clayg> *I* obviously think it's a gap in the api and should be considered a bug, but regardless it'll be helpful to folks that are stuck on folsom for the next six months if it gets in
16:12:28 <resker> jgriffith... I don't think you're supposed to defer stuff until after the PTL election closes down ;-)
16:12:44 <jgriffith> resker: I actually didn't *defer* it myself
16:12:52 <clayg> heh, jgriffith but really? who said that you can have anything in cinder if it can't get back into nova?
16:12:57 <resker> I know... 'tis a joke
16:13:04 <jgriffith> resker: :)
16:13:12 <clayg> I thought the goal was to just not BREAK nova-volumes
16:13:40 <jgriffith> clayg: No, unfortunately that was changed after the huge email chain a couple months ago
16:14:04 <jgriffith> clayg: After the outcry from certain individuals it was decided that nova-vol and cinder had to be in sync
16:14:18 <jgriffith> clayg: It's been determintal to say the least
16:14:21 <jgriffith> IMO
16:14:38 <clayg> I think that "in sync" could be grety - but I digress
16:14:41 <clayg> *grey
16:14:50 <jgriffith> clayg: :)
16:14:59 <clayg> my real question is does cinder want it's initial api to support updates or not?
16:15:14 <jgriffith> clayg: So if you have a good case then present it to ttx nova core
16:15:36 <jgriffith> clayg: That's another thorny issue for me
16:15:40 <clayg> well I think they will agree it has to be in cinder first, and I think that's a good point
16:16:03 <jgriffith> clayg: Cinder first is not a problem, I'll take the change as I said earlier
16:16:18 <jgriffith> clayg: I only won't take it if nova won't take it... that's all
16:16:28 <zykes-> what meeting is now ?
16:16:28 <jgriffith> I'm neutral
16:16:34 <jgriffith> zykes-: cinder/volumes
16:16:35 <clayg> ok, so can anyone else look at https://review.openstack.org/#/c/12067/
16:16:46 <zykes-> Question since you're all here ?
16:16:57 <jgriffith> zykes-: maybe at the end of the meeting?
16:17:00 <clayg> well since they've tagged the bug I'm guessing they'd like to see it fixed, and the nova side is ready to go
16:17:03 <zykes-> Ok, nice nice
16:17:07 <clayg> jgriffith: thanks, i'll keep working on it
16:17:09 <jgriffith> alright...
16:17:16 <DuncanT> clayg, I'm quite happy with that change
16:17:31 <jgriffith> #action clayg sort out change for nova and let us know
16:17:36 <DuncanT> I've just failed to submit my review. Sorry
16:17:57 <clayg> DuncanT: if you could plus 1 on it, I think i can explain to ttx/nova-core that cinder wants to merge this if the nova side can land
16:18:08 <DuncanT> clayg: Done
16:18:13 <jgriffith> So we'll say that one is still under consideration
16:18:15 * clayg hugs EVERYONE!
16:18:19 <jgriffith> My next question....
16:18:36 <jgriffith> Is there anything anybody has squirled away they were going to spring on me today or tomorrow?
16:18:42 <jgriffith> Other than critical bugs?
16:18:49 <jgriffith> that haven't been found yet :)
16:19:01 * jgriffith is holding his breath
16:19:08 <DuncanT> I've got a slight change to Josh's driver addition
16:19:17 <DuncanT> But I've screwed up my unit tests
16:19:40 <jgriffith> DuncanT: On Josh's already submitted version?
16:19:41 <DuncanT> If it doesn't make it, I won't cry, it /could/ wait til 'g' but it would be nice
16:19:51 <jgriffith> ie already merged?
16:20:04 <jgriffith> What's the addition?
16:20:05 <DuncanT> jgriffith: Yeah... his version is no use if you use provider location/auth
16:20:28 <clayg> i'm confused aboutwhat's going on with this api validation/openstack.common massive fix
16:20:37 <DuncanT> So I changed return boolean to return db update, same as the other create methods, and raise an exception if it didn't work
16:20:58 <jgriffith> DuncanT: Ok, file a bug against cinder and nova for it and submit ASAP
16:21:03 <clayg> from mark... dunno if anyone else had been looking at it... I think he's doing the work on most projects
16:21:08 <DuncanT> jgriffith: Will do, cheers
16:21:19 <jgriffith> clayg: yeah....
16:21:40 <jgriffith> So, that exercise is trying to catch up cinder to all of the changes that have been made in nova and specifically common
16:22:07 <clayg> jgriffith: are you working on 'stuck in deleting (vol-manager restart)' and 'stuck in attaching'?
16:22:33 <clayg> oic, ok well, so that's on the radar, very good
16:22:36 <jgriffith> clayg: I'm hoping to get back to it. I've been messing with the snapshot delete issue again
16:22:45 <clayg> yeah i saw the revert :(
16:22:49 <jgriffith> Saving that for it's own topic
16:22:50 <jgriffith> :)
16:23:17 <jgriffith> Anybody else have anything that they're head will explode if they don't get it in RC1
16:23:25 <jgriffith> s/they're/their/
16:23:47 <jgriffith> yeah... change the topic quick!
16:23:54 <jgriffith> #topic snapshot-delete
16:23:58 <clayg> does ack :\
16:24:01 <resker> bswartz isn't here, but I think we're good... I'll ask him to get in touch if he disagrees
16:24:20 <jgriffith> resker: Send me a note and let me know if something comes up
16:24:26 <resker> will do... thanks
16:24:40 <jgriffith> I think everything he had was in line at F3 timeframe so should be good
16:24:46 <resker> yep
16:24:48 <jgriffith> ahead of schedule :)
16:24:57 <jgriffith> So on the delete
16:25:17 <jgriffith> The work around of zeroing out on volume create was a valiant effort
16:25:29 <jgriffith> and for the most part it did skirt the issue
16:25:39 <jgriffith> There were some things I didn't like though....
16:25:54 <jgriffith> 1. We should get the kernel issue fixed
16:26:17 <jgriffith> 2. The hang although extermely rare in this case did pop up in a loop test of 100 runs
16:26:35 <jgriffith> 3. volumes sit in creating state FOREVER and can't be used/mounted
16:26:45 <jgriffith> TBH 3 was the big issue in my mind
16:27:04 <jgriffith> Folks are used to being able to create/attach right away and I think this would cause serious complaints
16:27:24 <jgriffith> Also the other PTL's didn't like this work around :(
16:27:44 <jgriffith> So, we have a kernel bug logged against Ubuntu
16:27:59 <jgriffith> I've tested it on Fedora with kernel 3.4.4 and no problems
16:28:12 <jgriffith> I'm working on installing a new kernel on my ubuntu system just to verify
16:28:26 <jgriffith> then maybe the kernel guys can diff the versions or find a kernel patch to fix
16:28:43 <jgriffith> Any questions? Ideas?
16:28:45 <jgriffith> Anybody care?
16:28:56 <jgriffith> :)
16:29:12 <DuncanT> Not massively bothered personally since I don't use that storage backend
16:29:17 <jgriffith> :)
16:29:19 <winston-d> if it's a kernel bug, it is _not_ our bug
16:29:30 <DuncanT> Kernel fix would be nice but currently it means devstack can hang, no?
16:29:39 <jgriffith> winston-d: agreee... but it makes us NOT work which is bad
16:29:43 <DuncanT> Hanging devstack is probably a bad thing
16:29:59 <jgriffith> DuncanT: Worse than that it hangs the kernel completely on that system
16:30:02 <clayg> jgriffith: can you like the ubuntu bug?
16:30:31 <jgriffith> clayg: It's linked to the original bug... lemme grab the LP id
16:30:38 <clayg> I was trolling all the lp bugs related to this issue and there was some vauage references to ML threads about maybe an issue with clustered lvm (clvm) - but I"m not sure I really see the bug
16:31:05 <jgriffith> https://bugs.launchpad.net/cinder/+bug/1023755
16:31:07 <clayg> writing a bunch of zeros to the snapshot meta device is just going to be slow and eventually lead to blkio errors
16:31:07 <uvirtbot> Launchpad bug 1023755 in nova "Unable to delete the volume snapshot" [Critical,In progress]
16:31:43 <clayg> so yeah, the cinder bug, where's the ubuntu bug?
16:32:11 <jgriffith> clayg: linux(Ubuntu) was added on top of it
16:32:29 <jgriffith> This is how the cannonical guys chose to deal with it so... :)
16:32:40 <clayg> oic, undecided/unassigned :\
16:32:48 <jgriffith> If I get some more solid info today I'll file another one against them only
16:32:56 <jgriffith> clayg: Yeah... not good
16:33:12 <jgriffith> Honestly I don't know what we can do other than document the issue and move on
16:33:13 <clayg> I think they'll probably want to see the issue reproduced outside of openstack?
16:33:24 <jgriffith> clayg: Yep, that's what I'm working on today
16:33:25 <clayg> jgriffith: fine by me, don't use this driver
16:33:29 <jgriffith> :)
16:33:54 <jgriffith> Ok... anything else or shall we try and forget this one for a few minutes :)
16:34:14 * jgriffith is moving onward...
16:34:19 <jgriffith> #topic reviews
16:34:26 <jgriffith> My favorite subject :)
16:34:45 <jgriffith> Please go here: https://review.openstack.org/#/q/status:open+cinder,n,z
16:35:01 <jgriffith> And pick some reviews and enjoy :)
16:35:11 <DuncanT> Thousands of the little buggers again...
16:35:19 <jgriffith> Specifically I have a few that haven't been looked at by anyone :(
16:35:35 <jgriffith> DuncanT: Yes, it's been a productive week again :)
16:35:50 <jgriffith> Many of them are small changes though, so it's not so bad
16:36:05 <jgriffith> Some I can push through on my own but I don't like doing that
16:36:21 <jgriffith> And I definitely can't do that with ones that I comitted... so please help out if you can
16:36:33 <DuncanT> Ok, will worth though a few this evening and carry on in the morning
16:36:39 <jgriffith> :)
16:36:53 <clayg> yeah I can do that today, I want to look at quota's anyway
16:36:59 <jgriffith> Like I said last week to somebody... he who has the most reviews gets free beer from me at the summit ;)
16:37:08 <clayg> poor Vincent just keeps pushing that iscsi supoort :(
16:37:32 <clayg> oh yeah! where's the leader board? +2 ALL THE THINGS!
16:37:48 <jgriffith> clayg: yeah, but I think he and are on the same page, he just wants to keep the patch alive so when we're ready to push to G it'll be set
16:38:00 <clayg> oic, very good then
16:38:24 <jgriffith> So that's about all I have I think...
16:38:31 <jgriffith> Reviews and testing!
16:38:46 <jgriffith> Remember, anything that goes in Cinder has to go in Nova :(
16:38:49 <clayg> oh nice so there _is_ a quota management api?
16:39:03 <jgriffith> clayg: Yep, been hanging in there for a while
16:39:23 <zykes-> does Cinder work with XenServer ?
16:39:30 <jgriffith> clayg: I was crushed after how long it took to get that thing to work and it never got a review :(
16:39:42 <jgriffith> zykes-: parts... that brings up a new topic :)
16:39:48 <jgriffith> #topic xen
16:40:01 <zykes-> :/
16:40:11 <winston-d> I've just submit the patch for scheduling based on volume type. if you have spare time and want to see what's been messed-up by me, you might want to take a look at that.
16:40:16 <jgriffith> So I'm not a xen expert.. I was hoping renuka would be around but not here this week
16:41:15 <winston-d> i think as long as cinder is in-synch with nova-volume, it should work with xenserver.
16:41:20 <jgriffith> winston-d: :) Not messed up *fixed*
16:41:31 <jgriffith> So... sorry, got pulled away
16:41:35 <jgriffith> Here's the deal
16:41:42 <clayg> i don't know how I missed it
16:41:58 <jgriffith> If you're talking xen using cinder/volumes as it did in nova it works as always
16:42:10 <jgriffith> If you're talking the various xen-sm layers that's a different story
16:42:35 <jgriffith> renuka made some major changes to nova but not to cinder
16:42:49 <jgriffith> She was of the opinon that she wouldn't make those changes to cinder
16:42:50 <ogelbukh> winston-d: is this change specific to xensm api?
16:42:52 <jgriffith> clayg: don't say a thing
16:42:53 <jgriffith> :)
16:43:08 <winston-d> ogelbukh, no, of course not.
16:43:24 <jgriffith> ogelbukh: that would've been too easy
16:43:31 <clayg> no one uses xensm, best i can tell its a wip
16:43:39 <zykes-> xensm ?
16:43:46 <jgriffith> clayg: that's what renukas logic was :)
16:43:59 <jgriffith> zykes-: xen storage manager
16:44:05 <ogelbukh> winston-d: could you please share a link to that change?
16:44:19 <clayg> i'll get hyper-v'd from nova at some point, and citrix will try to hack it into cinder
16:44:35 <zykes-> clayg: hyper-v'd ?
16:45:27 <winston-d> ogelbukh, sure. https://review.openstack.org/#/c/12886/
16:45:50 <ogelbukh> thanks!
16:45:53 <clayg> zykes-: wasn't it hyper-v that got ripped out from nova last release for not working? (I know it recently got readded)
16:45:53 <DuncanT> winston-d: I don't have permission to view that
16:46:08 <ogelbukh> oh, me too
16:46:12 <zykes-> yeh
16:46:13 <winston-d> well, let me re-submit it again.
16:46:14 <jgriffith> clayg: yes, correct :)
16:47:00 <jgriffith> #topic open discussion
16:47:07 <ogelbukh> winston-d: thanks for i
16:47:08 <ogelbukh> t
16:47:21 <jgriffith> Anybody have anything they want to bring up real quick?
16:47:25 <clayg> somehow i get an app error clicking on that link - what change is this?
16:47:26 <resker> Hey, jgriffith, FYI, just replied to your PTL candidacy mail on the wider openstack list. Had meant to send the questions earlier...
16:47:48 <zykes-> so will cinder work fine with xen ?
16:47:58 <resker> We've a bunch of stuff queued up to submit against Grizzly once it becomes available.
16:48:06 <clayg> zykes-: yes, raw iscsi sr's work fine
16:48:08 <jgriffith> resker: Thanks... I'll check it out ad get a response out to you shortly
16:48:09 <ogelbukh> quick question: is there a blueprint to port FilterScheduler to Cinder/Nova volume in folsom or Grizzly?
16:48:13 <resker> cool, thanks
16:48:14 <jgriffith> resker: cool!
16:48:16 <zykes-> clayg: what others are there ?
16:48:25 <clayg> rdb, ceph, xensm
16:48:43 <resker> btw, when do we think grizzly will open up?
16:48:56 <winston-d> ogelbukh, DuncanT please check again.
16:49:04 <zykes-> clayg: can''t ceph with xen ?
16:49:06 <clayg> ogelbukh: I think someone was working on a types scheduler, I think we would piggy back on that with something *like* filter scheduler
16:49:07 <ogelbukh> oh
16:49:17 <ogelbukh> actually, it's winston-d's change
16:49:21 <ogelbukh> :)
16:49:24 <zykes-> jgriffith: my question was will there be multi volume backend in Folsom ?
16:49:32 <clayg> zykes-: never tried, maybe you have to get the ceph stuff plugged into dom0 - maybe that works?
16:49:35 <jgriffith> resker: depends on how the rest of this week and next go
16:49:36 <resker> I thought that got deferred.
16:49:42 <jgriffith> zykes-: no
16:49:53 <jgriffith> :(
16:49:54 <zykes-> jgriffith: so sad :(
16:49:59 <jgriffith> zykes-: agreed
16:50:05 <zykes-> jgriffith: reason beeing ?
16:50:19 <DuncanT> winston-d: That's better, cheers
16:50:24 <jgriffith> zykes-: long story
16:50:46 <clayg> is it really that long? I haven't seen a purposed impl
16:50:49 <jgriffith> zykes-: I'd like to have a summit sesssion dedicated to this topic
16:50:54 <winston-d> zykes-, actually you can have multiple backends, but the problem is scheduler (for now) can't tell the difference between them.
16:51:20 <jgriffith> winston-d: yes, sorry... didn't mean to leave out the work you've been doing on that :)
16:51:21 <clayg> deployers can write their own scheduler...
16:51:43 <resker> jgriffith: agreed a session is in order...
16:51:48 <jgriffith> zykes-: the problem with that method is it means a physical/seperate cinder node for each backend
16:51:52 <zykes-> jgriffith: why's it such a big deal ? I mean it makes sense to have that..
16:52:14 <zykes-> jgriffith: wouldn't it be like you have in "Quantum" like flavours or similar ?
16:52:26 <jgriffith> zykes-: There is disagreeement in whether it's necessary and how it should be implemented
16:52:37 <clayg> Quantum supports flavours?!
16:52:45 <jgriffith> zykes-: You're pinging the wrong guy... it was something I really wanted in Folsom
16:52:47 <zykes-> clayg: using the MetaPlugin yes.
16:52:53 <jgriffith> So... speaking of summit
16:52:59 <DuncanT> zykes-: Read the logs for teh last four or so weeks
16:53:02 <jgriffith> If you have session proposals get them in!
16:53:09 <jgriffith> DuncanT: :)
16:53:13 <zykes-> DuncanT: no thank you .
16:53:21 <clayg> roflmao
16:53:29 <winston-d> :)
16:53:31 <zykes-> But yes, you can mix multi-agents for Quantum using the MetaPlugin
16:53:31 <zykes-> :)
16:53:37 <zykes-> or "plugins" if you will
16:53:44 <ogelbukh> then another small question
16:53:45 <jgriffith> Also.. just my own personal pitch, I have a proposal for the conference... if you want please vote for it :)
16:53:55 <clayg> can we vote already?!
16:54:00 <winston-d> jgriffith, already done
16:54:01 <ogelbukh> is scheduler_hint supported in this change?
16:54:06 <DuncanT> clayg: Yes
16:54:07 <jgriffith> clayg: for conference stuff yes
16:54:11 <winston-d> ogelbukh, yes, i think so
16:54:19 <ogelbukh> great
16:54:26 <zykes-> DuncanT: can you summarize why it didn't get in in short ? ;)
16:54:31 <clayg> wait, is this the right site to submit too -> http://summit.openstack.org/
16:54:38 <jgriffith> zykes-: I'll catch up with you after the meeting if you'd like
16:54:44 <ogelbukh> winston-d: yes, now I can see
16:54:58 <jgriffith> I need to run to a meeting... but will be back in 1/2 hour or so
16:55:05 <zykes-> jgriffith: yes please :)
16:55:11 <zykes-> ping me then :)
16:55:49 <clayg> where should I got to vote on purposed sessions? I don't see anything from jgriff on summit.openstack.org
16:56:07 <winston-d> so guys, please give me comments, especially on do we need a standard format for driver/backend to report their capabilities.
16:56:46 <resker> clayg: the summit.openstack.org is for the design summit track
16:57:10 <clayg> ummm... isn't that what we want?
16:57:19 <jgriffith> http://www.openstack.org/summit/san-diego-2012/vote-for-speakers/
16:57:26 <jgriffith> I'm talking conf side
16:57:28 <resker> clayg: the general session speaking slots can be voted on here:
16:57:29 <resker> http://openstack.org/summit/san-diego-2012/vote-for-speakers/
16:57:35 <jgriffith> resker: :)
16:57:39 <resker> sorry... jgriffith quicker on the draw
16:57:48 <jgriffith> resker: Nice work :)
16:58:12 <jgriffith> Ok...
16:58:20 <zykes-> For me (As a operations / developer) person I can say surely that there's many cases where having multiple different storage techs available in the same cluster can be __really__ handy just to state the fact.
16:58:33 <jgriffith> 1. reviews, reviews, reviews
16:58:40 <jgriffith> 2. propose summit topics
16:58:42 <resker> zykes: run multiple Cinder instances, no?
16:58:45 <jgriffith> 3. test
16:58:49 <zykes-> resker: run 1 instance.
16:59:03 <DuncanT> zykes-: There's plenty of support for the concept, just not an agreement on how it should work
16:59:10 <jgriffith> zykes-: Nobody in this group is going to argue against that
16:59:14 <resker> zykes: this seems like a debate best hashed out in a summit session!
16:59:22 <jgriffith> zykes-: I don't know how much more clearly I have to say that we AGREE with you
16:59:31 <clayg> I think it would be great to have working to code to discuss at the summit
16:59:33 <zykes-> resker: will you fly me over ? :)
17:00:01 <jgriffith> Alright, we seem to have lost productivity and I need to get going
17:00:08 <jgriffith> Thank you very much to EVERYONE
17:00:12 <winston-d> clayg, I'll make sure it works before summit, please help review: https://review.openstack.org/#/c/12886/
17:00:17 <jgriffith> Not only for the participation in this weeks meeting...
17:00:19 <clayg> will do
17:00:27 <winston-d> thx
17:00:29 <jgriffith> But all of the hard work the past couple of weeks!!
17:00:42 <jgriffith> #end meeting
17:00:47 <jgriffith> #endmeeting