16:00:43 <jgriffith> #startmeeting cinder
16:00:44 <openstack> Meeting started Wed Mar  6 16:00:43 2013 UTC.  The chair is jgriffith. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:47 <openstack> The meeting name has been set to 'cinder'
16:01:14 <jgriffith> Hmmm... anybody here this morning?
16:01:20 <bvibhu> Hi
16:01:24 <jgallard> hi!
16:01:29 <smulcahy> hi
16:01:30 <vincent_hou> y
16:01:42 <jgriffith> There's some folks... morning guys
16:01:50 <thingee> o/
16:02:08 <jgriffith> Pretty short agenda today
16:02:20 <jgriffith> might be even shorter without some of the folks being around
16:02:28 <guitarzan> morning!
16:02:34 <JM1> hi
16:02:34 <jgriffith> heyhey
16:02:43 <jgriffith> alright, now we're rolling, let's get started
16:02:51 <jgriffith> #topic RC1 status updates
16:03:14 <jgriffith> I'm hoping to cut next week unless folks see a problem getting their fixes in
16:03:31 <jgriffith> Or of course somebody finds something horrible between now and then
16:03:39 <jgriffith> any objections on that?
16:04:00 <jgriffith> BTW: https://launchpad.net/cinder/+milestone/grizzly-rc1
16:04:34 <jgriffith> Take a look and if you have something new let me know, or if you have something that should be targetted and isn't let me know that as well
16:04:35 <bswartz> hey sorry I'm late
16:04:41 <jgriffith> bswartz: no worries
16:04:42 <winston-d> i see john's got 6 bug assigned. :)
16:04:54 <jgriffith> winston-d: :)
16:04:56 <kmartin> jgriffith: It is too late to get the LeftHand driver fixes into RC1
16:05:04 <jgriffith> kmartin: nope
16:05:27 <jgriffith> kmartin: I am not super strict about targetting
16:05:45 <jgriffith> kmartin: but we should probably update those bugs with RC1 tags
16:05:57 <kmartin> ok, I 'll have hemna send bug to you today
16:06:04 <jgriffith> kmartin: do you expect to get them in this week?
16:06:10 <kmartin> yes
16:06:17 <jgriffith> kmartin: we should be just fine then
16:06:46 <jgriffith> winston-d: that reminds me, do you want https://bugs.launchpad.net/cinder/+bug/1131322
16:06:48 <uvirtbot> Launchpad bug 1131322 in cinder "Cinder service not logging exceptions from stevedore library" [High,Confirmed]
16:07:04 <winston-d> jgriffith: yes, please
16:07:11 <jgriffith> winston-d: All yours :)
16:07:13 <matelakat> jgriffith: Can we have this in rc1 as well? https://bugs.launchpad.net/cinder/+bug/1131291
16:07:15 <uvirtbot> Launchpad bug 1131291 in cinder "XenAPINFS: Volume always uploaded as vhd/ovf" [Undecided,Fix committed]
16:07:15 <smulcahy> jgriffith: https://bugs.launchpad.net/cinder/+bug/1136174 has been fixed aswell so not sure if you want to target that too?
16:07:17 <uvirtbot> Launchpad bug 1136174 in cinder "cinder-backup doesn't use/check metadata version during restore" [Undecided,Fix committed]
16:07:21 <jgriffith> winston-d: do you think we can get that done this week?
16:07:27 <winston-d> jgriffith: but if it requires something in olso, it might not make it to RC1
16:07:59 <jgriffith> matelakat: committed ones don't need much persuasion frm me  :)
16:08:20 <jgriffith> smulcahy: I can if you'd like it for tracking/record keeping
16:08:35 <jgriffith> smulcahy: done
16:08:39 <winston-d> jgriffith: i'll try my best
16:08:44 <smulcahy> jgriffith: ta
16:08:45 <jgriffith> winston-d: I was afraid of that
16:08:57 <thingee> jgriffith: is there an update from j_king on https://bugs.launchpad.net/cinder/+bug/1087817 ?
16:08:58 <uvirtbot> Launchpad bug 1087817 in cinder "Update v2 with volume_type_id switch to uuid" [Medium,In progress]
16:09:00 <jgriffith> winston-d: Let me know if I need to work with Mark to try and get it in if you can get it proposed
16:09:08 <matelakat> jgriffith: So I don't need to take actions to get that to rc1, right (sorry, if this is a stupid q)
16:09:15 <winston-d> jgriffith: sure
16:09:43 <jgriffith> thingee: I've not heard back from him, I did ping him the other day on it
16:10:08 <thingee> I can do last minute work if needed there
16:10:10 <jgriffith> thingee: wonder if we should just reassign and fix it
16:10:12 <jgriffith> :)
16:10:16 <thingee> I'm sure he has it though
16:10:21 <jgriffith> thingee: alright, let's give him another day or so
16:10:26 <jgriffith> thingee: thanks!
16:10:36 <jgriffith> matelakat: nope, I already did it
16:10:50 <jgriffith> and just in case others are not sure how that works...
16:11:01 <jgriffith> basicly anything that's going in to trunk right now is going in to RC1
16:11:28 <matelakat> Oh, ok.
16:11:35 <jgriffith> The targetting exercise just makes sure we know what we have deemed as *required* for rc1
16:12:25 <jgriffith> Technically one could argue that everything that goes in should be targetted at this point
16:12:38 <jgriffith> but Cinder is a bit unique with it's heavy driver model :)
16:13:02 <jgriffith> Any folks having the chance to do some good testing lately?
16:13:43 <jgriffith> I'd like to see as many of us as possible start switching context to testing and documentation over the next few days if possible
16:14:11 <jgriffith> and grenade testing as well (Folsom to Grizzly upgrade testing)
16:14:42 <jgriffith> Well I see that was a popular topic :)
16:14:44 <matelakat> btw, I asked Anne About it, but is this the right place for the driver docs? #link http://docs.openstack.org/trunk/openstack-compute/admin/content/ch_volumes.html
16:15:17 <jgriffith> matelakat: it is for now, I have a todo item to create a "block storage" section and move all of that out of compute admin
16:15:47 <jgriffith> #action jgriffith get the doc formatting stuff figured out with Anne and done
16:16:19 <jgriffith> any other big questions/concerns for RC1?
16:16:51 <jgriffith> #topic core team status
16:17:11 <jgriffith> So we've talked about this before but always wait for the *next* mile marker
16:17:30 <jgriffith> I'd like to propose that we clean out the core list of cinder
16:17:52 <jgriffith> What I mean here is the folks that were set up in Folsom but never really participated
16:18:06 <bswartz> jgriffith: is this "core list" published somewhere?
16:18:14 <jgriffith> I'd like to trim that list and make some new nominations this week if possible
16:19:11 <jgriffith> bswartz: yes of course https://launchpad.net/~cinder-core
16:19:34 <bswartz> thanks
16:19:40 <annegentle> what do you all think about starting a storage admin manual?
16:19:51 <jgriffith> annegentle: :)
16:20:06 <annegentle> also I would like eyes on https://review.openstack.org/#/c/23625/
16:20:08 <DuncanT> Do we have a list of contributers and reviewers for the last few months? Seems like a good place to start for list trimming...
16:20:12 <jgriffith> annegentle: That's what I was getting at earlier
16:20:27 <annegentle> sorry I am late and the topic changed :)
16:20:33 <jgriffith> annegentle: no worries
16:20:45 <thingee> annegentle: I'll check it out :)
16:20:50 <jgriffith> I'll have a look at the review you pointed out as well
16:21:07 <jgriffith> annegentle: and I'd definitely like to have a block-storage admin guide
16:21:15 <jgriffith> move the cinder stuff out of the compute admin doc
16:21:22 <annegentle> jgriffith: yeah I think that's the way to go
16:21:32 <annegentle> jgriffith: anyone in mind to do the refactor?
16:21:47 <jgriffith> annegentle: unless somebody else steps up proabably me
16:22:07 <annegentle> jgriffith: there may be others interested I can recruit for you if you want :)
16:22:08 <thingee> annegentle, jgriffith: I did it for api, why not? :)
16:22:11 <jgriffith> I'd like this to be ASAP
16:22:15 <annegentle> thingee: woo! :)
16:22:25 <annegentle> thingee: yeah you have your plate full getting the API docs in shipshape
16:22:29 <jgriffith> thingee: You're the MAN!!!
16:22:56 <jgriffith> So let's do this
16:22:59 <thingee> those are at least in a review phase. I still have more I want to do with them, but in the mean time can focus on admin
16:23:14 <jgriffith> I'd like to have this refactor by next week at latest
16:23:35 <jgriffith> If anybody has some cycles and gets to it before I'll have a chance (which will be mid next week)
16:23:45 <jgriffith> Let folks know
16:24:00 <jgriffith> We'll open a docs bug for it and target it so folks will know if it's picked up active etc
16:24:08 <jgriffith> annegentle: thingee sound good?
16:24:12 <annegentle> jgriffith: sounds jus tright
16:24:15 <annegentle> just right even
16:24:18 <jgriffith> coolness
16:24:23 <thingee> sounds good
16:24:34 <bswartz> jgriffith: is there any officially organized group of "cinder team members" who are not not in the core team but more involved than your average Joe on the street?
16:24:37 <jgriffith> thingee: if you've got the band-width that's awesome by me :)
16:24:40 <thingee> I don't have anything planned atm, so I'm fine with it
16:24:45 <jgriffith> bswartz: nope
16:24:59 <jgriffith> bswartz: DuncanT to that point searches in gerrit are the answer
16:25:28 <winston-d> jgriffith: i'll see if i can provide you some review numbers tomorrow
16:25:32 <DuncanT> jgriffith: I'll try to produce some stats if you want...
16:25:45 <DuncanT> (or winston-d can beat me to it... I'm easy ;-) )
16:26:01 <winston-d> DuncanT: :)
16:26:07 <jgriffith> winston-d: oh, cool  I was going to be less formal and do it ad-hoc
16:26:20 <jgriffith> winston-d: however the stats would be good for *new* core nominees
16:26:32 <bswartz> jgriffith: is there are difference between the "cinder core" team and the set of people who are "core approvers" (can +2 stuff)?
16:26:46 <jgriffith> bswartz: nope, they're one in the same
16:26:57 <bswartz> okay
16:27:34 <jgriffith> anybody have anything else on core team, or docs?
16:27:34 <kmartin> jgriffith: Regarding docs, will they take changes all the way up to the end of the release or are the docs connected to the RC releases as well
16:27:52 <jgriffith> kmartin: docs we have more flexibility there
16:28:16 <jgriffith> but we've procrastinated before and we always seem to run out of time
16:28:25 <annegentle> kmartin: right. We take a look at the bugs and figure out if the docs are releasable
16:28:38 <kmartin> ok we have doc person that wants to be a OpenStack contributor, so he is working though that process
16:28:39 <annegentle> kmartin: it's that balancing act between "will this answer questions or cause more questions"
16:28:48 <jgriffith> kmartin: NICE!
16:29:51 <jgriffith> alright, folks think about if you know of somebody that you think should be core, or if you want to nominate somebody (even yourself) and let me know
16:29:55 <kmartin> goal is to get the changes in the end on next week
16:30:01 <bswartz> regarding the core team -- I find the idea of a 2-tier core team structure appealing
16:30:38 <jgriffith> bswartz: I'm not really interested in changing the OpenStack management/organization structure but I'm listening...
16:31:10 <jgriffith> bswartz: what are you proposing?
16:31:37 <bswartz> well I sympathize with the desire to keep the team small, and weed out non-participators, but I think it's good to have a wider group of people who are incentivised to be online answering questions and participating in code reviews, etc
16:31:58 <jgriffith> bswartz: Actually that's what *core* is supposed to be
16:32:28 <jgriffith> bswartz: our team is rather small because our consistent participation until the past couple of months has been relatively minimal
16:33:02 <bswartz> I guess I worry that people who don't make the cut for the "core team" won't feel any incentive to contribute
16:33:05 <jgriffith> bswartz: and everyone so here's my metric...
16:33:15 <jgriffith> What I've been looking at the past week is this:
16:33:29 <jgriffith> 1. People that have contributed code to the core cinder project this cycle
16:33:39 <jgriffith> 2. People that have reviewed code
16:33:55 <jgriffith> 3. People that participate in IRC (including this meeting)
16:34:56 <bswartz> maybe your definition of core team includes my notion of both tiers or participation
16:35:04 <jgriffith> bswartz: perhaps
16:35:16 <jgriffith> Also bear in mind core definition is an OpenStack wide policy
16:35:18 <bswartz> I just wanted to throw it out there -- I haven't though this through fully
16:35:18 <jgriffith> https://wiki.openstack.org/wiki/Governance/Approved/CoreDevProcess
16:35:30 <bswartz> thought*
16:36:01 <jgriffith> bswartz: believe me, I'm all for having more core team members!
16:36:19 <jgriffith> and I plan to nominate at least 3 folks later today
16:36:37 <jgriffith> bswartz: and if you'd like to step up and take on the responsibilities let me know
16:36:56 <dachary> as an occasional contributor to various free software, I would be very motivated to be on a separate list. I understand the separation between "core" and "contributor"
16:37:07 <dachary> my 2ct ;-)
16:37:17 <jgriffith> dachary: I'm confused, we already have this
16:37:26 <jgriffith> dachary: bswartz So we have contributors
16:37:38 <jgriffith> contributors can review, provide input, do anything they want
16:37:44 <dachary> jgriffith: yes, I was echoing on the "no motivation if not in the core" ;-)
16:37:54 <jgriffith> core just means you're especially active and responsible for +2/A authority
16:38:09 <jgriffith> dachary: Ahh... ok, :)
16:38:11 <jgriffith> thanks
16:38:46 <jgriffith> My thought is if you're not motivated when you're not core, you won't be much of a core contributor anyway
16:38:53 <jgriffith> but I digress
16:39:16 <jgriffith> bswartz: If you have some structuring ideas we can definitely talk through them and see if there's a better system
16:39:55 <jgriffith> anything else regarding core?
16:40:12 <jgriffith> #topic summit session
16:40:44 <thingee> http://summit.openstack.org
16:40:54 <winston-d> jgriffith: when is deadline for submitting session for summit?
16:40:57 <dachary> #link http://summit.openstack.org/cfp/details/38
16:41:23 <jgriffith> winston-d: I actually don't have an answer on that for you
16:41:37 <jgriffith> We haven't even begun talking about track scheduling etc yet
16:41:58 <winston-d> jgriffith: k. i'll submit my ideas ASAP anyway
16:42:22 <dachary> I've discussed this tentative session on the ceph mailing list and there is an interest. I feel it's better associated with cinder but I'm not 100% sure. Roadmap for Ceph integration with OpenStack http://summit.openstack.org/cfp/details/38
16:42:25 <jgriffith> winston-d: good idea :)
16:42:32 <jgriffith> If nothing else submit things as place holders
16:42:49 <jgriffith> dachary: yeah, I've been following that
16:43:23 <dachary> jgriffith: what's your advice ?
16:43:36 <jgriffith> dachary: I have no good advice at this point :)
16:43:41 <jgriffith> dachary: So my take was/is
16:44:01 <jgriffith> if there's room in Cinder tracks I don't mind it, however what you have planned seems much more nova related IMO
16:44:26 <jgriffith> dachary: bottom line, if it needs a place to land and you're in a jam we can work it out in Cinder
16:44:51 <jgriffith> but it almost seems you need your *own* independent track
16:45:09 <thingee> jgriffith: +1
16:45:11 <jgriffith> dachary: or if we do another *general all/around* bucket again that would be ideal
16:45:11 <dachary> that makes sense, I'll move it to nova then.
16:45:42 <jgriffith> dachary: Your call, if you get in a bind scheduling wise let me know and we'll work something out
16:45:53 <dachary> jgriffith: thanks :-)
16:45:54 <jgriffith> dachary: I also think we should ask about cross-project tracks
16:46:32 <dachary> I'll discuss this with ttx, good idea
16:46:40 <jgriffith> cool
16:47:03 <jgriffith> we've had that sort of thing in the past IIRC
16:47:15 <jgriffith> Ok... anything else on sessions?
16:47:17 <jgriffith> bswartz: ?
16:47:38 <jgriffith> I'm assuming we're going to need to hash something out for real this time on File Shares
16:48:29 <jgriffith> bswartz: But that might be better as it's own type of session as well (non-cinder track)
16:48:40 <jgriffith> well if nobody else has anything....
16:48:43 <bswartz> We're planning to address the feedback we've gotten so far on the NAS stuff so it's ready when Havana opens up
16:48:48 <DuncanT> jgriffith: Would you rather have separate proposals for small things then combine them later?
16:49:00 <jgriffith> DuncanT: small and combine later please
16:49:08 <thingee> dachary: IMO, ceph has little to do with cinder's core. Unless your proposed changes are actually requesting big changes.
16:49:12 <jgriffith> DuncanT: it tends to make things easier to schedule
16:49:19 <jgriffith> thingee: +1
16:49:20 <DuncanT> jgriffith: Understood
16:49:40 <jgriffith> DuncanT: but if you have a well organized grouping by all means, it's up to you
16:49:56 <bswartz> I worry a little that another conference session might feel like a rerun given that the features have not changed significantly, just the impelmentation
16:50:04 <jgriffith> DuncanT: It's just easier for me to see overlap and tie ins if they're seperated
16:50:10 <dachary> thingee: yes, you are correct
16:50:20 <jgriffith> bswartz: agreed, I have some suggestions for how to do this differently this time
16:50:39 <jgriffith> bswartz: one is already taken care of (don't have a *surprise* proposal in the session)
16:50:58 <DuncanT> bswartz: I think some of the concerns, particularly about buy-in from other users, might benefit from a session if we can get some of them there
16:51:05 <jgriffith> if there had been some communication and the code was shared before the session I think it would have been moe productive
16:51:23 <jgriffith> s/moe/more/
16:51:44 <bswartz> jgriffith, DuncanT: I agree
16:51:57 <jgriffith> DuncanT: bswartz Recall in SanFran there was actually a storage panel that discussed this with a broader audience
16:52:13 <jgriffith> The resounding response was *yes, we want shared filesystem support*
16:52:20 <jgriffith> *no, it shouldn't be in Cinder*
16:52:34 <jgriffith> It's actually on video somewhere
16:52:39 <bswartz> jgriffith: I'm not sure which session you're referring to
16:53:07 <jgriffith> bswartz: It was a panel discussion... Rob, SF, Mirantis, Nexenta
16:53:29 <bswartz> On the first day? I think I was there
16:53:42 <jgriffith> bswartz: I think it was the last day, but not sure
16:53:46 <bswartz> I have a different memory of events -- but I might be remembering a different session
16:53:48 <jgriffith> I'll see if I can't find the link
16:53:52 <bswartz> please do
16:54:23 <jgriffith> Yes you and Rob have pointed out that my memory is apparantly *wrong*
16:54:46 <bswartz> I think the point of contention is about how resounding the response was
16:55:02 <bswartz> clearly some people think NAS doesn't belong in cinder
16:55:36 <jgriffith> bswartz: sure...
16:55:45 <jgriffith> anyway, we'll sort it this time around
16:55:55 <jgriffith> anybody have anything else?
16:56:08 <jgriffith> I'll find the link and hit you up in the channel with it
16:56:17 <jgriffith> Ok... thanks everyone
16:56:24 <jgallard> The work regarding multi backend / tempest integration test is in progress.
16:56:25 <jgriffith> #end meeting
16:56:25 <dachary> thanks :-)
16:56:31 <jgriffith> #endmeeting