16:06:00 <thingee> #startmeeting Cinder
16:06:01 <openstack> Meeting started Wed Apr 23 16:06:00 2014 UTC and is due to finish in 60 minutes.  The chair is thingee. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:06:04 <openstack> The meeting name has been set to 'cinder'
16:06:27 <thingee> hey all
16:06:30 <winston-d_> o/
16:06:34 <kmartin> hello
16:06:35 <Xyang> Hi
16:06:37 <jungleboyj> Howdy.
16:06:38 <vbala> Hi
16:06:39 <asselin2> hi
16:06:56 <thingee> #link https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting
16:07:07 <thingee> got our agenda today, pretty small
16:07:18 <thingee> #topic Cinder specs
16:07:25 <thingee> jungleboyj: you have the floor
16:07:58 <jungleboyj> thingee: Thanks.  I am not sure how much progress we can make on this but wanted to start the conversation.
16:08:44 <jungleboyj> Just wondering if we have any thoughts/definition around how this cinder-spec process is going to work.
16:08:57 <jungleboyj> When I mentioned it here to our developers I get questions for more details.
16:09:25 <jungleboyj> Anyone know more?
16:09:52 <kmartin> is this the new blueprint process? or something different?
16:10:00 <jungleboyj> kmartin: Yes.
16:10:39 <kmartin> did jgriffith set up a wiki page with the details yet?
16:10:48 <jungleboyj> kmartin: Not that I am aware of.
16:11:08 <thingee> I think most of these questions can be answered from previous threads on the dev list http://lists.openstack.org/pipermail/openstack-dev/2014-April/032796.html
16:11:38 <thingee> at least with what nova is doing
16:11:56 * jungleboyj is looking.
16:12:06 <thingee> I think it would be great to follow suit so the process is consistent across projects.
16:12:24 <kmartin> thingee: +1
16:12:32 <thingee> and I don't really have any oppositions with nova's terms
16:12:45 <jungleboyj> Since we don't have a drivers team, it would just be our core review team that is on the hook here .
16:13:10 <thingee> jungleboyj: yes, and I think it has always been that way.
16:13:29 <jungleboyj> thingee: Ok, was just making sure.  :-)
16:13:54 <thingee> if we had problems with bps in the past, jgriffith would weigh our opinions in before approving something
16:14:03 <thingee> just wasn't official
16:14:23 <jungleboyj> thingee 2 +2's required to move on?
16:14:31 <thingee> yes
16:14:39 <jungleboyj> thingee: or I am guessing PTL +2 .
16:15:08 <kmartin> I think the cinder-specs repository needs to be setup still in GitHub, similiar to nova's https://github.com/openstack/nova-specs
16:15:09 <thingee> I guess this would be slightly different in that it does require someone else to weigh in besides the ptl
16:15:17 <thingee> kmartin: yes
16:15:50 <thingee> originally on the list though when nova was moving towards this direction, there was some hesitation in letting nova try it before everybody jumped on board
16:15:55 <jungleboyj> kmartin: So, PTL +2 and at least one more +2.
16:16:01 <thingee> it was one of the first threads around this...does anyone remember that?
16:17:15 <kmartin> nova has a small readme but not to that detail: https://github.com/openstack/nova-specs/blob/master/README.rst
16:18:10 <jungleboyj> kmartin: Thanks.
16:19:00 <jungleboyj> The other question for Cinder is what the process is for proposing driver changes.  Do they all use the same template or is there a less complicated method for driver owners to propose changes.
16:19:16 <jungleboyj> opinions?
16:19:32 <jungleboyj> The nova template is quite lengthy.
16:20:02 <thingee> jungleboyj: yeah, but as I understood it's a way to communicate to ops too
16:20:08 <thingee> of what this change exactly means
16:20:25 <jungleboyj> Ok.
16:20:49 <thingee> for example cinder v2 support https://review.openstack.org/#/c/88500/
16:20:59 <jungleboyj> thingee: I wonder if this is a discussion I should take to the mailing list so we can have this all documented.
16:21:25 <thingee> it would probably be best yes. I don't think a lot of people are present in this meeting, or are just being silent
16:21:50 <thingee> neutron has started a thread for themselves too
16:21:53 <jungleboyj> thingee: Agreed.  I will get a note put together today with thoughts/proposals and we can go from there.
16:22:38 <kmartin> these meetings get recorded, but I'm sure jgriffith would have input on this topic
16:22:38 <thingee> #action jungleboyj will put together proposal for cinder-specs and post to openstack-dev ML
16:23:14 <thingee> I think not having things ready for a new development release makes it hard.
16:23:27 <jungleboyj> kmartin: Right.  Want to also make sure that winston-d_ avishay DuncanT- give input.
16:23:41 <kmartin> yes, this should be in place now if it's required for juno
16:23:43 <jungleboyj> thingee +2
16:24:22 <jungleboyj> That was all I had.
16:24:30 <thingee> #topic Open discussion
16:24:33 <thingee> heh
16:24:35 <thingee> easy meeting
16:24:46 <jungleboyj> :-)  I get to go to lunch early.
16:24:49 * jungleboyj is hungry
16:25:00 <thingee> anything else?
16:25:13 <kmartin> nice and fast, any idea when the cinder design session will be scheduled
16:25:37 <winston-d_> jgriffith: ^^
16:25:57 <thingee> likely thursday and friday like it usual is
16:26:26 <deepakcs> Sorry i got in late here.. cinder design session is in the context of juno summit or somethign else ?
16:26:51 <thingee> deepakcs: yes the design summit
16:27:30 <deepakcs> thingee, ok.. the las ttime i saw the summit.os.org.. it wasnt' clear what summits are in and what are not.. is it frozen now ?
16:28:08 <thingee> deepakcs: we're more wondering when cinder sessions will be, not what's going to be in it
16:28:21 <deepakcs> thingee, do we have any design session to discuss the way to provide a graceful cleanup for cinder plugins .. I had a mail thread on it on -dev in the recent past
16:28:33 <deepakcs> thingee, ok :)
16:29:08 <thingee> deepakcs: I don't think it was proposed at summit.openstack.org
16:29:32 <thingee> but I believe it's too late too submit now
16:29:35 <deepakcs> thingee, Ya, i was not sure of the travel then :)
16:30:25 <thingee> anything else?
16:30:25 <deepakcs> thingee, I also had a mail thread in -dev on the ensure_shares_mounted and issues around it.. need to see if that will get addressed in any of the submitted summits
16:30:34 <deepakcs> thingee, do u know ^^ just in case ?
16:31:03 * deepakcs haven't gotten to see all the proposals
16:31:20 <thingee> deepakcs: If it's not listed in summit.openstack.org, it's not being discussed. I don't remember seeing it myself
16:31:30 <deepakcs> thingee, ok thanks... i am done
16:31:52 <thingee> #endmeeting