16:00:59 <DuncanT-> #startmeeting cinder
16:01:00 <openstack> Meeting started Wed Jul 23 16:00:59 2014 UTC and is due to finish in 60 minutes.  The chair is DuncanT-. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:04 <openstack> The meeting name has been set to 'cinder'
16:01:07 <DuncanT-> Who's about?
16:01:12 <eharney> hi
16:01:16 <bruff> hi
16:01:18 <xyang1> hi
16:01:21 <winston-d_> hi
16:01:22 <jungleboyj> o/
16:01:24 <glenng> Hey
16:01:26 <jungleboyj> \o
16:01:30 <e0ne> hi
16:01:35 <jungleboyj> \o/
16:01:39 <smcginnis> o/
16:01:39 <Arkady_Kanevsky> hello
16:01:52 <DuncanT-> Agenda at https://wiki.openstack.org/wiki/CinderMeetings - I've hijacked it and put a first item in at JGriffith's request
16:02:33 <flip214> DuncanT-: is that to be read as "everything that has a bp may go on"?
16:02:34 <DuncanT-> #topic J-2
16:02:43 <thingee> o/
16:02:50 <kmartin> hello
16:02:51 <Swanson> hi
16:02:57 <beecee> hi
16:02:59 <stevetan> hi
16:03:14 <DuncanT-> flip214: Every driver taht has a blueprint may go in, though any individual driver might get blocked for other reasons
16:03:25 <DuncanT-> flip214: Volume driver
16:03:44 <DuncanT-> Anybody feel that is unreasonable?
16:03:56 <kmartin> new drivers that is?
16:04:03 <DuncanT-> Any driver that doesn't currently have a BP up will get bumped
16:04:09 <DuncanT-> kmartin: Yes, new drivers
16:04:12 <Arkady_Kanevsky> if the code is not submited for Juno will a driver make it?
16:04:36 <thingee> Arkady_Kanevsky: well if we don't see code for Juno, no ;)
16:04:54 <stevetan> +1
16:04:59 <tbarron> hi
16:04:59 <DuncanT-> Arkady_Kanevsky: If you've got a blueprint up, then you aren't automatically blocked
16:05:11 <Arkady_Kanevsky> I think only the drivers that are udner review should move forward, the rest is retargeted to K-release
16:05:12 <e0ne> DuncanT-, make sense  for Juno release
16:05:21 <asselin> hi
16:05:24 <DuncanT-> Arkady_Kanevsky: However, if you don't get code up real soon then you're likely to not get merged due to time constraints
16:05:40 <kmartin> DuncanT-: +1
16:05:48 <jungleboyj> DuncanT-: Yeah, we are quickly running out of runway.
16:06:15 <Arkady_Kanevsky> I saw that Dell CMPL blueprint was obsolited today, that I why I asked.
16:06:19 <DuncanT-> #agreed Any driver that doesn't have a review (BP or code) currently up will be punted to Kilo
16:06:35 <Arkady_Kanevsky> I am trying to see if we can make it into Juno if we submit somethign by next week.
16:06:42 <DuncanT-> Arkady_Kanevsky: I've not noticed that one specifically.... link?
16:06:48 <stevetan> i would like to have a discussion on our SDS driver which blocked. should we discuss now or later in the agenda
16:07:04 <Arkady_Kanevsky> https://blueprints.launchpad.net/cinder/+spec/dell-storage-center-block-storage-driver
16:07:05 <DuncanT-> stevetan: Add it to the end of the agenda please?
16:07:11 <navneet> DuncanT-: what about driver modifications? will that be allowed?
16:07:19 <navneet> if its not already up there
16:07:29 <stevetan> DucanT- it is in the agenda under ProphetStor Cinder drivers
16:07:33 <DuncanT-> navneet: Yes, they are not automatically blocked
16:07:39 <jungleboyj> What is the stance on things like volume drivers implementing new features, I.E. adding the code for replication ?
16:08:07 <DuncanT-> Arkady_Kanevsky: I'd say that was in on time and so can submit code
16:08:15 <navneet> DuncanT-: gr8...
16:08:21 <Arkady_Kanevsky> thanks
16:08:25 <DuncanT-> jungleboyj: That is still fine, at least until J-3 I think
16:08:34 <hemna> morning
16:08:37 <DuncanT-> jungleboyj: Though sooner is always better so that reviews have time
16:08:41 <jungleboyj> DuncanT-: Ok, that was what I was communicating.
16:08:45 <jungleboyj> Right.
16:08:54 * jungleboyj waves at hemna
16:09:01 <Arkady_Kanevsky> is there a pointer to Driver Specs which is next on agend?
16:09:33 <DuncanT-> Arkady_Kanevsky: That's a general point, not a specific one
16:09:39 <DuncanT-> Right, moving on
16:09:47 <DuncanT-> #topic review priorities
16:09:56 <avishay> sorry i'm late
16:10:01 <hemna> another thing I've noticed on new driver reviews is that they submitted the certification results in the 1st patch, but 12 patch sets later, they haven't updated the cert results.
16:10:05 <winston-d> avishay: hi
16:10:18 <hemna> I've been asking driver writers to make sure they submit new cert results on every patch set
16:10:21 <DuncanT-> Any driver specs that aren't yet approved, can people (particularly cores) focus on
16:10:33 <hemna> ok
16:10:38 <DuncanT-> hemna: I've been asking for CI :-)
16:10:57 <xyang1> DuncanT-: what exactly is the requirement for CI?
16:11:08 <hemna> yah CI is ideal
16:11:10 <xyang1> DuncanT-: I thought it is by J-2
16:11:21 <stevetan> how about adding to DriverLog? when should that happen?
16:11:36 <winston-d> DuncanT-: I found myself can only +1 for specs, is that expected?
16:11:40 <kmartin> xyang1: that's not on the agenda and could very well take up the entire meeting
16:11:48 <DuncanT-> xyang1: We said at the conference it was J-2, but we'd have one driver if we went with that
16:11:53 <hemna> getting CI in place is really freaking hard for new driver submitters.   It's really freaking hard for us!
16:12:22 <DuncanT-> xyang1: I've been emailing everybody for updates, I'm going to start being rude during / after the mid-cycle meetup
16:12:28 <xyang1> DuncanT-: :)  At least the one driver that has it should get more reviews, I hope?
16:12:49 <DuncanT-> xyang1: It is my top priority after CGs to review
16:13:01 <xyang1> DuncanT-: thanks!
16:13:33 <DuncanT-> Winston's pool scheduler patch seems really close, and like the CG patch it needs driver updates to be useful, so can we focus on those this week please?
16:13:36 <jungleboyj> xyang1: I am have the CGs up to look at today as well.
16:13:50 <xyang1> jungleboy:  thanks!
16:13:56 <navneet> DuncanT-: xyang1 : Is it mandatory for every driver to implement CG in juno?
16:14:06 <xyang1> navneet: no
16:14:09 <jungleboyj> DuncanT-: We also should get focus on the replication patch for the same reason.
16:14:21 <jungleboyj> ronenkat: You are welcome.  ;-)
16:14:21 <navneet> xyang1: ok
16:14:21 <xyang1> navneet: it is an advanced feature, not a requirement
16:14:21 <DuncanT-> They are both likely to be pushed through soon, so if you don't like anything then you're coming to the end of your opportunities to give feedback
16:14:29 <hemna> any news about the pool scheduler support ?
16:14:30 <DuncanT-> navneet: It is optional
16:14:32 <navneet> xyang1: makes sense
16:14:37 <xyang1> navneet: it does change lots of common code though
16:14:37 <ronenkat> jungleboyj: hello
16:14:58 <navneet> xyang1: oh yeah ...I understand
16:15:12 <Arkady_Kanevsky> For CG do we have a pointer on the call that drivers should support for it (for juno or later)?
16:15:13 <DuncanT-> hemna: pool scheduler is very close I think.... asking for people to prioritise review and testing of it
16:15:30 <hemna> DuncanT-, ok.  we'll have to modify our drivers to make use of it to test
16:15:31 <navneet> winston-d: DuncanT- : same question....how far are we on pools
16:15:42 <xyang1> Arkady_Kanevsky: it is not required feature
16:15:46 <navneet> winston-d: when can we get it merged
16:16:05 <DuncanT-> winston-d: Are you aware of anything blocking pool scheduler merge?
16:16:14 <hemna> xyang1, I would hope that CG wouldn't require drivers to make external calls ?
16:16:17 <avishay> DuncanT-: winston-d: there were two versions of the pool scheduler thing - winston-d's is the one we're going with?
16:16:29 <xyang1> hemna: what do you mean?
16:16:30 <Arkady_Kanevsky> understand, but you would like to support SG what is the interface for drivers?
16:16:32 <navneet> avishay: yes
16:16:45 <avishay> navneet: ok, didn't know what to review
16:16:50 <xyang1> hemna: CG is not a required driver feature
16:16:55 <hemna> correct
16:16:58 <winston-d> DuncanT-: nope, it just need more eyes and tests.  My tests when well, but I don't have a real backend that supports pool to test it.
16:17:26 <DuncanT-> avishay: Yes, the vote is strongly selecting winston-d approach
16:17:29 <navneet> winston-d: did u not test it with lvm?
16:17:30 <hemna> winston-d, we'll try and update the hp drivers soon to get the pools supported.   Do we have samples of what the get_volume_stats needs to return?
16:17:37 <avishay> DuncanT-: my vote as well, cool
16:17:39 <DuncanT-> winston-d: Can we get an LVM driver supporting pools?
16:17:39 <winston-d> So please, review the change https://review.openstack.org/#/c/98715/
16:17:51 <xyang1> Arkady_Kanevsky: https://review.openstack.org/#/c/104732/  take a look of changes in lvm.py
16:18:17 <hemna> winston-d, ok it looks well documented in the review :)
16:18:20 <winston-d> DuncanT-: I've updated lvm driver a little bit to report a defalut pool
16:18:27 <DuncanT-> I think we need to put some work into documenting how replication, CGs and pools work once we've merged the code
16:18:37 <hemna> DuncanT-, +1
16:18:47 <navneet> DuncanT-: +1 for docs
16:18:49 <winston-d> DuncanT-: but that's all I have for lvm driver.
16:19:00 <jungleboyj> DuncanT-: +1
16:19:02 <DuncanT-> I'll collect some volenteers for docs work in the near future
16:19:32 <xyang1> we need to coordinate the merge too.  we are changing the same files
16:19:34 <navneet> winston-d: you need t atleast verify pols work for lvm....its the minimum
16:19:36 <ronenkat> DuncanT-: I planned to do a proper docu for replication - would make sense
16:19:50 <DuncanT-> Can somebody add the links to the three reviews (pools, CGs, replication) to the agenda please?
16:20:00 <hemna> navneet, his pools patch has changes for lvm in it.
16:20:07 <jungleboyj> ronenkat: +2
16:20:08 <winston-d> I am happy to document pool scheduling, and happy to review any pool related driver change.
16:20:15 <flip214> what I'd like to see is some doc about expected *return* values from the methods - what parts the dicts should have.
16:20:16 <ronenkat> DuncanT-: replication patch is on the agenda
16:20:19 <navneet> hemna: ya...just asking if he also QAed it
16:20:45 <DuncanT-> Ok, anybody got anything else they think should be a review priority?
16:20:47 <flip214> the input is easily seen by doing a debug dump of them - but figuring out what should be returned is a major piece of work sometimes.
16:20:57 <winston-d> navneet: yes, it works. it's just a report status change.
16:21:09 <navneet> winston-d: cool
16:21:32 <DuncanT-> flip214: If you start a wiki page hinting at what docs you feel are needed, I'll get people to fill it in... might be the easiest way to make a start
16:21:54 <winston-d> DuncanT-: I think this might get some attention as well: https://review.openstack.org/#/c/101412/27
16:22:09 <winston-d> Use pbr entry_points to setup the cinder scripts
16:22:20 <flip214> DuncanT-: somewhere below https://wiki.openstack.org/wiki/Cinder ?
16:22:25 <winston-d> I am working on it
16:22:36 <flip214> thanks a lot for the offer!!
16:22:38 <DuncanT-> flip214: yEAH. wE CAN CLEAN IT UP LATER ONCE WE'VE COLLECTED THE INFO
16:22:46 <DuncanT-> Ooops
16:22:51 <DuncanT-> Capslock fail
16:23:01 <avishay> stop yelling :(
16:23:31 <winston-d> avishay: :)
16:23:34 <DuncanT-> winston-d: That pbr one has been on my list for a while... not had chance to test it, and it is the sort of change that isn't tested by the gate
16:23:50 <DuncanT-> Right, I think we can move ob
16:23:52 <DuncanT-> on
16:24:05 <DuncanT-> #topic 3rd party CI
16:24:09 <xyang1> DuncanT-: this one needs reviews too: https://review.openstack.org/#/c/105923/.
16:24:52 <DuncanT-> xyang1: Fair point. That one will affect all drivers eventually so poeple should definitely look and ask questions if it makes no sense
16:24:57 <Arkady_Kanevsky> We are working on setting CI for EQL driver. bumping into expected firewall issues for ports
16:25:03 <jungleboyj> xyang1: +1
16:25:28 <jungleboyj> DuncanT-: All I wanted to say was that I had attended this week's 3rd Party Status meeting.
16:25:32 <winston-d> xyang1: yup, thx for bringing it to the table
16:25:32 <Arkady_Kanevsky> +1 ofre connecttor
16:25:46 <DuncanT-> Right, I've been emailing people over 3rd party CI, and collecting a table of results. 'We're working on it' is the most common reply. I intend to start being more insistent by the time the mid-cycle meet rolls around next month
16:25:50 <jungleboyj> DuncanT-: Gave a quick update on where we are, as I had seen it.
16:26:14 <asselin> We're making progress. Got stuck on zuul not able to get data from cinder project even though it works for the sandbox.
16:26:16 <jungleboyj> DuncanT-: Right.  They would like us to attend the weekly meeting and keep them updated on where that status is really at.
16:26:17 <DuncanT-> jungleboyj: Any feedback from them?
16:26:47 <jungleboyj> Strongly encouraged anyone involved with CI from the vendors to try to attend the meetings.
16:27:02 <DuncanT-> jungleboyj: I'll see if I can make it, and I'll share the tracking spreadsheet with you
16:27:03 <jungleboyj> Mondays, 1pm Central Time, 18 or 19:00 UTC.
16:27:14 <beecee> DuncanT-: are you collecting what CI tools 3rd party people are using?
16:27:19 <jungleboyj> DuncanT-: If you can't make it I can take the info forward.
16:27:52 <beecee> DuncanT-: ( I'm in there with the 'fragile little flower' line if it helps ;) )
16:27:58 <jungleboyj> DuncanT-: They were fine with our plan as far as how to enforce the 3rd Party CI, but wanted to make sure we were communicating everything well.
16:27:59 <e0ne> jungleboyj, thanks! i'll be on the next 3rd party meeting
16:28:11 <DuncanT-> I've missing contacts for at least the following drivers: Coraid, Nexenta, Scality, VMWare and Solaris(ZFS)
16:28:18 <xyang1> DuncanT-: our VNX driver has end-to-end CI up and running.  Other drivers VMAX, ViPR, XIO still have one or two test failures (i.e., timeout) from time to time.  I have asked them to do end-to-end CI as well.
16:28:26 <kmartin> asselin: can you make the meeting jungleboyj referenced?
16:28:44 <DuncanT-> beecee: I've not been collecting that so far
16:28:45 <asselin> kmartin, yes, I've been attending the past few weeks.
16:28:52 <jungleboyj> asselin: You would be good to have there.
16:28:55 <jungleboyj> asselin: +2
16:29:10 <asselin> jungleboyj, was on vacation monday, so missed this week.
16:29:18 <jungleboyj> asselin: Gotcha.
16:29:20 <Arkady_Kanevsky> need to drop
16:29:34 <xyang1> DuncanT-: VMAX and XIO CI works with sandbox, but haven't tried with Cinder yet
16:30:03 <jungleboyj> IBM has made good progress.  Most of the drivers are close to being tied into gerrit and being able to post results.
16:30:06 <DuncanT-> There seems to be a common problem that devstack fails in none-cinder places. I'm wondering if somebody involved in building CI wants of correlate those failures and pass them on to the infra team?
16:30:28 <jungleboyj> One exception is GPFS as we are having issues getting the CI scripts running on RHEL which is required for GPFS.
16:30:44 <DuncanT-> Has anybody got the email address for the following maintainers? Coraid, Nexenta, Scality, VMWare and Solaris(ZFS)
16:31:08 <navneet> DuncanT-: VMWare contacts I know
16:31:17 <navneet> but not sure if they handle CI
16:31:26 <DuncanT-> navneet: Can you pass them on please? I'll start pinging them
16:31:33 <navneet> DuncanT-: sure
16:33:31 <DuncanT-> Right, I'll be chasing people over CI. If you are working on it and haven't had an email on the subject from me, please let me know
16:33:47 <DuncanT-> Next up, stevetan
16:33:50 <smcginnis> DuncanT-: No update from Dell, still working on it.
16:34:09 <stevetan> yea, we have 2 drivers pending
16:34:15 <DuncanT-> smcginnis: Can you PM me your email address please? I don't have it on my list
16:34:16 <asselin> DuncanT-, I haven't gotten an e-mail from you
16:34:24 <DuncanT-> #topic prophetstore
16:34:25 <stevetan> wanna get feedback on this https://review.openstack.org/#/c/95829/
16:34:28 <e0ne> DuncanT-, i'm working for CI with ceph, no e-mails from you
16:34:51 <stevetan> this is our first time, so please pardon our ignorance some process
16:34:52 <DuncanT-> e0ne: Can you pm me your email address too please?
16:35:04 <e0ne> DuncanT-: sure
16:35:27 <eharney> we are also working on CI for Ceph
16:35:28 <stevetan> so what else do we have to do to get this into J-2?
16:35:29 <stevetan> https://review.openstack.org/#/c/95829/
16:35:57 <xyang1> stevetan: do you have CI
16:36:49 <stevetan> xyang1: is this what you are refering to? http://download.prophetstor.com/cinder-cert-results/tmp.FLf8UoGtEp
16:37:10 <e0ne> eharney: you're the ceph drivers :)
16:37:13 <xyang1> stevetan: that is cert test.  CI is more than that
16:37:15 <thingee> stevetan: a ci is continuous integration. One cert test is the initial start of submitting a driver
16:37:40 <asselin> xyang1, thingee I thought ci was not needed for new drivers?
16:38:18 <stevetan> yes, i believe my guy said he did CI. can u tell from the review? https://review.openstack.org/#/c/95829/
16:38:27 <thingee> stevetan: https://wiki.openstack.org/wiki/Cinder/certified-drivers
16:38:28 <xyang1> asselin: is it?  I was told to do it
16:38:43 <thingee> asselin: that wiki doc still says otherwise.
16:39:04 <jungleboyj> xyang1: There was back and forth whether you were a new shop coming in versus the big iron companies.
16:39:17 <kmartin> stevetan: It would be good to respond to the inline comments from the reviewers, reply Done or answer there question inline.
16:39:38 <jungleboyj> kmartin: Good advice.
16:39:39 <asselin> jungleboyj, yes, that's what I understood. new drivers from new vendors just need cert tests
16:39:40 <stevetan> but there is no more after the last
16:39:41 <DuncanT-> CI is needed for all new drivers... any driver (old or new) with no CI and no good excuse is like to get pulled from the release
16:39:54 <thingee> stevetan: I don't see any third party ci posting results on other patches from ProphetStor, so no.
16:40:24 <thingee> stevetan: take a look at the wiki doc I posted.
16:40:24 <stevetan> EMC VNX CI		Jul 21 2:20 PM
16:40:25 <stevetan> Patch Set 42:
16:40:25 <stevetan> Build succeed.
16:40:27 <stevetan> EMC_VNX_ISCSI SUCCESS in 39m 15s
16:40:29 <stevetan> EMC_VNX_FC SUCCESS in 9m 35s
16:40:38 <stevetan> isn't that part of the CI?
16:40:47 <thingee> that's an example of emc doing it
16:40:53 <asselin> stevetan, yes, you would need your own account for yourself
16:41:13 <stevetan> thingee: please send me the wiki link
16:41:21 <thingee> https://wiki.openstack.org/wiki/Cinder/certified-drivers
16:41:48 <stevetan> ok... so what do we need to do from the current review status... https://review.openstack.org/#/c/95829/
16:41:50 <kmartin> stevetan: You may have responded to teh comments but they might still be in Draftl(and show in red), press the review button and they will get posted.
16:42:11 <DuncanT-> stevetan: You'll be expected to set up your own system that runs tests against your real hardware on every commit
16:42:22 <thingee> DuncanT-, stevetan: I think we can take this to #openstack-cinder.
16:42:32 <jungleboyj> thingee: +1
16:42:37 <stevetan> DucnanT: we did set up
16:43:00 <thingee> stevetan: ok, well we need to see the CI posting results.
16:43:07 <thingee> stevetan: I'm not seeing that
16:44:02 <stevetan> thingee: something like this u mean? https://s3.amazonaws.com/solidfire-cert-results/tmp.wsfgEXbccC
16:44:51 <stevetan> thingee: this https://bugs.launchpad.net/cinder/+bug/1281119?
16:44:52 <uvirtbot> Launchpad bug 1281119 in cinder "IBM XIV/DS8K driver certification results" [Low,Confirmed]
16:45:08 <kmartin> stevetan: cert results and CI are two different things
16:45:13 <asselin> stevetan, it would post the result automatically in the review section
16:45:19 <DuncanT-> thingee: stevetan: Are you both ok with taking this to #openstack-cinder after the meeting? We've a couple more topics I'd like to get through and we've only quarter of an hour left
16:45:27 <thingee> DuncanT-: +1
16:45:38 <stevetan> DuncanT: ok, thanks
16:45:39 <glenng> DuncanT-: +12
16:45:59 <DuncanT-> #topic Volume replication
16:46:02 <e0ne> stevetan: plese, look to this request	https://review.openstack.org/#/c/101227/ too
16:46:02 <ronenkat> hi
16:46:09 <DuncanT-> ronenkat: Tag, you're up
16:46:29 <stevetan> e0ne: thanks!
16:46:29 <ronenkat> I put up the 1st version of replication - https://review.openstack.org/#/c/106718
16:46:44 <ronenkat> Thanks for those you already took a look
16:46:57 <ronenkat> Seems I rushed a bit
16:47:21 <ronenkat> I would like to have driver owners to take a look at the driver implmentation part - we need that to make the feature usefull
16:47:31 <hemna> ronenkat, you should mark the review as WIP workflow
16:47:37 <DuncanT-> Has anybody from Netapp been able to look at it yet? I know they had serious concerns about avishay's original design
16:48:00 <ronenkat> I wanted to asked if anyone is interested in setting up time to review how the replication works with the driver
16:48:02 <glenng> DuncanT-: I have not. I don't know about anyone else.
16:48:16 <ronenkat> hemna: Thanks, will do
16:48:37 <hemna> ronenkat, any chance you are making the mid-cycle meeting?
16:48:51 <hemna> would be a good place to talk about it, even if it's late in the cycle
16:49:02 <ronenkat> in person... don't think so
16:49:07 <hemna> dang ok.
16:49:11 <DuncanT-> glenng: Can you chase somebody into looking please? You guys seemed to have the most concerns but left the feedback very late last time
16:49:41 <glenng> DuncanT-: Yes sir. :-)  I'll bring it up tmrw in our meeting.
16:49:48 <DuncanT-> Thanks
16:50:03 <ronenkat> is there an interest for me to do a "walk though" ?
16:50:12 <jungleboyj> ronenkat: I am going to be at the mid-cycle meetup.  :-)  Why couldn't you get approved.  ;-)
16:50:37 <flip214> ronenkat: it would help if the methods input/outputs were specified in details
16:50:40 <ronenkat> jungleboyj: I need more miles than you... :-)
16:50:57 <flip214> then it's easier to see what each method is expected to do
16:51:30 <jungleboyj> ronenkat: I know.  Giving you a hard time.
16:51:36 <kmartin> DuncanT-: You were looking for driver maintainer emails? see http://stackalytics.com/report/driverlog?project_id=openstack%2Fcinder
16:51:40 <ronenkat> flip214: make sense, I wiill beef up the method documentation
16:52:01 <flip214> please, thank you very much.
16:52:08 <DuncanT-> kmartin: Sweet! Thanks
16:52:35 <flip214> times up in a few mins
16:53:05 <glenng> DuncanT-: Any time for my topic?
16:53:40 <DuncanT-> Ok, last topic
16:53:51 <DuncanT-> #topic BNFS security
16:53:56 <DuncanT-> #topic NFS security
16:54:06 <DuncanT-> glenng: You're up
16:54:20 <glenng> Just wanted to request that the colective trust look at the NFS Security enahnce,ents.
16:54:45 <glenng> BP is 	•	https://blueprints.launchpad.net/cinder/+spec/secure-nfs
16:55:10 <DuncanT-> glenng: How is it looking for upgrade?
16:55:14 <glenng> There was one review by eharney, but need much more feedback.
16:55:32 <glenng> DuncanT-: Upgrade is a factor here.
16:55:45 <eharney> upgrade was one of my concerns... i need to review it some more, though
16:56:09 <glenng> The security changes will require the Admin to set up the environment correctly, and would most likely require changes to existing volume config.
16:56:21 <DuncanT-> glenng: Can you document the upgrade steps please? I took a look and it looks like it might be significant
16:56:26 <glenng> As in, changing ownership to the stack user.
16:56:49 <glenng> DuncanT-: How about I add that to blueprint text?
16:57:02 <DuncanT-> glenng: That seems as good a place as any, yes
16:57:13 <hemna> shouldn't that be in the cinder-specs patch?
16:57:19 <hemna> or has that ship sailed?
16:57:34 <hemna> can always patch a spec that has landed to update it.
16:57:34 <glenng> DuncanT-: Great. I'll update. I ask that others give it some serious consideration so that we can close the security issue.
16:58:04 <DuncanT-> #agreed People with relevant knowledge to look at the NFS security patch
16:58:22 <DuncanT-> Right, that's su just about out of time... Thanks all
16:58:23 <glenng> DuncanT-: THat's it for me :-)
16:58:46 <glenng> Bye
16:58:53 <jungleboyj> Thanks DuncanT-
16:59:21 <DuncanT-> #endmeeting