#openstack-meeting: Cinder

Meeting started by thingee at 16:00:01 UTC (full logs).

Meeting summary

    1. https://launchpad.net/cinder/+milestone/kilo-1 (thingee, 16:03:09)

  1. 3rd party CI (thingee, 16:04:06)
    1. ACTION: or whatever (DuncanT_, 16:13:35)
    2. AGREED: end of k-2 deadline for existing drivers to have a ci (thingee, 16:14:29)
    3. ACTION: DuncanT_ to post to the openstack dev list about ci deadline (thingee, 16:14:52)
    4. ACTION: DuncanT_ to email existing driver maintainers about ci deadline (thingee, 16:15:10)

  2. Kilo mid-cycle meet-up: (thingee, 16:15:30)
    1. https://etherpad.openstack.org/p/cinder-kilo-midcycle-meetup (thingee, 16:16:09)
    2. dates for meetup is Jan 27-29 2015 (thingee, 16:19:01)
    3. room for 20 people sign up now! (thingee, 16:19:18)
    4. ACTION: jungleboyj to post to the openstack lists about the meetup (thingee, 16:20:30)

  3. What to do about cinder.conf.sample (thingee, 16:21:37)
    1. IDEA: stop generating cinder.conf.sample based on external libs (thingee, 16:25:22)
    2. ACTION: jungleboyj to make a bug to for removing external libs from cinder.conf.sample generation (thingee, 16:30:03)

  4. Volume metadata having semantic meaning to Cinder (thingee, 16:32:05)
    1. ACTION: DuncanT_ to write up the problem and mention it in the openstack dev ML for discussion (thingee, 16:42:47)

  5. Discuss how to cleanup stuck volumes (creating/deleting/attaching/detaching) (thingee, 16:43:03)
    1. https://blueprints.launchpad.net/cinder/+spec/reset-state-with-driver (thingee, 16:43:20)
    2. IDEA: reset state should also involve drivers (thingee, 16:43:40)
    3. ACTION: scottda to document more use cases and most the openstack dev ML to involve nova folks (thingee, 16:50:49)

  6. Are changes to the Cinder V1 API still worth the trouble? (thingee, 16:51:02)
    1. https://review.openstack.org/#/c/132657/ (thingee, 16:51:32)

  7. Backport NFS security bugfix to stable/juno and stable/icehouse (thingee, 16:54:27)
    1. https://review.openstack.org/#/c/107693/ (thingee, 16:55:02)


Meeting ended at 17:00:05 UTC (full logs).

Action items

  1. or whatever
  2. DuncanT_ to post to the openstack dev list about ci deadline
  3. DuncanT_ to email existing driver maintainers about ci deadline
  4. jungleboyj to post to the openstack lists about the meetup
  5. jungleboyj to make a bug to for removing external libs from cinder.conf.sample generation
  6. DuncanT_ to write up the problem and mention it in the openstack dev ML for discussion
  7. scottda to document more use cases and most the openstack dev ML to involve nova folks


Action items, by person

  1. DuncanT_
    1. DuncanT_ to post to the openstack dev list about ci deadline
    2. DuncanT_ to email existing driver maintainers about ci deadline
    3. DuncanT_ to write up the problem and mention it in the openstack dev ML for discussion
  2. jungleboyj
    1. jungleboyj to post to the openstack lists about the meetup
    2. jungleboyj to make a bug to for removing external libs from cinder.conf.sample generation
  3. openstack
    1. DuncanT_ to post to the openstack dev list about ci deadline
    2. jungleboyj to post to the openstack lists about the meetup
    3. DuncanT_ to write up the problem and mention it in the openstack dev ML for discussion
    4. scottda to document more use cases and most the openstack dev ML to involve nova folks
  4. scottda
    1. scottda to document more use cases and most the openstack dev ML to involve nova folks


People present (lines said)

  1. thingee (115)
  2. DuncanT_ (86)
  3. jungleboyj (47)
  4. hemna (45)
  5. scottda (30)
  6. eharney (18)
  7. bswartz (15)
  8. guitarzan (14)
  9. flip214 (13)
  10. pwehrle (8)
  11. e0ne (7)
  12. xyang1 (7)
  13. ameade_ (7)
  14. winston-d (6)
  15. rushiagr (4)
  16. anteaya (3)
  17. openstack (3)
  18. tbarron (3)
  19. timcl (3)
  20. rhe00_ (2)
  21. jbernard (2)
  22. lpabon (1)
  23. asselin (1)
  24. mtanino (1)
  25. rushil1 (1)
  26. AmitKDas (1)
  27. TobiasE1 (1)
  28. akerr (1)


Generated by MeetBot 0.1.4.