16:00:55 <thingee> #startmeeting cinder
16:00:56 <openstack> Meeting started Wed Mar 18 16:00:55 2015 UTC and is due to finish in 60 minutes.  The chair is thingee. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:58 <e0ne> hi!
16:00:59 <winston-d_> o/
16:00:59 <openstack> The meeting name has been set to 'cinder'
16:01:02 <kaisers1> Hi
16:01:02 <eharney> hi
16:01:03 <geguileo> Hi
16:01:05 <cebruns> Hi
16:01:05 <jbernard> o/
16:01:09 <rushil> \o
16:01:11 <tbarron> hi
16:01:12 <thingee> hello all!
16:01:14 <patrickeast> hi
16:01:16 <jungleboyj> o/
16:01:19 <yuriy_n17> hi
16:01:29 <jgriffith> 0/
16:01:31 <thingee> some usual announcements
16:01:34 <hemna> mep
16:01:39 <thingee> Third party ci
16:01:42 <thingee> #link http://lists.openstack.org/pipermail/openstack-dev/2015-January/054614.html
16:01:42 <avishay> hello
16:01:47 <jgravel> hi
16:01:51 <thingee> Tomorrow is the last day
16:02:02 <rhe00> hi
16:02:02 <Swanson> hellop
16:02:05 <Swanson> hello
16:02:08 <bswartz> hi
16:02:12 <deepakcs> o/
16:02:12 <thingee> I will begin WIP patches that remove drivers out that have not responded back to me
16:02:21 <hemna> boom
16:02:37 <jgriffith> I think my favorite part is the 32 links included for reference :)
16:02:40 <jungleboyj> Ok.
16:02:54 <thingee> jgriffith: just to cover my ass more or less
16:02:58 <thingee> ;)
16:03:01 <hemna> :)
16:03:02 <jgriffith> thingee: roger that
16:03:11 <thingee> so please talk to me
16:03:20 <thingee> it's better to talk to me than be silent about the ci deadline
16:03:23 <thingee> I will work with people
16:03:33 <rhe00> looks like a few CIs are missing from the wiki page
16:03:42 <thingee> I will also be posting later today on the dev ML my report of all drivers of who is reporting
16:03:48 <rhe00> some that are already reporting
16:03:58 <hemna> thingee, do you have a page of the drivers that haven't replied yet ?
16:04:09 <hemna> page/doc/public list ?
16:04:11 <flip214> thingee: #infra will take care about opensource drivers, is that still correct?
16:04:21 <thingee> hemna: I have a spread sheet, but it's out of date from eight emails I recieved just this week ;)
16:04:30 <thingee> hemna: would like to update that before people get all up in arms about it
16:04:43 <hemna> probably should make that public ?
16:04:50 <kaisers1> hemna: +1
16:04:54 <thingee> hemna: I just said that earlier
16:04:57 <hemna> ok sorry
16:05:05 <thingee> 09:03:42        thingee | I will also be posting later today on the dev ML my report of all drivers   │ andreykurilin
16:05:07 <hemna> still ingesting coffee this a.m.
16:05:07 <thingee> | of who is reporting
16:05:13 <hemna> my bad
16:05:29 <thingee> ok, also deadlines
16:05:37 <thingee> #link http://lists.openstack.org/pipermail/openstack-dev/2015-February/056964.html
16:05:41 <thingee> we're past new proposals
16:05:52 <andreykurilin> thingee: ?
16:05:55 <thingee> Been still getting them. I've been giving them a -2 and I recommend everyone else to do the same
16:06:03 <thingee> andreykurilin: my mistake in copy/paste
16:06:09 <thingee> andreykurilin: sorry
16:06:13 <andreykurilin> np:)
16:06:25 <thingee> we're just accepting bug fixes at this point
16:06:46 <thingee> If you need to know what to review
16:06:49 <thingee> go here https://wiki.openstack.org/wiki/Cinder#Review_Links
16:06:58 <thingee> click the cinder review inbox link
16:07:05 <thingee> and review the group that is bug fixes
16:07:18 <thingee> should greatly help in filtering what to review
16:07:23 <thingee> alright lets get started!
16:07:24 <rhe00> is tomorrow the last day for bug fixes?
16:07:35 <thingee> rhe00: oh yes thanks for reminding me
16:07:55 <hemna> so I have a question about a patch that really seems like a continuation of the new objects feature
16:08:00 <hemna> https://review.openstack.org/#/c/161077/
16:08:01 <hemna> that guy
16:08:07 <thingee> rhe00: so I will be doing a cut at some point tomorrow. Hoping to not be late. Please lets work together on get our bug fixes through.
16:08:20 <hemna> I'm not sure that should get in
16:08:22 <thingee> I'm really relying on folks to help because I got a few security issues on my plate atm
16:08:26 <hemna> unless something is broken w/o it
16:08:31 <e0ne> hemna: good question
16:08:54 <hemna> I think it should get -2 unless others object
16:08:55 <thingee> hemna: I don't think it should go in either
16:09:01 <hemna> ok
16:09:01 <thangp> hemna: it's just finishing the snapshot api
16:09:21 <thingee> ok lets get started!
16:09:30 <hemna> ok done.
16:09:30 <hemna> :P
16:09:37 <thingee> agenda!
16:09:40 <thingee> #link https://wiki.openstack.org/wiki/CinderMeetings#Weekly_Cinder_team_meeting
16:09:54 <jgriffith> hemna: thingee WRT to the objects....
16:10:06 <jgriffith> hemna: thingee I'd like to at least think about it if we could
16:10:18 <jungleboyj> thingee: Sorry, jsut want to clarify.  We are taking bug fixes beyond tomorrow.  Correct.
16:10:22 <jgriffith> hemna: thingee we're in a funky place right now with a bunch of 1/2 in 1/2 out stuff
16:10:34 <hemna> jgriffith, well yah that's why I was questioning it
16:10:42 <hemna> if stuff is broken w/o this getting in....
16:10:45 <hemna> I can remove the -2
16:10:48 <jgriffith> hemna: thingee some object, some taskflow etc
16:10:54 <hemna> but it seems like a significant change at this point
16:10:58 <jgriffith> hemna: well I don't think there's anyting "broken"
16:11:09 <thingee> jgriffith: my only concern is how many bugs have been popping up with the object stuff. Just worried about stuff getting in the release.
16:11:10 <jgriffith> hemna: but I hate having such inconsistency in our code base
16:11:19 <jgriffith> hemna: and blocking progress for a month or so
16:11:22 <thingee> sounds like we might have to revert back entirely? that might be sad though.
16:11:29 <jgriffith> thingee: only a couple right?
16:11:32 <jgriffith> bugs that is
16:11:36 <hemna> jgriffith, yah I get that too.
16:11:51 <jgriffith> and actually I think the default getter solved any issues I've seen
16:11:57 <thingee> jgriffith: have they been mostly in drivers? Accept my apologies, I have been just observing the surface of what's reported.
16:11:58 <jgriffith> anyway... just wanted to throw it out there
16:12:17 <hemna> I can remove the -2 if you want
16:12:21 <jgriffith> thingee: yeah, just drivers but I think my add will keep that from happening
16:12:26 <hemna> I'm just concerned about the changes it makes now
16:12:34 <jgriffith> thingee: so it's up to you all... I just wanted to throw it out there
16:12:42 <jgriffith> thingee: hemna if you guys think there's risk no worries
16:12:44 <thingee> jgriffith: ok, that's fair
16:12:45 <jgriffith> we can wait
16:13:13 <thingee> I was under the impression we were hitting problems left and right, but if it's just drivers, we should be paying attention to the CI's right?
16:13:20 <thingee> Which I think erlon brought up on the ML
16:13:33 <jgriffith> thingee: well, maybe I'm misinformed
16:13:49 <thingee> thangp: can you comment on the number of bugs that have been reported :P
16:13:53 <jgriffith> ok... ignore what I said :)
16:14:02 <thangp> thingee: I think we fixed mose of them
16:14:18 <thangp> thingee: and it was minor stuff, like getattr
16:14:30 <thingee> which jgriffith said his patch would take care of
16:14:37 <thangp> thangp: I have not seen anything major
16:14:38 <thingee> from preventing future problems
16:15:01 <thangp> thingee: correct, jgriffith patch fixed that
16:15:11 <thingee> fixed or is going to fix? did it already land?
16:15:21 <jgriffith> thingee: landed
16:15:22 <thangp> thingee: already landed and fixed it
16:15:24 <jgriffith> while ago
16:15:28 <thingee> jgriffith: oh ok
16:15:47 <thangp> thingee: which other bugs have there been?
16:16:21 <thangp> thingee: maybe we should tag them under "objects" or something to make it more identifiable
16:16:23 <thingee> hemna, jgriffith: If it leaves us in a half state and makes things bad for us that we would have to revert everything that's already merged, perhaps we can consider letting this merge if we're certain we won't have regression in drivers.
16:16:42 <thingee> hemna, jgriffith: do you mind if I leave it to you two for merge consideration today/tomorrow?
16:16:43 <hemna> thingee, yah
16:16:52 <hemna> it has a dep patch that needs to land first
16:17:39 <thingee> jgriffith: ?
16:17:52 <hemna> the dep patch looks like a bug fix
16:17:53 <jgriffith> thingee: yeah, that's fine
16:17:55 <hemna> I can review it today
16:18:20 <thingee> #action hemna and jgriffith to consider merging snapshot object patch
16:18:23 <thingee> thanks guys
16:18:26 <hemna> ok cool
16:18:32 <thingee> #topic Modifying existing migrations
16:18:34 <thingee> DuncanT: hi
16:18:41 <thingee> #link https://review.openstack.org/#/c/159854/
16:18:42 <DuncanT> Hi
16:19:07 <DuncanT> So we've had a long standing policy of not changing old migrations
16:19:20 <DuncanT> For the simple reason that some people might have run them
16:19:21 <thingee> DuncanT: is that the right link in the agenda?
16:19:34 <thingee> this looks like the utc change
16:19:51 <DuncanT> The UTC change makes some functional changes to migrations
16:20:10 <DuncanT> 3 of them
16:20:27 <thingee> DuncanT: got it
16:20:28 <e0ne> we could leave as is, but need to add a comment why it is not changed
16:20:49 <e0ne> and do not allow using not utc time in future migrations
16:20:56 <DuncanT> e0ne: Makes sense. '#noqa' should stop the hacking check from puking too
16:21:12 <e0ne> DuncanT: +1
16:21:21 <hemna> patch needs a rebase at least
16:21:37 <thingee> #info DuncanT thinks this looks fine, but needs more eyes
16:21:38 <e0ne> i prefer to change only functional parts in migration
16:21:46 <DuncanT> I'm not sure it actually causes any functional problems, but certainly we've been bitten by this sort of 'safe' change before, so I'd prefer to err on the side of safety
16:21:59 <e0ne> we should not allow to chage data format in old migrations
16:22:02 <thingee> we don't need to land this in k3 right?
16:22:11 <thingee> can we let this sit in gate l-1?
16:22:21 <DuncanT> It would be better to land it
16:22:24 <DuncanT> It is a real bug
16:22:28 <winston-d_> i thought it was volume migration...
16:22:31 <e0ne> DuncanT: we don't store  timezone so it shouln'd break anything
16:23:41 <DuncanT> e0ne: I *think* the change is safe, I'm just not sure
16:24:14 <avishay> winston-d_: :)
16:24:14 <e0ne> DuncanT: i've got your point. if it's not, we definatly should fix granade job
16:24:33 * thingee is going to say anything with schema migrations and time change this late is scary.
16:25:07 <DuncanT> e0ne: So leave it and #noqa in the migrations?
16:25:25 <e0ne> DuncanT: that is my point
16:25:55 <DuncanT> https://review.openstack.org/#/c/159854/12/cinder/db/sqlalchemy/api.py should be landed, I think, it solves a real bug
16:26:12 <DuncanT> e0ne: Ok, I'll update the review
16:26:37 <thingee> DuncanT: can we just have that piece then? This will look weird after upgrade?
16:27:02 <hemna> separate patch just for that guy ?
16:27:13 <hemna> DuncanT, is there a bug for that one specifically ?
16:27:14 <DuncanT> thingee: If we drop the 3 migration changes, the rest are just unit test cleanups - I'd rather merge them and get the hacking check in
16:27:16 <thingee> hemna: just of the sqlalchemy/api.py part
16:27:22 <hemna> thingee, yah
16:27:51 <thingee> sounds fine to me.
16:27:52 <DuncanT> https://review.openstack.org/#/c/159854/12/cinder/volume/drivers/zfssa/zfssanfs.py might or might not result in a real bug, I haven't looked
16:28:06 <thingee> DuncanT: still curious on upgrades though
16:28:07 <DuncanT> Any reason not to fix up the unit tests too?
16:28:18 <hemna> should be ok no ?
16:28:36 <thingee> I'm asking because I think you'll have some entries wit UTC and others aren't
16:28:41 <DuncanT> thingee: On upgrades, you just get a weird value in the the db... harmless I think
16:29:04 <DuncanT> thingee: The timezone doesn't seem to be stored in the db
16:29:16 <thingee> anyone else have concerns?
16:29:46 <e0ne> DuncanT: you're rigth. and the default value for datetime fields is datetime.utcnow()
16:29:49 <jungleboyj> So, entries in the DB would not be UTC before the upgrade?
16:29:53 <jgriffith> thingee: not yet :)
16:30:06 <thingee> I would prefer this not go in K-3, mostly because there are unknowns it seems and would like this to sit in gate.
16:30:36 <DuncanT> Missing k-3 is fine, missing the release is not IMO
16:30:49 <DuncanT> We've had this bug for a while, so it can't be /that/ major
16:30:53 <jgriffith> DuncanT: by definition you miss K3 you miss release
16:30:54 <jungleboyj> thingee: +1
16:30:56 <thingee> DuncanT: can't promise an RC though.
16:31:13 <jgriffith> If we get it in now we have plenty of soak time no?
16:31:31 <jgriffith> especially if we're "looking" at it
16:31:45 <thingee> I suppose this would be a reason to do an RC if we notice issues :)
16:31:54 <thingee> I just really want to know what happens with upgrades.
16:32:27 <jbernard> is there a possibility there will be no RC ?
16:32:42 <thingee> jbernard: sure in a perfect world.
16:32:42 <e0ne> thingee: by default, our models use utc timezone. current migrations use just datetime.now()
16:32:44 <winston-d_> jbernard: not really. :)
16:32:51 <jgriffith> jbernard: There's always one I think
16:33:06 <jgriffith> jbernard: the real question is can you have "only one" :)
16:33:20 <thingee> ok lets go ahead and merge it today. soak, revisit in RC.
16:33:41 <DuncanT> I'll update it not to change the migrations and rebase
16:33:49 <DuncanT> Should be done shortly
16:34:01 <thingee> DuncanT: anything else?
16:34:30 <DuncanT> Nope, thanks
16:34:32 <thingee> #topic Non-eventlet WSGI endpoint for cinder-api
16:34:34 <thingee> e0ne: hi!
16:34:37 <thingee> e0ne: +1000
16:34:42 <e0ne> thingee: hi
16:34:46 <thingee> #link http://lists.openstack.org/pipermail/openstack-dev/2015-February/057359.html
16:34:54 <thingee> #link https://review.openstack.org/#/c/142659/
16:34:59 <e0ne> one comment form my side
16:35:16 <e0ne> it is not about _removing_ eventlet from cinder-api
16:35:35 <e0ne> it's about addine one more option how could we deploy it
16:36:05 <thingee> #info this is not about removing eventlet from cinder-api, this is adding another option for deploying
16:36:07 <e0ne> DuncanT: pointed to me that it requires more tests for CI. I think we could do it in infra
16:36:20 <winston-d_> e0ne: I can understand why keystone choose not to use eventlet, given the history
16:36:26 <jgriffith> thingee: do we need more options :)
16:36:42 <jgriffith> thingee: especially ones we won't test?
16:37:00 <jgriffith> this makes sense for keystone, they have a different problem to solve
16:37:07 <e0ne> jgriffith: we will test it on gates, i hope
16:37:12 <jgriffith> trying to figure out what's in it for us, so to speak
16:37:14 <winston-d_> e0ne: but any real benefit adopting apache?
16:37:31 <jgriffith> e0ne: I dunno... look at ZMQ and other things like that
16:37:38 <thingee> morganfainberg: ^
16:37:39 <winston-d_> e0ne: test cinder with apache?
16:37:45 <e0ne> winston-d_: we've got process launcher now
16:37:59 <jgriffith> wouldn't be so sure it'll get tested... but still leaves the main question from me: "What's in it for us"
16:38:04 <e0ne> winston-d_:  and we need to use haproxy or something else
16:38:26 <winston-d_> e0ne: yes, i am well aware of that, so you were saying we should test multi Cinder workers in gate?
16:38:29 <e0ne> winston-d_:  apache/nginx + wsgi could be an option for deployment
16:39:04 <jgriffith> e0ne: is it a *better* option?
16:39:06 <e0ne> winston-d_:  it could be configured by devstack and we'll add new dsvm job
16:39:39 <e0ne> jgriffith: we could test performance in our case
16:39:39 <winston-d_> e0ne: you want apache/nginx option 'cos it works better with haproxy?
16:39:42 <jgriffith> e0ne: don't get me wrong, I wouldn't be sad to see eventlet replaced, but that's if it can be replaced :)
16:40:09 <jgriffith> winston-d_: ahhh.... that's the kind of thing I'm looking for
16:40:16 <e0ne> jgriffith: i'm talking only for wsgi app for cinder-api
16:40:41 <winston-d_> e0ne: yes, i'd like understand the pros/cons
16:40:43 <jgriffith> e0ne: hehe.. yeah, you prefaced the conversation with that and I ignored you :)  sorry
16:41:18 <jgriffith> either way this is after L opens up right... so I think we can talk more later or try some stuff
16:41:32 <jgriffith> probably not wort me rat holing on the details today :)
16:41:36 <jgriffith> wort
16:41:45 <thingee> #info have apache/nginx so cinder-api works better with haproxy
16:41:55 <jgriffith> ARRRR H key popped out again!!
16:42:01 * jgriffith needs to get a new keyboard today
16:42:01 <e0ne> :)
16:42:04 <thingee> jgriffith: +1
16:42:10 <winston-d_> thingee: well, that's a question from me...
16:42:18 <winston-d_> e0ne: is that true or not?
16:42:30 <flip214> jgriffith: vim without an "h" is _ard, right?
16:42:32 <e0ne> winston-d_, thingee: it depends
16:43:00 <hemna> flip214, :)
16:43:05 <e0ne> apache/nginx has more users than haproxy
16:43:11 <winston-d_> e0ne: so i need some education here, i appreciate if you can give me some pointers
16:43:14 <jgriffith> flip214: Exactly!!!
16:43:20 <jungleboyj> thingee: I need to step away.  Just a quick question.
16:43:37 <thingee> I'm going to assume that e0ne will have give a better arguement of why he wants to see this option in the spec.
16:43:41 <e0ne> so we could get more happy users to deploy it
16:44:04 <thingee> there doesn't seem to be a reason give atm
16:44:09 <thingee> given*
16:44:11 <e0ne> thingee: sure, i'll do it. could you please crate an action itom?
16:44:14 <e0ne> *item
16:44:48 <thingee> #action e0ne will create a spec that gives the actual reasons why a user would want another option for deploying cinder-api
16:44:59 <e0ne> thingee: thanks
16:45:06 <thingee> e0ne: anything else?
16:45:27 <thingee> jungleboyj: I'll circle back to your topic
16:45:32 <e0ne> thingee: thants all. i've got early feedback and could continue to work on it
16:45:43 <thingee> #topic  Bugs triage
16:45:45 <thingee> e0ne: hi
16:45:47 <jungleboyj> thingee: Ok, I actually need to leave.  So if you can just discuss it and I will catch up later.
16:45:53 <jungleboyj> Thanks.
16:45:53 <thingee> jungleboyj: k!
16:46:01 <e0ne> thingee: hi :)
16:46:11 <e0ne> i want just to remind all to do it
16:46:25 <thingee> so bug triage. I've been behind actually all this month. my bad
16:46:25 <e0ne> i'm going to spend next day for it
16:46:27 <jgriffith> did anybody else see the "quick question" ?
16:47:04 <jgriffith> Oh.. guess it's the question that he posed on agenda.... or thingee is psychic :)
16:47:07 <flip214> no, only the remark about the question
16:47:12 <jgriffith> physic
16:47:14 <jgriffith> BAHHHH
16:47:17 <e0ne> imo, 135 new bugs is too big number
16:47:23 <erlon> thingee: theres one more bug we would like to get in in this release, have created a bug, but not sure if it falls in any criteria to get it reviewed: https://bugs.launchpad.net/cinder/+bug/1430782
16:47:24 <openstack> Launchpad bug 1430782 in Cinder "Error on LUN creation on HNAS iSCSI driver" [Undecided,In progress] - Assigned to Erlon R. Cruz (sombrafam)
16:47:47 <thingee> e0ne: agreed. I was on top of this, but I had to step away earlier this month and do some reviews here and there. Had some personal issues that came up.
16:47:49 <kmartin> jgriffith, now the h key has moved?
16:47:55 <flip214> jgriffith: psychic was correct, wasn't it?
16:47:56 <thingee> although bug triaging shouldn't just be me :)
16:47:58 <jgriffith> kmartin: LOL
16:48:02 <jgriffith> flip214: yes
16:48:09 <e0ne> thingee: sure
16:48:27 <flip214> sorry, gotta go.
16:48:36 <e0ne> thingee: whats about send notification to openstack-dev?
16:49:09 <jgriffith> thingee: oh?
16:49:12 <thingee> e0ne: if you want to send something to the ML, that's fine, but I don't think it's necessary. We're already full alert on bugs. I think I just need to get back to it, and maybe others can pitch in
16:49:24 <e0ne> thingee: a lot of newcomers should be imformed:)
16:49:35 <hemna> So do we have to get all of those bugs fixed by K-3?
16:49:43 <thingee> hemna: haha
16:49:51 <hemna> or do we have leeway after for RC.
16:50:01 <thingee> hemna: we never have in any release
16:50:07 <hemna> I have one on my plate that I'm not sure I can get in by tomorrow.
16:50:14 <hemna> ok, I just wanted to be clear :)
16:50:17 <e0ne> hemna: after RC we should fix onli high/critical bugs, shouldn't we?
16:50:18 <thingee> hemna: I think what's important is at least triaging and understanding if we blockers
16:50:33 <e0ne> thingee: +1
16:50:35 <thingee> if we have blockers, bring it up in #openstack-cinder
16:50:44 <thingee> if we have blockers*
16:51:24 <e0ne> btw,  i have nothing to add to this topic.
16:51:31 <thingee> e0ne: heh ok
16:51:52 <thingee> so sure, I'll be doing some triaginag later in RC time frame.
16:52:00 <jgriffith> bugs are always fair game
16:52:08 <thingee> e0ne: you can send somethign out if you like
16:52:15 <jgriffith> up to thingee and core to weigh impact of the fix
16:52:16 <e0ne> thingee: ok, i'll do
16:52:21 <jgriffith> but never stop working on bugs
16:52:30 <thingee> just right now top priority to me are issues bugs in k3 we know about and security bugs
16:52:32 * jgriffith thinks maybe that's why we have so many bugs
16:52:55 <e0ne> jgriffith: i know few openstack newcomers that don't now anything about bugs triage.
16:53:09 <thingee> #action e0ne to email ML about bug triage in cinder
16:53:15 <erlon> e0ne: o/
16:53:23 <thingee> #topic Liberty Specs
16:53:30 <thingee> jungleboyj original proposed this
16:53:46 <thingee> I really want us to have a use case section in sepcs
16:53:48 <thingee> https://review.openstack.org/#/c/149449/
16:53:48 <jgriffith> Just say NO
16:54:07 <jgriffith> not regarding use cases... regarding L specs until we get to RC
16:54:08 <jgriffith> :)
16:54:19 <thingee> Not accepting Liberty specs right now. Would like to get through the K release atm
16:54:19 <DuncanT> jgriffith: +1
16:54:21 <thingee> jgriffith: +1
16:54:22 <e0ne> jgriffith: RC or K-3?
16:54:23 <hemna> jgriffith, you know what happened to that drug campaign, everyone ended up doing them.
16:54:23 <thingee> heh
16:54:27 <jgriffith> thingee: :)
16:54:29 <vilobhmm> thingee : about heirarchical multitenany do we have any plan for L release
16:54:41 <hemna> jgriffith, +1
16:54:55 <thingee> vilobhmm: if it's not security bugs in k-3, I don't know
16:54:57 <cebruns> jgriffith: I thought you were saying "No" to Liberty.  :)
16:55:01 <jgriffith> vivek-ebay: thingee I would like to work on that in L, or at least get it going
16:55:02 <e0ne> people could start working on it, but we'll give -2 without review
16:55:05 <thingee> vilobhmm: sec bugs are top priority right now
16:55:13 <vilobhmm> thingee : sure
16:55:25 <jgriffith> oops... vilobhmm ^^
16:55:37 <hemna> but we have other issues to iron out in L as well, replication, extra specs, nova -> cinder api issues, etc.
16:55:38 <vilobhmm> as you mentioned few weeks back got it
16:55:45 <vilobhmm> sure jgriffith
16:55:47 <hemna> I'd like to get those solved before we start working on new cinder features
16:56:01 <hemna> we seem to always churn on the new w/o solving some of our white elephants
16:56:04 <e0ne> hemna: agree
16:56:08 <jgriffith> hemna: :)
16:56:11 <vilobhmm> hemna : +1
16:56:13 <thingee> #topic Open discussion
16:56:22 <bswartz> I don't understand how there could be no RC
16:56:22 <morganfainberg> thingee: (a bit delayed) if you need help with wsgi (mod_wsgi etc) I can help or at least point you guys to resources in devstack and in the keystone tree for making it happen.
16:56:26 <hemna> but that's just my take on it.
16:56:30 <jgriffith> it's like ground hog day (the movie)
16:56:30 <bswartz> (12:30:56 PM) thingee: DuncanT: can't promise an RC though.
16:56:36 <hemna> jgriffith, yup
16:56:38 <thingee> bswartz: :)
16:56:39 <Swanson> "white elephants"?
16:56:39 <morganfainberg> Let me know when you're looking at it (or whomever is).
16:56:42 <e0ne> hemna: but i would like to get state machine or at least fault tolerance for all services in L
16:57:00 <thingee> morganfainberg: I think we were trying to understand why Cinder would need. while it's understood for keystone's use case.
16:57:19 <vilobhmm> eone : +1 for fault tolerance; need to have it before adding more features i feel
16:57:22 <thingee> morganfainberg: e0ne is proposing this right now, so he may reach out to you
16:57:26 <hemna> e0ne, I would like a lot of stuff for L.   it's up to the PTL really to help set the agenda...dunno.
16:57:41 <hemna> I just would like to see others step up and help fix some of our existing known issues first.
16:57:43 <e0ne> hemna: agree, it's fair
16:57:56 <hemna> but I'm one to talk....mr. multiattach. bleh
16:58:02 <morganfainberg> So for the api surface area, it allows Apache to manage the workers - and Apache does a good job of ssl termination. I can provide more details for e0ne when ready (down the line)
16:58:19 <thingee> morganfainberg: thanks
16:58:23 <morganfainberg> (Also no greenlet bugs in Apache wsgi mode)
16:58:35 <e0ne> morganfainberg: thanks! i'll ping you
16:59:54 <thingee> thanks everyone!
17:00:01 <thingee> #endmeeting