16:00:04 <thingee> #startmeeting cinder
16:00:05 <openstack> Meeting started Wed Apr 22 16:00:04 2015 UTC and is due to finish in 60 minutes.  The chair is thingee. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:08 <openstack> The meeting name has been set to 'cinder'
16:00:09 <Swanson> Hello.
16:00:14 <thingee> hi everyone!
16:00:16 <DuncanT> Hi
16:00:24 <rhe00> hi
16:00:31 <geguileo> Hi
16:00:33 <e0ne> hi
16:00:38 <xyang1> Hi
16:00:48 <vilobhmm1> Hello All !
16:00:49 <deepakcs> hello
16:00:51 <thingee> announcements!
16:00:51 <cebruns> Hi
16:00:54 <eharney> hi
16:00:56 <thingee> Common CI solution
16:00:58 <thingee> http://lists.openstack.org/pipermail/openstack-dev/2015-April/061929.html
16:01:16 <thingee> This is of interest in our group from asselin
16:01:55 <jungleboyj> o/
16:01:57 <tbarron> hi
16:02:08 <thingee> recommend interested in parties in helping improve our common CI solution for third parties to reach out to asselin to contribute
16:02:22 <winston-d_> o/
16:02:25 <thingee> ok lets get started with the meeting
16:02:34 <vilobhmm1> sounds like a good idea the common ci soln
16:02:38 <hemna> mornin
16:02:39 <thingee> #link https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting
16:02:44 <avishay> hola
16:02:48 <cebruns> 85 3rd part CIs registered? wow...
16:02:55 <thingee> #topic Cinder Liberty Midcycle Meetup Planning
16:03:04 <thingee> #link https://etherpad.openstack.org/p/cinder-liberty-midcycle-meetup
16:03:23 <thingee> we don't have a plan
16:03:35 <thingee> should get a place/date figured out soon
16:03:39 <e0ne> when do we plan to have it?
16:03:48 <hemna> we might be able to host it here in CA
16:03:53 <deepakcs> that etherpad is not opening for me
16:03:54 <winston-d_> can't wait until design summit?
16:03:58 <hemna> I've spoken with my mgr in the past about it.
16:04:01 <winston-d_> hemna: that'll be nice
16:04:13 <hemna> I'll have to ping him again to make sure
16:04:39 <thingee> when did we have the fort collins one?
16:04:44 <jungleboyj> thingee: The sooner the better.
16:04:57 <hemna> we did fort collins the first time around, last year
16:05:03 <hemna> I don't mind going back! :)
16:05:11 <hemna> my fly rod can come with me there. :P
16:05:14 <jgriffith> *fish on*
16:05:28 <DuncanT> Certainly happy to host in FC again if that sorts people
16:05:29 <cebruns> Mid-late August seems about right
16:05:31 <thingee> was trying to remember the date of the midcycle then
16:05:40 <thingee> got it
16:05:44 <jungleboyj> For Collins worked great as well.
16:05:44 <vilobhmm1> jan 25th or 27th
16:05:47 <thingee> cebruns: hey!
16:05:57 <thingee> was hoping you were going to show up to this topic :)
16:06:02 <vilobhmm1> was the one for fort colling if i remember
16:06:19 <thingee> vilobhmm1: I think that was Kilo midcycle
16:06:28 <vilobhmm1> oh ok
16:06:34 <cebruns> Yep - was thinking we could host, but Intel CO site is going through renovations (no big conference rooms)
16:06:40 <jgriffith> vilobhmm1: nahh... it was summer 8/10/14
16:06:55 <cebruns> Don't think people want to do Phx in August.  :)
16:06:55 <thingee> jgriffith: thanks
16:07:07 <hemna> lol
16:07:07 <jungleboyj> Yeah, looks like it was that first week in August.
16:07:13 <thingee> cebruns: ha yeah not so much
16:07:15 <vilobhmm1> jgriffith : oh okay
16:07:15 <hemna> yah, Phx is warm in August.
16:07:19 <asselin> o/
16:07:27 <thingee> maybe M midcycle
16:07:54 <jungleboyj> cebruns: No thank you.
16:07:59 <hemna> we could 'save' Roseville, CA for winter midcycle meetup
16:08:01 <thingee> ok so wanted to put that out there. I would like to have things figured out soon so I can coordinate with other projects.
16:08:04 <jungleboyj> Phx in January, yes.
16:08:05 <hemna> wx here usually isn't bad.
16:08:14 <thingee> last time we had people who were sad nova's was happening the same time as Cinder
16:08:56 <winston-d_> thingee: which is bad?
16:08:58 <thingee> it would be great if I could delegate this to someone like jungleboyj did last time. ;)
16:09:04 <hemna> shouldn't be too hard to coordinate it w/ the Nova meetup
16:09:24 <jungleboyj> thingee: You want me to lead this again?
16:09:38 <DuncanT> Is scottda about?
16:09:40 <jungleboyj> thingee: Or looking for someone to step up and run it for their site?
16:09:41 <hemna> jungleboyj, can I put in a request for wifi this time around?
16:09:47 <jungleboyj> hemna: :-p
16:09:49 <hemna> :P
16:09:51 <thingee> so whoever can offer a spot. please add it to the etherpad and we'll revisit and decide next week maybe?
16:10:13 <e0ne> i'll ask my manager this week
16:10:18 <hemna> ok I'll ping my mgr about it and see.
16:10:27 <jungleboyj> DuncanT: Yeah, scottda did a great job!
16:10:27 <e0ne> we've got office in Mounting View, CA
16:10:27 <cebruns> I'd like to help out where possible though for L midcycle - at least get a dinner on the books or something...
16:10:28 <avishay> i am not even offering :)
16:10:29 <rhe00> I'll ask here in Colorado Springs as well
16:10:30 <winston-d_> e0ne: In Mascow, yes!
16:10:42 <e0ne> winston-d_: Kharkiv or Lviv:)
16:10:53 <DuncanT> jungleboyj: He/we are happy to host again
16:10:55 <vilobhmm1> me too will ask
16:10:55 <thingee> yes also people who can host dinners, please feel free to list those in the etherpad as well
16:11:06 <esker> How big of a facility is needed?
16:11:10 <jungleboyj> thingee: Yeah, I can check into that again.
16:11:12 <hemna> we have good beer here in Roseville
16:11:18 <esker> How many people in one room?  Any need to have breakout rooms?
16:11:20 <thingee> hemna: +1
16:11:21 <DuncanT> avishay: We could sort something between us?
16:11:26 <jungleboyj> hemna: I have heard.  :-)  Now we are talking about the important stuff.
16:11:29 <thingee> jungleboyj: how many were at the last meetup?
16:11:31 <hemna> :)
16:11:41 <scottda> hey
16:11:44 <avishay> DuncanT: i don't think many will get travel approval :)
16:11:47 <jungleboyj> ~28 ... Let me double check.
16:11:57 <thingee> esker: ^
16:12:01 <esker> jungleboyj: thx
16:12:14 <thingee> ok good, conversations started.
16:12:35 <esker> thingee: I'll add to the etherpad if I can confirm one of our locations... want to validate we can get various IT network types to agree before I do so though...
16:12:51 <jungleboyj> thingee: 21
16:12:53 <thingee> esker: yes wifi was lacking at the last meetup
16:12:54 <tbarron> good beer should be an ingredient in the weighing function for this decision
16:12:56 <esker> They tend to be rather intractable about things...
16:13:04 <jungleboyj> tbarron: +2
16:13:10 <e0ne> tbarron: +A
16:13:12 <thingee> we all had to tether to jungleboyj's phone
16:13:16 <DuncanT> tbarron: +2/A
16:13:23 <vilobhmm1> :)
16:13:24 <cebruns> Ft. Collins has many breweries... :)
16:13:32 * jungleboyj sighs
16:13:35 <smcginnis> +1
16:13:39 <jungleboyj> Hey, it worked.
16:13:42 <xyang1> jungleboyj: How much did you get charged last time?
16:13:44 <avishay> beer is a weight function, not filter? :)
16:13:45 <thingee> jungleboyj: never going to let that go. we can laugh about it now
16:13:48 <smcginnis> jungleboyj: You pulled it off.
16:13:52 <xyang1> jungleboyj: :)
16:14:01 <jungleboyj> xyang1: It was all in my plan.  :-)
16:14:03 <esker> potential NetApp locations I might be able to offer up... Austin, TX,  Raleigh, NC, Sunnyvale, CA
16:14:07 <jungleboyj> They did eventually fix it a few weeks later.
16:14:12 <esker> any preferences?
16:14:17 <winston-d_> avishay: temperature is the filter
16:14:23 <thingee> #action to send announcement on dev ML for midcycle meetup planning
16:14:23 <avishay> winston-d_: :)
16:14:25 <hemna> I'd like to see the east coast.  NC
16:14:28 <esker> FWIW, Ft. Collins has the beer thing covered rather well  :-)
16:14:29 <winston-d_> avishay: they already filtered out PHX for summer
16:14:30 <hemna> :P
16:14:32 <tbarron> esker: I can find good beer in Austin or Raleigh for sure
16:14:36 <cebruns> :)
16:14:36 <thingee> #action thingee to send announcement on dev ML for midcycle meetup planning
16:14:40 <avishay> winston-d_: sounds about right
16:14:42 <DuncanT> esker: I hear the NetApp Tel Aviv office is nice, right on the beach
16:14:50 <smcginnis> DuncanT: :D
16:15:02 <esker> DuncanT: true... beach volleyball at lunch...
16:15:03 <avishay> DuncanT: I will never get travel approval for that
16:15:07 <smcginnis> Haven't been to NC yet.
16:15:15 <e0ne> DuncanT, esker: and it's not too far for me:)
16:15:15 <DuncanT> Austin is... not pleasant... in the summer though, right??
16:15:28 <smcginnis> Yeah
16:15:28 <avishay> DuncanT: neither is tel aviv
16:15:28 <esker> DuncanT: this is true
16:15:30 <tbarron> avishay: :-)
16:15:36 <smcginnis> NC or CA would be my preference.
16:15:55 <thingee> #topic OpenStack Liberty Summit Proposals
16:15:57 <winston-d_> avishay: for Tel Aviv, can you just walk there?
16:16:03 <jungleboyj> smcginnis: Or CO again.
16:16:11 <thingee> #link https://etherpad.openstack.org/p/cinder-liberty-proposed-sessions
16:16:18 <smcginnis> Actually, CO would probably be my top preference.
16:16:22 <thingee> I have listed the number of slots available in each
16:16:27 <avishay> winston-d_: 10 minute drive
16:16:32 <thingee> fish bowl, working session, sprints
16:16:42 <winston-d_> avishay: nice
16:16:44 <scottda> HP can host in Fort Collins for sure...I'll look into free beer from the local breweries.
16:16:53 <hemna> well put the locations on the etherpad
16:16:56 <scottda> (not kidding about the beer, I've connections)
16:16:57 <smcginnis> scottda: ++++1 :)
16:17:00 <e0ne> thingee: what is sprint slot? something like at pycon?
16:17:04 <hemna> scottda, lol!
16:17:04 <smcginnis> CO it is. Hah
16:17:15 <cebruns> LOL
16:17:20 <thingee> e0ne: it's suppose to be a time for us to actually do work, while everyone is present
16:17:32 <e0ne> :)
16:17:33 * jungleboyj will bring my wifi jammer to even the playing field. ;-)
16:17:40 <smcginnis> :)
16:18:03 <thingee> also we can have talks like we did in paris where we talk about mock, or certain ide's, etc.
16:18:18 <thingee> it's the slots for everything else basically.
16:18:23 <thingee> and will last throughout friday
16:18:29 <e0ne> i've missed these talks:(
16:18:31 <hemna> you can work and drink beer at the same time right ?
16:18:39 <avishay> jungleboyj: :)
16:18:47 <thingee> hemna: sure
16:18:48 <e0ne> hemna: sure
16:18:53 <hemna> ok phew
16:19:05 <rhe00> thingee: are these slots spread out Tuesday - Friday during the summit?
16:19:27 <jungleboyj> hemna: Heck yeah.
16:19:45 <thingee> rhe00: that was my understanding yes. So fish bowl is good to get user's opinions and will be the normal larger audience sessions we've had in the past.
16:20:09 <rhe00> thingee: ok
16:20:25 <thingee> working sessions will be more low key. mainly hashing out internal bits to things users may or may not really care about
16:20:32 <thingee> it will be a smaller room for sure.
16:20:42 <smcginnis> So we have more working sessions than slots proposed. What's the process for selection?
16:21:00 <thingee> so everyone who proposed a topic, please keep that in mind and move things around if necessary. I think some of the ones under working session have catchy titles
16:21:03 <e0ne> smcginnis: voting!
16:21:03 <thingee> like live migration
16:21:16 <vilobhmm1> thingee : ok thanks for the clarification knowing diff between fish bowl and sprint was nice
16:21:36 <vilobhmm1> %s/sprint/working session i mean
16:22:06 <thingee> smcginnis: yeah last time I kind of just discussed each one with people and we merged things, decided on other topics that might be more important to discuss in person and what made sense for the Friday only topics
16:22:29 <smcginnis> thingee: Did that work well? Seemed good as an attendee.
16:23:05 <thingee> smcginnis: yes the friday meetup/sprint thing was a success I thought. The room was packed for Cinder and people could barely hear me
16:23:18 <thingee> that's going to be addressed this time. because well, people need to hear me.
16:23:20 <smcginnis> thingee: Yeah, that room was loud.
16:23:33 <jungleboyj> Yeah, that was good but the room was not.
16:23:39 <hemna> it was basically useless in that room.
16:23:50 <thingee> should have a dedicated room this time
16:24:03 <jungleboyj> hemna: We should have just started our own party on our side of the room.
16:24:16 <hemna> bring a keg, boom box.
16:24:17 <vilobhmm1> thingee : have a suggestion; can we merge topics that address the same problem and have a bunch of us who are working on similar problem propose a combined session…i feel that way content of the talk will also be richer and we can cover different problem rather than different varient of smae problem ?
16:24:23 <cebruns> need to bring a bullhorn?
16:24:29 <jungleboyj> Thought it was fun to watch DuncanT go over and stare at the other group.
16:24:30 <thingee> vilobhmm1: yes please
16:24:40 <thingee> jungleboyj: lol
16:25:29 <thingee> ok so please keep this all in mind and merge, move stuff around. Next meeting we will be finally deciding on things.
16:25:38 <vilobhmm1> ok cool
16:25:41 <thingee> also leave your name next to a topic so I know who is leading this
16:25:49 <thingee> and so I can coordinate with you
16:25:57 <thingee> anyone else want to add something to this?
16:26:00 <cebruns> Seems like some sessions might be good as fishbowl, like: Asyncronous Error Reporting to the end user
16:26:13 <thingee> #action thingee to start clean up before next Cinder meeting to decide on topics
16:26:24 <jungleboyj> cebruns: Yeah, that might be a good thougyht.
16:26:29 <winston-d_> cebruns: but that's rather technical actually
16:26:30 <thingee> #action thingee to send reminder the Dev ML on decisions happening next week
16:27:09 <cebruns> winston-d_: Ok - was just judging by the title.
16:27:23 <thingee> winston-d_: would you benefit from some parts getting user feedback?
16:27:51 <DuncanT> winston-d_: There's no point designing the technical side until we know what sort of errors should go, if any
16:28:12 <DuncanT> winston-d_: There's never been any agreement at all on that...
16:28:47 <thingee> I would say getting user feedback and then working out more technical stuff on friday
16:28:49 <winston-d_> DuncanT: well, yeah, I have to agree.
16:29:02 <vilobhmm1> thingee : one quick question if we don't get enough fish bowl slots or something like that can the extra slots be moved to proposed working sessions :)
16:29:05 <cebruns> thingee: Are we locked on 5 fishbowls and 8 working?  I remember some talk about moving those numbers.
16:29:12 <thingee> we can still discuss technical stuff at the fish bowl...
16:29:17 <vilobhmm1> entries for fish bowl session
16:29:32 <vilobhmm1> ok
16:29:36 <thingee> cebruns: yeah, I'll give up some fishbowl sessions if we don't use them
16:29:40 <jungleboyj> We can also use some of the sprint time to hit things that we don't get to in Working sessions.  Right?
16:29:54 <thingee> vilobhmm1: I could see, but might drive ttx crazy
16:30:12 * ttx is alreday high on steroids
16:30:21 <jgriffith> LOL
16:30:25 <tbarron> jungleboyj: +1
16:30:27 <vilobhmm1> haha
16:30:31 <ttx> sleep deprivation probably
16:30:40 <jungleboyj> :-)
16:30:44 <winston-d_> ttx: get some fish oil :)
16:30:52 <thingee> jungleboyj: yes
16:30:54 <ttx> I'll get A BEER NOW
16:31:02 <jungleboyj> ttx +2
16:31:11 <cebruns> IMHO: probably better to keep fishbowls (as a sign that we want user feedback/input) and make them more technical if needed.
16:31:25 <jungleboyj> cebruns: +2
16:31:27 <thingee> the popular word in today's meeting is beer apparently..
16:31:33 <winston-d_> cebruns: +1
16:31:45 <jgriffith> thingee: I was noticing that
16:31:46 <jungleboyj> thingee: We should make it into a drinking game.
16:31:56 <cebruns> LOL - should've brought up mid-cycle last.  :)
16:32:14 <thingee> ok, anything else for this topic?
16:32:15 <hemna> thingee, what's your point?
16:32:17 <hemna> :P
16:32:30 * thingee has no point
16:32:31 <kmartin> could the "Volume Migration: Current state and future direction" be moved to a fish bowl session
16:32:57 <winston-d_> kmartin: could be conference session
16:33:03 <DuncanT> kmartin: Are the problems interface or implementation?
16:33:04 <jungleboyj> kmartin: I don't see why not.
16:33:24 <thingee> how about live migration?
16:33:28 <jungleboyj> DuncanT: I think that is an area that has caused a lot of user confusion.
16:33:38 <kmartin> it in the working session now and I know it a big issue with users
16:34:02 <DuncanT> jungleboyj: kmartin: If it's a user issue then moving it sounds sensible
16:34:03 <winston-d_> jungleboyj: would you or vincent lead that one (migration)?
16:34:03 <kmartin> and live migration
16:34:25 <DuncanT> Also, can I request people try to get their outlines up well before the conference? Analysing a design cold has turned out to be a disaster, year on year
16:34:27 <hemna> live migration always seems to be in a perpetual state of failure.
16:34:31 <jungleboyj> winston-d_: Vincent I believe since he has been actively working those issues.
16:34:49 <thingee> would like to see jgriffith and ameade on the live migration topic
16:35:24 <kmartin> thingee, +1 push live migration was recently added to the gate
16:35:43 <thingee> ameade: you present?
16:36:16 <kmartin> not sure if the live migration tests were written in a way to have block storage attached
16:36:25 <xyang1> kmartin tests added on the nova side?
16:36:30 <winston-d_> jungleboyj: ok
16:36:30 <thingee> ok, well I'll talk to ameade later about it.
16:36:36 <kmartin> xyang1, yes
16:36:45 <jungleboyj> winston-d_: Will verify with him.
16:36:50 <tbarron> thingee: ameade has a conflicting mtg today but I'll follow up with him
16:37:09 <tbarron> thingee: I'll follow up with ameade
16:37:11 <thingee> tbarron: thanks. just would like to see this maybe be a fishbowl instead
16:37:40 <thingee> and maybe jgriffith can help out since he has a popular blog post about it ;)
16:37:43 <tbarron> thingee: understood
16:37:54 <thingee> #topic Open Discussion
16:38:14 <xyang1> kmartin: That will involve 2 compute nodes
16:38:36 <jgriffith> kmartin: the problem is you have to have multinode to test live-migratoin
16:38:46 <jgriffith> kmartin: and we don't have multi-node gate testing currently
16:39:02 <flip214> as people with block storage transport protocols know...
16:39:11 <jgriffith> kmartin: did live-migration break again?  I patched Kilo and Juno
16:39:15 <xyang1> jgriffith: Makes sense.  I was wondering about it
16:39:17 <kmartin> I believe jogo added this ability recently, I'll look for the patch
16:39:20 <jgriffith> kmartin: but that was a couple months ago
16:40:00 <jgriffith> kmartin: he's working on it yes, but it's not gating as of yet
16:40:10 <jgriffith> kmartin: but I'm still confused, is there a new bug/problem again?
16:40:36 <jgriffith> kmartin: NM, I guess I'll just set it up and test it on my side again
16:40:57 <thingee> ok seems like we have no open discussions
16:41:10 <kmartin> jgriffith, on some backend yes, others work fine
16:41:15 <xyang1> jgriffith: Which did you test with?  LVM?
16:41:29 <jgriffith> kmartin: xyang1 I tested with LVM and of course SF
16:41:29 <hemna> thingee, so if no one else has an open topic, I have one.
16:41:35 <xyang1> Ok
16:41:37 <thingee> hemna: sure
16:41:37 <jgriffith> kmartin: xyang1 so iSCSI in general works
16:41:39 <vilobhmm1> jgriffith, thingee : there was a review posted by jgriffith on seperating unit tests under tests/unit so going ahead whats the plan ? we seperate out unit and functional tests or anything else ?
16:41:58 <jgriffith> vilobhmm1: yeah, the idea is to split those
16:41:59 <thingee> vilobhmm1: yeah did that merge yet?
16:42:01 <hemna> jgriffith, there are a few assumptions that nova makes during live migration that causes failures
16:42:03 <jgriffith> vilobhmm1: and add functional tests
16:42:16 <jgriffith> vilobhmm1: I have a slew of functional tests to start with once things land
16:42:28 <jgriffith> hemna: there are a lot of assumptions :)
16:42:34 <hemna> nova assumes the target information is always the same for the 2 initiator hosts
16:42:42 <jgriffith> hemna: and there are several that I fixed, and others on the Nova team fixed
16:42:58 <vilobhmm1> i think it needs few https://review.openstack.org/#/c/175583/ +2 before it again runs into merge conflict :P
16:43:17 <jgriffith> hemna: ummm
16:43:25 <hemna> it assumes the target portal, ip and lun id are going to be the same between the first host and the 2nd host, when for some arrays, those values will be different
16:43:39 <vilobhmm1> jgriffith : thanks for letting me know
16:43:45 <jgriffith> hemna: it's the same volume and we don't do multi-attach so why would it be different?
16:43:56 <jgriffith> hemna: the iqn is stored in the Volume DB object
16:44:05 <jgriffith> hemna: that shouldn't change that I'm aware of
16:44:14 <hemna> not all arrays export volumes the same way.   it might not even be the same LUN id on the array for host 1 vs. host 2
16:44:22 <hemna> and in fact it does for 3PAR
16:44:34 <jgriffith> hemna: well... they kinda have to :)
16:44:49 * jungleboyj needs to drop.  Back on in a little while.
16:44:50 <jgriffith> hemna: I mean, unless you go back and recall attach
16:44:50 <thingee> hemna: can't nova just login instead of doing an additional export?
16:44:54 <xyang1> hemna: For us, everything is different on a different host
16:44:55 <thingee> hemna: or ensure export
16:45:01 <hemna> so when nova attaches the volume to the 2nd host, it then tries to detach from the original host, and it can't find the volume to detach
16:45:23 <jgriffith> hemna: I'm pretty familiar with how it works and what it does :)
16:45:24 <hemna> because it's using the information for the destination host (as the BDM has been updated after the destination attach)
16:45:33 <xyang1> hemna: But live migration worked last time we tested it.  Broken again?
16:45:33 <ameade> o/
16:45:37 <jgriffith> hemna: I'm just trying to understand what's broke :)
16:45:40 <hemna> the bdm information is wrong on detach
16:45:50 <jgriffith> hemna: as of when?
16:45:51 <hemna> anyway, we can take this offline
16:46:05 <thingee> hemna: was this your open topic? :P
16:46:10 <hemna> thingee, no
16:46:10 <hemna> heh
16:46:18 <xyang1> hemna: I thought that was fixed?
16:46:24 <hemna> xyang1, nope
16:46:25 <jgriffith> xyang1: +1
16:46:31 <hemna> xyang1, we see it today
16:46:40 <jgriffith> hemna: that's weird, because it's been tested by multiple people
16:46:49 <xyang1> hemna: Your team tested it in Juno?
16:46:50 <jgriffith> hemna: hmm... bummer, ok.  I'll test it again
16:47:01 <xyang1> hemna: Maybe broken again?
16:47:12 <hemna> if the target portal, and lun id is the same from the 2 attaches, it will be fine
16:47:23 <jgriffith> xyang1: hemna so FWIW the backport to Juno did finally land.  Took a long time, but it landed
16:47:25 <hemna> if it changes on the 2nd attach, it breaks.
16:47:37 <hemna> I'll confirm here again today just to make sure.
16:47:48 <thingee> hemna: your topic? :)
16:47:57 <xyang1> hemna: Are you testing in trunk or another release?
16:48:07 <hemna> we tested in kilo
16:48:17 <hemna> haven't tested on truck in a few weeks
16:48:35 <hemna> thingee, so, how are we going to do CI with os-brick
16:48:36 <hemna> :P
16:48:53 <hemna> we need to make sure that when os-brick patches get pushed up to gerrit, that cinder CI tests get fired off
16:49:06 <hemna> because it affects copy volume <--> image operations against each driver.
16:49:24 <hemna> I want to make sure that os-brick changes don't break cinder
16:49:57 <thingee> that's a good question
16:50:05 <kmartin> xyang1, jgriffith: a few defects regarding the identical IQNs and luns issues https://bugs.launchpad.net/nova/+bug/1423772 & https://bugs.launchpad.net/nova/+bug/1288039
16:50:05 <openstack> Launchpad bug 1423772 in OpenStack Compute (nova) "During live-migration Nova expects identical IQN from attached volume(s)" [Medium,Confirmed]
16:50:05 <asselin> i think we can do it by manually pulling in the cinder patch that remove's brick and uses os-brick
16:50:06 <openstack> Launchpad bug 1288039 in OpenStack Compute (nova) "live-migration cinder boot volume target_lun id incorrect" [High,Confirmed] - Assigned to Bartosz Fic (bartosz-fic)
16:50:44 <hemna> asselin, do we need to always have Depends-On: ASDASD131231231  in commit messages for os-brick?
16:50:53 <hemna> not sure if that does anything though for CI
16:51:02 <xyang1> kmartin: thanks.  We'll test again
16:51:07 <asselin> hemna, I don't think that's sufficient b/c the cinder code won't use it
16:51:34 <hemna> ok
16:51:44 <asselin> hemna, oh, you mean the os-brick patch has depends-on cinder patch that removes brick?
16:51:51 <hemna> I'd like to get it ironed out before my cinder patch to remove cinder/brick lands
16:51:59 <hemna> asselin, no
16:51:59 <asselin> hemna, that may work
16:52:31 <hemna> asselin, I just want a way to kick off 3rd party CI tests on os-brick patch submissions
16:52:32 <kmartin> jgriffith,seems that are making progress on multi-node gate https://review.openstack.org/#/c/173614/ & https://review.openstack.org/#/c/141530/ two that landed might be more
16:52:42 <hemna> but make cinder use the os-brick patch as part of the tests.
16:52:54 <hemna> to make sure that 1) Cinder doesn't break and 2) drivers don't break.
16:53:36 <asselin> yes...I think my 1st proposal would work: run ci on each os-brick patch. then in cinder, for that job, cherry pick the cinder patch removing os-brick.
16:53:50 <asselin> assumes no cherry pick conflicts
16:54:08 <hemna> asselin, is this something that we can do w/o making every 3rd party CI vendor do?
16:54:24 <hemna> and by we, I mean...cinder or infra ?
16:54:51 <asselin> hemna, yes...maybe good to see if we can get an infra job on it
16:55:01 <thingee> 5 minute warning
16:55:01 <asselin> and any 3rd party ci who's interested
16:55:36 <hemna> well every 3rd party driver IS interested whether they know it or not :)
16:56:17 <tbarron> hemna: +1
16:56:21 <hemna> ok I'm not sure I'm understanding how it can be done just yet
16:56:33 <thingee> hemna: lets talk about it later today
16:56:37 <hemna> but I'm just concerned.   os-brick's tests are simple right now.  they are just unit tests and pep8
16:56:45 <ameade> just sounds like another project to run against for me and should be added as a CI req at some point
16:56:45 <hemna> thingee, ok please.
16:56:46 <asselin> yes, let's take it offline
16:57:05 <thingee> anything else from anyone?
16:57:48 <thingee> oh in case people didn't notice, os-brick 0.1.0 was tagged. issues with the job to make the pypi release happen. I'll be checking with infra later when things aren't hectic
16:58:05 <thingee> I'll also be approving more cinderclient changes today to get ready for the next tag release
16:58:19 <thingee> which includes version discovery!
16:58:34 <thingee> and backwards compat. messy stuff
16:58:36 <hemna> :)!
16:58:53 <thingee> thanks everyone
16:58:55 <thingee> #endmeeting