16:00:01 <thingee> #startmeeting cinder
16:00:01 <openstack> Meeting started Wed May 13 16:00:01 2015 UTC and is due to finish in 60 minutes.  The chair is thingee. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <openstack> The meeting name has been set to 'cinder'
16:00:22 <thingee> Hi everyone!
16:00:27 <tbarron> howdy
16:00:28 <geguileo> Hi!
16:00:28 <xyang1> Hi
16:00:29 <smcginnis> Morning!
16:00:29 <rhedlind> hi
16:00:35 <patrickeast> hi
16:00:35 <scottda> Hi
16:00:43 <Swanson> Hello.
16:00:47 <e0ne> evening:)
16:00:50 <adurbin_> hi
16:00:59 <thingee> Well my laptop decided to just not work at this convenient time. Reporting from my phone.
16:01:05 <thingee> Yay technology.
16:01:12 <asselin> hi
16:01:26 <jungleboyj> Hello!
16:01:30 <smcginnis> Not another summit without a laptop. :)
16:01:31 <DuncanT> lo
16:01:33 <thingee> Usually I start with announcements but I'll do those last, hopefully once my laptop is working.
16:01:50 <jungleboyj> thingee: Summits are bad for your laptop.
16:01:54 <DuncanT> HP do some nice tablets....
16:02:03 <Swanson> I prefer Dells.
16:02:04 <thingee> Let's start with the first agenda item for the liberty mid cycle meet up.
16:02:16 <winston-d> o/
16:02:19 <jungleboyj> Swanson: Thinkpads all the way!
16:02:19 <DuncanT> Ok
16:02:21 <thingee> #topic liberty mid cycle meetup results
16:02:23 <jgriffith> thingee: http://goo.gl/E4DoUy
16:02:24 <thingee> DuncanT: hi
16:02:53 <DuncanT> Survey says: Dates are nearly tied, with a slight preference for the earlier date
16:02:55 <thingee> jgriffith: lol
16:02:59 <vilobhmm1> hello all
16:03:28 <DuncanT> Location is also nearly tied, FC wins by two votes
16:03:39 <jgriffith> sweet!
16:03:39 <asselin> were are the results?
16:03:47 <smcginnis> DuncanT: How many times did you vote. ;)
16:03:55 <DuncanT> smcginnis: zero
16:04:12 <rhedlind> what about wifi? :)
16:04:12 <hemna> yo
16:04:22 <jungleboyj> rhedlind: :-p
16:04:30 <smcginnis> rhedlind: We know it works in FC at least.
16:04:31 <DuncanT> asselin: I'll post them up to a spreadsheet later, I don't seem to be able to just make them public
16:04:43 <hemna> where are the results ?
16:04:50 <DuncanT> Wifi is apparently either very important, not funny or a reason for tears
16:04:52 <asselin> DuncanT, how about openstack paste?
16:05:00 <DuncanT> asselin: Working on it
16:05:20 <jungleboyj> Jennifer was glad to see you hadn't forgotten she couldn't get the wireless working.
16:05:37 <vilobhmm1> where r the results ? are we planning to have hangout sessions or some remote video conf session for people who will be remote and can't make it
16:05:41 <jungleboyj> DuncanT: There was one vote that it wasn't required.
16:05:43 <jungleboyj> ;-)
16:05:54 <vilobhmm1> :P
16:06:00 * thingee has his laptop back
16:06:03 <jungleboyj> vilobhmm1: I am sure we will do Hangout again.
16:06:13 <jungleboyj> thingee: Yay!
16:06:18 <vilobhmm1> that helps..so that everyone can learn and contribute
16:06:19 <DuncanT> jungleboyj: Two people say we should abuse your phone bill again
16:06:26 <thingee> #action DuncanT will post results and link to it from the original OpenStack dev ML post
16:07:06 <scottda> So when will a decision be made? Do we need to look at the survey first?
16:07:16 <thingee> ok great so Fort Collins, and aug 3-5?
16:07:34 <jungleboyj> DuncanT: +2
16:07:40 <winston-d> and no wifi, no beer? ;)
16:07:44 <scottda> There was a query on the etherpad for extending an extra day.
16:07:52 <thingee> scottda: that was me
16:07:58 <jungleboyj> winston-d:  Bite your tongue!  There must be beer!
16:08:01 <adurbin_> +1 on an extra day
16:08:05 <hemna> wait, hold on...no beer?
16:08:07 <hemna> wth
16:08:09 <smcginnis> thingee: Optional extra day would be nice.
16:08:10 <thingee> I thought it would be great if just like at the summit, we had a day for sprints
16:08:12 <scottda> It's fine from a standpoint of hosting to extend to Aug 6th.
16:08:30 <thingee> while we're all motivated after discussions
16:08:51 <scottda> Don't spread rumours about running out of beer. That will not be a problem.
16:08:56 <thingee> I think the only person that couldn't make the early date was jungleboyj \
16:08:59 <deepakcs> o/
16:08:59 <thingee> :(
16:09:16 <jungleboyj> To be clear, are we going to do like we did in the past where Monday is a day to travel and the real action is 4,5,6 and maybe 7?
16:09:35 <smcginnis> I like that plan.
16:09:52 <scottda> +1 to 4-6 plus maybe 7th
16:09:53 <thingee> jungleboyj: +1
16:10:24 <jungleboyj> Ok, that helps.  Hopefully we can get the girl watching my boys to do one over night so I can fly out Monday.
16:10:32 <hemna> isn't Friday a fishing day in Fort Collins ?
16:10:33 <adurbin_> jungleboyj: +1
16:10:41 <scottda> Every day is a fishing day
16:10:42 <jungleboyj> Worst case scenario I will have to come in on Tuesday.
16:10:54 <rhedlind> scottda: +1
16:11:09 <thingee> ok so sounds like people are fine with these dates?
16:11:09 <hemna> scottda, +1
16:11:14 <thingee> and location
16:11:24 <thingee> assuming we have someone who can host in the area again
16:11:30 <hemna> so who is hosting in Fort Collins ?
16:11:33 <hemna> :P
16:11:36 <jungleboyj> thingee: I will make it work.
16:11:36 <scottda> I've planned on it
16:11:42 <scottda> hosting, that is
16:11:46 <rhedlind> New Belgium brewery?
16:11:46 <ameade> lol shouldn't that have been the first question?
16:11:54 <scottda> I've got a room booked already
16:11:59 <hemna> scottda, sweet
16:12:02 <thingee> scottda: ha
16:12:04 <jgriffith> scottda: we can arm wrestle over it :)
16:12:04 <ameade> why not hawaii then we'll find someone to host?
16:12:05 <ameade> lol
16:12:22 <hemna> ameade, +A
16:12:24 <thingee> ameade: not sure if jgriffith can surf.
16:12:34 <scottda> jgriffith: You want to host in Boulder?
16:12:41 <scottda> OR in Fort Collins?
16:12:42 <jgriffith> thingee: as a matter of fact, I used to surf quite a bit :)
16:13:00 <thingee> whoa cool
16:13:02 <jgriffith> scottda: I'd love to be able to offer something up, but HP in FTC is a way better setup
16:13:20 <thingee> jgriffith: you do have great divide where you're at..
16:13:22 <thingee> sort of close
16:13:24 <thingee> ;D
16:13:24 <scottda> OK. I'm not trying to hog the hosting.
16:13:26 <jgriffith> scottda: was thinking Boulder would be nice/different and still close, but we don't have the same facilities you do
16:13:57 <jgriffith> scottda: I was kidding, I think you did a great job last time and we'd be stupid not to take advantage of you again :)
16:14:11 <jungleboyj> jgriffith: ++
16:14:17 * scottda likes to be taken advantage of, but that's a different story....
16:14:20 <thingee> scottda: yeah I was happy with the HP's hosting last time. Good location
16:14:23 <jgriffith> and we had network!
16:14:29 <thingee> jgriffith: +10000
16:14:32 * jungleboyj sighs
16:14:40 <hemna> :)
16:14:48 <thingee> ok great. so this seems like we're fine. hosting details seem to be in the works
16:14:50 * jungleboyj starts looking into wifi jammers.  ;-)
16:14:50 <akerr> cruise ships have wifi
16:14:51 <scottda> Ok, I'll post up more details on the etherpad, and I'll book blocks of rooms at HP discount at local hotels this time.
16:15:04 <jungleboyj> scottda: ++
16:15:13 <smcginnis> We can put jgriffith's horse barn as a backup plan. :P
16:15:15 <jungleboyj> So should we plan to stay through Friday?
16:15:30 <jgriffith> smcginnis: oh yeah, good point
16:15:31 <hemna> work through Friday ?
16:15:35 <hemna> Friday is a hackathon day ?
16:15:40 * DuncanT might not be able to stay friday :-(
16:15:58 <thingee> smcginnis: I was hoping I would find an airbnb for jgriffith's farm. Just like a clean lump of hay in the barm or something
16:16:08 <jgriffith> full week might be a bit of a burden for some folks
16:16:09 <smcginnis> thingee: Hah!
16:16:13 <thingee> hemna: yes sprints
16:16:20 <jungleboyj> Ok.
16:16:21 <thingee> hemna: I hate hackathon now. :P
16:16:35 <hemna> sprints is the new hackathon ?
16:16:39 <thingee> jgriffith: the friday is completely optional
16:16:40 <winston-d> beerathon
16:16:41 <hemna> man I'm so behind in my vernacular
16:16:49 <jungleboyj> winston-d: ++
16:16:50 <jgriffith> thingee: cool... I get it
16:16:52 <hemna> winston-d, fish-a-thon
16:17:01 <hemna> you guys can work, I'm hitting the river....
16:17:02 <hemna> :P
16:17:07 <thingee> hemna: :)
16:17:41 <thingee> #agreed Fort Collins Aug 4-6. 7th is optional sprints
16:18:01 <thingee> #action thingee announce to the OpenStack Dev ML
16:18:28 <thingee> #topic Social Monday Night at the summit
16:18:37 <thingee> #link http://lists.openstack.org/pipermail/openstack-dev/2015-May/064024.html
16:19:01 <thingee> jgriffith brought this up from the ML today. Are we interested in having our own get together?
16:19:23 <smcginnis> +1
16:19:26 <vilobhmm1> at the summit yes +2
16:19:35 <jungleboyj> thingee: +1  Especially if there is nothing else going on.
16:19:42 <ameade> +1
16:19:45 <hemna> no OS parties Monday night ?
16:20:09 <thingee> and if so, who can have their resources do planning/reservations? I'm spent for summit planning.
16:20:14 <e0ne> hemna: everybody wait for Tuesday's party:)
16:21:04 <thingee> got quiet
16:21:11 <scottda> +1
16:21:39 <cebruns> Who has the biggest hotel room?  :)
16:21:40 <smcginnis> Just everyone grab some 40's and meet down by the harbor. ;)
16:21:47 <adurbin_> thingee: +1 on monday night social
16:22:06 <jungleboyj> smcginnis: That sounds like fun.
16:22:11 <DuncanT> +1 on the idea, I can't vollenteer to org rhough
16:22:34 <DuncanT> I remember a good microbrewery in the gaslight district, can't remember the name though
16:22:36 <jungleboyj> How many people are we talking?
16:22:51 <e0ne> inderesting idea, something new  for me, so I +1 on it
16:23:17 <scottda> Maybe an etherpad to get a head count, post location, etc?
16:23:27 <jungleboyj> scottda: Not a bad idea.
16:23:28 <smcginnis> That would work.
16:23:46 <thingee> scottda: http://attending.io/events/new someone mentioned
16:23:47 <vilobhmm1> scottda : good idea!
16:23:55 <thingee> maybe we can do that after count.
16:24:17 <thingee> just was hoping someone would spearhead this
16:25:32 <adurbin_> what is the estimated group size looking like?
16:25:34 <thingee> spearheading does not mean you're paying. If vendors want to sponsor this event, that's cool. I guess I sort of saw this as us hanging out and catching up before the summit. Like we did at the last midcycle
16:25:50 <jungleboyj> thingee: ++
16:25:51 * DuncanT can look for a venue on sat eve once I'm there if needed
16:26:01 <scottda> I'll count up the people and try to book a room or something at a local pub
16:26:10 <thingee> scottda: cool
16:26:15 <scottda> Maybe I can work with Duncan
16:26:18 <scottda> https://etherpad.openstack.org/p/LibertySocialMondayCinderEvent
16:26:20 <jungleboyj> scottda: Thanks!
16:26:35 <scottda> sure. Beer motivates me, if you couldn't already tell.
16:26:40 <thingee> I think people all have their own expenses they can tap from. Maybe some people will buy rounds depending on group size.
16:26:58 <jungleboyj> Just got this as one possible idea:  http://the-roof.ca/
16:27:21 <thingee> So people post ideas of places we can reserve to the etherpad
16:27:28 <jungleboyj> Will do.
16:27:32 <thingee> #link https://etherpad.openstack.org/p/LibertySocialMondayCinderEvent
16:27:33 <asselin> I think there's an hp gathering going on monday night
16:27:55 <thingee> asselin: meet us after? :)
16:28:02 <rhedlind> asselin: can we crash it?
16:28:15 <rhedlind> :)
16:28:17 <thingee> #topic announcements
16:28:41 <thingee> #idea New drivers for Liberty need to be in by June 19th with CI.
16:29:20 <thingee> I guess that's more of a topic, but this sticks to our previous planning in previous releases
16:29:50 <thingee> questions? comments? concerns?
16:29:53 <xyang1> thingee: 6/19 is the merge date?
16:29:58 <jungleboyj> thingee: I had someone asking about that earlier and that was about what I had estimaed.
16:30:03 <jungleboyj> *estimated
16:30:13 <thingee> xyang1: yes needs to be merged.
16:30:59 <thingee> anyone opposed to the date?
16:31:15 <xyang1> thingee: Is there a driver code submission deadline?
16:31:16 <winston-d> Is that a deadline for brand new drivers, or for feature implementation of existing drivers as well?
16:31:21 <hemna> so just to be clear, in order to +A a driver, it has to have CI working and reporting on the driver patch itself right ?
16:31:22 <e0ne> thingee: could big queue in zuul be an issue for it before L-1 deadline?
16:31:33 <jgriffith> thingee: I'm not sure TBH
16:31:34 <thingee> hemna: yes
16:31:43 <hemna> thingee, ok good.  that's what I was hoping.
16:31:47 <jgriffith> thingee: I'd also really like to figure out what we're doing going forward
16:32:02 <jgriffith> thingee: IMHO having 50+ drivers in Cinder is not going to be sustainable
16:32:13 <thingee> e0ne: definitely. so owners to the patches shouldn't wait
16:32:31 <hemna> jgriffith, well, I think that can be a separate topic, but until we find a viable solution, we should stick to this no?
16:32:32 <jgriffith> thingee: if you look at the stats on patches/bugs/review queue right now it's already greater than 85% drivers
16:32:32 <thingee> jgriffith: agreed. I actually forgot about the talks about out of tree for the summit.
16:32:50 <thingee> jgriffith: but I didn't have time to review previous spec on the idea when neutron did it.
16:32:54 <jgriffith> hemna: my point is we have talks planned at the summit so why make a decision now?
16:33:15 <jgriffith> hemna: thingee I guess it doesn't hurt
16:33:19 <hemna> sure, I think the only decision at this point is to stick to the existing plan.
16:33:28 <jgriffith> hemna: fair enough
16:33:35 <e0ne> thingee: do you have any plans to make current 3rd party CIs more effective?
16:33:53 <thingee> jgriffith: I wanted something in the air now, so there is time for people to make arrangements. I agree we should have something planned at the summit to discuss this
16:33:55 <jungleboyj> hemna: +1
16:34:03 <e0ne> e.g. Oracle CI voted on my patch after about 4 days when it posted
16:34:04 <jungleboyj> Good topic after a couple of beers.  :-)
16:34:08 <jgriffith> thingee: that makes sense
16:34:20 <asselin> e0ne, there's quite a few infras sessions to get and common openstack ci solution scheduled
16:34:20 <hemna> e0ne, doh
16:34:24 <jgriffith> e0ne: I'm more concerned with stats for those that regularly vote
16:34:44 <e0ne> jgriffith: +1
16:34:44 <jgriffith> e0ne: by stats I mean false fail rate
16:35:01 <jgriffith> e0ne: thingee I'm trying to figure out how to get radar to work and make it a req
16:35:14 <thingee> jgriffith: how about I announce that we're looking at this being the date, but we'll have a final decision at the summit?
16:35:17 <jgriffith> but node is being a PITA for me... maybe we should look at patrickeast 's solution
16:35:18 <DuncanT> jgriffith: How about a cinder-drivers repo with a more open (larger) core?
16:35:25 <jgriffith> thingee: I think that's great
16:35:43 <jgriffith> DuncanT: yeah, I mean hell... if we have a repo for brick WTF not?
16:35:48 <e0ne> jgriffith: we need to try get a list of requirements to CI. maybe on Friday at Summit?
16:35:50 <thingee> xyang1: do you mind proof reading my announcement to make sure it's clear? :)
16:35:55 <jgriffith> err... WTH (why the heck)
16:36:06 <xyang1> thingee: Sure
16:36:10 <thingee> I think I had more questions from you on the announcement for Kilo, so your feedback would be great.
16:36:17 <DuncanT> jgriffith: repos are cheap... it seems better than totally out-of-tree
16:36:29 <xyang1> thingee: Ok
16:36:49 <jgriffith> DuncanT: dont' disagree, need some thought/discussion though IMO which we have slated for Summit
16:36:50 <smcginnis> DuncanT: +1
16:36:55 <jungleboyj> DuncanT: +1
16:36:57 <hemna> DuncanT, I'm not clear what that buys us really.
16:37:13 <jgriffith> hemna: let's people like me ignore that repo :)
16:37:18 <thingee> #agreed Final decision for drivers to be submitted in Liberty will be decided at the summit. So far June 19th is a possible date
16:37:35 <jgriffith> hemna: seriously though... it doesn't buy a ton
16:37:40 <hemna> jgriffith, can't you ignore reviews in volume/drivers now ?
16:37:40 <DuncanT> hemna: We can have more people with +2 on that repo than cinder core
16:37:41 <thingee> #action thingee will announce June 19th as being a possible date, and the arrangements for discussion at the summit
16:37:58 <e0ne> DuncanT: do you have any feedback about out-of-tree drivers from nuetron?
16:37:59 <DuncanT> hemna: Essentially encourage people to review each other's drivers
16:38:01 <hemna> anyway, just thinking out loud sorry.
16:38:06 <asselin> there's some disucssions going on in Nova about splitting core responsibilities...I think there's a session scheduled for it
16:38:08 <thingee> So other announcements.. Cinder specs!
16:38:17 <thingee> keep on reviewing.
16:38:26 <DuncanT> e0ne: Neutron is a mess re code quality and functional consistency
16:38:27 <jgriffith> we can save it for the summit, but I'd like to come up with a way to incentivize more "community" participation
16:38:37 <thingee> patrickeast just posted a generic image caching spec https://review.openstack.org/182520
16:38:50 <thingee> please to be reviewing ^^
16:39:19 <thingee> jgriffith also needs feedback before the summit on replication v2 spec https://review.openstack.org/155644
16:39:24 <thingee> also to be reviewing ^^
16:39:59 <jungleboyj> ++
16:40:03 <jgriffith> thingee: while you're asking :)
16:40:04 <jgriffith> https://goo.gl/TrrLuF
16:40:38 <thingee> jgriffith: ah yes, I have a vm waiting for me to test that
16:40:54 <asselin> #link https://libertydesignsummit.sched.org/event/179f43bed9fb2afdb3999c13d9a39480#.VVN-jvlVhBc
16:40:55 <thingee> saw your message when I was already reading in bed :)
16:41:17 <asselin> Cross-project: in-team scaling link ^^
16:41:46 <thingee> we also have a fish bowl session at the summit for discussing Volume performance and Health collection from backends
16:41:48 <thingee> #link https://review.openstack.org/#/c/178748/
16:42:01 <thingee> need vendors to give feedback to help adurbin_ with the session
16:42:19 <thingee> don't wait until the session please.
16:42:29 <hemna> ok I'll check it out
16:43:11 <thingee> ok, so next up
16:43:12 <thingee> removing v1
16:43:21 <thingee> I have the patch up. it fails everything
16:43:42 <thingee> there are a lot of little areas here and there on different projects that are doing weird things are default to v1
16:43:44 <hemna> ship it!
16:44:04 <thingee> I'm looking for people to help me on getting things ready in other projects
16:44:07 <thingee> like heat, nova, etc
16:44:14 <thingee> openstack client
16:44:20 <adurbin_> thingee: sorry, I stepped out for a second
16:44:30 <e0ne> thingee: what about version descovering in cinderclient?
16:44:40 <thingee> e0ne: it's shipped
16:44:45 <thingee> 1.2.1
16:44:54 <e0ne> thingee: great!
16:44:59 <adurbin_> thingee: I have some ammendments to make to https://review.openstack.org/#/c/178748/, i'll try to get them up this week
16:45:20 <thingee> so if anyone wants to help me with the v1 removal effort, please contact me
16:45:36 <e0ne> thingee: i'll ping you:)
16:45:40 <thingee> other great news, cinder is now using os-brick!
16:45:43 <thingee> yay hemna !
16:45:44 <thingee> https://review.openstack.org/155552
16:45:47 <hemna> :)
16:46:00 <thingee> hemna: got the nova patch handy?
16:46:05 <thingee> to switch it to os-brick?
16:46:13 <hemna> https://review.openstack.org/#/c/175569/
16:46:19 <thingee> #link https://review.openstack.org/155552
16:46:19 <hemna> that's my WIP nova patch
16:46:29 <thingee> #link https://review.openstack.org/#/c/175569/
16:46:43 <thingee> hemna: what's the plan so far?
16:46:51 <hemna> there are some os-brick patches I'd like to see land
16:46:57 <thingee> hemna: when do we expect this to be ready for review/testing
16:47:15 <hemna> I was hoping to get it done before Vancouver
16:47:19 <hemna> but I'm running out of time
16:47:21 <patrickeast> does this mean we should have our ci systems start testing os-brick changes?
16:47:24 <e0ne> hemna: do you have some kind of roadmap/blueprints/etc?
16:47:29 <asselin> patrickeast, +1
16:47:31 <hemna> e0ne, not yet
16:47:41 <thingee> patrickeast: hemna and I were going to have a discussion about os-brick testing
16:47:44 <thingee> never happened
16:47:46 <hemna> patrickeast, asselin and I have started thinking about CI'ing os-brick patches
16:47:59 <hemna> basically we need every os-brick patch to kick off cinder 3rd party CI tests as well
16:48:05 <jgriffith> patrickeast: oh crap, really?
16:48:07 <hemna> making sure we aren't breaking cinder
16:48:15 <jgriffith> patrickeast: that's a side effect I didn't think of
16:48:20 <patrickeast> its easy enough to add it as a project to watch in zuul
16:48:32 <thingee> jgriffith: sort of simple
16:48:42 <jgriffith> ok, can I just say that's kind of crazy IMO
16:48:52 <jgriffith> CI brick and Cinder?
16:49:01 <hemna> making sure we don't break things ?
16:49:07 <e0ne> hemna: at least, it would be great to run tempest over the each brick patch
16:49:08 <patrickeast> i guess the alternative is to wait for the cinder changes where we rev the brick version, right?
16:49:09 <jgriffith> hemna: ineffeciency
16:49:23 <jgriffith> patrickeast: yeah, but that's probably not a great option :)
16:49:44 <DuncanT> All of the brick code used to be in cinder, so there shouldn't be a significant change in the number of changes...
16:49:45 <jgriffith> hemna: what ROC do you expect to see in the lib?
16:49:57 <hemna> ROC ?
16:49:59 <jgriffith> it should be minimal right?  Otherwise it shouldn't be a lib
16:49:59 <e0ne> ROC?
16:50:05 <jungleboyj> Rate of Change
16:50:05 <DuncanT> rate of change
16:50:06 <jgriffith> Rate Of Change
16:50:10 <hemna> heh
16:50:14 <jungleboyj> :-)
16:50:15 <hemna> it shouldn't be changing much
16:50:21 <smcginnis> Wouldn't that entail that we (our CIs) would need to pull down Cinder master and brick patch to test it.
16:50:25 * jungleboyj Heard it come out in harmony
16:50:31 <hemna> there is a bit of changes we need to add to it, due to features that made it into Nova that didn't get into Cinder
16:50:32 <smcginnis> That's not a trivial change from how it works right now.
16:50:35 <thingee> DuncanT raises a good point. The change would've been triggered in the Cinder project. The change is just in a different project, so it's not really adding more to CI's
16:50:44 <jgriffith> hemna: thingee so actually this is a non-issue
16:50:45 <thingee> it's just you have another project to watch
16:50:50 <hemna> There are a few bugs I filed about those, but after that, the ROC shouldn't be much at all IMHO
16:50:53 <e0ne> smcginnis: need to take a look how oslo libs are tested
16:50:59 <jgriffith> hemna: thingee rules for upgrading brick in Cinder are just like any other req lib
16:51:07 <jgriffith> hemna: thingee needs a patch to reqs file
16:51:07 <smcginnis> e0ne: True. I would see this as the same.
16:51:16 <hemna> ok
16:51:19 <jgriffith> you try and update Cinder, shit fails, you fail the merge/patch
16:51:21 <e0ne> smcginnis: because cinder and nova will use brick not from master
16:51:34 <jgriffith> e0ne: exactly
16:51:59 <hemna> sorrison, we need to pin the requirements.txt to a specific version then ?
16:52:02 <hemna> gah
16:52:03 <hemna> so
16:52:07 <thingee> jgriffith: finding what broke when updating requirements is cinder will be fun
16:52:09 <thingee> git bisect
16:52:10 <jgriffith> hemna: well, yeah.
16:52:11 <thingee> :)
16:52:11 <hemna> right now it's open to any version.
16:52:12 <e0ne> and that's why devstack installs it from pypi, not from git master
16:52:22 <hemna> global-requirements.txt just says 'os-brick'
16:52:26 <hemna> no versioning
16:52:31 <thingee> hemna: we can change that
16:52:35 <jgriffith> thingee: no different than oslo, keystone and the giant list of libs we have currently
16:52:40 <thingee> jgriffith: true
16:52:40 <hemna> thingee, yah I think we should
16:52:45 <jgriffith> hemna: well that's the first patch brick needs then
16:52:47 <e0ne> hemna: it doesn't metter while we have only one release
16:52:56 <jgriffith> hemna: you can't have an externallib with no versioning
16:53:00 <hemna> jgriffith, yup.
16:53:07 <hemna> jgriffith, should add that today.
16:53:26 <thingee> ok last announcement...
16:53:28 <jgriffith> hemna: cool
16:53:40 <thingee> LVM thin type
16:53:42 <thingee> https://review.openstack.org/#/c/182498/
16:53:42 <winston-d> hemna: I asked that earlier in your patch adding os-brick to requirements.txt
16:53:50 <thingee> https://review.openstack.org/#/c/182499/
16:53:58 <thingee> https://review.openstack.org/#/c/182528/
16:54:34 <hemna> winston-d, we are ok right now.  we only have 1 release of os-brick in pypi, with nothing planned in the short term.  we can update global-requirements to pin it to 0.1.0 for now and then update cinder.
16:54:43 <thingee> jgriffith is adding this option to devstack, add an experimental gate job
16:54:46 <winston-d> hemna: cool
16:55:22 <thingee> jgriffith: what improvements do you see this bringing to gate?
16:55:26 <jgriffith> hemna: we'll have to figure out that stuff later I think
16:55:34 <jgriffith> thingee: LVMThin?
16:55:36 <hemna> jgriffith, yah
16:55:41 <jgriffith> thingee: it's better
16:55:50 <jgriffith> thingee: faster
16:55:56 <jgriffith> better snaps etc
16:56:07 <e0ne> and it works! :)
16:56:13 <jgriffith> and ideally I'd like to see it made the default for Cinder in the future
16:56:22 <thingee> #idea LVM Thin experimental job in gate. Better, Faster, Stronger.
16:56:25 <jgriffith> thingee: main thing is we keep piling in options and we don't test them
16:56:30 <thingee> #link https://review.openstack.org/#/c/182498/
16:56:38 <jgriffith> we either need to remove options, or test them propertly IMO
16:56:40 <thingee> #link https://review.openstack.org/#/c/182499/
16:56:45 <jgriffith> and probably a little of both
16:56:49 <thingee> #link https://review.openstack.org/#/c/182528/
16:56:57 <jgriffith> thingee: LOL
16:57:00 <jgriffith> BFS
16:57:40 <thingee> those are the reviews. interested folks, please show support ^
16:57:49 <e0ne> 3 minutes reminder
16:57:58 <hemna> thingee, jgriffith e0ne https://review.openstack.org/182756
16:57:58 <thingee> #topic open discussion
16:58:23 <cebruns> Have the fishbowl and working sessions been given timeslots in Vancouver?
16:58:31 <thingee> cebruns: yes
16:59:02 <cebruns> Ok - I looked for them but didn't see 'em in the schedule. Is there a link?
16:59:28 <thingee> cebruns: http://libertydesignsummit.sched.org/type/design+summit/Cinder
16:59:49 <cebruns> thingee: Thanks!
17:00:01 <thingee> fwiw, work session topic in most of those names is on purpose.
17:00:05 <thingee> #endmeeting