16:00:03 <thingee> #startmeeting Cinder
16:00:04 <openstack> Meeting started Wed Jul 15 16:00:03 2015 UTC and is due to finish in 60 minutes.  The chair is thingee. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:07 <smcginnis> Howdy
16:00:08 <openstack> The meeting name has been set to 'cinder'
16:00:10 <geguileo> Hi!
16:00:14 <thingee> hi everyone
16:00:18 <DuncanT> Hi
16:00:20 <vincent_hou> Hi folks.
16:00:20 <winston-d_> o/
16:00:20 <jseiler> hi
16:00:25 <scottda> hi
16:00:28 <thingee> #topic announcements
16:00:30 <eharney> hi
16:00:32 <Fdaisuke> Hello!
16:00:40 <dannywilson> hello
16:00:47 <srikanth_poolla> Hello everyone..
16:00:54 <Swanson> Hello
16:00:59 <rhe00_> hi
16:01:02 <patrickeast> hi
16:01:08 <janonymous_> o/
16:01:14 <thingee> #info hemna is continuing with the brick switch in nova, please help and review!
16:01:17 <thingee> #link https://review.openstack.org/#/c/175569/
16:01:30 <jungleboyj> o/
16:01:35 <cebruns> Hello
16:01:47 <thingee> #info Nova patches in flight for multi-attach support, please help and review!
16:01:48 <e0ne> hi
16:01:50 <thingee> #link https://etherpad.openstack.org/p/liberty-volume-multiattach
16:01:51 <tbarron> hi
16:02:00 <erlon> hi
16:02:02 <xyang1> hi
16:02:03 <flip214> hi
16:02:17 <thingee> #info Propose your topics for the Cinder Midcycle meetup!
16:02:19 <thingee> #link https://etherpad.openstack.org/p/cinder-liberty-midcycle-meetup
16:02:27 <thingee> you should see the header with "topics"
16:02:36 <ameade> o/
16:02:46 <thingee> #action thingee to mention this in the mailing list
16:02:48 <hemna> yo
16:03:00 <jgriffith> o/
16:03:03 <kmartin> o/
16:03:07 <mtanino> o/
16:03:21 <thingee> #info apache/nginx support in cinder api will be approved assuming no objections this week
16:03:23 <thingee> #link https://review.openstack.org/#/c/192683/6
16:03:43 <thingee> #info clone consistency group spec will be approved this week assuming no objections
16:03:45 <thingee> #link https://review.openstack.org/#/c/194834/4
16:03:50 <e0ne> thingee: thank you
16:04:13 <thingee> #info incremental backup enhancement spec will be approved this week assuming no objections
16:04:17 <thingee> #link https://review.openstack.org/#/c/187926/8
16:04:22 <xyang1> thingee: thanks
16:04:42 <thingee> #info os-brick 0.3.0 will be released this week
16:05:04 <smcginnis> +1
16:05:14 <hemna> nice
16:05:16 <vincent_hou> Cool
16:05:17 <thingee> #info cinderclient 1.3.1 is released with version discovery removed
16:05:18 <hemna> thingee,  thanks
16:05:29 <thingee> alright lets get started!
16:05:35 <smcginnis> One other announcement in case folks don't keep up on the mailing list: M release == Mitaka now.
16:05:36 <thingee> Agenda for today https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting
16:05:45 <thingee> smcginnis: yes thank you :)
16:06:00 <vincent_hou> Wow.
16:06:19 * jgriffith starts a pool on whether it changes again :)
16:06:20 <thingee> so I moved scottda's topic up because he has to cut out early
16:06:27 <thingee> #topic Cinder <-> Nova API fixes Update
16:06:29 <thingee> scottda: hi
16:06:32 <scottda> HI
16:06:32 <jungleboyj> smcginnis: Was so hoping for Musashi!
16:06:33 <vincent_hou> Sounds Japanese.
16:06:37 <thingee> #link https://etherpad.openstack.org/p/CinderNovaAPI
16:06:51 <Swanson> I vote for Miku.
16:06:54 <smcginnis> jungleboyj: Might get there yet. ;)
16:07:03 <scottda> So, I'm trying to corral all the info, bugs, design ideas, work in this etherpad...
16:07:19 <vincent_hou> Actually they all sound the same to me. :-)
16:07:28 <geguileo> jungleboyj: Me too
16:07:35 <hemna> scottda, I still have some work on my TODO list for this, mostly regarding live migration
16:07:38 <scottda> I've put some goals, just my ideas. Please comment if they seem crazy or if you can think of other goals that involve fixing cinder-nova
16:07:49 <scottda> I've listed ~20 bugs.
16:07:51 <hemna> scottda, I'm going to document the drivers that have potential problems with initialize_connection
16:08:05 <scottda> Not an exhaustive list, just that I got exhausted from searching.
16:08:11 <smcginnis> hemna: Add me to your list. :)
16:08:19 <scottda> I've put some design ideas and questions....
16:08:28 <scottda> Please add and comment to that if you are interested.
16:08:36 <thingee> #action scottda is corral all the bugs, design ideas in etherpad https://etherpad.openstack.org/p/CinderNovaAPI
16:08:36 <winston-d_> scottda: appreciate your efforts
16:08:37 <hemna> smcginnis, heh ok.  yah live migration is still a mess due to several things, but mostly because of how nova is calling cinder in some cases.
16:08:44 <jgriffith> scottda: wondering if we could take a small step back maybe.
16:08:47 <scottda> I think I'll put out a survey on design ideas prior to the mid-cycle
16:08:49 <jgriffith> scottda: so first, awesome job!!!
16:08:51 <scottda> sure jgriffith
16:09:00 <jgriffith> scottda: really great details and info here
16:09:17 <jgriffith> scottda: but I twinge a little when I see things like "assumptions are wrong"
16:09:21 <jgriffith> scottda: about "xyz"
16:09:43 <jgriffith> scottda: the reason being is that we have never clearly defined these things to say who's right/wrong
16:09:43 * scottda is looking for that part
16:09:55 <scottda> makes sense jgriffith
16:10:10 <scottda> I think one goal is to clearly define the API
16:10:20 <jgriffith> scottda: I'm wondering if we should start by proposing what the flow "should" be form Cinder's point of view (and in some cases why)
16:10:21 <hemna> having spent a great deal of time looking at this myself, nova is making some assumptions about cinder, what it can call and when, that just happen to not work for everyone.
16:10:32 <jgriffith> hemna: and there it is again :)
16:10:43 <hemna> yes, there it is again.
16:10:54 <hemna> I've been spending a great deal of time on this the last few weeks.
16:11:07 <scottda> That's Goal #4 jgriffith , but I don't necessarily care about the ordering.
16:11:16 <hemna> scottda, +1
16:11:19 <jgriffith> hemna: My point is rather than continuing to just say "nova makes assumptions", lets define what we want these interfaces to do/mean
16:11:30 <scottda> jgriffith: +1
16:11:34 <jgriffith> scottda: yes... so if I can finish :)
16:11:36 <hemna> jgriffith, sure, that's always been our plan
16:11:42 <thingee> scottda: if possible I would like to have a rough idea of a timeline based on volunteers what we can commit to in liberty
16:11:49 <hemna> but I think what we had to do first is understand what nova is doing right now and why it doesn't work.
16:11:59 <jgriffith> scottda: I think it would be ideal and much easier for all of us to help out here if we started by defining the interface/s
16:12:01 <scottda> first, jgriffith please finish..
16:12:14 <thingee> scottda: of course not this entire list, but some movement instead of us coming with yet another etherpad on this subject.
16:12:27 <jgriffith> thingee: LOL
16:12:55 <jgriffith> scottda: so what I was trying to ask.... do *you* see any benefit in starting out by laying out the definition of the calls/interface first?
16:13:01 <thingee> scottda: that wasn't meant to come across what you're doing is a waste of time. I just want some people to commit to some work here.
16:13:04 <jgriffith> scottda: then proceeding from there?
16:13:22 <scottda> Sure. I figured that after gathering input we would discuss this at the mid-cycle.
16:13:34 <jgriffith> scottda: fi we did that, then I *think* it would be fairly easy to go forth and conquer
16:13:57 <hemna> you have to understand the problem points first before you can propose solutions.
16:13:59 <scottda> I imagine that there will be enough contention on things that we won't be able to come to consensus without being (mostly) face-to-face
16:14:02 <jgriffith> scottda: ahh.. yeah, I suppose that's not so far into the future at this point
16:14:12 <jgriffith> hemna: You have to have a definition to start IMHO
16:14:12 <thingee> scottda: I'm assuming we have communicated anything in the nova meetings yet because of how much yet has been defined?
16:14:26 <scottda> thingee: correct
16:14:31 <thingee> johnthetubaguy: ^
16:14:50 <scottda> I had hoped that post-midcycle we'd have some concrete plan and consensus to take to Nova
16:15:24 <johnthetubaguy> so do reach out to me, if/when you want to get things reviewed in Nova, will do my best to make that happen for you
16:15:24 <jgriffith> scottda: Ok, that makes sense.  Honestly it might be late for L to make changes in Nova... but I'd be curious depending on what we come up with how much we could just fix up on the Cinder side anyway
16:15:38 <scottda> johnthetubaguy: Great, I/we will do.
16:15:39 <jgriffith> scottda: but anyhow, that's a completely different disucssion
16:15:52 <jgriffith> scottda: Thanks for listening to me
16:15:56 <thingee> alright so who is going to lay out the the definitions of the calls/interfaces?
16:15:59 <smcginnis> jgriffith: +1, see what we can do, then prep for M in nova.
16:16:04 <scottda> I think it will take >= 2 cycles for all this to change (nova and cinder)
16:16:18 <hemna> I think it's 2 separate things at this point.  1) what can we do short term to make stuff work for L and 2) what do we do long term to fix the API and interaction.
16:16:23 <thingee> #info it maybe too late to get changes into Nova at this point, may prep for M
16:16:24 <jgriffith> thingee: I'm happy to do a first draft.. then hemna and scottda or anybody else can jump in and shred it up :)
16:16:37 <scottda> I tried to capture long and short goals under Goals
16:16:46 <scottda> jgriffith: that would be great
16:16:54 <thingee> jgriffith: can you commit to that be ready to show at the midcycle?
16:16:56 <jgriffith> thingee: I can start it based on what we did in nova-volume when most of those calls were created
16:16:58 <johnthetubaguy> trying to get a backlog nova-spec merged before the summit sounds like a good goal for that stuff (and getting a summit session if we don't agree in time)
16:17:03 <jgriffith> thingee: yes
16:17:07 <thingee> jgriffith: thank you!
16:17:14 <jgriffith> thingee: wait.. when is the mid-cycle?
16:17:16 <scottda> johnthetubaguy: +1 to summit session
16:17:17 * jgriffith jokes
16:17:18 <thingee> jgriffith: haha
16:17:41 <smcginnis> jgriffith: Make sure you get your travel arranged. :)
16:17:46 <johnthetubaguy> scottda: in a happy world, we will have agreed the plan by then, but if not, yeah, a joint summit session might be a good plan
16:17:55 <scottda> hemna: short term seems like bug fixes, long term is discussion, docs, and mid-cycle wrangling over issue IMO
16:18:01 <hemna> scottda, +1
16:18:05 <thingee> #action jgriffith will write a first draft of defining call/interface
16:18:05 <jgriffith> smcginnis: LOL... funny thing is I do have to do that... I'll be traveling all the week before ;)
16:18:09 <tbarron> jgriffith will travel by horse
16:18:20 <smcginnis> :)
16:18:23 <hemna> scottda, leeantho and I have been working hard on the bug fix side for live migration at least.  it's a mess.
16:18:31 <jgriffith> scottda: that sounds good
16:18:33 <thingee> tbarron: +1
16:18:58 <tbarron> just tie him to his saddle after he visits microbreweries ...
16:19:00 <thingee> scottda: great anything else?
16:19:03 <scottda> Cool. Please comment wildly in the etherpad on the big stuff, i.e goals and design
16:19:09 <scottda> that's it. Thanks all.
16:19:21 <thingee> #topic Volume Migration Improvement has made some progress
16:19:24 <thingee> vincent_hou: hi
16:19:26 <asselin> o/
16:19:29 <vincent_hou> Hi
16:19:44 <vincent_hou> I have a quick update with all cinder folks.
16:19:44 <thingee> #info volume status management is waiting for comments
16:19:47 <thingee> #link https://review.openstack.org/#/c/186312/
16:19:58 <vincent_hou> I made some progress in the volume migration for L.
16:20:02 <thingee> #info migration status management waiting for comments
16:20:04 <thingee> #link https://review.openstack.org/#/c/189614/
16:20:25 <vincent_hou> Have got 2 patches submitted for cinder . one for client. one for tempest.
16:20:29 <thingee> #info tempest tests
16:20:29 <thingee> #link https://review.openstack.org/#/c/195443/
16:20:38 <thingee> #info cinder client changes
16:20:38 <thingee> #link https://review.openstack.org/#/c/189547/
16:20:39 <vincent_hou> You are welcome to download them and try them.
16:21:02 <vincent_hou> I love you folks' comments BTW.
16:21:39 <vincent_hou> The volume has a better status and migration status management, with the migration progress.
16:21:45 <jungleboyj> :-)
16:22:00 <erlon> vincent_hou: great!
16:22:17 <vincent_hou> Tempest can check if the retype/migration work among any drivers, if you configure two backends. Any back-end!
16:23:05 <vincent_hou> Cinder client can help you to check the migration status and progress if available.
16:23:26 <thingee> vincent_hou: great thanks
16:23:35 <mtanino> vincent_hou: great for your much work.
16:23:36 <thingee> anyone have objections they'd like to raise with some of this progress?
16:23:59 <smcginnis> vincent_hou: Thanks for your work on this!
16:24:08 <jungleboyj> vincent_hou: Thank you very much!
16:24:39 <thingee> ok with that then...
16:24:51 <thingee> #topic Add Fujitsu ETERNUS DX Volume Driver (again)
16:24:59 <thingee> Fdaisuke: hi
16:25:07 <thingee> #link https://review.openstack.org/#/c/201500/
16:25:13 <Fdaisuke> I'm here
16:25:27 <Fdaisuke> thingee: hi
16:25:34 <thingee> Fdaisuke: are you aware of previous openstack mailing list posts about this subject?
16:26:07 <smcginnis> My question is, if it was dropped in Kilo, why wasn't this addressed prior to L1 instead of waiting until now?
16:26:26 <jgriffith> smcginnis: maybe they didn't know it was dropped :)
16:26:26 <e0ne> smcginnis: +1 on your question
16:26:27 <Fdaisuke> yes, I understand the deadline was already past.
16:26:45 <smcginnis> jgriffith: :) We should probably talk about that one too.
16:27:07 <jgriffith> smcginnis: indeed :)
16:27:16 <thingee> Fdaisuke: we also have other vendors with drivers removed in K, that didn't make the cut in L-1. It wouldn't really be fair for us to make an exception here.
16:27:25 <thingee> Fdaisuke: but this was communicated well ahead of time http://lists.openstack.org/pipermail/openstack-dev/2015-May/064072.html
16:27:42 <Fdaisuke> so, we planned re-merging of our driver for L, assuming the deadline would be l-3 as it was k-3.
16:28:23 <hemna> thingee, when was the driver removed?  K ?
16:28:34 <Fdaisuke> We couldn't fit our schedule to it as there're a lots of stuff to do such as purchasing new servers, assign people, etc.
16:28:43 <smcginnis> hemna: Yep
16:29:03 <hemna> smcginnis, then I'd say, they missed the L deadline.  M isn't that far away.
16:29:05 <thingee> Fdaisuke: so I'm going to tell you what I tell everyone in this situation. You have priorities, and so does the community. Vendors don't define the timelines here, the community does. I absolutely welcome you to join the community and participate in these discussions so they're not a surprise.
16:29:15 <smcginnis> hemna: +1
16:29:43 <jungleboyj> thingee: ++
16:29:53 <e0ne> thingee: +1
16:29:58 <jgriffith> hemna: thingee +1 to both of you
16:31:56 <thingee> Fdaisuke: the cinder community working towards this effort has been known for almost two years now. Things really being defined in a long email i sent in January 2015. This being a timing issue at this point is not really a good excuse.
16:32:42 <thingee> Fdaisuke: http://lists.openstack.org/pipermail/openstack-dev/2015-January/054614.html
16:33:08 <vincent_hou> Fdaisuke: Try to stay more with the cinder community. IRC, Mail list, etc.
16:33:52 <erlon> thingee: do you have those links on your copy area? :P impossible to find that so fast
16:34:13 <thingee> erlon: I do certain finds from the archive page of the mailing list.
16:34:26 <winston-d_> erlon: trust search engine and your memory ;)
16:34:48 <thingee> Fdaisuke: I'm going to move on from this topic, but please start making preparations for M.
16:34:54 <jungleboyj> thingee: Would be good to spend a few minutes talking at the meetup about how to find stuff in the mailing list.  :-)
16:35:10 <erlon> winston-d_: I would have to rely on the search engine, my memory is a disaster
16:35:12 <thingee> #topic Move cinderclient-dsvm-functional job to (non)voting queue
16:35:15 <thingee> e0ne: hi
16:35:22 <e0ne> thingee: hi
16:35:28 <thingee> so mtreinish explained I'm crazy here for proposing this for a meeting topic
16:35:31 <thingee> I agree
16:35:41 <thingee> so any strong objections with this?
16:35:47 <jgriffith> LOL
16:35:56 <thingee> heh
16:35:56 <e0ne> quick topic:)
16:36:02 <jgriffith> thingee: the part about the job, or you being crazy?
16:36:03 <jgriffith> :)
16:36:04 <mtreinish> thingee: heh, I think we can all agree to blame jgriffith and move on :)
16:36:11 <thingee> #info job stats
16:36:13 <thingee> #link
16:36:13 <thingee> http://graphite.openstack.org/render/?width=877&height=548&_salt=1436533755.887&from=00%3A00_20150524&until=23%3A59_20150715&target=stats.zuul.pipeline.experimental.job.check-cinderclient-dsvm-functional.FAILURE&target=stats.zuul.pipeline.experimental.job.check-cinderclient-dsvm-functional.SUCCESS&target=stats.zuul.pipeline.experimental.openstack.python-cind
16:36:13 <thingee> erclient.total_changes&title=check-cinderclient-dsvm-functional
16:36:14 <DuncanT> +A on both motions
16:36:17 <thingee> dang it
16:36:30 <thingee> #info review request
16:36:32 <thingee> #link https://review.openstack.org/#/c/200522/
16:36:42 <smcginnis> +1
16:36:50 <jgriffith> thingee: rebase an I'm good with it for sure!!
16:36:54 <jgriffith> err... e0ne
16:36:57 <thingee> excellent!
16:37:06 <thingee> #agreed rebase and merge it!
16:37:12 <e0ne> i've updated change request
16:37:17 * jgriffith was just waiting for rebase
16:37:34 <jungleboyj> DuncanT: ++
16:37:34 <e0ne> jgriffith: done
16:37:42 <jgriffith> e0ne: me too :)
16:37:46 <thingee> e0ne: anything else?
16:37:55 <e0ne> thingee: no, thank you
16:37:58 <flip214> thingee: got that link from me? ;P
16:38:10 <e0ne> it was too quickly for me
16:38:12 <flip214> it's a bit long, though...
16:38:12 <thingee> flip214: link?
16:38:17 <thingee> oh
16:38:20 <flip214> graphite.openstack.org/render...
16:38:27 <thingee> flip214: https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting
16:38:30 <thingee> flip214: last item
16:38:38 <thingee> #topic open discussion
16:38:42 <flip214> no problem
16:38:57 <Swanson> Blueprints for driver changes?
16:39:00 <jgriffith> thingee: I've got a couple things :)
16:39:11 <thingee> jgriffith: you have the floor
16:39:20 <jgriffith> thingee: thanks!
16:39:24 <jgriffith> so first.. replication V2
16:39:31 <erlon> me too, id like to discus about our HBSD2 CI status
16:39:44 <jgriffith> I put a POC up to try and give a clearer picture of what was in the spec
16:39:55 * jungleboyj is excited!
16:39:56 <jgriffith> https://goo.gl/eTNPrb
16:40:20 <thingee> #info replication v2
16:40:24 <thingee> #link https://review.openstack.org/#/c/155644/
16:40:37 <jgriffith> So most of the comments are detail things... but a couple bigger ones
16:40:57 <jgriffith> well... not really big ones; the auto-failover thing
16:41:04 <jgriffith> everybody agree on just leaving that out for now?
16:41:19 <patrickeast> yea
16:41:22 <dannywilson> +1
16:41:28 <patrickeast> i think the initial version of this doesn’t really need it, right?
16:41:30 <jungleboyj> jgriffith: +1
16:41:32 <kmartin> +1
16:41:33 <jgriffith> and anybody have any glaring objections to the current direction?
16:41:37 <vincent_hou> y
16:41:49 <jgriffith> One question that came up fro me when doing this was (well couple questions):
16:41:53 <hemna> jgriffith, +1
16:41:53 <vilobhmm> +1
16:42:17 <jgriffith> 1. The existing V1 stuff... just replace it's API calls and reuse them, or keep them and make it a config option to fall back for a deprecation period?
16:42:17 <jungleboyj> jgriffith: Still need to actually review closely.
16:42:20 <thingee> #agreed auto-failover isn't needed in the initial version
16:42:28 <thingee> jgriffith: please reference this when needed ^
16:42:32 <thingee> :)
16:42:39 <j_king> can I close https://bugs.launchpad.net/cinder/+bug/1298135 ? anyone affected by that?
16:42:39 <openstack> Launchpad bug 1298135 in Cinder "Cinder should handle token expiration for long ops" [Medium,Confirmed] - Assigned to j_king (james-agentultra)
16:42:39 <jgriffith> thingee: :)
16:43:02 <jgriffith> the other question I had....
16:43:18 <Swanson> Haven't read that spec since it first came out.  Will take another look.
16:43:39 <jgriffith> Config versus just using update_targets?
16:43:44 <DuncanT> j_king: We're affected by it, not looked at the implied trusts stuff yet
16:43:56 <jgriffith> Swanson: sorry.. forget the spec.... just look at this: https://review.openstack.org/#/c/200269/
16:44:09 <jgriffith> IMO it's easier to get an idea from that than the spec
16:44:23 <jgriffith> on opinions on the two questions there?
16:44:34 <Swanson> jgriffith: thanks!
16:44:35 <e0ne> j_king: we met this issue few times
16:44:38 <thingee> jgriffith: sorry not familiar to comment
16:44:38 <jgriffith> Yayyy!  /me has full liberty :)
16:44:54 <dannywilson> jgriffith: more info on config vs. update_targets?
16:45:02 <dannywilson> or is it too much detail to go into?
16:45:12 <jungleboyj> jgriffith:  As far as leaving an option to go back to V1 and having an option.  I think we want to just move forward with V2.  I know Tao and Ronen are looking at the impact on the existing code right now but their first impression is that we can move forward pretty easily.
16:45:14 <jgriffith> dannywilson: so initially I thought "use config file to specify replication targets to a driver"
16:45:23 <jungleboyj> dannywilson: ++
16:45:30 <j_king> DuncanT: I have some ideas/code I can put into a WIP review but it looks like it might not work without some help from keystone folks.
16:45:33 <jgriffith> dannywilson: but then I wrote a little code that introduced an "add_target" method to the api
16:45:43 <jgriffith> making the config file seem somewhat pointless
16:45:56 <jgriffith> j_king: DuncanT do you mind waiting till I finish this topic?
16:46:01 <j_king> sure.
16:46:06 <DuncanT> sure
16:46:06 <jgriffith> or have your side conversation elsewhere?
16:46:31 <jgriffith> dannywilson: so using the API is trivial IMO
16:46:35 <dannywilson> jgriffith: add_target would be called on a per volume basis?
16:46:47 <jgriffith> dannywilson: no, it would be called for a backend
16:47:04 <jgriffith> dannywilson: specify valid secondary configs via that call
16:47:20 <jgriffith> dannywilson: then it's up to you to set up which (or all) via type specification
16:47:31 <jgriffith> dannywilson: which can be auto-handled by driver, or explicit or whatever you want
16:47:47 <jgriffith> dannywilson: but my main goal here is to remove as much of the vendor unique stuff from the main code
16:47:48 <dannywilson> jgriffith: gotcha
16:47:56 <patrickeast> so is the thought here that there would also be api’s to change the targets, list them, etc?
16:48:02 <jgriffith> and leave most of the burden on the driver, rather than the proper cinder code
16:48:06 <Fdaisuke> thingee: Thanks for the comments.  We might sounded like we're not aware of all the announcements in the past, but we're :) Since our driver is not completely new one, we thought we could find a chance to discuss it for Liberty inclusion.
16:48:14 <jgriffith> patrickeast: yes... admin API's
16:48:21 <patrickeast> gotcha
16:48:31 <jgriffith> patrickeast: and only two... "list" and "update"
16:49:10 <jgriffith> patrickeast: dannywilson please see: https://review.openstack.org/#/c/200269/1/cinder/volume/manager.py L#2737
16:49:24 <dannywilson> jgriffith: +1 for apis, makes it easier to change as well (though that probably doesn't happen often)
16:49:26 <jgriffith> patrickeast: I don't have the list method in there though
16:49:53 <jgriffith> dannywilson: Hope not, but regardless at least there' s no downtime or restart of services to make a change
16:50:12 <dannywilson> jgriffith: right
16:50:21 <jgriffith> I guess nobody has looked at this yet, so we can table the conversation for now
16:50:37 <jgriffith> DuncanT: j_king all yours
16:50:47 <jgriffith> Oh.. no, wait
16:50:49 <j_king> jgriffith: solved it out of band. :)
16:50:49 <jgriffith> one other thing :)
16:50:56 <jgriffith> j_king: cool!
16:51:04 <Swanson> Blueprints for driver changes?  Like, say, mine?  https://review.openstack.org/#/c/199631/
16:51:25 * jgriffith puts on flame retardant suit!
16:51:28 <jgriffith> https://review.openstack.org/#/c/201812/
16:51:30 <smcginnis> Swanson: Added it as a midcycle meeting topic to discuss bps and bugs.
16:51:30 <jungleboyj> jgriffith: Will be on it ASAP.
16:51:55 <jgriffith> I don't want to take up meeting time arguing and trying to justify, but happy to have a conversation in channel
16:52:14 <jgriffith> and explain the rationale in more detail as well as pros/cons etc
16:52:32 <jgriffith> which could lead to an updated commit message
16:53:02 <erlon> Can we talk about the HBSD2 CI status?
16:53:10 <erlon> real quick
16:53:19 <thingee> erlon: sure
16:53:52 <erlon> so, our CI was disabled, we had it turn off due a bug we where working
16:54:30 <erlon> after a power failure, we bring up the machine, and it stated to post failure status into gerrit
16:55:08 <erlon> as, the change has just being merged, we needed it enabled again to test against the new patch
16:55:42 <smcginnis> erlon: I do think you were disabled too quickly. There are certainly others that deserve it more.
16:56:14 <erlon> anteaya: Anita asked to talk to you guys to ask her to re-enable it
16:56:40 <erlon> smcginnis: yep, surely, I not even notice that
16:56:45 <thingee> erlon: I'll look at the stats
16:57:17 <erlon> thingee: you mean the stats of this CI?
16:57:52 <thingee> erlon: I'll look at the announce third party list
16:57:57 <thingee> anything else from anyone?
16:58:02 <erlon> thingee: ok
16:58:05 <smcginnis> 2 minute warning.
16:58:18 <thingee> #endmeeting