16:00:02 <thingee> #startmeeting cinder
16:00:03 <openstack> Meeting started Wed Sep 16 16:00:02 2015 UTC and is due to finish in 60 minutes.  The chair is thingee. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:09 <openstack> The meeting name has been set to 'cinder'
16:00:16 <thingee> hello all!
16:00:16 <eharney> hi
16:00:16 <dulek> Hi!
16:00:16 <e0ne> hi
16:00:18 <hemna> doink
16:00:19 <cFouts> hi
16:00:20 <kmartin> o/
16:00:20 <mriedem> o/
16:00:26 <jgregor> Hello!
16:00:26 <scottda> hi
16:00:30 <jseiler_> hi
16:00:30 <xyang> hi
16:00:32 <thingee> #topic announcements
16:00:44 <rhedlind> hi
16:00:52 <thingee> #info we have blockers for liberty release
16:00:55 <diablo_rojo> hello :)
16:00:56 <thingee> #link https://launchpad.net/cinder/+milestone/liberty-rc1
16:00:57 <hodos|2> hi
16:01:06 <thingee> Lets get these pushed through today
16:01:09 <DuncanT> Hi
16:01:12 <tbarron> hi
16:01:20 <smcginnis> o/
16:01:20 <thingee> if there's anything missing from that list, please ping me in #openstack-cinder to discuss
16:01:28 <thingee> otherwise I'll give the OK
16:01:42 <hemna> I'll work with e0ne on the cinder-all binary.  I was helping him test that last night
16:01:54 <e0ne> hemna: thanks
16:02:01 <thingee> hemna: I believe that patch has one +2 now
16:02:09 <erlon> hey!
16:02:12 <xyang> thingee: when are you planning to cut RC1
16:02:15 <jungleboyj> Happy Wednesday!
16:02:23 <thingee> xyang: asap
16:02:23 <dulek> thingee: Is this worth to get into RC1 - https://review.openstack.org/#/c/223602/ ?
16:02:40 <hemna> thingee, ok.  I had seen problems with it last night before I left.  I'll follow up.
16:02:40 <thingee> dulek: taking note, will discuss after meeting in #openstack-cinder
16:02:48 <thingee> hemna: thanks
16:03:00 <DuncanT> thingee: the fact that quota-get for a normal user is broken with the default keystone policy is a bug that should be on that list IMO
16:03:03 <dulek> thingee: Got it.
16:03:30 <thingee> DuncanT: ack, can you ping me on #openstack-cinder with the bug link, please?
16:03:38 <e0ne> thingee: I've verified dulek's patch with devstack
16:03:39 <DuncanT> Aye
16:04:09 <e0ne> DuncanT: +1. do we have filed bug?
16:04:11 <thingee> #info Cinder PTL nominations/elections happening
16:04:14 <thingee> #link https://wiki.openstack.org/wiki/PTL_Elections_September_2015
16:04:28 <thingee> just a reminder to folks that nominations are being accepted now
16:04:37 <thingee> we have smcginnis stepping up for the position in mitaka!
16:04:44 <DuncanT> So far Sean and myself have announced candidacy
16:04:44 <e0ne> DuncanT: https://launchpad.net/bugs/1491495
16:04:46 <openstack> Launchpad bug 1491495 in Cinder "cinderclient.quotas.get() fails against Cinder service in a Devstack" [Undecided,Fix committed] - Assigned to Ivan Kolodyazhny (e0ne)
16:04:50 <thingee> oh and DuncanT !
16:05:20 <asselin> o/
16:05:25 <e0ne> I created a patch with nomination too
16:05:35 <thingee> any other announcements?
16:05:37 <smcginnis> DuncanT: Awesome!
16:05:58 <smcginnis> e0ne: Cool!
16:06:10 <hemna> I'm going to post mine here in a bit.
16:06:38 <thingee> looks like we got a healthy election coming
16:06:44 <thingee> alright lets get started
16:06:45 <jungleboyj> Wow!
16:06:59 <xyang> Nice!  I'm going to throw a dice to decide:)
16:07:04 <thingee> agenda for today: https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting
16:07:13 <ShamailT> :)
16:07:26 <jungleboyj> xyang: :-)
16:07:28 <thingee> going to switch the order
16:07:33 <thingee> #topic Nova summit session for Cinder issues
16:07:35 <thingee> scottda: hi
16:07:37 <scottda> hi
16:07:50 <thingee> #info Etherpad for session
16:07:52 <thingee> #link https://etherpad.openstack.org/p/NovaCinderMitakaSession
16:07:52 <scottda> I wanted to setup a session with Nova to discuss Cinder issues
16:08:11 <scottda> I figured we could put all things Cinder <-> Nova in one session.
16:08:28 <hemna> scottda, that's a lot :)
16:08:29 <scottda> multi-attach, brick (rootwrap), api changes, bugs
16:08:34 <scottda> well, it might be too much
16:08:35 <mriedem> 40 minutes
16:08:50 <scottda> And I haven't submitted the request for a Nova session yet.
16:08:52 <mriedem> scotttda: the rootwrap thing might be covered in a session with oslo
16:09:00 <scottda> mriedem: roger that
16:09:05 <mriedem> i posted for nova to do the rootwrap thing already
16:09:14 <hemna> mriedem, yah that's going to require oslo participation, so we should just do that there.
16:09:39 <mriedem> so probably focus on features/api changes in a nova session
16:09:51 <scottda> so, if folks think differently, I could avoid doing a 0ne-session-for-all, but johnthetubaguy like that idea. It's a matter of topic scope
16:09:56 <hemna> e0ne, if cinder-baremetal is going to use os-brick, then it's going to need rootwrap fun as well.
16:10:08 <scottda> does multi-attach need it's own session?
16:10:14 <mriedem> keep in mind the amount of bikeshedding that will happen in a design session
16:10:20 <e0ne> hemna: you're right
16:10:24 <hemna> mriedem, +1
16:10:29 <mriedem> so make sure this is focused
16:10:33 <mriedem> with homework assigned before hand
16:10:36 <hemna> mriedem, scottda should we do the multi-attach session in nova ?
16:10:44 <scottda> perhaps a separate session just for the bikeshedding?
16:10:48 <hemna> :)
16:10:59 <johnthetubaguy> so the sessions with lots of topic do tend to fail
16:11:02 <scottda> hemna: This is about a NOva session, not a cinder session.
16:11:03 <jungleboyj> scottda: ++
16:11:41 <hemna> johnthetubaguy, +1
16:11:41 <johnthetubaguy> now if there is a full story around improving integration that could be reviewed, maybe thats a good single session, at least thats where I was thinking
16:12:15 <johnthetubaguy> I was hoping once we have the list of things we want to talk about, it should become much clearer about what the best way forward is
16:12:15 <scottda> ok, so maybe a single session about improving integration and any API changes being proposed....
16:12:28 <scottda> johnthetubaguy: fair enough.
16:12:45 <johnthetubaguy> I suspect a combination of already agreeing stuff in specs, and a session to cover some loose ends, might be a good approach
16:12:48 <scottda> so perhaps cinder folk can put any additional ideas on that etherpad, and we can go from there?
16:13:06 <hemna> scottda, url
16:13:07 <mriedem> yeah, provide any and all education/background up front
16:13:18 <scottda> https://etherpad.openstack.org/p/NovaCinderMitakaSession
16:13:19 <mriedem> otherwise you're going to be explaining the cinder use cases to the nova people for half the session
16:13:22 <johnthetubaguy> I am good with that, a Nova-cinder topics, and we can work out what needs doing to make that work
16:13:25 <johnthetubaguy> mriedem: +1
16:13:26 <thingee> scottda: Initially when this was discussed at the Cinder midcycle sprint, we wanted to have our API defined properly so others can consume it properly. Maybe appropriate for this session.
16:13:57 <scottda> thingee: yes, including a spec for that.
16:14:38 <scottda> OK, if you are interested, add to that etherpad and let me know.
16:14:52 <scottda> johnthetubaguy: What's the time frame for requesting a NOva session?
16:15:01 <johnthetubaguy> yeah, discussing spec disagreements tends to be more productive, focused bikeshedding, a shed for only one bike (waffle waffle)
16:15:08 <johnthetubaguy> scottda: we don't have one right now
16:15:17 <johnthetubaguy> scottda: maybe point to your etherpad, and submit one now?
16:15:33 <scottda> ok. I'll do that today.
16:15:43 <thingee> #action scottda to propose nova session with etherpad
16:15:46 <scottda> I think that's it for me
16:15:46 <johnthetubaguy> awesome, that will stop me forgetting about it at the last moment
16:16:13 <thingee> #action scottda to follow up with spec on proper Cinder API usage
16:16:20 <thingee> scottda: got a lot to do
16:16:35 <scottda> yeah, I think hemna will also help with the api spec
16:16:41 * scottda volunteers hemna
16:16:57 <jungleboyj> :-)
16:16:58 <thingee> scottda: thanks, anything else?
16:17:03 <scottda> nope. Thanks
16:17:07 <hemna> :)
16:17:21 <thingee> #topic Design summit topics
16:17:23 <thingee> #link https://etherpad.openstack.org/p/cinder-mitaka-summit-topics
16:17:26 <hemna> scottda, I have it on my plate to rework the volume manager locks -> ING checks spec
16:17:48 <thingee> Not much notice to get proposals added here, but we can take another look next week
16:17:50 <scottda> hemna: OK, I guess this is separate. We'll talk....
16:18:25 <dulek> thingee: +1, it seems people need time to come up with the topics.
16:18:37 <dulek> thingee: Last time it was harder to get this scheduled.
16:18:41 * thingee is noticing people adding things now :)
16:18:45 <e0ne> thingee: +1
16:19:23 <thingee> patrickeast: hi
16:19:29 <patrickeast> hey
16:19:38 <thingee> Expermental/api features I think is a great topic
16:19:48 <thingee> for the user input, what were you interested in
16:19:58 <dulek> When I was looking in the morning all the sessions proposed for Friday would fit to the two other categories. I thought we will go for a beer at Friday then. ;)
16:20:12 <patrickeast> mostly looking for feedback on if we did it, would operators want them
16:20:23 <patrickeast> or maybe they prefer not to be exposed at all to that sort of thing
16:20:39 <patrickeast> and if we do implement them, maybe they have suggestions/requirements for the how
16:20:44 <jgriffith> patrickeast: we sould have a summit session, I have a proposal for a "different" model
16:20:54 <jgriffith> patrickeast: using a contrib directory
16:20:59 <jungleboyj> jgriffith: The next ViPR !?!
16:21:02 <jgriffith> jungleboyj: :)
16:21:09 <thingee> o_o
16:21:16 <xyang> :)
16:21:19 <thingee> to both of those things
16:21:22 <jungleboyj> jgriffith: What has come over you man!?!
16:21:24 <jungleboyj> ;-)
16:21:42 <thingee> contrib/vipr.py solved
16:21:42 <xyang> manila just implemented experimental API.  we can take a look of that
16:22:02 <tbarron> xyang: +1
16:22:12 * thingee takes note
16:22:52 <thingee> patrickeast: I have took notes on things mentioned. would be good to research manila and jgriffith's different approach
16:23:09 <jungleboyj> thingee: +1  Sounds like experimental API is working into.
16:23:11 <patrickeast> yea i'll take a look
16:23:21 <scottda> I've already linked manila's patch in the etherpad
16:23:23 <thingee> patrickeast: please post an etherpad on your findings and link to your topic
16:23:25 <tbarron> manila experimental is built on microversions
16:23:28 <xyang> need micro versions too
16:23:29 <patrickeast> thingee: will do
16:23:38 <xyang> tbarron: +1
16:23:39 <scottda> I'm working on microversions ATM
16:23:43 <thingee> #action patrickeast to make etherpad on expermental API research
16:24:00 <xyang> scottda: I saw you have a spec
16:24:04 <tbarron> scottda: great
16:24:11 <thingee> not sure if we need micro versions in fishbowl
16:24:22 <scottda> xyang: Yes, and I'm porting code from Manila this morning
16:24:26 <thingee> I'd recommend working session
16:24:30 <thingee> scottda: ^
16:24:31 <xyang> scottda: nice
16:24:34 <scottda> ok
16:24:40 <smcginnis> +1
16:24:49 <xyang> scottda: then you will get experimental too
16:24:57 <jungleboyj> scottda: Rocks!
16:25:05 <scottda> Well, I didn't port the experimental bits.
16:25:11 <scottda> I thought that should wait
16:25:12 <thingee> I'm not sure how we solve the dependency problem of patrickeast's fishbowl happening first then working session on micro versions
16:25:23 <hemna> scottda, awesome
16:25:29 <xyang> thingee: they should be one session
16:25:38 <thingee> xyang: good idea
16:26:04 <xyang> especially if you are using experimental from manila that needs microversions
16:26:54 <thingee> #info Proposal Availability Zones in Cinder
16:27:03 <thingee> dulek: DuncanT hi
16:27:08 <dulek> hi
16:27:13 <DuncanT> Hi
16:27:27 <thingee> I definitely think this is good for fishbowl
16:27:32 <thingee> for getting user feedback
16:27:36 <thingee> operator rather
16:27:43 <tbarron> ++
16:27:43 <dulek> So basically we were talking about that multiple times on IRC, always the conclusion was - what do operators expect from Cinder.
16:27:44 <jgriffith> thingee: +1
16:27:56 <DuncanT> So this has come up on the mailing list recently, and of the two modes we defacto supported, one is currently broken (though the bug is a blocker). I've pinged a few operators
16:27:59 <dulek> We don't know that, let's gather feedback.
16:28:05 <e0ne> thingee: can we do it after operators session?
16:28:05 <jungleboyj> thingee: ++
16:28:20 <DuncanT> I've three replies so far, all saying the same thing, plus the HP answers
16:28:31 <DuncanT> I'll write them up soon
16:28:37 <ShamailT> thingee: is the cinder team thinking about possibly getting a session at the ops track to get feedback or is this cinder design summit fishbowl session?
16:28:47 <DuncanT> That should give us a starting point for discussion
16:28:58 <thingee> e0ne: might be difficult to schedule this around ops sessions. Fishbowl will be taking place tuesday and ops happens tuesday-wednesday
16:29:02 <ShamailT> If there is a list of questions that need feedback, I'll be glad to pass them to the Product WG too.
16:29:27 <thingee> ShamailT: we've done it in the past and it was a flop ... although with discussions with the foundation, might've been a schedule issue
16:29:42 <hemna> that's a bummer they are done on the same days.  It would be nice if the ops stuff happened first, so we could bring some of the feedback into the fishbowl and sprint sessions.
16:29:49 <jgriffith> thingee: IIRC we were the only ones there :(
16:29:51 <mriedem> if cinder does AZ's, don't repeat the issues that nova has had
16:29:55 <thingee> jgriffith: yup
16:29:58 <ShamailT> thingee: gotcha
16:30:18 <hemna> we tried in Vancouver and almost no one showed :(
16:30:26 <dulek> mriedem: ?
16:30:30 <thingee> dulek, DuncanT would appreciate an etherpad with what Nova has done ... maybe connect with mriedem
16:30:35 <jungleboyj> hemna: That was a bummer.
16:30:37 <mriedem> dulek: https://review.openstack.org/#/c/223802/
16:30:38 <scottda> Yeah, Vancouver ops sync up was a dissapointing turn out
16:30:44 <DuncanT> mriedem: Cinder already does AZs, with two different configs 'supported'
16:30:47 <mriedem> dulek: speak with bauzas in the nova channel
16:30:59 <mriedem> we've just had some really gross bugs with AZs
16:31:10 <dulek> thingee: I've got the problem described in the spec linked in description, getting the info into the etherpad isn't a problem.
16:31:14 <mriedem> ultimately user error, but really not good usability
16:31:45 <mriedem> scottda: nova ops sessions at summit are also very sparse, it's mostly nova people talking to each other
16:31:59 <hemna> :(
16:32:05 <thingee> #action dulek to post an etherpad link under the topic proposal with previous nova AZ issues in mind
16:32:45 <dulek> Okay, that's probably all.
16:33:08 <thingee> dulek DuncanT thanks
16:33:21 <thingee> that leaves us two more slots for fishbowl
16:33:30 <thingee> #info two more slots available for fishbowl
16:33:39 <thingee> working session
16:34:00 <thingee> cinder<->driver interface
16:34:01 <thingee> eharney: hi
16:34:10 <eharney> hey
16:34:12 <thingee> glad to see this up and seems appropriate for working session
16:34:34 <hemna> thingee, +1
16:34:36 <eharney> i don't have a lot of specifics on this yet, but based on various chatter over the last cycle, it seems like something that needs some work and definition
16:35:20 <thingee> eharney: makes sense to just document the driver api now and have the review or merged doc be included with your session
16:35:25 <thingee> don't think things need to wait
16:35:43 <xyang> hemna: I'll submit a patch to fix the CG interfaces before the summit
16:35:47 <thingee> if things need to be decided, they don't need to be documented right away
16:36:02 <eharney> sounds good
16:36:18 <thingee> eharney: do you have bandwidth for proposing that to the cinder dev docs?
16:36:18 <hemna> xyang, :)
16:36:21 <thingee> before the summit
16:36:26 <xyang> hemna: :)
16:36:29 <DuncanT> It would be good to talk about the worts on out interface
16:36:35 <eharney> thingee: hard to say at this point
16:36:56 <hemna> xyang, that would be awesome.  we'll need to file bugs against drivers after that lands to get them fixed.  I can help with documenting which drivers are doing it because of CG.
16:37:05 <thingee> can anyone collaborate with eharney to get a doc patch going?
16:37:10 <eharney> part of this is collecting up knowledge on some of the things like drivers that don't use interfaces exactly in the intended way, etc
16:37:11 <xyang> hemna: sure
16:37:17 <eharney> and i'm not sure how big the scope of that kind of thing is yet
16:38:01 <rhedlind> I can help
16:38:06 <thingee> #info cinder<->driver interface working session
16:38:22 <thingee> rhedlind: thanks
16:39:00 <thingee> #action rhedlind and eharney to collaborate on a driver api doc for cinder dev docs
16:40:12 <thingee> #info proposal for c-vol A/a working session
16:40:17 <thingee> dulek: hi
16:40:26 <dulek> hello again
16:40:31 <thingee> so cross project distributed lock topic should be happening before this, yay
16:40:39 <dulek> Ah, definitely.
16:40:45 <thingee> #info cross project distributed lock topic will happen before this
16:40:54 <dulek> I think we all know what's this about.
16:41:04 <dulek> And I don't think there's a clear action plan for Mitaka.
16:41:16 <dulek> So I would expect that to be the aim of the session.
16:41:24 <thingee> Based on discussions in the cinder midcycle sprint, I think work can just begin with for -ing state work, no need to discuss things more
16:41:39 <hemna> thingee, +1
16:41:53 <thingee> it would be great if those patches were ready and linked with the etherpad topic
16:42:13 <hemna> thingee, do we need a spec for the -ing checking, or a bug ?
16:42:45 <hemna> thingee, we have this old one that started talking about it...https://review.openstack.org/#/c/149894
16:43:03 <dulek> Isn't -ing checking changing the behavior of the API and therefore invalidates API contract?
16:43:20 <hemna> dulek, yes.  I think we need microversioning in place prior
16:43:41 <hemna> we'll be returning VolumeIsBusy in many places, and nova doesn't really expect that currently.
16:43:41 <dulek> hemna: Okay! :)
16:43:42 <thingee> hemna: yeah lets just renew that spec
16:43:49 * scottda types microversioning code faster....
16:44:03 <hemna> thingee, ok I'll post up a new version of that spec and add the deps for microversioning and we can churn on it.
16:44:16 <dulek> So I would say - let's move that as a backup for the sprint and we'll discuss things there if needed.
16:44:19 <hemna> scottda, is it passing jenkins yet?
16:44:37 <scottda> I've not finished the port, but I should be done later today.
16:44:40 <thingee> hemna, dulek I need some to spearhead renewing that spec and have our nova liason present this to the nova folks so there are no surprises
16:44:58 <thingee> someone*
16:45:06 <hemna> thingee, scottda and I will work on that asap.
16:45:11 <scottda> Yes, when spec is ready I'll take it to Nova (meeting or IRC )
16:45:29 <dulek> thingee: I see hemna's volunteering, but I can also help to work on the spec. I think geguileo will be also interested.
16:45:49 <thingee> #action hemna to renew spec on return VolumeIsBusy on ing states
16:46:03 <thingee> #action scottda will present spec to Nova meeting
16:46:30 <thingee> dulek: I'm sure hemna will be happy to delegate since he's a busy guy and all
16:46:47 <e0ne> :)
16:46:53 <dulek> hemna: Just tell me what to do if you need. ;)
16:47:02 <dulek> Okay, so I'm moving that to the sprint, right?
16:47:03 <thingee> #info proposal for continuing abc work working session
16:47:04 <thingee> jgriffith: hi
16:47:09 <jgriffith> thingee: hola
16:47:34 <thingee> I agree this is a good working session topic.
16:47:53 <jgriffith> thingee: which one :)  I added two :)
16:47:56 <jungleboyj> thingee ++
16:48:03 <jgriffith> thingee: OHH
16:48:05 <jgriffith> never mind :)
16:48:06 <jgriffith> my bad
16:48:10 <thingee> jgriffith: one at a time :D
16:48:10 <e0ne> jgriffith: all of them:)
16:48:11 <hemna> dulek, ok I'll post up a new patchset on that review and we can all go at it.
16:48:17 <jgriffith> thingee: got ya... sorry
16:48:35 <eharney> i'll continue to be involved in the abc work, seems like a good session
16:49:05 <thingee> jgriffith: we should probably take a different approach from the cinder midcycle sprint to make headway
16:49:14 <jgriffith> eharney: I'd like to run some ideas / POC's by you in the coming weeks if you're intrested
16:49:22 <eharney> jgriffith: for sure
16:49:25 <jgriffith> thingee: agreed
16:49:47 <jgriffith> thingee: I'll have POC's, if nobody likes them we can swap something else into the slot :)
16:50:07 <jgriffith> thingee: and I will not raise it again afte r this :)
16:50:17 <thingee> #action jgriffith to propose more POC's
16:50:35 <thingee> jgriffith: you have already done a poc :P ... but always welcomed
16:50:59 <thingee> #action eharney and jgriffith will have discussion on pocs in the coming weeks
16:51:15 <thingee> eharney jgriffith We'll still check back next week on progress if that's fine ^
16:51:30 <eharney> sure
16:51:41 <eharney> note that there are still some pending patches cleaning up the current state of abc things out there, too
16:51:51 <thingee> ok enough time for one more working session
16:52:16 <thingee> #info Proposal for why fight it, cinder could should be the next vipr
16:52:21 <thingee> jgriffith: hi again
16:52:32 <jgriffith> thingee: :)
16:52:40 <thingee> maybe appropriate for fishbowl?
16:52:42 <hemna> lol
16:52:50 <xyang> :)
16:52:51 <hemna> jgriffith, are you feeling ok today? :P
16:52:56 <jungleboyj> hemna: ++
16:52:59 <jgriffith> thingee: so honestly I don't know/care necessarily where they land
16:53:00 <tbarron> :)
16:53:19 * thingee doesn't care either... it's the next ptl's problem j/k
16:53:25 <patrickeast> lol
16:53:36 <hemna> hehe
16:53:37 <eharney> i'm not sure i really see the whole picture for this one, but part of my driver interface proposal may be asking some related questions from a different direction
16:53:51 <hemna> eharney, yah seems like it might be related
16:53:52 <jgriffith> hemna: jungleboyj :)  So maybe a better title, but the point being there's no reason we souldn't be offering the same sort of functionality to make those things osbolete
16:53:53 <jgriffith> if we're not already
16:54:05 <hemna> jgriffith, +1
16:54:08 <jgriffith> eharney: could be for sure
16:54:09 <kmartin> And the PTL nominations just went from five down to one
16:54:19 <jgriffith> eharney: I'm fine with covering it ad-hoc in other discussions
16:54:22 <jungleboyj> jgriffith: I think it is actually an important discussion.
16:54:23 <hemna> kmartin, lol
16:54:36 <jgriffith> kmartin: huh?
16:54:52 <hemna> jgriffith, </sarcasm>
16:54:57 <thingee> jgriffith: I think he was replying to my remark of me making the next ptl's job harder
16:54:58 <jgriffith> hemna: oh... :)
16:55:07 <jgriffith> Ahhhh!!!
16:55:09 <jgriffith> got it!
16:55:10 <jgriffith> sorry
16:55:15 <kmartin> :)
16:55:30 <jungleboyj> kmartin: You and your sarcasm.  ;-)
16:55:40 <jungleboyj> 5 minute warning, BTW.
16:55:43 <jgriffith> jungleboyj: I agree... I don't know if it needs to be its own session or not, but I'll let others decide based on available time
16:55:53 <jgriffith> but I certainly plan on discussing it
16:56:02 <jgriffith> even if I hijack somebody elses talk :)
16:56:06 <jgriffith> just kidding
16:56:12 <jungleboyj> jgriffith: I think that is great.  It has a lot to do with keeping Cinder relevant.
16:56:13 <thingee> jgriffith: can you work with eharney and decide next week if it can be merged in with the driver interface session
16:56:25 <jgriffith> thingee: certainly
16:56:42 <jgriffith> thingee: I can also fold it into one of my other proposals.. like "future of cinder"
16:56:49 <jgriffith> it fits there as well and has some overlap IMO
16:57:13 <jungleboyj> The future is bright man!
16:57:27 <thingee> #action jgriffith and eharney to discuss if the cinder should be the next vipr session should be folded in the cinder<->driver api session
16:57:46 <thingee> jgriffith: If it's about what I think we've discussed in the past, that would be a great discussion.
16:57:58 <thingee> jgriffith: might need more planning of making sure key people are there
16:58:00 <e0ne> jgriffith: did you see DuncanT's coment in the etherpad?
16:58:01 <jgriffith> thingee: I think it is, yes
16:58:06 <thingee> jgriffith: excellent
16:58:10 <thingee> #topic open discussion
16:58:13 <thingee> 2 mins left
16:58:19 <thingee> we'll return back to summit topics next week
16:58:24 <thingee> this was good though
16:58:53 <jungleboyj> Good stuff.
16:59:12 <jungleboyj> So, how much longer do we have to approve and merge bug fixes?
16:59:26 <eharney> can someone add to the summit topics etherpad how long these sessions are?
16:59:41 <thingee> jungleboyj: at some point this week I'll make a cut. Ideally I'll give the word for tomorrow
17:00:02 <thingee> I also removed some stuff from rc-1...
17:00:05 <thingee> #endmeeting