16:00:05 <thingee> #startmeeting cinder
16:00:06 <openstack> Meeting started Wed Sep 23 16:00:05 2015 UTC and is due to finish in 60 minutes.  The chair is thingee. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:10 <openstack> The meeting name has been set to 'cinder'
16:00:12 <jgriffith> o/
16:00:15 <smcginnis> o/
16:00:16 <geguileo> Hi!
16:00:17 <thingee> hey all!
16:00:17 <rajinir> hi
16:00:18 <hemna> mep
16:00:19 <xyang> hi
16:00:21 <ShamailT> hi
16:00:24 <Swanson> Good morning.
16:00:29 <jgregor> Hello!
16:00:30 <diablo_rojo> Hello :)
16:00:39 <kmartin> o/
16:00:43 <tbarron> hi
16:00:47 <mriedem> o/
16:00:51 <scottda> hi
16:00:52 <thingee> Today is my last time in this cushy chair in the meeting!
16:00:56 <thingee> it has been a fun ride
16:00:58 <jgriffith> :(
16:01:03 <geguileo> :'-(
16:01:05 <hemna> :(
16:01:12 <scottda> sniffles
16:01:18 <thingee> maybe I'll fell in for the next PTL sometimes, who knows!
16:01:24 <thingee> fill*
16:01:42 <thingee> all is good though :)
16:01:51 <smcginnis> Thanks for the last year!
16:01:56 <jgriffith> thingee: if you think you're going to ride off into the sunset you're mistaken :)
16:02:00 <thingee> diversity is good in leaders
16:02:07 <hemna> jgriffith, +1
16:02:08 <hemna> :)
16:02:29 <thingee> #topic announcements
16:02:50 <thingee> So I don't really have any...
16:02:56 <thingee> oh!
16:03:07 <thingee> RC1 should be cut today
16:03:16 <thingee> #info Cinder RC1 should be cut today
16:03:17 <dulek> Isn't master opened for Mitaka?
16:03:17 <thingee> #link https://review.openstack.org/#/c/226850/1
16:03:35 <thingee> dulek: yes that would mean mitaka would be open after that patch lands and ttx does the cut
16:03:53 <dulek> :)
16:04:02 <diablo_rojo> thingee: so there won't be an rc2 then correct?
16:04:18 <hemna> thingee, are we pushing os-brick 0.4.1 for L ?
16:04:18 <e0ne> we need to not forget remove -2 after master unfreeze
16:04:21 <thingee> diablo_rojo: there could be, if users, ops, other tests notice issues with rc 1
16:04:28 <smcginnis> hemna: 5.0 I believe now.
16:04:48 <smcginnis> thingee: That would be off of stable/liberty though, right?
16:04:50 <thingee> hemna: os-brick 0.5.0 will be available
16:05:00 <e0ne> hemna: it should be os-brick 0.5.0
16:05:04 <hemna> thingee, ok coolio.  I didn't see the patch up for it
16:05:24 <thingee> smcginnis: the upper constraints was set, but not requirements.txt for os-brick 0.5.0
16:05:25 <e0ne> hemna: Doug Hellmann anounced it yesterday in openstack-dev ML
16:05:32 <smcginnis> thingee: Ah
16:05:38 <thingee> just keep that in mind
16:05:38 <hemna> e0ne, sweet.
16:05:56 <mriedem> nova has an rc2 for translations, not sure if cinder is in that same boat
16:06:15 <thingee> mriedem: not...yea :D
16:06:17 <ttx> mriedem: probably
16:06:29 <thingee> /yea/yet/
16:06:38 <ttx> (depends how much work the translators will actually put in the coming days :)
16:06:51 <thingee> any other announcements before we move on?
16:07:12 <smcginnis> < crickets >
16:07:23 <jungleboyj> o/
16:07:33 <thingee> I did want to give a quick plug while I have everyone's attention...
16:07:54 <thingee> so I know you all look forward to the openstack newsletter weekly!
16:08:04 <thingee> and there is a new section to help with a common problem people give..
16:08:09 <thingee> http://www.openstack.org/blog/2015/09/openstack-community-weekly-newsletter-sept-12-18/
16:08:21 <thingee> "What you need to know from the developer’s list"
16:08:36 <smcginnis> +1
16:08:44 <hemna> nice
16:08:47 <thingee> summary of the dev list... quick important points to keep you updated without having to read the entire thread
16:08:49 <xyang> thingee: that's a great addition
16:08:56 <markus_z> +1
16:09:05 <geguileo> Sounds great!
16:09:31 <thingee> give me feedback please! :)
16:09:35 <thingee> ok lets gets started!
16:09:54 <thingee> agenda for today!
16:09:57 <thingee> https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting
16:09:59 <thingee> short
16:10:07 <thingee> maybe with design summit topics
16:10:17 <thingee> oh and nova volume bug by mriedem
16:10:20 <thingee> got it
16:10:31 <thingee> #topic Cinder API races bugs
16:10:33 <thingee> geguileo: hi
16:10:36 <geguileo> Hey
16:10:43 <geguileo> Sorry, forgot to remote that
16:10:44 <thingee> too late
16:10:47 <thingee> geguileo: :)
16:10:47 <e0ne> :)
16:10:53 <geguileo> We agreed in cinder channel to not include it
16:10:57 <thingee> #info first patch
16:10:59 <thingee> #link https://review.openstack.org/#/c/218012
16:11:14 <geguileo> So nothing to discuss really
16:11:21 <thingee> #info This follows dependency chain
16:11:23 <thingee> #link https://review.openstack.org/#/c/221442
16:11:26 <thingee> oh
16:11:34 <thingee> #info nothing to discuss
16:11:42 <thingee> :)
16:11:48 <geguileo> Sorry
16:11:51 <thingee> no prob
16:12:12 <thingee> #agreed in the cinder channel it was agreed this would not be in L
16:12:25 <thingee> #topic Nova volume bugs
16:12:28 <thingee> mriedem: hi
16:12:36 <mriedem> hey, so just a quick note about nova volume bugs
16:12:41 <thingee> #info there are lots of nova/cinder bugs
16:12:44 <mriedem> https://bugs.launchpad.net/nova/+bugs?field.tag=volumes
16:12:45 <thingee> #link https://bugs.launchpad.net/nova/+bugs?field.tag=volumes
16:12:45 <mriedem> yeah
16:12:50 <mriedem> i was poking through those last friday
16:12:56 <mriedem> it's at 102
16:13:06 <mriedem> i suspect some are closed now
16:13:11 <mriedem> some could be issues in os-brick
16:13:11 <thingee> mriedem: I actually went through a bit of nova bugs to triage originally to that tag.
16:13:14 <thingee> :)
16:13:15 <hemna> mriedem, thanks for raising this one.  I'm starting to go through that list.  I think some of them might already be fixed using os-brick
16:13:36 <mriedem> i was also noting how many multipath bugs there were
16:13:42 <mriedem> which i'm assuming is in no way CI tested
16:14:00 <hemna> mriedem, some of the cinder 3rd party CI tests use mpath
16:14:01 <hemna> some don't
16:14:01 <patrickeast> my ci tests multipath FC and iSCSI... not sure if anyone else is though
16:14:14 <thingee> #info some might actually already be fixed. Maybe also since os-brick.
16:14:15 <mriedem> ah, that's good to know
16:14:26 <hemna> but I don't think any of the multipath tests actually look at the state of the host after the detach is done
16:14:27 <mriedem> b/c there was a bug i think that actually said fc attach with multipath failed
16:14:45 <mriedem> the problem i have with looking at some of these is i don't have an environment to recreate
16:14:55 <mriedem> so was hoping to lean more on the cinder people that had these environments
16:14:59 <hemna> mriedem, I'm working on some os-brick patches that will allow us to test before detach and after detach to make sure the volumes are gone.  https://review.openstack.org/#/c/199764/
16:15:41 <thingee> #info mriedem noticed many multi-path bugs. patrickeast has Pure CI testing multi-path with FC and iSCSI
16:15:49 <hemna> mriedem, I'd like some feedback on the spec if possible.  that would help cover one of the missing pieces.
16:16:12 <hemna> we can test iSCSI and FC multipath here
16:16:27 <xyang> we also test iSCSI and FC multipath
16:16:38 <mriedem> ok
16:16:41 <mriedem> i don't have anything else really
16:16:45 <mriedem> was just raising awareness
16:17:01 <hemna> since scottda is the nova liason, he and I can start looking through those bugs as well.
16:17:08 <scottda> yup
16:17:12 * hemna volunteers scottda for more work :)
16:17:19 <scottda> thanks
16:18:01 <thingee> scottda: might be good to start prioritizing what we want to focus on for Mitaka. I know some of these already come from your initial list of bugs.
16:18:02 <hemna> scottda, no problem, I was pretty sure you were getting bored anyway :)
16:18:09 <jungleboyj_> hemna: I also noted that we could get some of my team helping out on those as well.
16:18:27 <thingee> scottda: prioritize and a group...we might not be able to do all 100 bugs... but some managable goal for Mitaka I think would be good
16:18:50 <scottda> Yes, We'll gather bugs , prioritize and publish . I'll get something going by next week's meeting.
16:19:23 <thingee> #action scottda to priortize and set some expectation for Mitaka
16:19:26 <thingee> mriedem: anything else?
16:19:30 <markus_z> scottda: Would you keep me in the loop? I'm the nova bug czar since 2 months or so.
16:19:36 <scottda> https://etherpad.openstack.org/p/Mitaka_Priorites_for_Nova_Volume_bugs
16:19:53 <thingee> #info markus_z would like to stay in the loop, being the nova bug czar
16:19:54 <scottda> sure markus_z
16:20:00 <markus_z> scottda: thanks
16:20:04 <mriedem> thingee: nope
16:20:07 <thingee> thanks
16:20:25 <thingee> #topic Design summit topics
16:20:29 <markus_z> Regarding bugs, I have this one in the pipeline: https://review.openstack.org/#/c/209847/
16:20:33 <thingee> #link https://etherpad.openstack.org/p/cinder-mitaka-summit-topics
16:20:35 <markus_z> whops, too late :(
16:21:16 <thingee> so we got some agreements from last week
16:21:35 <thingee> let me just skim action items from last meeting in this area...
16:22:08 <jgriffith> markus_z: I like that proposal BTW
16:22:22 <thingee> patrickeast: you have an action for making an etherpad on experimental API research?
16:22:45 <markus_z> jgriffith: thanks, I'm currently figuring out how to make that an project wide blueprint.
16:22:59 <thingee> patrickeast: didn't see a link for it though on the topic etherpad
16:23:35 <thingee> cricket
16:23:40 <thingee> ok, we'll circle back
16:24:13 <thingee> dulek: you have an action for an etherpad for nova AZ issues
16:24:15 <patrickeast> thingee: ah, sry, stepped away for a minute.... I do still intend to do that, have been side tracked with some other bugs
16:24:34 <thingee> patrickeast: ok, I'll make a note for the next meeting organizer
16:24:51 <thingee> #action patrickeast to make etherpad on expermental API research
16:25:12 <thingee> wake up everyone :)
16:25:19 <dulek> thingee: Yeah, that haven't happened, I was waiting for DuncanT to post his findings and discussion.
16:25:37 <thingee> DuncanT: how's that coming along?
16:25:55 <dulek> thingee: Added it to TODO for tomorrow morning, DuncanT will add there I think. Sorry about that!
16:26:14 <thingee> dulek: no problem, just making sure we're ready for the summit! :)
16:26:21 <bswartz> patrickeast: ping me when you do that
16:26:40 <scottda> patrickeast: me too
16:26:45 <thingee> #action dulk to post an etherpad link under the topic proposal availability zone issues.
16:26:55 <patrickeast> bswartz: scottda: will do
16:27:02 <thingee> #action DuncanT to post his findings and discuss with dulek
16:27:06 * bswartz is already waist-deep in experimental APIs and their issues
16:27:23 <thingee> rhedlind and eharney how is the driver api doc coming along?
16:27:41 <eharney> thingee: not really moving yet, but i'll be getting things going more this week
16:28:00 <thingee> ok, next meeting we'll circle back
16:28:14 <thingee> #action rhedlind and eharney to collaborate on a driver api doc for cinder dev docs
16:28:32 <thingee> hemna: renewing spec return VolumeIsBusy for ing states
16:28:44 <hemna> https://review.openstack.org/#/c/149894/
16:28:52 <hemna> I started updating that guy yesterday
16:28:59 <thingee> very nice!
16:29:02 <hemna> working on some feedback from dulek and will push up a new version today.
16:29:18 <thingee> #info spec renewed for VolumeIsBusy with ing states
16:29:21 <thingee> #link https://review.openstack.org/#/c/149894/
16:29:50 <hemna> more reviewers would be good
16:29:54 <thingee> scottda: you're still set to present that spec to Nova in their next meeting :P
16:29:58 <scottda> We need a Nova spec for that as well
16:30:10 <dulek> hemna: I'll be around, but may reply with delay. Anyway - ask what you need. :)
16:30:19 <scottda> Yes, but I'd like to have a Nova spec ready for Nova meeting.
16:30:26 <hemna> scottda, ok I can put that together.
16:30:52 <scottda> cool, thx. Perhaps mriedem has input or can help with the NOva spec?
16:30:57 <thingee> #action hemna to put together a nova spec for scottda to present VolumeIsBusy being returned for ing states at next nova meeting
16:30:59 <thingee> whew
16:31:01 <thingee> thanks
16:31:15 <hemna> scottda, yah I was hoping to get some feedback/help from mriedem on that as well
16:31:24 <mriedem> i remember -1ing a cinder spec at one point
16:31:29 <thingee> jgriffith: POC's for ABC class proposals
16:31:45 <hemna> mriedem, heh yah, that url ^^
16:31:52 <scottda> mriedem: We will have cinder-api-microversions for this. YOur -1 was because of API changes
16:32:01 <scottda> IIRC
16:32:06 <jgriffith> thingee: nothing this week
16:32:10 <thingee> jgriffith: I think we wanted this ready for your topic at the summit
16:32:10 * jgriffith still has a month :)
16:32:22 <thingee> jgriffith: just checking in
16:32:26 <jgriffith> roger
16:32:49 <thingee> ok, I won't circle back :D
16:33:31 <thingee> jgriffith: I'm assuming you had discussions with eharney on that and your other topic of should cinder be the next vipr?
16:33:59 <jgriffith> thingee: not really... will need to try and link up with him next week
16:34:10 <jgriffith> thingee: I think we're both a bit busy this week
16:34:15 <thingee> jgriffith: ok just reminding :)
16:34:18 <jgriffith> :)
16:34:20 <eharney> will do
16:34:24 <thingee> summit will be here before you know it
16:34:29 <jgriffith> thingee: good thing, because I will certainly forget again :)
16:34:34 <thingee> ok lets look at new topics
16:34:39 <hemna> thingee, so do we only have 2 fishbowls planned (according to the etherpad ?)
16:34:41 <thingee> https://etherpad.openstack.org/p/cinder-mitaka-summit-topics
16:34:48 <thingee> hemna: yes!
16:35:07 <thingee> so we have four fish bowl slots... we only have two proposed which I agree are fine..just need to have etherpads ready ;)
16:35:08 <smcginnis> jgriffith: If I can find the time I would be interested in helping with the ABC/zope/etc POCs
16:35:16 <thingee> dulek: dulek patrickeast ^ ;)
16:35:20 <jgriffith> smcginnis: excellent
16:35:39 <smcginnis> Wondering if "Future of Cinder, and getting back to our roots" should move to a fishbowl?
16:35:47 <thingee> lets take a look at working sessions
16:35:56 <e0ne> jgriffith: I will be glad to discuss next VIPR too
16:36:14 <thingee> So Milestone deadline ... not sure who put that up... could be a sprint
16:36:17 <jgriffith> e0ne: noted
16:36:20 <e0ne> jgriffith: my bo cinder-without-nova could be related
16:36:27 <thingee> anyone have thoughts?
16:36:48 <hemna> e0ne, a session on attaching cinder volumes w/o nova could be good
16:36:52 <eharney> i think jgriffith had a different one about deadlines below
16:36:58 <e0ne> thingee: we could discuss it in a cinder weekly meeting, imo
16:37:00 <thingee> #info working session proposal: milestone deadlines
16:37:03 <jgriffith> eharney: yes, I did
16:37:11 <smcginnis> e0ne: I agree.
16:37:18 <e0ne> hemna: will you add a proposal?
16:37:18 <thingee> I have two agreements
16:37:23 <thingee> going...
16:37:25 <thingee> going...
16:37:27 <jgriffith> I don't know where that one came from either... but not sure it needs a working session slot
16:37:28 <jungleboyj_> thingee: I think that is a good place for that discussion.
16:37:38 <bswartz> milestone deadlines is not my proposal but do have a proposal related to milestone deadlines -- I'll make a ML post
16:37:45 <smcginnis> jungleboyj_: That being weekly meeting?
16:38:07 <thingee> smcginnis: I was also wondering what he was agreeing to :)
16:38:18 <smcginnis> :)
16:38:23 <jungleboyj_> smcginnis: or sprint, don't need a whole session on it.
16:38:31 <jungleboyj_> thingee: smcginnis Sorry, too many things going on at once.
16:38:45 <thingee> #agreed moving milestone deadlines to sprint
16:38:52 <jungleboyj_> thingee: ++
16:38:53 <hemna> jungleboyj_, a sprint session would be good for it.  I'd like to see any/all deadlines decided upon asap and published.
16:39:03 <jungleboyj_> hemna: ++
16:39:21 <smcginnis> hemna: The sooner that starts getting communicated, the better.
16:39:26 <thingee> #info working session proposal cinder-api microversions
16:39:27 <hemna> smcginnis, +A
16:39:35 <e0ne> smcginnis: agree
16:39:42 <xyang> are we going to add any new minimum feature requirement
16:39:43 <thingee> scottda: hi
16:39:45 <scottda> hi
16:39:55 <scottda> I've already put up spec and code
16:39:59 <smcginnis> xyang: Any you think should become minimum?
16:40:01 <thingee> so we already have the fishbowl session which is experimental api and micro versions
16:40:10 <thingee> patrickeast: ^
16:40:12 <scottda> https://review.openstack.org/#/c/223803/   #spec
16:40:22 <xyang> smcginnis: migration, retype, manage
16:40:28 <thingee> #info spec for microversions
16:40:29 <scottda> https://review.openstack.org/#/c/224910/ #code
16:40:37 <thingee> #link https://review.openstack.org/#/c/223803/
16:40:41 <scottda> I thought we might need a session to iron out details
16:40:43 <jungleboyj_> xyang: What would we add to the minimum?
16:40:48 <thingee> #info code for microversions
16:40:50 <thingee> #link https://review.openstack.org/#/c/224910/
16:41:05 <xyang> jungleboyj_: let me just add a note to the etherpad
16:41:08 <smcginnis> xyang: Seems reasonable.
16:41:13 <thingee> scottda: this is true. the fish bowl will be more user facing... working session can be more of a technical deep dive
16:41:20 <patrickeast> i kind of like the idea of having another more deep dive in how the microversions will be implemented
16:41:21 <thingee> patrickeast: does that make sense? ^
16:41:25 <hemna> also, FWIW, we seem to have a bunch of things that are looking like dependencies on the microversioning stuff landing early in M
16:41:27 <jungleboyj_> xyang: Ok.
16:41:28 <thingee> patrickeast: yay!
16:41:28 <patrickeast> thingee: yep :D
16:42:00 <thingee> #agreed Cinder-api microversion working session deep dive seems good!
16:42:03 <thingee> scottda: thanks
16:42:11 <hemna> so the more folks looking at scottda's spec and code the better.
16:42:15 <thingee> scottda: and thank for already being ready with spec/code
16:42:36 <scottda> sure. As hemna said, it's a dependency for a few things
16:42:39 <thingee> #info working session proposal: Remove volume manager locks
16:42:40 <thingee> hemna: hi
16:43:00 <hemna> so, I don't think we need a fishbowl for this one as it's more of a deep dive
16:43:11 <thingee> hemna: I agree.
16:43:13 <hemna> this one has some dependencies that need to happen prior to this.
16:43:19 <hemna> the microversion stuff that scottda is working on
16:43:30 <hemna> as well as gorka's compare/swap changes
16:43:31 <thingee> hemna: users shouldn't really know or care about this... just that stuff works
16:43:37 <hemna> thingee, yah.
16:44:02 <hemna> I'm still working on the review for the spec, so any eyes on it at this point would be good.
16:44:16 <hemna> I'd like to get started on the code soon, but want to iron it out first in spec if possible.
16:44:21 <thingee> hemna: my question though is what are we going to do differently here? I think last summit we had this similar topic, but it didn't really go anywhere.
16:44:40 <hemna> thingee, I think there are a few small differences
16:45:01 <hemna> mostly the above mentioned dependencies
16:45:19 <dulek> Maybe a sprint session then?
16:45:22 <hemna> and the addition of the new 'reading' states that gorka has mentioned as well
16:45:36 <hemna> those might already be in place now thought, unsure.
16:45:45 <hemna> the other related topic
16:45:47 <jgriffith> thingee: hemna IMO removal of locks shouldn't need a session at all, just some code
16:45:55 <hemna> is how to deal with the microversioning stuffs.
16:45:59 <jgriffith> no  spec either really
16:46:31 <hemna> what to do when the version doesn't match the new code.  how to deal with the existing volume manager locks, etc.
16:46:35 * jgriffith is no completely confused
16:46:36 <hemna> that part I'm unclear on still.
16:47:00 <hemna> anyway, we can take it offline in #cinder channel
16:47:08 <scottda> hemna: We can talk. I *think* I've got a picture about how it will work
16:47:28 <jgriffith> s/is no/is now/
16:47:43 <thingee> ok, just going to leave a note for the next meeting organizer to check back
16:47:45 <jgriffith> seems to be multiple conversations taking place, none having anything to do with current topic?
16:47:53 <hemna> scottda, coolio.   microversioning API only changes seems straight forward, but stuff that bleeds into the volume manager is a bit more involved.
16:48:23 <thingee> #action scottda will talk to hemna on volume manager locks to see if we need a topic in working session
16:48:24 <hemna> jgriffith, it's all related.
16:49:05 <thingee> ok 11 mins for sprints
16:49:06 <thingee> there's a lot
16:49:35 <thingee> one I want to focus on first are the potential to other session types
16:49:51 <thingee> #info sprint proposal: Future of Cinder and getting back to our roots
16:49:53 <thingee> jgriffith: hi!
16:49:57 <jgriffith> hola
16:50:16 <jgriffith> That might be a good fishbowl as you mentioned (or somebody mentioned)
16:50:38 <thingee> so my initial question is the difference here with your working session cinder should/could be the next vipr
16:50:43 <smcginnis> Seems like it might have wide interest. Or impact.
16:50:46 <jungleboyj_> jgriffith: That makes sense to me.  Seems like we want that to be open to a wider audience.
16:51:00 <thingee> I know one session is user wide, the other is cinder dev wide
16:51:09 <jgriffith> thingee: ahh... yeah, so they're different in my mind
16:51:38 <jgriffith> thingee: one is stressing Cinder/OpenStack is NOT VMware and we are crazy with vendor features
16:51:56 <jgriffith> thingee: the other is, how to make Cinder something more consumable outside of OpenStack
16:52:22 <jgriffith> thingee: and what features to all these "new" abstractions have that we're missing and do they really matter?  Or is it just marketing
16:52:46 <jgriffith> features is not a good choice of words maybe...
16:52:52 <jgriffith> but more along design
16:53:20 <jgriffith> are there things we need to look at in our design to offer more flexibility for plugins that does not impact core API
16:53:30 <jgriffith> that sort of thing... does that clarify at all?
16:53:37 <thingee> jgriffith: ok, so the future of cinder is more focused on reference implementation
16:53:49 <thingee> but a catchy title, as you would want... for a fish bowl :)
16:54:01 <jgriffith> thingee: and what do we do with these things like multi-attach, CG's, replication etc etc etc
16:54:10 <thingee> got it
16:54:14 <jgriffith> thingee: as in... "don't do them"
16:54:24 <jgriffith> or "do"
16:54:31 <thingee> well, users might be like "I want all the features"
16:54:38 <jgriffith> thingee: indeed!
16:54:46 <jungleboyj_> Do all the things!  Now!
16:54:54 <thingee> but ... some of us will be like "lets give them what they want because it makes my company happy" :)
16:54:55 <hemna> this sounds like the extensions discussion
16:55:03 <jgriffith> hemna: it's not
16:55:14 <jgriffith> it's about Cinder and what it should be
16:55:21 <thingee> and some of us will be like "this hurts cinder core, how do we ensure these features work without the reference..."
16:55:34 <jgriffith> regardless of the other components like extensions, contribs experimental API's and all that craziness
16:55:49 <thingee> jgriffith: I agree, it's different from extensions.
16:56:18 <jgriffith> hemna: it's more about a robust stable service that's maintainable/supportable
16:56:20 <thingee> so I think the discussion will play out like that.
16:56:34 <smcginnis> jgriffith: So - should we be adding new features that aren't core across all of not? Is that the point?
16:56:35 <jgriffith> and actually "works" without being a mess of spaghetti code and weird hacks all over the place
16:56:49 <hemna> jgriffith, I'm all for that :)  re: fixing nova <--> cinder interactions.
16:56:51 <jgriffith> smcginnis: yes, that's part of the point absolutely
16:56:52 <smcginnis> s/of not/or not/
16:57:05 * thingee is standing because there is a spider somewhere on his desk
16:57:10 <jgriffith> LOL
16:57:15 <jgriffith> thingee: you don't like spiders?
16:57:21 <smcginnis> Hah!
16:57:27 * jgriffith doesn't like them either... can't tell what kind of mood they're in
16:57:27 <thingee> jgriffith: not quick black spiders
16:57:31 <bswartz> only 2 minutes left
16:57:39 <smcginnis> My wife would be screaming bloody murder.
16:57:49 <jgriffith> ha
16:57:51 <diablo_rojo> it's the eyes...too many of them..
16:58:03 * hemna grabs the shotgun.....
16:58:08 <e0ne> :)
16:58:09 <jgriffith> diablo_rojo: yeah, I don't trust anything with more than 3 eyes
16:58:09 <thingee> ok... so fishbowl wise, I'm not sure the user can contribute to this.
16:58:13 <xyang> can we not talk about bugs here?:)
16:58:25 <jgriffith> thingee: yeah, may be a good point
16:58:30 <thingee> it might be good to get user/ops feedback though, because we're essentially saying we want to move away from providing all the features
16:58:31 <diablo_rojo> jgriffith: so people with glasses are untrustworthy?
16:58:42 <jgriffith> thingee: and honestly we as a dev team may not be able to even agree on anything here anyway
16:59:01 <jgriffith> diablo_rojo: those aren't eyes... just lenses :)
16:59:04 <thingee> jgriffith: I think it's going to be the next interesting move for the cinder PTL
16:59:08 <scottda> thingee: ++ I think user/ops will care about this
16:59:10 <thingee> *hint hint*
16:59:18 <jgriffith> thingee: indeed!!
16:59:33 <jgriffith> IMO it really could be a make or break for Cinder
16:59:37 <thingee> you want fame and glamour cinder ptl, this decision is it
16:59:38 <diablo_rojo> jgriffith:  okay good :)
16:59:42 <jgriffith> No pressure future PTL :)
16:59:55 <jungleboyj_> When are the election results?
16:59:56 <smcginnis> Hah, fame and glamour.
17:00:02 <thingee> ok we're out of time..
17:00:08 <thingee> thanks all for letting me lead the team for two cycles
17:00:11 <thingee> been a pleasure
17:00:16 <thingee> and I'm not disappearing
17:00:18 <thingee> so no rumors
17:00:20 <geguileo> thingee: thank you for leading!!
17:00:21 <smcginnis> Thanks thingee!
17:00:27 <jgriffith> jungleboyj_: 13:00 UTC Sept 24
17:00:29 <hemna> thingee, yah nice job man.
17:00:30 <tbarron> thingee: thanks!
17:00:32 <scottda> thank
17:00:32 <e0ne> thingee: thanks for leading!
17:00:32 <kmartin> thanks thingee
17:00:34 <jgriffith> thanks Mike!!!
17:00:38 <dulek> thanks!
17:00:40 <eharney> don't let that spider take you out :)  thanks for the leadership
17:00:43 <thingee> #endmeeting