16:00:11 <smcginnis> #startmeeting Cinder
16:00:11 <openstack> Meeting started Wed Oct 21 16:00:11 2015 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:15 <openstack> The meeting name has been set to 'cinder'
16:00:21 <jseiler_> hi
16:00:27 <geguileo> Hi!
16:00:31 <patrickeast> hi
16:00:32 <jungleboyj> Hello!
16:00:37 <dulek> o/
16:00:37 <smcginnis> Hey everyone.
16:00:39 <hemna> floop
16:00:40 <diablo_rojo> Hello :)
16:00:41 <jgregor> Hello!
16:00:44 <scottda> hey
16:00:45 <rhe00> hi
16:00:51 <ntpttr> hi
16:00:56 <bswartz> hi
16:01:06 <smcginnis> Maybe short meeting this week. We'll see. ;)
16:01:06 <kmartin> hi
16:01:12 <tbarron> hi
16:01:21 <smcginnis> #topic Announcements
16:01:37 <smcginnis> #info Summit sessions scheduled for next week
16:01:45 <smcginnis> Everything should be up to date on the sched site.
16:02:07 <smcginnis> If you looks at the design summit schedule you get a better view.
16:02:15 <xyang1> hi
16:02:23 <smcginnis> No design stuff on the main summit schedule to prevent wayward attendees. :)
16:02:34 * bswartz chuckles
16:02:35 <e0ne> hi
16:02:46 <smcginnis> #info No meeting next week
16:02:55 <smcginnis> Since it seems like it is asked every time.
16:03:03 <smcginnis> No meeting next week due to the summit taking place.
16:03:06 <geguileo> XD
16:03:19 <dulek> smcginnis: You should probably get annoucement on openstack-dev
16:03:21 <jungleboyj> smcginnis: Aren't we really haven't one big meeting!?!
16:03:23 <e0ne> smcginnis: it would be useful to send such things to the openstack-dev
16:03:27 <smcginnis> jungleboyj: True
16:03:41 <hemna> smcginnis, did we get a Cinder youtube.com account to record the sessions ?   I'm planning on bringing my camera w/ me.
16:03:44 <geguileo> dulek: e0ne +1
16:03:47 <smcginnis> dulek, e0ne: Sure, I'll send out an announcement.
16:04:00 <smcginnis> #action smcginnis to set up a Cinder youtube account
16:04:05 <jungleboyj> hemna: ++  Good idea.
16:04:11 <hemna> smcginnis, coolio thanks.
16:04:12 <geguileo> hemna: Great idea!!
16:04:13 <smcginnis> hemna: I had meant to do that. Thanks for the reminder.
16:04:14 <diablo_rojo> hemna +1
16:04:29 <smcginnis> That should help having that.
16:04:42 <smcginnis> #topic Rolling upgrades
16:04:44 <hemna> ok let me know I can stream those to the account.
16:04:46 <Swanson> hello
16:04:47 <smcginnis> dulek: Hey
16:05:02 <dulek> hemna: This will probably work worse than Google Hangout without a few good mics.
16:05:29 <smcginnis> #link http://lists.openstack.org/pipermail/openstack-dev/2015-October/077411.html
16:05:41 <dulek> Hi!
16:05:45 <hemna> dulek, yah dunno I'll play with the mic on my camera.
16:05:57 <dulek> hemna: Also - I think Nova guys used OpenStack Foundation channel to put their stuff.
16:06:18 <smcginnis> dulek: You brought up the rolling upgrades on the ML. Thought it would be good to make sure everyone was aware of it here. Can you give an overview?
16:06:34 <dulek> smcginnis: Yeah. :)
16:06:36 <dulek> So it
16:07:00 <dulek> It's all based on the fact that services should interoperate between versions.
16:07:11 <dulek> There are few channels of communication:
16:07:13 <dulek> RPC
16:07:18 <dulek> API
16:07:19 <dulek> DB
16:07:37 <dulek> We won't care on the API - that's what outside services call. ;)
16:08:12 <dulek> RPC consists of definitions of RPC methods and what's actually sent through.
16:08:26 <dulek> For that we have RPC versioning which is in poor state in Cinder.
16:08:38 <dulek> And versioned objects - which we're adopting.
16:09:05 <dulek> Apart from that there's DB compatibility - if we remove a column from the DB, then older services will fail.
16:09:45 <dulek> So we have some work in terms of RPC done by thangp and I think this is going in good direction.
16:09:51 <smcginnis> dulek: And we haven't dropped any columns so far, right?
16:10:02 <dulek> We need to think of DB mirations.
16:10:34 <dulek> smcginnis: Not since Juno. We may get a test into the tree that will ensure that we won't merge such migration.
16:10:56 <geguileo> dulek: Can't we remove the column once everything is upgraded?
16:11:14 <dulek> I'm not sure if that satisfies everyone - for example geguileo's specs will get harder to implement.
16:11:52 <dulek> geguileo: That's called online schema migrations - Nova's implemented it. It means all migrations have 3 phases.
16:12:05 <dulek> Problem is - their implementation is very experimental.
16:12:07 <geguileo> I thought that's what we were going to do
16:12:32 <geguileo> But that's because they had other version before, right?
16:12:32 <dulek> dansmith suggested that it isn't a best idea to adopt that.
16:12:43 <geguileo> Really?  :-(
16:12:59 <geguileo> So we wouldn't have renaming or removal of columns?
16:13:14 <dulek> Generally current Nova's approach would be hard to implement without conductor-like service.
16:13:22 <smcginnis> dulek: Is the concern that it isn't baked enough? Or are they actually running into problems with it?
16:13:45 <dulek> smcginnis: I'm not sure on that.
16:14:06 <dansmith> the online schema stuff has nothing to do with anything really
16:14:13 <dansmith> it's an optimization of writing manual migrations
16:14:27 <dansmith> the hard problems are all the same with manual migrations or the online stuff
16:14:43 <dulek> There's another idea - just manually split migrations when writing the code.
16:14:44 <dansmith> but upgrades are achievable without what you see in our tree as "online schema"
16:15:05 <dansmith> my blog posts should explain what we currently do, which isn't using that online schema experimental thing
16:15:08 <geguileo> dansmith: Can those upgrade remove/rename columns?
16:15:28 <smcginnis> #link http://www.danplanet.com/blog/2015/10/05/upgrades-in-nova-the-details/
16:15:29 <dulek> dansmith: Doesn't it require something like conductor to translate objects?
16:15:36 <dansmith> geguileo: you can't do that in any kind of migration unless you require downtime
16:15:38 <smcginnis> dansmith: That one, right? And its follow ons.
16:15:43 <dansmith> smcginnis: yep
16:15:55 <dansmith> I think we should plan to talk about this in the cross-project session on tuesday
16:16:08 <dansmith> because I'm technically on vacation today and it's a complicated thing to discuss
16:16:16 <smcginnis> dansmith: :)
16:16:26 <dulek> I can volunteer to be there. :)
16:16:39 <scottda> I'll add it to the Tuesday cinder-nova session agenda
16:17:07 <dulek> scottda: Isn't it already packed and actually has nothing to do with cinder-nova interactions?
16:17:14 <jungleboyj> scottda: How many things we have in there now?
16:17:19 <smcginnis> dansmith: That's the Live Upgrades on Tuesday at 4:40pm, correct?
16:17:24 <dansmith> smcginnis: yep
16:17:29 <scottda> Not that many...I was going to bring this up later in the meeting
16:17:35 <smcginnis> On my schedule
16:17:44 <dansmith> smcginnis: if you show up with good questions/concerns it will really help get that discussion going
16:17:52 <scottda> ahhh...we're talking about 2 different things
16:17:54 <dansmith> you meaning "people"
16:17:59 <smcginnis> dansmith: I'll try to do my homework ahead of time.
16:18:24 <dansmith> smcginnis: just "how do we rename columns" is good stuff, although my posts should explain how to do that
16:18:30 <smcginnis> scottda: Still could be interesting in the cinder-nova meeting.
16:18:39 <dulek> dansmith: It is but not without conductor. ;)
16:18:51 <dulek> dansmith: Our problem is we have all the services accessing the DB.
16:19:17 <dansmith> dulek: yep, which is a problem you're going to have to solve, either by rules and care or by doing something different :)
16:20:23 <dulek> Okay. So that's it on the DB stuff I think… Follow up will be in Tokyo.
16:20:49 <smcginnis> dulek: Thank you.
16:20:49 <dulek> There's still some RPC stuff to discuss.
16:21:19 <dulek> smcginnis: Can I continue? ;)
16:21:27 <smcginnis> dulek: Yes, please do!
16:21:31 <dansmith> I gotta run, but I hope you guys will bring these questions on tuesday :)
16:21:40 <smcginnis> dansmith: Thanks Dan.
16:21:45 <dulek> dansmith: Thanks!
16:21:58 <dulek> So one thing I've noticed is that we're passing some dicts as RPC arguments.
16:22:18 <dulek> These are request_spec, filter_properties and capabilities (sent c-vol->c-sch).
16:22:36 <dulek> Question is - are we allowing that we will remove/rename stuff from them?
16:22:47 <dulek> If so - we need to convert them into versioned objects.
16:23:03 <dulek> Thoughts?
16:23:58 <smcginnis> It seems like it would be safer to convert them.
16:24:04 <dulek> Okay, my opinion is that we should do that just in case.
16:24:06 <smcginnis> Anyone else?
16:24:33 <geguileo> Aren't versioned objects intended for DB stuff?
16:24:57 <hemna> geguileo, I thought so
16:24:59 <dulek> geguileo: Also. But main purpose is compatibility of the stuff you send over RPC.
16:25:17 <smcginnis> I didn't think they had to be DB objects.
16:25:27 <geguileo> OK, then we should convert them
16:25:36 <dulek> If you change structure of object sent over RPC - older version of service would not understand it.
16:26:00 <dulek> Versioned objects provide layer to translate that object to older version before sending.
16:26:14 <dulek> So it is understood by everyone.
16:26:30 <dulek> Okay. :)
16:26:43 <dulek> #link https://review.openstack.org/#/c/177054/
16:26:44 <geguileo> Yeah, that part I know, I just thought we were only going to use it for the DB side of it
16:26:59 <geguileo> Anyway +1 to move those to VO
16:27:23 <smcginnis> I believe we have this on the sprint session list for next Friday. It might be good to at least have a quick discussion on it.
16:27:35 <smcginnis> But from what I can see, VO is probably necessary.
16:28:00 <smcginnis> dulek: OK, anything else you want to cover on this topic?
16:28:01 <dulek> We have this patch by thangp - it's huge. Before L-release jgriffith said that we should merge it just after master opens.
16:28:13 <dulek> (talking about this one - https://review.openstack.org/#/c/177054)
16:28:14 <smcginnis> That one? ^^
16:28:17 <smcginnis> :)
16:28:17 <jgriffith> dulek: :)
16:28:35 <dulek> So - is this still true or we should revisit that decision? ;)
16:28:55 <smcginnis> I haven't noticed ThangP around lately. That needs a rebase.
16:29:11 <jgriffith> I'm more than a little concerned about that patch
16:29:31 <dulek> I can take over the work if he isn't able to work on that further.
16:29:44 <jgriffith> I recall thingee wanted that merged for L, but I'm not quite sure
16:29:55 <dulek> Anyway - a decision on direction would be needed.
16:29:59 <jgriffith> well... I was def -2 for L, still not sure
16:30:08 <jgriffith> has to be a better way to break that up
16:30:18 <hemna> it only changes everything, what could go wrong?
16:30:26 <jgriffith> hemna: :)
16:30:42 <dulek> snapshot object patch as also big and we lived.
16:31:06 <jgriffith> dulek: ummm... we are still fixing bugs on that one I think
16:31:11 <geguileo> I'm not too happy about that patch, as I mentioned in the comments, but I think it needs to happen
16:31:30 <jgriffith> geguileo: I agree... we probably do need to bite the bullet
16:31:32 <geguileo> Although it will require a lot of reviewers
16:31:52 <geguileo> I mean, it's easy to miss something, so the more the merrier
16:31:52 <smcginnis> geguileo: +111
16:31:58 <jgriffith> I'm just not looking forward to it :(
16:32:02 <dulek> jgriffith: Recent comments were on upgradeability of RPC methods. We don't even have clear strategy on that yet.
16:32:03 <hemna> I guess it's a dumb question, but is there anyway to break that patch up into a series ?
16:32:09 <geguileo> jgriffith: Me neither  XD
16:32:48 <geguileo> hemna: That's the broken down version after I required it to be split  ;-)
16:32:48 <dulek> hemna: We've tried, but ended up writing even more code in the broken up patches.
16:32:57 <hemna> :(
16:33:00 <dulek> hemna: To make tests work.
16:33:04 <geguileo> hemna: 1037 LOC changes are from 1 test file
16:33:25 <hemna> yah test_volume.py looks painful
16:33:32 <smcginnis> :{
16:33:33 <dulek> Yeah, a lot of the changes are to tests.
16:33:38 <hemna> heh, like I said, it was a dumb question
16:33:48 <jgriffith> test_volume.py sucks
16:33:50 * dulek thinks that test_volume.py always looked painful.
16:33:56 <jgriffith> plain and simple... worst unit test ever
16:34:07 <hemna> jgriffith, +1
16:34:08 <eharney> that's why i started breaking it up into smaller bitss
16:34:19 <hemna> that file = hell
16:34:19 <jgriffith> eharney: yes... and MUCH appreciated
16:34:27 <jgriffith> ok... side tracked
16:34:34 <jgriffith> so I think we just move forward with it
16:34:45 <jgriffith> I do think we need a lot of focus on it from everyone
16:34:45 <geguileo> jgriffith: +1
16:35:01 <dulek> Okay, I'll make sure to get that rebased and ready for reviews.
16:35:17 <jgriffith> and I REALLY appreciate the help from dansmith and would like to make sure we continue to get his input assuming he has bandwidth and is willing
16:35:51 * jgriffith realizes he's on vacation and that puts us out to possibly after summit
16:36:02 <dulek> So that's how you get reviewers from other projects to review your code…
16:36:48 <dulek> I think my topic's over for now. We should talk more in Japan. :)
16:37:08 <geguileo> And we really need proper specs for that
16:37:16 <smcginnis> dulek: Thanks!
16:37:16 <geguileo> By that I mean rolling upgrades
16:37:30 <dulek> geguileo: +1, I'll take care of that (maybe not before the summit).
16:37:31 <dulek> Thank you everyone!
16:37:47 <geguileo> dulek: Thanks
16:37:49 <smcginnis> #topic Open discussion
16:38:07 <scottda> I wanted to talk about the agenda for the nova-cinder session
16:38:29 <scottda> I copied info from the etherpad to the session agenda:https://etherpad.openstack.org/p/NovaCinderMitakaSession
16:38:49 <scottda> hemna: Do we need to talk about the os-brick rootwrap issue?
16:39:03 <hemna> scottda, yes
16:39:09 <smcginnis> #info Cinder-nova session planning
16:39:11 <smcginnis> #link http://www.danplanet.com/blog/2015/10/05/upgrades-in-nova-the-details/
16:39:18 <scottda> and is is ok to put you on the hook for that?
16:39:25 <hemna> sure
16:39:41 <scottda> jungleboyj: Did you put up the item for Extend Attached Volumes ?
16:39:55 <jungleboyj> scottda: Yes.
16:40:02 <hemna> scottda, matt thinks it's an oslo discussion fwiw
16:40:02 <scottda> and you are OK to lead that?
16:40:26 <jungleboyj> scottda: Yes, I can.  How is that an oslo discussion?
16:40:39 <hemna> jungleboyj, I was referring to the os-brick item
16:40:41 <scottda> I think hemna meant rootwrap
16:41:00 <scottda> OK. There's an open section on Bugs, but nothing there to discuss yet....
16:41:07 <smcginnis> We should see where privsep is. That was pitched as a rootwrap replacement.
16:41:12 <jungleboyj> hemna: Ok, *phew*  Was confused.
16:41:22 <scottda> Please list things that are nova volume bugs that you have an interest in.
16:41:54 <scottda> Otherwise, the session looks like it could be a little light on content.
16:42:02 <scottda> That's all I had on this.
16:42:24 <smcginnis> scottda: I'm sure we'll rathole on a few things to fill the time. :)
16:42:34 <hemna> smcginnis, we are experts at that.
16:42:50 <scottda> Yes, I promised a separate session for bike-shedding, but I failed to schedule that.
16:43:19 <jungleboyj> hemna: ++
16:44:51 <smcginnis> Anything else? Anyone?
16:45:03 <eharney> one quick thing
16:45:09 <jungleboyj> smcginnis: Do we want to try to nail down a plan for Monday night?
16:45:36 <eharney> i've been poking at documenting our driver API (related to a summit session) -- some early pieces here if anyone is curious  https://github.com/eharney/driver_doc/blob/master/driver.rst
16:46:23 <smcginnis> #link https://github.com/eharney/driver_doc/blob/master/driver.rst Start of driver API documentation
16:46:46 <eharney> once it's more complete/polished/etc i'll push it toward our devref docs
16:46:56 <eharney> (the todo list is still pretty long)
16:47:12 <smcginnis> eharney: Need any help on anything with that?
16:47:35 <hemna> eharney, nice
16:47:56 <eharney> any help collecting all of the "you need to know these three magic incantations when implementing method X" kind of knowledge, is useful
16:48:26 <hemna> eharney, you can ping me about initialize_connection and terminate_connection for FC based drivers
16:48:27 <jungleboyj> eharney: Thanks for getting that started.  Looks like a good start.
16:48:34 <smcginnis> eharney: Looks really nice. I'll try to spend some time looking for implied things that should be stated clearly.
16:48:40 <eharney> https://etherpad.openstack.org/p/Cinder_Driver_API_Doc   is my working todo list
16:48:49 <eharney> just throwing that out there for anyone interested
16:48:54 <smcginnis> #link https://github.com/eharney/driver_doc/blob/master/driver.rst
16:48:59 <smcginnis> eharney: Awesome, thanks!
16:49:17 <smcginnis> jungleboyj: Monday night sounds good.
16:49:42 <smcginnis> Folks want to meet up somewhere?
16:50:01 <jungleboyj> smcginnis: I am game.
16:50:02 <geguileo> eharney: You should add those links to https://etherpad.openstack.org/p/mitaka-cinder-driver-interface
16:50:09 <kmartin> eharney, it would be nice to get all the export stuff include, that jgriffith documented
16:50:11 <dulek> smcginnis: Yeah. :)
16:50:13 <smcginnis> geguileo: Good point.
16:50:16 <patrickeast> monday works for me
16:50:28 <scottda> Do we have anyone Cinder devs in Japan that can help pick a place to meet?
16:50:49 <eharney> geguileo: ahh i didn't realize the etherpads were already up
16:51:24 <jungleboyj> smcginnis: I wonder if we want to just pick a time and place at the conference center to meet and then go from there?
16:51:36 * smcginnis was trying to be proactive
16:51:41 <jungleboyj> smcginnis: When are you getting into Tokyo?
16:51:54 <smcginnis> jungleboyj: That might work best. Unless someone knows the area and has a suggestion.
16:52:15 <smcginnis> jungleboyj: I should be getting there around mid day, depending on when we get out of Hakone.
16:52:44 <geguileo> jungleboyj: +1
16:52:51 <smcginnis> jungleboyj: How late is the Women of OpenStack event.
16:53:06 <kmartin> smcginnis, I have a private HP party on Monday, but will try to make both
16:53:13 <dulek> smcginnis: 4:30 PM to 7:30 PM
16:53:16 <smcginnis> kmartin: Of course you do. :P
16:53:21 <jungleboyj> 7:30.
16:53:47 <smcginnis> Well, we can follow tradition and do it overlapping with the HP private party. :)
16:53:51 <jungleboyj> kmartin and his private parties.
16:54:04 <kmartin> thanks to scottda, they shared the same parking lot in Vancouver :)
16:54:24 <smcginnis> OK, how about convention center lobby at 7:30. Meet up there and find somewhere from there.
16:54:29 * jungleboyj thinks we just go crash the HP party then.  ;-)
16:54:41 <smcginnis> kmartin: Where's the party this year. Maybe we can find somewhere next door again.
16:54:45 <jungleboyj> smcginnis: That works for me.
16:54:52 <patrickeast> smcginnis: sounds good
16:54:54 <dulek> smcginnis: I'm fine with that.
16:55:00 * smcginnis apoligizes to anyone attending this meeting trying to actually be productive
16:55:20 <jungleboyj> smcginnis: hemna and I get there earlier.  We can maybe scope things out earlier in the day.
16:55:28 <kmartin> smcginnis, I'll look it up and send it to you, walking distance from the convention center
16:55:42 <smcginnis> kmartin: Cool, then maybe we can do the same as last time. ;)
16:55:56 <smcginnis> jungleboyj: Volunteering to do bar research?
16:56:07 <smcginnis> Sounds like a plan.
16:56:12 <jungleboyj> :-)
16:56:21 <scottda> jungleboyj: It should be easy to find. It is here: 土風炉 品川店,
16:56:29 <smcginnis> Hah
16:56:30 <kmartin> Tofuro 2-15-1 Konan, Minato, Tokyo 108-0075
16:56:35 <jungleboyj> scottda: I have friends who can read that.
16:56:53 <jungleboyj> smcginnis: So, lets specify meeting by registration at the conference center at 7:30.
16:57:01 <kmartin> I've been practicing that one was easy scottda :)
16:57:02 <smcginnis> I'm leaving in the morning. If you need anything feel free to message me. I'll check in as I can.
16:57:08 <hemna> scottda, it could be at おなら
16:57:10 <smcginnis> jungleboyj: +1 it's official.
16:57:15 <geguileo> jungleboyj: +1
16:57:44 <jungleboyj> Cool.
16:57:49 <smcginnis> OK, thanks everyone. Looking forward to seeing folks next week.
16:57:53 <dulek> bye!
16:57:57 <jungleboyj> smcginnis: You going to send something to the mailing list or should I?
16:58:00 <smcginnis> #endmeeting