16:00:01 <smcginnis> #startmeeting Cinder
16:00:01 <openstack> Meeting started Wed Dec 23 16:00:01 2015 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <openstack> The meeting name has been set to 'cinder'
16:00:10 <smcginnis> Courtesy ping: dulek duncant eharney geguileo winston-d e0ne jungleboyj jgriffith thingee smcginnis hemna xyang tbarron scottda erlon rhedlind vincent_hou
16:00:14 <geguileo> Hi!
16:00:22 <kmartin> o/
16:00:22 <eharney> hi
16:00:23 <e0ne> hi
16:00:25 <tbarron> hi
16:00:34 <patrickeast> hi
16:00:38 <smcginnis> Hey everyone. Hopefully a short one today.
16:00:38 <wilson1> hello
16:00:43 * smcginnis knocks on counter
16:00:55 <smcginnis> #topic Announcements
16:01:11 <DuncanT> Hi
16:01:12 <smcginnis> #info Cinder Liberty 7.0.1 released
16:01:28 <smcginnis> We had enough bug fixes ready.
16:01:37 <erlon> Hi
16:01:47 <smcginnis> And eharney reminded me that it was now up to us when to do a stable release, so thanks for that. ;)
16:01:58 <smcginnis> Maybe interesting to deployers.
16:02:33 <eharney> we had more patches than average for the first stable release, iirc
16:03:02 <smcginnis> eharney: Yeah, it seemed like t.
16:03:05 <smcginnis> it*
16:03:27 <kmartin> it seems like more items were allowed to be backported this release
16:03:29 <e0ne> and we've still got few more on review
16:03:32 <xyang1> hi
16:03:59 <e0ne> it was a lot of drivers fixes
16:04:15 <scottda> Hi
16:04:18 <smcginnis> It may also be a difference since we have more stable cores now, so better chance of something making it through.
16:04:48 <winston-d> o/
16:04:57 <smcginnis> #info Bug stats- Cinder: 465, cinderclient: 37, os-brick: 12
16:05:09 <e0ne> one more announcement
16:05:16 <smcginnis> Cinder numbers looking a lot better.
16:05:21 <smcginnis> e0ne: Sure, what's that?
16:05:24 <e0ne> https://github.com/openstack/python-brick-cinderclient-ext if now under OpenStack tent
16:05:38 <smcginnis> e0ne: That's right! :)
16:06:02 <e0ne> technically, it's not a part of cinder yet, one more patch has to be merged
16:06:19 <e0ne> but we did a good job and everybody welcome to contribute
16:06:20 <smcginnis> e0ne: So a big step forward in being able to do non-Nova volume management.
16:06:32 <smcginnis> e0ne: Thanks for all you've done on that so far.
16:06:40 <e0ne> smcginnis: thanks!
16:06:48 <winston-d> e0ne: kudos
16:06:55 <smcginnis> Definitely if anyone else is willing to help, I personally would love to see that get supported.
16:07:20 <e0ne> I'll propose few patches for attach/detach features early next week
16:07:37 <smcginnis> Great!
16:07:42 <e0ne> smcginnis: that's all from my side on this topic
16:07:48 <smcginnis> e0ne: Thanks!
16:08:21 <e0ne> #action e0nt to sede e-mail to openstack-dev
16:08:21 <smcginnis> That's all I really had for announcments as well. Anyone else?
16:08:30 <erlon> What are the implemented features so far?
16:08:49 <e0ne> erlon: only 'get-connector'
16:09:08 <e0ne> we can discuss it in #openstack-cinder
16:09:53 <erlon> e0ne oj
16:10:01 <smcginnis> #topic Open discussion
16:10:20 <e0ne> will he have meeting next two weeks?
16:10:50 <smcginnis> e0ne: Good question. I'm travelling next week, so I'm not sure yet if I'll be able to be online at this time.
16:11:15 <e0ne> there will be New Year and Orthodox Christmas.
16:11:32 <smcginnis> Any objects from anyone if we skip the next two weeks?
16:11:42 <kmartin> HP is shutting down starting tomorrow until the Jan 4th
16:12:01 <xyang1> smcginnis: probably just skip 1 week
16:12:08 <e0ne> kmartin: do you close your public clouds for holidays too? :)
16:12:18 <eharney> skipping Dec 30 seems sensible
16:12:19 <smcginnis> Dell's off this week. :)
16:12:23 <kmartin> smcginnis, has the mid-cycle wiki been started for topics?
16:12:43 <kmartin> e0ne, something like that :)
16:12:46 <xyang1> smcginnis: people should be back on 1/6
16:13:00 <smcginnis> kmartin: We've started in the planning wiki - https://etherpad.openstack.org/p/mitaka-cinder-midcycle
16:13:04 <diablo_rojo> Hello Sorry I'm late.
16:13:13 <smcginnis> #info Midcycle topic planning - https://etherpad.openstack.org/p/mitaka-cinder-midcycle
16:13:21 <smcginnis> diablo_rojo: This is going on your record.
16:13:41 <diablo_rojo> smcginnis: I blame jungleboy
16:13:44 <smcginnis> xyang1: That makes sense. I'll send out an announcement on the ML for no meeting next week.
16:13:49 <smcginnis> diablo_rojo: ;)
16:13:58 <smcginnis> Then we can see where things are for the week after.
16:14:29 <kmartin> most things can be blamed on jungleboy
16:14:31 <e0ne> there are still no much topics for midcycle
16:14:33 <scottda> kmartin: HP public cloud did not shut down..We're still on call!
16:14:38 <e0ne> :)
16:14:56 <smcginnis> e0ne: Good point. We haven't really focused on it.
16:15:08 <smcginnis> #action Add topics to midcycle: https://etherpad.openstack.org/p/mitaka-cinder-midcycle
16:15:14 <kmartin> scottda, nice Holiday pay :)
16:15:40 <smcginnis> e0ne: I'm sure we'll find plenty to discuss. We always do. :)
16:16:06 <smcginnis> e0ne: Are there any items from your non-Nova work that we should go over?
16:16:55 <e0ne> smcginnis: not sure yet. at least, we can disscuss current status and some kind of the roadmap
16:17:19 <smcginnis> We can probably put in placeholders for all the main specs, at least to mention and make sure everyone is aware of the work being done.
16:17:25 <e0ne> smcginnis: I didn't get final agreement from my menager that my business trip to midcycle will be approved:(
16:17:41 <kmartin> smcginnis, would it make sense to make a push to get some of the priority items(version objects, microversions, HA) reviewed and merged before the mid-cycle
16:17:45 <smcginnis> e0ne: Let me know if an email would help. ;)
16:17:57 <e0ne> smcginnis: :)
16:18:01 <e0ne> thanks, Sean
16:18:22 <winston-d> the coming midcycle will be in Ireland, right?
16:18:32 <smcginnis> kmartin: Good point. Midcycle is after M-2, so it really would be best if we get some complete.
16:18:37 <kmartin> e0ne, we'll plan on recording again
16:18:54 <smcginnis> winston-d: We tried for Ireland, but ended up back in the US. NetApp offices in Raleigh.
16:19:08 <winston-d> smcginnis: oh
16:19:19 <winston-d> smcginnis: good to know, thx
16:19:30 <kmartin> NetApp/SolidFire office :)
16:19:45 <smcginnis> I do hope that whoever ends up planning the next one is able to get it in EMEA. It would be great if at least every 4th or 5th is easier for non-US folks.
16:19:57 <smcginnis> kmartin: Hehe, I thought about saying that but didn't. ;)
16:20:04 <jgriffith> :)
16:20:14 <jgriffith> I'm all in on EMEA for the summer mid-cycle
16:20:23 <esker> smcginnis: winston-d:  Raleigh may not stack up in the Guinness dept.... but it's not so bad ;-)
16:20:24 <smcginnis> jgriffith: That trip works for you. Meet your new bosses. :P
16:20:24 <e0ne> jgriffith: +2/A
16:20:31 <kmartin> jgriffith, +1, your badge might work
16:20:36 <jgriffith> smcginnis: yeah, that's what i was thinking
16:20:41 <smcginnis> esker: Haven't been there yet, so I am looking forward to it.
16:20:45 <jgriffith> kmartin: LOL
16:21:12 <e0ne> kmartin, jgriffith: only if we'll rename the driver ;)
16:21:29 * jgriffith rolls his eyes about renaming things
16:21:33 <smcginnis> mv cinder/volume/drivers/solidfire.* cinder/volume/drivers/netapp/
16:21:40 <smcginnis> :)
16:21:46 <e0ne> :)
16:21:59 <jungleboyj> :-)
16:22:15 <e0ne> smcginnis: nit: git mv
16:22:25 <jungleboyj> smcginnis: -1
16:22:36 <smcginnis> e0ne: Hah, -1'd in the meeting. :)
16:22:55 <smcginnis> OK, everyone please spend a little time on the top specs and implementions in https://etherpad.openstack.org/p/mitaka-cinder-spec-review-tracking
16:23:02 <smcginnis> Would be great to get those through.
16:23:12 <smcginnis> And please add any midcycle topics to the planning etherpad.
16:23:36 <kmartin> #link https://etherpad.openstack.org/p/mitaka-cinder-spec-review-tracking
16:23:45 <smcginnis> Anyone else have anything to discuss, or should we go back to our own little corner?
16:24:16 <kmartin> #link https://etherpad.openstack.org/p/mitaka-cinder-midcycle
16:24:52 <smcginnis> OK, have a good holiday all. See you in two weeks.
16:25:02 <smcginnis> #endmeeting