16:00:05 <smcginnis> #startmeeting Cinder
16:00:06 <openstack> Meeting started Wed May  4 16:00:05 2016 UTC and is due to finish in 60 minutes.  The chair is smcginnis. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:08 <thingee> o/
16:00:09 <smcginnis> Ping: dulek duncant eharney geguileo winston-d e0ne jungleboyj jgriffith thingee smcginnis hemna xyang tbarron scottda erlon rhedlind jbernard _alastor_ vincent_hou kmartin patrickeast sheel dongwenjuan JaniceLee cFouts Thelo vivekd adrianofr mtanino yuriy_n17 karlamrhein diablo_rojo jay.xu jgregor baumann rajinir
16:00:09 <openstack> The meeting name has been set to 'cinder'
16:00:13 <eharney> hi
16:00:18 <geguileo> smcginnis: Thanks
16:00:18 <e0ne> hi
16:00:18 <ameade> here
16:00:19 <patrickeast> hey
16:00:20 <geguileo> Hi
16:00:21 <mtanino> hi
16:00:21 <aimeeu> hello - lurking and learning
16:00:23 <scottda> hi
16:00:29 <smcginnis> aimeeu: Welcome!
16:00:33 <xyang1> hi
16:00:34 <scottda> welcom aimeeu
16:00:37 <jungleboyj> Hello!
16:00:38 <jgregor> Hello!
16:00:38 <thingee> aimeeu: hey!
16:00:41 <e0ne> #link https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting
16:00:42 <adrianofr> hello
16:00:48 <jungleboyj> Hey aimeeu !  Glad to have you join us.
16:00:49 <diablo_rojo> hello :)
16:00:53 <baumann> Hello!
16:00:57 <smcginnis> #topic Announcements
16:00:58 <Swanson> hello
16:01:03 <aimeeu> jungleboy jay: thanks!
16:01:14 <smcginnis> So not too much coming off of the summit last week.
16:01:25 <sheel> hi
16:01:27 <ntpttr_> o/
16:01:30 <smcginnis> I will be writing up and sending out a summary of our design summit sessions soon.
16:01:54 <smcginnis> And updating the tracking etherpad based on our identified priorities.
16:02:03 <smcginnis> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking Review Priorities Etherpad
16:02:19 <e0ne> smcginnis: what about anouncing requirements for backups ci's?
16:02:31 <e0ne> and for os-brick too
16:02:35 <smcginnis> Also just want to mention the link for Nova volume related bugs:
16:02:43 <smcginnis> #link https://bugs.launchpad.net/nova/+bugs?field.status:list=NEW&field.tag=volumes Nova volume issues
16:02:50 <smcginnis> e0ne: Yep, that too.
16:02:57 <diablo_rojo> We recorded almost all the sessions for those that couldn't attend
16:02:58 <smcginnis> I have a few todo's from the summit to go through.
16:03:02 * thingee adds to agenda hoping smcginnis notices
16:03:04 <diablo_rojo> #link https://www.youtube.com/channel/UCJ8Koy4gsISMy0qW3CWZmaQ Cinder Youtube Channel
16:03:15 * smcginnis refreshes his browser
16:03:21 <tbarron> hi
16:03:27 <smcginnis> diablo_rojo: Thanks! Good to capture that.
16:03:40 <diablo_rojo> smcginnis: No problem :) AV club represent!
16:04:15 <jungleboyj> :-)
16:04:20 <smcginnis> We did discuss at the summit enforcing CI for backup drivers and os-brick. Especially for those with specific os-brick connectors.
16:04:30 <smcginnis> I will send out an official announcement on that soon.
16:04:41 <zhanghao> hi
16:04:45 <smcginnis> Makes sense since we require that for volume and fczm drivers.
16:04:54 <diablo_rojo> Yes please, more brick CI would be wonderful
16:05:05 <thingee> smcginnis: if people were fine the last way I handled things, I would be happy to add this to my plate.
16:05:06 * jungleboyj missed those dsicussions.
16:05:15 <smcginnis> thingee: Sure!
16:05:23 <smcginnis> thingee: Thanks, that would be great!
16:05:42 <thingee> etherpad with the community agreed timeline?
16:06:02 <diablo_rojo> Was it end of n2?
16:06:08 <jungleboyj> So, all 3rd Party CIs need to now watch for changes to brick?
16:06:12 <smcginnis> No timeline discussed so far. I think maybe a goal by the end of Newton, start seriously enforcing in Ocata?
16:06:25 <diablo_rojo> jungleboyj: Just ones with connectors in brick
16:06:30 <smcginnis> jungleboyj: Yep
16:06:38 <e0ne> jungleboyj: I don't thinks so. IMO, only for specified connectors
16:06:38 <jungleboyj> diablo_rojo: Ok.
16:06:47 <jgriffith> I just want to say on record again that I'm not going to do another CI for brick
16:06:47 <smcginnis> Definitely for ones with connectors in brick. Bonus points for anyone else.
16:06:48 <jungleboyj> e0ne: Thanks.
16:06:50 <diablo_rojo> e0ne: Thats what I thought
16:06:52 <jgriffith> I think we need a better answer there
16:07:02 <smcginnis> jgriffith: What do you mean?
16:07:04 <jgriffith> by this logic we should all be required to have CI for oslo libs
16:07:05 <diablo_rojo> smcginnis: +1
16:07:17 <e0ne> jgriffith: how to earse history in irc? ;)
16:07:26 <jgriffith> smcginnis: maybe I'm misunderstanding, but are you proposing requiring 3'rd party CI for brick?
16:07:34 <xyang1> smcginnis: are you saying iscsi and fc drivers don't need ci in brick?
16:07:39 <smcginnis> jgriffith: If you have a vendor specific connector in brick.
16:07:40 <diablo_rojo> jgriffith: You don't have a brick connector so you dont NEED CI
16:07:46 <thingee> smcginnis: wait I'm confused by the brick piece too.. aren't these indirectly tested already?
16:07:56 <smcginnis> thingee: Yes and no.
16:08:01 <thingee> last time we talked about this, issues would eventually surface on the cinder third party testing
16:08:02 <smcginnis> Ultimately yes.
16:08:06 <jgriffith> diablo_rojo: smcginnis ok
16:08:18 <e0ne> thingee: we can break connector in the new release of os-brick now
16:08:21 <smcginnis> But until we do a release, we don't find out if something broke until it's out there.
16:08:33 <smcginnis> Which did happen for a few folks last cycle.
16:08:40 <thingee> e0ne: right, but that new release would be tested in cinder eventually
16:08:43 <e0ne> smcginnis: that was my point too. thanks
16:08:48 <thingee> e0ne: which eventually would surface a problem
16:08:53 <thingee> it sounds more like a release problem
16:09:06 <smcginnis> Timing was especially bad last cycle because the breakage wasn't found until the final brick release.
16:09:12 <Swanson> ('os-bricked')
16:09:19 <diablo_rojo> So the connectors that need CI: AoE, DISCO, DRBD, HGST, Huawei, Sheepdog, etc
16:09:19 <e0ne> thingee: agree. but is it too late? we can found issues before release with CI
16:09:26 <jgriffith> Swanson: that was one of your better ones :)
16:09:27 <smcginnis> And then it was library freeze and close to total freeze, so we couldn't fix it until after things opened up again.
16:09:27 <thingee> smcginnis: yeah, I think we just need to work on that, rather than add burden to the vendors.
16:09:37 <thingee> smcginnis: I'm not even with a vendor and I'm saying that :)
16:09:48 <smcginnis> :)
16:09:52 <jgriffith> smcginnis: which connector broke?
16:10:04 <thingee> smcginnis: can we maybe just try to be strict on brick releases to give time for problems to surface on the cinder side?
16:10:07 <smcginnis> Sheepdog and one other one.
16:10:13 <jgriffith> thingee: +1
16:10:17 <thingee> if that doesn't work, start considering the additional CI testing
16:10:29 <ameade> how much churn is there in brick? can't imagine it'll take up a lot of resources to test it and for me it's just another line in a yaml file to test it as well
16:10:38 <patrickeast> fwiw extending an existing ci to watch brick is pretty minimal, there aren't a ton of changes on it... i'm not advocating that we make cinder 3rd party ci's vote on it, but its not hard if anyone wants to
16:10:48 <thingee> patrickeast: that is true...
16:10:55 <smcginnis> OK, so maybe "strongly recommending" CI on os-brick for now, with the hint that we may make it mandatory in the future for those with connectors?
16:11:09 <smcginnis> patrickeast: +1
16:11:09 <diablo_rojo> smcginnis: That sounds reasonable
16:11:22 <e0ne> smcginnis: +1
16:11:23 <thingee> smcginnis: how about this, I can start reaching out to people and saying as you say strongly recommended. We'll see how many people do it.
16:11:40 <thingee> as people have voiced it's pretty minimal as an additional entry in a yaml file.
16:11:41 <smcginnis> I guess it's a start.
16:12:01 <kmartin> the connectors already have driver CIs, they just need to make a small change to pull in the latest brick instead on the last released version
16:12:08 <jgriffith> one other option is to put the burden on brick
16:12:08 <smcginnis> We can see how that goes and decide later if we need to be more strict about it.
16:12:12 <jungleboyj> smcginnis: That sounds reasonable.
16:12:20 <jgriffith> in other words, run all the gate tests with brick
16:12:20 <smcginnis> kmartin: Still, that's after a possible breaking change has merged.
16:12:30 <thingee> smcginnis: can I get an action item please?
16:12:34 <kmartin> sure
16:12:37 <jgriffith> including rbd, sheepdog etc
16:12:40 <smcginnis> kmartin: But could at least catch before official library release.
16:13:01 <smcginnis> #action thingee to work on backup and os-brick CI policy communication
16:13:23 <patrickeast> jgriffith: +1, i was chatting to hemna about that, i think we get most of the connectors that way
16:13:34 <jgriffith> patrickeast: indeed
16:13:38 <smcginnis> OK, I'll save the midcycle discussion for last.
16:13:42 <patrickeast> jgriffith: the other 3rd party ones (for the most part) already have em
16:13:44 <smcginnis> #topic Reference Implementation Discussion
16:13:48 <smcginnis> thingee: All yours
16:14:59 <thingee> oh boy
16:15:18 <thingee> so I started learning about our proposed movement towards discovering capabilities
16:15:27 <thingee> I think from a defcore perspective, this isn't a good approach.
16:15:43 <thingee> This mainly comes and I take full responsibility of accepting capabilities like consistency groups
16:15:58 <thingee> today not everyone can do such feature. One important driver being our current reference implementation
16:16:00 <thingee> LVM
16:16:24 <jgriffith> thingee: FTR LVM could do it, I just haven't had a chance to write the code and nobody else cares :)
16:16:40 <thingee> so I'd like to kick start a conversation that has been tried time and time again by others of deciding on something that can or is possible eventually to support consistency groups as well as other features the community is interested in cinder supporting
16:16:42 <smcginnis> jgriffith: Someone contacted me actually working on that right now.
16:17:02 <thingee> jgriffith: this is cool, I had no idea!
16:17:06 <jgriffith> smcginnis: sweet
16:17:09 <thingee> consider me ignorant in this
16:17:12 <jgriffith> thingee: yeah, it's not trivial, but it's doable
16:17:18 <xyang1> thingee: drbd is working on it, just don't kniw the exact timeline
16:17:28 <thingee> jgriffith: what about some of the features being requested with tiramisu and cheesecake?
16:17:45 <jgriffith> thingee: well, half the drivers can't do them anyway :(
16:18:14 <thingee> yeaa, so that's what's leading me down this path that we're just making things not better in cinder
16:18:24 <xyang1> thingee: also if we move to generic group, we can do group actions using lvm, at least for snapshot
16:18:53 <thingee> today we have a lot of people that are happy with cinder and it's stance in this area, but things aren't getting better when we can't have something supported cross-driver wide
16:19:24 <ameade> i dont think it's drivers having differing capabilities, it's when the API isn't uniform based on the backend
16:19:30 <thingee> so I would say for some of these features we need to work with other drivers and understand why this is a problem and is this something they can support at some time.
16:19:40 <e0ne> thingee: agree. but we can't drop features replication and CGs
16:20:02 <thingee> e0ne: then def core can't even begin to support these
16:20:18 <e0ne> thingee: fair enough
16:20:35 <xyang1> thingee: I think we already have different capabilities betweent drivers with different volume types
16:20:59 <jgriffith> thingee: I think we may be distracting you... did you have a specific proposal?
16:21:02 <thingee> xyang1: yeah it's just if we're moving away from extensions, do we see some of this just not something we tell def core to support?
16:21:05 <e0ne> thingee: btw, I like the idea to contact drivers maintainers to help them implement these features
16:21:18 <jungleboyj> xyang1: +1
16:21:28 <xyang1> thingee: extention?
16:21:34 <smcginnis> e0ne: +1
16:21:35 <diablo_rojo> e0ne: +1
16:21:41 <ameade> the main issue here is different cinder APIs in different clouds right?
16:21:44 <thingee> jgriffith: yes, my proposal was just to start the communication on the unknown of why drivers can't support some of these features. I'd like to understand before we move forward on making this even more difficult to understand.
16:21:51 <jgriffith> xyang1: jungleboyj that's the point of types and why I've argued these features should've been isolated to types and nothing more
16:22:06 <jgriffith> thingee: agreed
16:22:11 <diablo_rojo> thingee: That sounds like a good place to start
16:22:16 <ameade> there will definitely be features not everyone can support, otherwise we are just least common denominator again
16:22:19 <e0ne> thingee: some vendors could care only about minimum features set
16:22:30 <jgriffith> FWIW I'd like to go back to a policy of "if everybody can't do it, it doesn't go in the API"
16:22:30 <ameade> e0ne: +1
16:22:45 <e0ne> but we can't extend this list without breaking a lot of drivers :(
16:22:50 <jgriffith> and provide an extension mechanism for fancier things for those that want it
16:23:03 <e0ne> jgriffith: +1
16:23:10 <jungleboyj> I don't understand why this is a frustration point.
16:23:12 <ameade> jgriffith: then you still end up with different apis
16:23:14 <thingee> so action item here...
16:23:20 <xyang1> I thought we are moving away from extentions?
16:23:21 <kmartin> jgriffith, we have that in Docker :)
16:23:25 <thingee> who wants to work with me on understanding where drivers are in this area?
16:23:25 <jgriffith> ameade: only for those that choose to explicitly add things
16:23:30 <thingee> for consistency groups say
16:23:30 <jgriffith> ameade: you're missing the point there
16:23:32 <xyang1> by using microversions
16:23:45 <jgriffith> ameade: Cinder is kept lean/mean with common defcore functionality and nothing more
16:23:51 <xyang1> thingee: I can help you with cg
16:23:52 <jungleboyj> Each vendor has decided how to design their backend storage.  We all have our special features.  Customers choose a vendor and they can then access the features that are supported.
16:23:57 <jgriffith> ameade: if a vendor or a distro wants to add on to it, that's up to them
16:24:00 <thingee> xyang1: thanks!
16:24:07 <thingee> so xyang1 is going to help me with cg
16:24:14 <thingee> who wants to help with cheese cake?
16:24:28 <ameade> so the point of cinder is to only abstract out some functionality common between vendors
16:24:28 <jgriffith> thingee: sure, not sure what I'm signing up for :)
16:24:28 <thingee> I definitely need help there since I haven't been part of it's development or review
16:24:37 <jgriffith> thingee: but I sign up for things all the time :)
16:24:55 <thingee> jgriffith: thanks!
16:25:04 <smcginnis> Not sure I like the lowest common denominator approach.
16:25:14 <xyang1> smcginnis: me neither
16:25:16 <smcginnis> I've worked with storage apis that have stuck to that in the past.
16:25:20 <ameade> +1
16:25:21 <jgriffith> smcginnis: such an ugly phrase :)
16:25:23 <smcginnis> And they all eventually failed miserably.
16:25:23 <thingee> Ok so the plan is for us to draw a list of drivers that do support, plan to, or just can't do these features
16:25:28 <smcginnis> jgriffith: :)
16:25:36 <cFouts> o/
16:25:37 <Swanson> If two drivers can support it cram it into the api.
16:25:39 <jungleboyj> smcginnis: I don't like the LCD approach.
16:25:49 <thingee> I think this will give us a better picture of where we are at today.
16:25:52 <jgriffith> Swanson: yeah, 2 out of 80 seems like good odds :)
16:25:52 <smcginnis> I'm certainly for helping identify who doesn't support what and helping them to add that support.
16:26:05 <e0ne> jungleboy: what is "LCD approach"?
16:26:11 <diablo_rojo> smcginnis: +1
16:26:14 <smcginnis> Lowest Common Denominator
16:26:20 <thingee> once we know who the people are that can't support these features, hopefully it's a small number and we can start communicating and asking why they can't
16:26:21 <e0ne> thanks:)
16:26:46 <jungleboyj> e0ne: What smcginnis said.
16:26:48 <jgriffith> smcginnis: diablo_rojo jungleboyj ameade ok... so by your logic I can just start dumping all my vendor unique features into Cinder's API's?
16:26:56 <thingee> jgriffith, xyang1 ^ that's the plan, I'll start up some doc for us to collaborate on
16:27:03 <ntpttr_> if a user has a backend that doesn't support something in the API and they try and use it unknowingly, do they get some kind of message telling them that it failed because their backend doesn't support it?
16:27:03 <jungleboyj> jgriffith: :-)
16:27:04 <diablo_rojo> thingee: Yeah I think it would be a good idea to get the lay of the land first before we make more decisions on where this should go
16:27:11 <ameade> jgriffith: perhaps some, there are ways to have a uniform api with different capabilities
16:27:14 <ntpttr_> or is it just 'cinder failed to do this'?
16:27:21 <xyang1> jgriffith: smcginnis about extension, are we moving away from it or continue? we are supposed to move all extensions to core for microversion
16:27:23 <smcginnis> jgriffith: Generally supported, but not completely ubiquitous is fine IMO.
16:27:25 <jgriffith> ameade: awesome!  I'll get busy
16:27:31 <jungleboyj> diablo_rojo: __
16:27:34 <jungleboyj> diablo_rojo: ++
16:27:53 <thingee> ntpttr_: it depends, most of the things are admin related, not user related. Users typically interact with a feature via volume types, so they're not even aware of any of that.
16:27:54 <jgriffith> and we'll send out a rabbits foot with each cinder deployment to wish the operators good luck
16:27:56 <jungleboyj> smcginnis: ++
16:28:08 <ameade> heh, or you could ask what those ways might be
16:28:14 <xyang1> ntpttr_: driver needs to report capabilities
16:28:18 <ntpttr_> thingee: ah gotcha, that makes sense
16:28:23 <smcginnis> I think it ultimately comes down to the choice of the cloud admin and what services they want to provide.
16:28:24 <guitarzan> smcginnis: sure, just make sure and keep the defcore people tamed :)
16:28:43 <smcginnis> But that does raise the question of extensions and having the ability to turn things on and off.
16:28:46 <xyang1> ntpttr_: scheduler will not choose the driver that cannot support it
16:29:07 <thingee> ntpttr_: example they might have a volume type from a cloud that is "super fast reliable storage" ... but behind the scenes it has some replication factor setting, it goes to ssd's, has some QOS burst setting.
16:29:11 <smcginnis> Not sure what the right answer is here, but at least getting a clear scope of who can do what probably helps.
16:29:14 <smcginnis> guitarzan: ;)
16:29:31 <xyang1> I have an idea, I think we only need LVM in cinder. no more argument on what can be supported:)
16:29:44 <ameade> lets just not settle for an easy answer just because a better one may be hard
16:29:50 <diablo_rojo> smcginnis: +1 So then thingee will go and figure out who can do what and with that info we can make better decisions?
16:29:58 <smcginnis> xyang1: Problem solved. We can all go home now. :)
16:30:08 <e0ne> :)
16:30:12 <sheel> haha
16:30:13 <scottda> xyang1: We can start by moving extensions that are supported by everyone to core
16:30:28 <jungleboyj> diablo_rojo: I think that is a good idea.
16:30:30 <ameade> scottda: we haven't dont that yet? :P
16:30:35 <sheel> scottda:  do we have such list with us?
16:30:37 <e0ne> scottda: do you mean microversions?
16:30:53 <scottda> ameade: no sheel No list yet e0ne yes, so we can microversion changes
16:30:55 <xyang1> scottda: sure
16:31:01 <jungleboyj> How many drivers really cant support CGs and replication versus just haven't implemented it yet.
16:31:21 <thingee> smcginnis: can I get an action item with xyang1 helping me on cg's and jgriffith helping me with cheesecake
16:31:24 <thingee> mmmm cheesecake :)
16:31:25 <sheel> scottda:  so we can pick some common part first
16:31:37 <jgriffith> jungleboyj: are CG's and replication really worth implementing at all :)
16:31:45 <guitarzan> zing
16:31:54 <jgriffith> jungleboyj: for the 1% of deployments that use them or care about them
16:31:57 <thingee> jungleboyj: right, that's the question I want to know
16:32:00 <smcginnis> #action thingee and xyang1 to identify drivers with CG support
16:32:09 <thingee> 1) who supports these now
16:32:10 <scottda> sheel: Yes, I'll get one started and after review to see how we want it to look, we can do the rest that are supported by all.
16:32:12 <thingee> 2) who plans to
16:32:12 <smcginnis> #action thingee and jgriffith to identify drivers with cheesecake support
16:32:15 <xyang1> jgriffith: what have you done in Mitaka?:)
16:32:15 <thingee> 3) who can't
16:32:21 * jungleboyj isn't going to start that discussion again.  :-)
16:32:29 <jgriffith> xyang1: I said from the start it was a bad idea :)
16:32:33 <thingee> and if #3, why?
16:32:47 <sheel> scottda:  sounds good.. i would like to help on it..
16:32:49 <jgriffith> thingee: sounds like a good plan
16:32:57 <diablo_rojo> thingee: Good plan.
16:32:58 <smcginnis> thingee: +1
16:33:03 <jungleboyj> thingee: Seems reasonable.
16:33:27 <thingee> thanks everyone for your support on this. I think understand the unknown here will really help us.
16:33:37 <smcginnis> thingee: ++1
16:33:40 <diablo_rojo> thingee: +1
16:33:45 <jungleboyj> thingee: +1
16:33:52 <sheel> thingee: exactly..
16:33:53 <jgriffith> thingee: oh... don't forget QoS is in the API now too
16:33:57 <jgriffith> thingee: might need to add that to the list
16:34:03 <thingee> jgriffith: that's a good point
16:34:17 <smcginnis> thingee: Cool, anything else?
16:34:33 <guitarzan> the qos api stuff doesn't really *do* anything though :)
16:34:44 * jungleboyj realizes I got through the summit design sessions with out a single heavy sigh.
16:34:58 <hemna> jungleboyj, need some help with that?
16:35:02 <ameade> jungleboyj: guess that streak is over
16:35:03 <thingee> smcginnis: nope, thanks
16:35:03 <smcginnis> jungleboyj: Hah!
16:35:21 <smcginnis> thingee: Thanks for bringing it up. Good to discuss if nothing else.
16:35:26 <smcginnis> #topic Midcycle
16:35:32 <jungleboyj> ameade: Ahhh, I am still good.  Have bigger issues making me sigh.
16:35:35 <smcginnis> #link
16:35:38 <smcginnis> Doh
16:35:38 <scottda> I'm sorry to report the hotels in Northern Colorado are pretty booked up the week of the mid-cycle (some big Softball Tournement). The hotel with HPE discount rate cannot block me rooms, and suggested other hotels will be pretty full.
16:35:58 <smcginnis> #link https://docs.google.com/document/d/1DT2Gj64efBDIvgG2j1W3jBw3u5Zs2btsWvQQOhn-j1g/edit Poorly formatted survey results
16:36:16 <ntpttr_> airb&b ;)?
16:36:17 <thingee> I'm going to try to cancel my other event to attend this one since I've had conflicts with the last midcycle :(
16:36:20 <smcginnis> So our original plan doesn't look like it will work.
16:36:22 <smcginnis> ntpttr_: Hah!
16:36:25 <scottda> I haven't actually checked with other hotels, but taking the one at their word it means we've an issue...
16:36:27 <diablo_rojo> So we either change the week or change the location
16:36:42 <smcginnis> diablo_rojo: Yep.
16:36:58 <smcginnis> So either switch it to Dublin, or switch it to Ft Collins R-10.
16:37:15 <smcginnis> Or start over from scratch is an option as well I suppose.
16:37:15 <ameade> how much to rent a yacht?
16:37:18 <scottda> I contacted HPE Dublin (outside Dublin 15 miles, actually) and they can accomodate  the same week. But I'll likely not go , so DuncanT or someone else would have to host.
16:37:23 <gouthamr> ameade: +1
16:37:27 <jungleboyj> ameade: Nice!
16:37:40 <jungleboyj> ameade: I have a beach house.  :-)
16:37:48 <smcginnis> The camping is nice in CO. :)
16:38:11 <jungleboyj> :-)
16:38:15 <thingee> r-10 I definitely can't do.
16:38:19 <jungleboyj> I am all for going with R-10
16:38:23 <jgriffith> seriously... all you fancy people and your new fangled hotels
16:38:32 <smcginnis> thingee: Is there any week where you don't have something going on? :)
16:38:46 <jungleboyj> Says the guy who doesn't need one.  Hey, we can just stay at jgriffith s house.  ;-)
16:38:51 <smcginnis> OK, we're all camping out in jgriffith 's barn.
16:38:52 <e0ne> maybe virtual midcycle like Ironic did?
16:38:53 <thingee> smcginnis: well some stuff I can't cancel, but this one might upset my father-in-law ;)
16:39:00 <jgriffith> smcginnis: +1
16:39:00 <thingee> can cancel*
16:39:09 <smcginnis> thingee: Defintiely a no go then!
16:39:21 <smcginnis> Virtual is an option.
16:39:37 <smcginnis> But it seems like things work more smoothly if we can all sit down together.
16:39:45 <diablo_rojo> What about R-9?
16:39:48 <smcginnis> And have side conversations in breaks and after hours.
16:39:50 <diablo_rojo> It was the third option
16:39:54 <e0ne> smcginnis: I'm absolutely agree with you
16:39:57 <diablo_rojo> third most popular
16:40:03 <geguileo> smcginnis: I agree, even if I can't go
16:40:06 <thingee> I can do r-9
16:40:26 <diablo_rojo> r-9 in Ft Collins would work for me
16:40:28 <geguileo> Virtual means that we can still get pulled by other things
16:40:30 <smcginnis> diablo_rojo: Seems like it's getting a little too late to me.
16:40:30 <jungleboyj> diablo_rojo: What were the dates there?
16:40:43 <smcginnis> geguileo: Yeah, never works well for me in that format.
16:40:46 <thingee> aug 1-5
16:40:55 <diablo_rojo> smcginnis: Fair point
16:41:06 <jungleboyj> That is a little late.  R-11?
16:41:15 <jungleboyj> smcginnis: Was that a no-go for you?
16:41:16 <diablo_rojo> jungleboyj: That's Novas
16:41:20 <smcginnis> Schedule for reference: http://releases.openstack.org/newton/schedule.html
16:41:22 <jungleboyj> Doh!
16:41:41 <thingee> yup r-11 is nova midcycle
16:42:00 <jungleboyj> Who all do we have that needs to be at both?
16:42:07 <scottda> I'm not sure conflict with NOva is such a bad thing. We had a good cross-project virtual meeting last time.
16:42:09 <smcginnis> My preference would be the same week in Dublin, or R-10 in CO.
16:42:15 <diablo_rojo> scottda: I agree
16:42:16 <jungleboyj> scottda: ++
16:42:21 <smcginnis> scottda: Good point.
16:42:26 <e0ne> scottda: +1
16:42:56 <jungleboyj> Doing the virtual cross project has been beneficial in the past.
16:43:11 <hemna> it worked well last midcycle
16:43:29 <jungleboyj> I know anteya didn't want that ... but if we can get the core team together ...
16:43:42 <smcginnis> It was the lowest ranked in the survey, but that could just be because we tried to avoid the overlap.
16:43:55 <jungleboyj> smcginnis: I think that was why I avoided it.
16:43:57 <smcginnis> It's probably not a bad thing. It kinda worked out well with the last midcycle.
16:43:57 <diablo_rojo> We can vote here again?
16:44:35 <smcginnis> What do folks think? Vote here in the meeting?
16:44:52 <scottda> sure
16:45:04 <thingee> if we did during the nova midcycle, that works for me. Not like our stuff has priority this cycle anyways
16:45:11 <jungleboyj> WFM
16:45:12 <scottda> A quick decision helps with the planning
16:45:13 <hemna> :(
16:45:45 <diablo_rojo> Works for me
16:45:53 <thingee> and I don't mean that message as to be angry, to be clear, they have set their priorities already in https://etherpad.openstack.org/p/newton-nova-summit-priorities
16:46:09 <thingee> and ildikov, jaypipes and I were the only ones there that spoke up for multi-attach
16:46:18 <diablo_rojo> How many cores do we have here? Since they are more important to the vote.
16:46:30 <jungleboyj> o/
16:46:45 <thingee> o/
16:46:51 <geguileo> o/
16:47:00 <smcginnis> #startvote Midcycle planning? DublinJune27, FtCollinsJuly18, FtCollinsJuly25, DublinJuly18, DublinJuly18
16:47:01 <openstack> Begin voting on: Midcycle planning? Valid vote options are DublinJune27, FtCollinsJuly18, FtCollinsJuly25, DublinJuly18, DublinJuly18.
16:47:02 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:47:34 <jgriffith> #vote FtCollinsJuly18
16:47:43 <thingee> #vote FtCollinsJuly18
16:47:45 <bswartz> #vote FtCollinsJune27
16:47:45 <openstack> bswartz: FtCollinsJune27 is not a valid option. Valid options are DublinJune27, FtCollinsJuly18, FtCollinsJuly25, DublinJuly18, DublinJuly18.
16:47:46 <patrickeast> #vote FtCollinsJuly18
16:47:53 * bswartz growls
16:47:58 <smcginnis> bswartz: :)\
16:47:58 <jungleboyj> #vote FtCollinsJuly18
16:47:59 <diablo_rojo> #vote FtCollinsJuly18
16:48:00 <jgregor> #vote FtCollinsJuly18
16:48:09 <geguileo> #vote DublinJune27
16:48:10 <scottda> #vote FtCollinsJuly18
16:48:15 <e0ne> I will be unpopular
16:48:17 <tbarron> #vote DublinJune27
16:48:18 <xyang1> #vote FtCollinsJuly18
16:48:21 <e0ne> #vote DublinJune27
16:48:31 <yuriy_n17> #vote DublinJune27
16:48:40 <geguileo> e0ne: Don't worry, I'll be unpopular with you  ;-)
16:48:57 <e0ne> geguileo: :)
16:49:18 <smcginnis> bswartz: No second vote?
16:49:40 <hemna> #vote FtCollinsJuly18
16:49:46 <bswartz> #vote FtCollinsJuly18
16:49:47 <smcginnis> DuncanT: Are you here?
16:50:09 <diablo_rojo> patrickeast: Going to vote?
16:50:14 <kmartin> #vote FtCollinsJuly18
16:50:18 <patrickeast> diablo_rojo: i did
16:50:29 <diablo_rojo> patrickeast: Lol sorry didn't see you
16:50:45 <smcginnis> Anyone else?
16:50:50 <smcginnis> Going once?
16:50:54 <diablo_rojo> patrickeast: Just so ninja fast I missed it
16:50:56 <smcginnis> Going twice
16:50:59 <patrickeast> diablo_rojo: haha
16:51:02 <Swanson> Dell will only pay for EP.
16:51:16 <smcginnis> #endvote
16:51:18 <openstack> Voted on "Midcycle planning?" Results are
16:51:19 <openstack> FtCollinsJuly18 (11): bswartz, scottda, hemna, thingee, jgregor, jgriffith, diablo_rojo, jungleboyj, kmartin, patrickeast, xyang1
16:51:20 <openstack> DublinJune27 (4): e0ne, tbarron, yuriy_n17, geguileo
16:51:46 <smcginnis> #startvote Beginning of the week or end? BEGIN, END
16:51:47 <openstack> Begin voting on: Beginning of the week or end? Valid vote options are BEGIN, END.
16:51:48 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:51:55 <thingee> almost voted for CancunJuly18
16:52:04 <smcginnis> thingee: +1 :)
16:52:07 <jungleboyj> thingee: +1
16:52:09 <bswartz> thingee: +1
16:52:12 <diablo_rojo> thingee: +1
16:52:12 <smcginnis> #vote END
16:52:21 <jungleboyj> #vote END
16:52:35 <hemna> MauiJuly18th
16:52:52 <diablo_rojo> #vote END
16:52:54 <patrickeast> if i don't have a preference should i just not vote?
16:53:07 <thingee> #vote END
16:53:13 <jgregor> #vote END
16:53:15 <sheel> we are left with 7 more minutes
16:53:16 <smcginnis> patrickeast: Sure.
16:53:17 <xyang1> patrickeast: I am the same
16:53:23 <smcginnis> Looks like pretty unanimous though.
16:53:39 <smcginnis> #endvote
16:53:40 <openstack> Voted on "Beginning of the week or end?" Results are
16:53:42 <openstack> END (5): jungleboyj, thingee, jgregor, smcginnis, diablo_rojo
16:54:20 <smcginnis> #info Cinder midcycle July 12-14, hackday July 15.
16:54:37 <smcginnis> scottda: Just realized that wasn't a week you checked on hotels though.
16:54:42 <smcginnis> Assuming we will be safe.
16:54:46 * smcginnis crosses fingers
16:54:48 <scottda> I"m on the phone now....
16:54:51 <xyang1> smcginnis: that is one week off
16:54:52 <smcginnis> scottda: ;)
16:54:58 <jungleboyj> smcginnis: Wait, that is off.
16:55:01 <thingee> smcginnis: should make an action to send out to the ML.
16:55:12 <smcginnis> xyang1: Oh, did I do the wrong dates?
16:55:14 <jungleboyj> YOu mean July 19-22
16:55:24 <xyang1> smcginnis: starts on July 19, yes
16:55:28 <smcginnis> #action smcginnis to send out midcycle announcement to mailing list
16:55:43 <smcginnis> xyang1: Oops. :)
16:55:48 <diablo_rojo> smcginnis: Nice ;)
16:55:48 <xyang1> :)
16:55:57 <scottda> I'm thinking of blocking around 12 rooms?
16:56:03 <thingee> ... #undo x2
16:56:04 <xyang1> we can skip N-2
16:56:05 <scottda> or more?
16:56:25 <smcginnis> #undo x2
16:56:25 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x9dfa9d0>
16:56:30 <smcginnis> #info Cinder midcycle July 19-21, hackday July 22.
16:56:34 <aimeeu> scottda: I'd like to go but will depend on cost, as I'm sure I will be paying my own way
16:56:50 <smcginnis> Nice thing about Ft Collins is it's fairly cheap.
16:56:50 <thingee> smcginnis: Oh I don't know if that syntax works ... just mean you'll have to do it twice :)
16:56:55 <smcginnis> At least for us US folks.
16:57:05 <smcginnis> Meh
16:57:12 <scottda> So I am hearing from the hotel that the HPE discount policy has changed...
16:57:16 <thingee> people will figure it out...
16:57:22 <smcginnis> #info Cinder midcycle July 19-21, hackday July 22. (FOR REAL)
16:57:26 <smcginnis> thingee: Good enough. :)
16:57:28 <scottda> And I'd need to give my credit card now and pay for any cancellations...
16:57:32 <thingee> ship it
16:57:36 <scottda> something new and weird like that.
16:57:42 <jungleboyj> scottda: Lovely.
16:57:49 <scottda> So, I'm not sure about getting discounted rooms :(
16:57:52 <diablo_rojo> scottda: We won't cancel..probably ;)
16:57:54 <smcginnis> scottda: Don't do it then. I don't want you financially liable for anything.
16:58:03 <xyang1> scottda: you are responsible for all cancellayions?
16:58:05 <scottda> Well, I cannot pay for anyone/eveyone in any case.
16:58:08 <kmartin> Dublin it is :)
16:58:16 <thingee> kmartin: +1
16:58:16 * bswartz changes his vote to dublin
16:58:20 <smcginnis> scottda: It seemed to work well to just tell them we were visiting HP last couple times to get a cheap rate.
16:58:21 <geguileo> kmartin: +1
16:58:29 <ameade> I put up a spec for the cheesecake backend promotion: https://review.openstack.org/#/c/312591/ I think the alternate solution makes more sense to me now than the proposed
16:58:36 <ameade> if you have ideas please braindump
16:58:44 <ameade> if you want to implement it, please volunteer
16:58:48 <smcginnis> #topic Open
16:58:54 <thingee> 2 mins left
16:58:56 <smcginnis> 1:30 minutes
16:58:59 <smcginnis> :)
16:59:03 <scottda> So, the hotel said you can just call the front desk and get HPE rate...
16:59:04 <sheel> :)
16:59:11 <smcginnis> scottda: +1 Thanks!
16:59:12 <patrickeast> heads up i got the ball rolling on using the cache as default for cinder https://review.openstack.org/#/c/312305/
16:59:16 <xyang1> ameade: do you really want to bring it up?  it will be removed any way:)
16:59:19 <thingee> scottda: which hotel?
16:59:24 <scottda> They just cannot reserve a block of rooms without a credit card.
16:59:27 <ildikov> thingee: I will speak up when the FFE comes too :)
16:59:29 <ameade> xyang1: lol
16:59:44 <smcginnis> scottda: Which one is it?
16:59:44 <scottda> https://www.irccloud.com/pastebin/5467tVNI/
16:59:50 * ildikov got pinged by IRC late...
17:00:00 <scottda> That is from last year, so rates may have changed ^^^
17:00:04 <smcginnis> scottda: Is that in the etherpad?
17:00:11 <scottda> It will be soon...
17:00:15 <smcginnis> I'll update it unless someone else gets to it first.
17:00:17 <keedya> hi All
17:00:17 <smcginnis> :)
17:00:23 <smcginnis> OK, we're out of time.
17:00:27 <diablo_rojo> link to the planning etherpad?
17:00:34 <diablo_rojo> midcycle planning that is
17:00:46 <smcginnis> #endmeeting