16:00:28 <jungleboyj> #startmeeting cinder
16:00:29 <openstack> Meeting started Wed Aug 30 16:00:28 2017 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:33 <Swanson> Hello.
16:00:34 <openstack> The meeting name has been set to 'cinder'
16:00:38 <smcginnis> Woot woot
16:00:50 <bswartz> .o/
16:00:50 <jungleboyj> Courtesy ping: dulek duncant eharney geguileo winston-d e0ne jungleboyj jgriffith thingee smcginnis hemna xyang1 tbarron scottda erlon jbernard _alastor_ bluex karthikp_ patrickeast dongwenjuan JaniceLee cFouts Thelo vivekd adrianofr mtanino karlamrhein diablo_rojo jay.xu jgregor lhx_ rajinir wilson-l reduxio wanghao thrawn01 chris_morrell watanabe.isao,tommylikehu mdovgal ildikov wxy viks ketonne abishop
16:00:50 <jungleboyj> sivn
16:00:51 <Swanson> Oh, ptlboyj is running the show!
16:00:53 * smcginnis grabs a beverage and sits back
16:00:54 <diablo_rojo_phon> Hello :)
16:00:58 <patrickeast> Hi
16:00:58 <e0ne> hi
16:00:59 <geguileo> hi! o/
16:01:01 <tommylikehu> hello
16:01:08 <jungleboyj> Hey now smcginnis  be nice this time.  :-p
16:01:11 <scottda> hi
16:01:20 <ildikov> smcginnis: no popcorn? :)
16:01:30 <jungleboyj> Oooh, if he does he needs to share.
16:01:36 <smcginnis> ildikov: Hah, we'll see if it's popcorn worthy.
16:01:40 <abishop> o/
16:01:46 <ildikov> smcginnis: fair enough :)
16:01:51 <jungleboyj> It is a short agenda.  Hopefully not popcorn worthy.
16:01:59 <DuncanT> Hi
16:02:07 <bswartz> I'm guessing it's an adult beverage
16:02:08 <smcginnis> DuncanT!
16:02:20 <jungleboyj> Duncan!!!!!!!!!
16:02:21 <smcginnis> bswartz: Just a little too early by my standards for that.
16:02:31 <smcginnis> Only a little though. :D
16:02:33 <DuncanT> Popcorn? I bought these rotten tomatoes
16:02:36 <bswartz> it's noon on the east coast...
16:02:48 <smcginnis> bswartz: After 5 somewhere...
16:03:01 <ildikov> smcginnis: 6pm here :)
16:03:05 <jungleboyj> smcginnis:  ++
16:03:05 <e0ne> #link https://wiki.openstack.org/wiki/CinderMeetings#Next_meeting
16:03:16 <smcginnis> I don't want him to feel left out, so...
16:03:19 <smcginnis> scottda!!
16:03:26 <smcginnis> :)
16:03:32 <jungleboyj> Ok, so lets get started.
16:03:42 <jungleboyj> #topic announcements
16:03:53 <tbarron> hi
16:03:55 <jungleboyj> So, RC2 went out for Cinder as the Pike release!
16:04:22 <bswartz> #link http://lists.openstack.org/pipermail/openstack-announce/2017-August/002009.html
16:04:43 <jungleboyj> Lots of work went into the release and I just wanted to say a note of gratitude for all the work that went into it.  I know there have been changes in job situation and responsibilities during the release.
16:05:09 <jungleboyj> We, however, continued to work as a team and kept making progress.  Thank you!
16:05:27 <jungleboyj> bswartz:  Thanks.
16:05:37 <tommylikehu> cheers
16:05:53 <jungleboyj> smcginnis:  Thanks for being our fearless leader through that and the 3 previous releases.
16:06:08 * jungleboyj claps for smcginnis  :-)
16:06:29 <smcginnis> jungleboyj: Here's to new leadership! :)
16:06:48 <jungleboyj> And thank you also team for trusting me to lead us into Queens.  I will try not to let you all down.
16:07:13 <lhx__> o/
16:07:17 <jungleboyj> I am excited to give this a shot and think there are good things to come for Cinder and OpenStack.
16:07:28 <bswartz> +1 for peaceful transitions of power
16:07:42 <jungleboyj> bswartz:  Indeed.  smcginnis  and I have been joking about that.
16:07:53 <jungleboyj> I won't be firing any missiles at the Twin Cities.
16:08:08 <smcginnis> bswartz: Unlike those dictatorships where the PTL just won't step aside. (jk)
16:08:14 <smcginnis> :)
16:08:22 <jungleboyj> ooooh!  Shots Fired!
16:08:31 <e0ne> :)
16:08:32 <jungleboyj> :-)
16:08:37 <jungleboyj> Ok, moving on.
16:08:47 <diablo_rojo_phon> Enough with all the touchy feelies ;)
16:08:49 <jungleboyj> I have a work item to look at the specs review tracking:  https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:09:33 <jungleboyj> I will work to get that update before the PTG.
16:09:41 <smcginnis> jungleboyj: I evolved that from what scottda started, so feel free to make it into whatever works for you.
16:09:53 <jungleboyj> We will continue to use that, however, as it seems to have worked in the past.
16:10:09 <jungleboyj> smcginnis:  Sounds good.  I don't see a reason to stop using that.
16:10:28 <jungleboyj> #action Jay to bring spec-review-tracking up to date for Pike.
16:10:57 <jungleboyj> The usual reminder to please add topics to the PTG etherpad:  https://etherpad.openstack.org/p/cinder-ptg-queens
16:11:18 <jungleboyj> We have a good list in there.  I am going to get the topics organized before our next meeting.
16:11:44 <jungleboyj> Also going to make sure that we have cross project topics for 9 to noon on Thursday as that is when we are meeting with Nova.
16:12:07 <jungleboyj> Hopefully everyone is registered and put their attendance in the etherpad:  https://www.eventbrite.com/e/project-teams-gathering-denver-2017-tickets-33219389087
16:12:29 <jungleboyj> If not there is the link for the registration again.  :-)
16:12:33 <jungleboyj> #link https://www.eventbrite.com/e/project-teams-gathering-denver-2017-tickets-33219389087
16:12:53 <jungleboyj> Last announcement is that we need to do a cinderclient release today now that Pike is out.
16:13:09 <jungleboyj> Any lingering patches or concerns that need to be addressed before I do that?
16:13:40 * jungleboyj hears crickets
16:13:50 <diablo_rojo_phon> Neither of those links are the ptg etherpad link?
16:14:00 <diablo_rojo_phon> They are both registration?
16:14:07 <diablo_rojo_phon> Oh, I have something ptg related.
16:14:08 <ildikov> jungleboyj: as far as I know we're good on the client side
16:14:19 <jungleboyj> I included the PTG Etherpad above it.
16:14:28 <tommylikehu> diablo_rojo_phon:  https://etherpad.openstack.org/p/cinder-ptg-queens
16:14:30 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-ptg-queens
16:14:42 <jungleboyj> ^^^ Queens etherpad.
16:14:42 <diablo_rojo_phon> If you haven't registered, do so by Friday before the 50$ price hike.
16:14:55 <diablo_rojo_phon> Got it.
16:14:55 <jungleboyj> Ah, good to know.  Thanks diablo_rojo_phon
16:15:16 <diablo_rojo_phon> You can technically register there but the price goes up a week out.
16:15:19 <jungleboyj> ildikov:  Great.  I will cut the client later today then.
16:15:23 <ildikov> jungleboyj: jgriffith approved the last fix two days ago and nothing client related came up since then I know of we would need right now
16:15:29 <ildikov> jungleboyj: sounds great, thanks
16:15:44 <jungleboyj> ildikov:  Welcome.  Thanks for all the continued work there.
16:16:09 <jungleboyj> Anything else for announcements or can we move on?
16:16:54 <jungleboyj> #topic Doc team needs help with Install Guide testing
16:17:06 <jungleboyj> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/121482.html
16:17:29 <jungleboyj> So, the doc team is seeking help with testing the install guide as they no longer have the resources to do it as a doc team.
16:17:36 <jungleboyj> So, they are asking for help from the projects.
16:17:57 <jungleboyj> Announcing it here to see if there is anyone who would be willing to help out with that effort.
16:18:35 <smcginnis> One of those things I've wanted to do, but just can't get it to the top of the todo list.
16:18:42 <smcginnis> New things keep taking priority.
16:18:58 <jungleboyj> smcginnis:  Yeah, I have a feeling that that is the case for many people.
16:19:15 <jungleboyj> What would the team think of working through that during the PTG if there is time?
16:19:30 <smcginnis> Might be a good Friday activity.
16:19:34 <jungleboyj> As we have a new focus on documentation it might be worth looking at together.
16:19:41 <smcginnis> Or ealier depending on how things work out.
16:19:48 <diablo_rojo_phon> smcginnis: +1 for Friday
16:19:50 <jungleboyj> smcginnis:  Exactly what I was thinking.  I wonder how many of us even know what all is in there.
16:20:24 <jungleboyj> Ok, so we have at least three of us ok with that idea.
16:20:25 <jungleboyj> :-)
16:20:31 <smcginnis> I would guess that number is low.
16:20:54 <lhx__> any statistics from OpenStack official?
16:20:58 <e0ne> it depends on how many of us will be at PTG on Friday
16:20:59 <jungleboyj> #action jungleboyj  to add looking at the install guide to the PTG agenda.  Work on it Friday or earlier if time allows.
16:21:28 <jungleboyj> #action jungleboyj to take initial first look to see how we can best use the time.
16:21:42 <jungleboyj> e0ne:  Good question.
16:21:46 <jungleboyj> Who will not be there Friday?
16:21:55 <jungleboyj> Of those planning to go ...
16:22:11 <e0ne> unfortunately, I have a flight at 2pm on Friday:(
16:22:31 <jungleboyj> e0ne:  Ok, so you will be there a bit in the morning.
16:22:50 <e0ne> jungleboyj: not sure yet, TBH
16:22:53 <diablo_rojo_phon> I actually have to leave early Friday so I won't be around.
16:23:00 <smcginnis> I leave later Friday afternoon.
16:23:08 <e0ne> but I'll be there Mon-Thu for sure
16:23:09 <diablo_rojo_phon> But I can work on stuff in the airport.
16:23:09 <jungleboyj> I leave late afternoon.
16:23:37 <e0ne> diablo_rojo_phon: did we book some meeting room in the airport? :)
16:24:09 <lhx__> lol
16:24:26 <jungleboyj> lhx__:  What was your question on statistics ?
16:24:30 <diablo_rojo_phon> @eOne Haha no, but I can get into the Delta sky lounge for free now I think.
16:24:42 <diablo_rojo_phon> Lol slack..
16:25:15 <jungleboyj> So, I will add this to the PTG agenda and we will do what we can to get to it.
16:25:35 <jungleboyj> If we can at least look at it and plan out some work we don't necessarily all have to be in the same room.
16:25:43 <jungleboyj> Anything else on this?
16:25:50 <smcginnis> Good plan.
16:26:22 <jungleboyj> #topic cross project meeting with Kolla team .
16:26:23 <lhx__> jungleboyj, I mean the number of people that will attend PTG, supposing everyone is here from Mon to Fri :)
16:26:45 <jungleboyj> lhx__:  Oh, everyone should have their info in the etherpad if they are planning to attend.
16:27:15 <jungleboyj> So, one of my co-workers and I have been doing more work with containerizing Cinder.
16:27:37 <jungleboyj> We have discovered that the Kolla team knows little about Cinder and I, at least, know little boy Kolla.
16:28:00 <jungleboyj> So, we thought it might be useful to use some of the cross project time on Monday afternoon to get members of both teams together.
16:28:22 <e0ne> jungleboyj: it's great! I can help in testing a bit, but I won't have a time to contribute for this activity a lot
16:28:44 <lhx__> jungleboyj, that maybe include everyone that will attend if someone didn't join in our weekly meeting, right?
16:28:45 <jungleboyj> jgriffith: diablo_rojo_phon e0ne ^^^ thought you would especially be interested.
16:28:54 <smcginnis> I got a lot of feedback from operators at their midcycle that they are using or planning to use kolla as their deployment model.
16:28:55 <jungleboyj> lhx__:  It should.
16:29:06 <jungleboyj> smcginnis:  That is good to know.
16:29:32 <jungleboyj> lhx__:  I could send a note to the ML and make sure that virtual attendees are also listed.
16:29:36 <smcginnis> lhx__: If they read the meeting notes they've hopefully added their name, but it is likely there will be more than what is listed there.
16:30:37 <lhx__> cool :D
16:30:38 <jungleboyj> e0ne: That sounds good.  Will you be around on Monday?
16:31:29 <jungleboyj> So, that was all I had on that topic.  Rich Wellum started discussion on the ML.  He is going to coordinate.
16:31:31 <e0ne> jungleboyj: I'm going to attend horizon sessions too, but I think I can to manage to attend Kolla+Cinder meetup too
16:31:43 <jungleboyj> I will have an update when we have the details ironed out.
16:31:58 <e0ne> jungleboyj: we need to clarify what time will it be
16:32:03 <jungleboyj> e0ne:  Ok good.  I am going to be in the doc meetings on Monday, Tuesday as well.
16:32:13 <jungleboyj> e0ne:  Right, working that right now.
16:32:24 <e0ne> jungleboyj: sound like a good plan
16:32:29 <jungleboyj> Cool.
16:32:36 <e0ne> jungleboyj: what about cinder+ironic session?
16:33:02 <jungleboyj> e0ne:  I haven't seen anything about one of those.
16:33:16 <e0ne> jungleboyj: it was in the same mail
16:33:43 <jungleboyj> Oh, yeah, I they are hoping to get ironic team members there as well.
16:33:55 <jungleboyj> Will be good to have all of us in the same room.
16:34:13 <jungleboyj> Not sure if Rich has heard from anyone there though.  I will follow up.
16:34:32 <jungleboyj> Last topic is an important one.
16:34:42 <e0ne> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/121607.html
16:34:43 <jungleboyj> #topic Cinder Team Outing
16:35:18 <jungleboyj> So, I am assuming that everyone would like to do an outing as we have done in the past.
16:35:28 <e0ne> +1
16:35:37 <bswartz> +1
16:35:47 <jungleboyj> Do people have a preference on day?
16:35:58 <jungleboyj> Tuesday, Wednesday, Thursday?
16:36:05 <bswartz> not friday
16:36:14 <jungleboyj> bswartz:  Yeah, had assumed that.
16:36:14 <e0ne> Thursday
16:36:28 <lhx__> outing for what?
16:36:29 <smcginnis> Thursday might be the best.
16:36:35 <smcginnis> Wednesday would be my second choice.
16:36:41 <jungleboyj> lhx__: Drinks, food, fun.
16:36:47 <e0ne> smcginnis: +1
16:36:48 <diablo_rojo_phon> Not wednesday
16:36:54 <diablo_rojo_phon> Woo things Wednesday
16:37:02 <jungleboyj> Couple of votes for Thursday.
16:37:10 <lhx__> jungleboyj, i'd love to ;)
16:37:23 <diablo_rojo_phon> Tuesday after the happy hour +Wednesday is my vote.
16:37:50 <jungleboyj> diablo_rojo_phon:  There is an organized happy hour Tuesday?
16:38:17 <e0ne> diablo_rojo_phon: do we need to be registered for happy hour?
16:38:19 <diablo_rojo_phon> There is. It's like an hour and a half.
16:38:46 <jungleboyj> diablo_rojo_phon:  Ok cool.  Like in Atlanta then ...
16:38:53 <lhx__> but the real question is what time of the day?
16:38:54 <diablo_rojo_phon> Monday we get like ten 10% off in the hotel bar too.
16:39:05 <smcginnis> Deals!
16:39:07 <jungleboyj> Nice!
16:39:23 <jungleboyj> Hope they have a good bar like the place in ATL.
16:39:47 <diablo_rojo_phon> I hope a cocktail isn't 14$/each like in ATL
16:40:11 <jungleboyj> Ok, so I am going to add a place in the etherpad to vote for the day and will send a note to the ML.  Will decide based on what works best for people.
16:40:39 <jungleboyj> Will find someplace and make a reservation based on roughly how many people seem interested.
16:40:53 <jungleboyj> Everyone ok with that?
16:41:02 <bswartz> y
16:41:25 <jungleboyj> #action add space to vote for best day to have Cinder outing in etherpad.
16:41:39 <jungleboyj> #open discussion
16:41:41 <smcginnis> jungleboyj: Sounds like a plan.
16:41:45 <jungleboyj> #topic open discussion
16:41:56 <jungleboyj> That was all on the agenda.
16:42:07 <jungleboyj> smcginnis: diablo_rojo_phon  Did you guys schedule a team photo time yet?
16:42:25 <smcginnis> jungleboyj: Nope, left that up to you.
16:42:36 <jungleboyj> smcginnis:  Ok, guessed as much.
16:42:49 <jungleboyj> Thinking after lunch Wednesday is maybe best?
16:43:01 <jungleboyj> diablo_rojo_phon:  Will that work for you?
16:43:23 <smcginnis> ++
16:43:28 <diablo_rojo_phon> If it's open in the spreadsheet go for it.
16:43:50 <jungleboyj> diablo_rojo_phon:  Ok, I will check out the spreadsheet and schedule something for Wednesday afternoon.
16:44:19 <smcginnis> jungleboyj: Oh, ocata is now going into phase II support phase - critical and security only.
16:44:24 <jungleboyj> Anything from anyone else?
16:44:34 <smcginnis> jungleboyj: We may want to land a few things sitting out there and do a final release before that.
16:44:36 <jungleboyj> smcginnis:  Oh yeah, good note.
16:44:37 <smcginnis> https://review.openstack.org/#/q/project:openstack/cinder+branch:stable/ocata+status:open
16:45:07 <jungleboyj> smcginnis:  Good call.  I will look at those and then do a release later this week.
16:45:41 <smcginnis> jungleboyj: Just keep in mind "later this week" will need to be today or tomorrow since there are no releases on Friday.
16:45:52 <smcginnis> And I hear the new release PTL is a stickler for rules.
16:45:59 <jungleboyj> smcginnis:  Is he now?
16:46:10 <jungleboyj> I will have to talk to him.
16:46:16 <tommylikehu> haha
16:46:18 <smcginnis> I've also heard he's easily bribed.
16:46:31 <jungleboyj> smcginnis:  Now there is the guy I know.
16:46:36 <smcginnis> :)
16:46:39 * jungleboyj hands smcginnis  a beer
16:46:51 <e0ne> are we going to create driverfixes/ocata branch?
16:47:05 <jungleboyj> e0ne:  Good question.
16:47:13 <jungleboyj> smcginnis:  What have we done there in the past?
16:47:22 <smcginnis> e0ne: Good point, we can do that too with the "final" ocata release.
16:47:32 <Swanson> No, make em upgrade.
16:47:35 <e0ne> I think, it's reasonable once we'll go to phase II
16:47:58 <smcginnis> jungleboyj: Still new enough that there's not a set pattern there, but with the transition to phase II that's probably a good time to create it.
16:48:05 <jungleboyj> e0ne:  Oh, just creating the branch.
16:48:15 <jungleboyj> Yeah, I agree we should do that.
16:48:23 <e0ne> jungleboyj: great, thanks!
16:48:31 <jungleboyj> e0ne: Thanks for mentioning it.
16:48:43 <e0ne> jungleboyj: you're welcome
16:48:54 <smcginnis> eharney raised a good point there. We should probably make sure unit tests still pass to make that actually useful for distros to pull changes in.
16:49:12 <smcginnis> He may set up a non-voting job for those branches.
16:49:23 <eharney> the non-voting part of that is looking tricky
16:49:29 <jungleboyj> smcginnis:  That would be good.
16:49:32 <jungleboyj> eharney:  :-(
16:49:45 <smcginnis> eharney: I wondered about that since we don't have any other non-voting unit test jobs.
16:49:53 <smcginnis> Maybe just have it voting?
16:50:06 <eharney> having it voting seems good to me
16:50:27 <smcginnis> The idea was to just have these as basically a file share for driver changes, but as eharney pointed out, that can cause some issues for distros to actual use them.
16:50:27 <jungleboyj> eharney:  Seems like if unit test isn't passing we have a problem.
16:50:38 <eharney> jungleboyj: yes, and, we do
16:51:13 <jungleboyj> We do have a problem?
16:51:26 <eharney> yes, unit tests (if you run them) on driverfixes branches are broken, currently
16:51:49 <jungleboyj> *sadness*
16:52:01 <jungleboyj> Should we try to fix that?
16:52:11 <e0ne> :(
16:52:24 <e0ne> jungleboyj: at lease, we can try if
16:52:27 <eharney> i'll be poking at fixing it if people are willing to land changes etc
16:52:39 <eharney> because i intend to do that kinda thing downstream anyway so i can run unit tests
16:52:53 <smcginnis> eharney: Yep, I watch those patches and will support getting those through.
16:52:53 <e0ne> eharney: +1
16:54:17 <jungleboyj> eharney:  +1
16:54:54 <jungleboyj> Ok, so I think we are in agreement we should fix up the existing driver fixes branch, cut the ocata one and work on getting a voting UT job in place.
16:55:10 <e0ne> 5 mins reminder
16:55:16 <jungleboyj> e0ne:  Thanks.
16:55:21 <eharney> jungleboyj: +1
16:55:24 <jungleboyj> I think we are wrapping up.
16:55:25 <e0ne> jungleboyj: np
16:56:04 <jungleboyj> Anything else from anyone?
16:56:40 <jungleboyj> 3 ... 2 ... 1 ....
16:56:53 <e0ne> see you next week!
16:56:56 <jungleboyj> Ok, thank you all for a good first meeting for me.
16:56:58 <smcginnis> Thanks!
16:57:19 <lhx__> thanks
16:57:20 <jungleboyj> Thanks for your work on Cinder.
16:57:29 <jungleboyj> See you all same time, same place next week.
16:57:31 <tommylikehu> thanks
16:57:39 <jungleboyj> #endmeeting