16:00:02 <jungleboyj> #startmeeting Cinder
16:00:08 <openstack> Meeting started Wed Sep 27 16:00:02 2017 UTC and is due to finish in 60 minutes. The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:12 <openstack> The meeting name has been set to 'cinder'
16:00:13 <Swanson> Hello.
16:00:15 <smcginnis> o/
16:00:19 <tommylikehu> hello
16:00:25 <erlon> Hey
16:00:29 <jungleboyj> Courtesy ping: jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon patrickeast tommylikehu eharney geguileo
16:00:29 <jungleboyj> smcginnis
16:00:32 <_alastor_> o/
16:00:34 <xyang1> Hi
16:00:38 <geguileo> hi! o/
16:00:39 <rajinir> o/
16:00:41 <e0ne> hi
16:00:41 <thingee> o/
16:01:07 <bswartz> .o/
16:01:11 <jungleboyj> Hey everyone. Will give people another minute to join.
16:01:45 <jungleboyj> Have a short agenda so I am sure things will spiral out of control and take the whole hour. ;-)
16:01:52 <patrickeast> o/
16:02:32 <jungleboyj> Going to ping jgriffith just for fun as well.
16:02:52 <jungleboyj> Even though he hasn't added his name to the list. Glad to see you joined again smcginnis
16:03:21 <jungleboyj> Ok, I guess we will get started.
16:03:30 <jungleboyj> #topic Announcements
16:03:42 <smcginnis> jungleboyj: What? My name is on there. You even pinged me. :)
16:03:42 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:04:02 <jungleboyj> smcginnis: I know, but it wasn't there yesterday. Thought maybe you had given up. ;-)
16:04:12 <lhx_> hi
16:04:31 <jungleboyj> The usual reminder to please keep an eye on the Review Tracking priorities.
16:05:04 <jungleboyj> I am trying to get updates in there as I see them. If you have reviews coming in that you know we talked about at the PTG, please feel free to add them to the etherpad.
16:05:32 <tommylikehu> oh!
16:05:36 <jungleboyj> Also, I have the notes from the PTG summarized in our wiki.
16:05:49 <jungleboyj> #link https://wiki.openstack.org/wiki/CinderQueensPTGSummary
16:06:08 <jungleboyj> The items we are greed upon and the associated actions are all summarized there.
16:06:22 <tommylikehu> jungleboyj: great, thanks!
16:06:24 <jungleboyj> Do not have the video links organized in there yet. Hoping to get some help on that.
16:06:44 <jungleboyj> tommylikehu: You are welcome!
16:07:22 <jungleboyj> Also, I need to review specs this week as we are already coming up on Pike 1 soon. Need to get things approved. Appreciate any help with that.
16:07:39 <jungleboyj> That was all I had for announcements.
16:07:52 <jungleboyj> #topic Sydney Forum Topics
16:08:09 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-sydney-forum-topics
16:08:17 <jungleboyj> So, my etherpad is lonely.
16:08:40 <jungleboyj> Has no one taken the time to update it or do we not have any topics?
16:09:04 <smcginnis> I couldn't think of anything we needed. Other than maybe more cross project with nova.
16:10:03 <jungleboyj> smcginnis: Ok, I can coordinate with Matt and submit that as a proposal in the case that he hasn't scheduled anything.
16:10:56 <jungleboyj> Have any projects scheduled just like an 'office hours' type of time to get feedback from operators/users?
16:11:12 <Swanson> Could add "Pedantic coding practices: Or PEP8 is your code thug friend."
16:11:35 <jungleboyj> :-) That sounds like PTG topics.
16:12:44 <jungleboyj> *crickets*
16:12:55 <smcginnis> :)
16:13:40 <jungleboyj> So, I will see if it would be appropriate to schedule a time for people to stop and ask questions about Cinder. That seems like something other teams have done in a virtual format.
16:13:59 <smcginnis> Oh yeah, are they doing the onboarding rooms again?
16:14:15 <jungleboyj> #action Jay to coordinate with mriedem to set up a cross-project session to continue API/multi-attach work.
16:14:32 <jungleboyj> smcginnis: Yes they are. They are scheduling them. diablo_rojo_phon is in charge of that.
16:14:49 <jungleboyj> smcginnis: I am planning on doing our on-boarding presentation again. Would like to get it recorded this time.
16:15:02 <jungleboyj> Have some changes/improvements I hope to make.
16:15:10 <smcginnis> Cool.
16:15:17 * jgriffith yawns and stretches
16:15:58 <jungleboyj> So, the deadline for the submission of forum topics is Friday.
16:16:00 <smcginnis> Wakey wakey.
16:16:07 <jgriffith> smcginnis: :)
16:16:18 <jungleboyj> #action Team to add ideas to etherpad by Friday is there is anything they want to propose.
16:16:46 <jungleboyj> #topic Driver Removal Patches
16:16:51 <jungleboyj> #link https://review.openstack.org/#/q/status:open+project:openstack/cinder+branch:master+topic:ci_unsupported
16:17:30 <jungleboyj> So, smcginnis Has proposed to remove the drivers that do not meet our CI requirements.
16:17:32 <smcginnis> If folks are behind our driver policy - please review! :)
16:17:41 <jungleboyj> I have +2'd .
16:17:59 <jungleboyj> If anyone else is willing to go review and maybe push the button, it would be appreciated.
16:18:05 <smcginnis> If there's any reason not to do it, please speak up.
16:18:13 <jungleboyj> smcginnis: ++
16:19:07 <jungleboyj> We have been doing this for a couple of releases now and think it is good to continue to follow our policy.
16:19:27 <jungleboyj> #action Team to review the proposed patches and vote.
16:19:30 <e0ne> jungleboyj: +1
16:19:50 <e0ne> jungleboyj: I put some +2 on them before meeting. looks like we're OK to approve them
16:20:05 <jungleboyj> smcginnis: Thank you for continuing to watch the CI's and push up patches.
16:20:14 <jungleboyj> e0ne: I saw that. Thank you.
16:20:46 <e0ne> jungleboyj: I just waited for meeting if we want to hold on on them or something like it
16:20:47 <jungleboyj> Ok, well, there don't seem to be objections, so we will move on unless you have anything else there smcginnis .
16:20:59 <smcginnis> Nope, that's good.
16:21:09 <jungleboyj> Cool.
16:21:12 <jungleboyj> e0ne: Makes sense.
16:21:27 <jungleboyj> #topic Update backup's size when backup is created
16:21:41 <jungleboyj> #link https://review.openstack.org/#/c/506141/
16:21:42 <patchbot> patch 506141 - cinder-specs - Update backup's size when backup is created
16:21:42 <tommylikehu> yeah
16:21:46 <jungleboyj> tommylikehu: Over to you
16:21:51 <e0ne> I like this idea but I think jgriffith could have some input on it
16:21:53 <tommylikehu> I think this one is kind of bug, because we use volume's size for backup now.
16:22:05 <tommylikehu> e0ne: oh?
16:22:32 <e0ne> tommylikehu: we discussed it some time (years?) ago, but I don't remember why we didn't change it
16:22:55 <tommylikehu> jgriffith: any update?
16:22:59 <smcginnis> I don't remember that. Must have been a long time ago.
16:23:06 <e0ne> I could be wrong, but maybe jgriffith had some objections. I don't remember, TBH
16:23:10 <jgriffith> I'm not sure what I think honestly
16:23:32 <jgriffith> e0ne: might have been a *different* do some magic thing :)
16:23:32 <e0ne> I just remember that we'd got such bug from our customer in the past
16:23:35 * jungleboyj needs to read the spec
16:23:46 <e0ne> jgriffith: :)
16:23:59 <tommylikehu> jgriffith: so I am proposing we can have backup driver to report the real size of the backup when backup object is created at backend
16:24:11 <jgriffith> I had some concerns about how this all works in reality
16:24:42 <jungleboyj> tommylikehu: In what cases does the backup not have the size of what is backed up?
16:24:44 <jgriffith> it leads us to your next request which will be to report only the actual size of a volume instead of the allocated size :)
16:25:01 <jungleboyj> Are you talking about like with thin provisioning or something?
16:25:03 * jgriffith is being humorous with that
16:25:07 <tommylikehu> jungleboyj: mostly the incremental backup
16:25:20 <jungleboyj> tommylikehu: Oh.
16:25:24 <jgriffith> tommylikehu: I think what you propose here makes sense
16:25:38 <tommylikehu> jgriffith: thanks
16:26:00 <jgriffith> tommylikehu: I am a little unsure when you throw in compresses vs uncompressed
16:26:57 <jgriffith> tommylikehu: honestly I think you would need to use either the *actual* size of the data or provide both
16:27:25 <jgriffith> use actual for things like restoring, and if a provider wants, they an use *compressed/on-disk* for billing
16:27:25 <tommylikehu> jgriffith: both?
16:27:49 <jungleboyj> jgriffith: oooh, that makes sense.
16:28:00 <jgriffith> tommylikehu: yes, I can't tell based on your spec what you're actually proposing to use for the *size*
16:28:02 <tommylikehu> jgriffith: that's right
16:28:13 <jgriffith> but they're very different things and both are important
16:29:23 <jungleboyj> tommylikehu: Any concerns with going that path?
16:29:57 <tommylikehu> jungleboyj: agreed with jgriffith , I can update my spec
16:30:26 <jungleboyj> tommylikehu: Cool.
16:30:33 <e0ne> jgriffith, jungleboyj: I remembered, we discussed a bit different issue in the past: it was about renaming backup.size to backup.volume_size and there were concerns about original volume resizing
16:31:13 <jungleboyj> #action tommylikehu to update the spec to cover including both the total data size and the amount of space used on disk by the backup.
16:32:41 <jungleboyj> e0ne: What is currently in backup.size ?
16:33:11 <tommylikehu> equal to volume's size at that time when backed up
16:33:15 <e0ne> jungleboyj: original volume size
16:33:53 <jungleboyj> e0ne: Ok, so, as far as resizing goes, if the user resizes their volume and then doesn't back it up to update that info ... well, oops.
16:34:28 <jgriffith> jungleboyj: it's fine
16:34:30 <e0ne> jungleboyj: yes. but it's a bit different and could be fixed out of scope of the proposed spec
16:34:52 <jungleboyj> e0ne: Ok, won't get off track.
16:35:01 <e0ne> jungleboyj: +1
16:35:02 <jgriffith> e0ne: I'm not sure I recall... but I say it "should be fine" because you can only extend a volumes size
16:35:11 <jgriffith> so I'm not sure that would be problematic
16:35:19 <tommylikehu> jgriffith: +1
16:35:51 <e0ne> jungleboyj: I agree. It's a bit confusing for users who don't know what is it, but not a big deal
16:36:04 <e0ne> jgriffith: ^
16:36:05 <jungleboyj> e0ne: Ok.
16:36:29 <jungleboyj> So, lets work this in the spec and make sure that we don't make things more confusing in the process.
16:37:16 <jungleboyj> #action Team to review the spec after tommylikehu updates it.
16:38:11 <jungleboyj> Anything else on that topic ?
16:38:15 <tommylikehu> nope
16:38:22 <jungleboyj> tommylikehu: Ok, thank you.
16:38:29 <jungleboyj> #topic Open Discussion
16:38:39 <jungleboyj> Anything else we need to discuss today?
16:38:57 <jungleboyj> Are people actually awake out there?
16:38:58 <smcginnis> I have on thing...
16:39:16 <jungleboyj> smcginnis: Go for it.
16:39:24 <smcginnis> Not sure if folks noticed, but ostestr swapped out using testr internally for stestr.
16:39:29 <smcginnis> Not confusing at all, right?
16:39:33 <lhx_> jungleboyj, a small issue http://logs.openstack.org/76/506976/8/check/gate-tempest-dsvm-full-devstack-plugin-ceph-ubuntu-xenial/a958f56/console.html#_2017-09-26_03_56_54_125829
16:39:36 <jgriffith> :)
16:39:39 * jungleboyj head explodes
16:39:50 <smcginnis> So minor thing, but we get warning output in test runs because of that.
16:39:59 <smcginnis> These take care of that: https://review.openstack.org/#/q/owner:sean.mcginnis%2540gmail.com+status:open+topic:stestr
16:40:14 <jgriffith> smcginnis: there seems to be something else with that change that I haven't been able to nail down...
16:40:19 <e0ne> lhx_: do we have patch for it
16:40:21 <e0ne> ?
16:40:34 <smcginnis> jgriffith: With the stestr change?
16:41:00 <jgriffith> smcginnis: yeah, but don't want to derail.... and need to try your patch first :)
16:41:04 <lhx_> e0ne, I think just add the __init__ file is ok, not sure if it's worthy
16:41:08 <jgriffith> smcginnis: To Be Continued....
16:42:00 <smcginnis> lhx_: No bug needed IMO, but that could be addressed with the move to separate repos for tempest plugins.
16:42:06 <smcginnis> Or after that move is complete.
16:42:09 <jungleboyj> smcginnis: Thanks for chasing that.
16:42:40 <smcginnis> That's all I've got for today.
16:43:14 <lhx_> smcginnis, yep, make sense
16:43:33 <jungleboyj> smcginnis: For lhx_ problem you are saying he doesn't need to submit a patch or that the patch doesn't need to have a bug created?
16:44:34 <lhx_> jungleboyj, I think it's the latter
16:44:44 <lhx_> smcginnis, right?
16:44:45 <smcginnis> Right, no bug.
16:44:57 <jungleboyj> lhx_: Ok, just making sure that was clear. :-) I agree, just fix it.
16:45:21 <lhx_> jungleboyj, sure :)
16:45:28 <jungleboyj> lhx_: Thanks!
16:45:38 <jungleboyj> Ok ... anything else?
16:45:51 <lhx_> you're welcome
16:46:00 <jungleboyj> :-)
16:46:11 <jungleboyj> @!h
16:46:11 <_pewp_> jungleboyj (/ .□.) ︵╰(゜Д゜)╯︵ /(.□. )
16:46:53 <jungleboyj> Since no one has anything else to share I guess we can wrap up and everyone get 14 minutes back. :-)
16:47:05 <smcginnis> Thanks!
16:47:07 <tommylikehu> 13
16:47:10 <jungleboyj> Thank you for working on Cinder!
16:47:12 <lhx_> thanks
16:47:16 <jungleboyj> Talk to you all next week.
16:47:20 <jungleboyj> @!
16:47:21 <_pewp_> jungleboyj ( ^_^)/
16:47:28 <jungleboyj> #endmeeting