16:00:47 <jungleboyj> #startmeeting cinder
16:00:48 <openstack> Meeting started Wed Dec  6 16:00:47 2017 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:51 <smcginnis> o/
16:00:52 <openstack> The meeting name has been set to 'cinder'
16:01:18 <jungleboyj> Courtesy ping:  jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh
16:01:21 <e0ne> hi
16:01:23 <tommylikehu> hey
16:01:31 <abishop> o/
16:02:03 <jungleboyj> Guessing that this might be kind-of quiet given people are at kubecon.
16:02:25 <DuncanT> I wish I was at kubecon
16:02:31 <tommylikehu> jungleboyj:  how many cinder guys are there
16:02:42 <jungleboyj> smcginnis:  and jgriffith
16:02:49 <smcginnis> I've seen many familiar faces.
16:02:54 <walshh> Hi Helen here
16:03:05 <jungleboyj> walshh:  Hey!  Great to have you join us!
16:03:08 <tommylikehu> hi walshh
16:03:13 * smcginnis waves at walshh
16:03:15 <walshh> about time for me
16:03:29 <jungleboyj> walshh:  I wasn't going to say it ... but yes.  :-)
16:03:33 <walshh> Hope ye all enjoyed Sydney
16:03:45 <walshh> Wish I had been able to travel
16:03:53 <jungleboyj> We did.  Wish you could have been there but looking forward to seeing you in Dublin.
16:04:01 * jungleboyj needs a tour guide.  ;-)
16:04:02 <lhx_> hi all
16:04:23 <jungleboyj> lhx_:  Welcome.
16:04:24 <walshh> I lived there for 2 years about 17 years ago
16:04:30 <walshh> I will need a tour guide
16:04:42 <lhx_> jungleboyj, thanks ;)
16:04:47 <jungleboyj> walshh:  Ok, you can just join us for the fun then.
16:04:56 <jungleboyj> Ok, so lets get started.
16:05:07 <jungleboyj> #topic announcements
16:05:37 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:06:05 <jungleboyj> We are coming up on the later part of the release so the review tracking becomes more important here.
16:06:31 <jungleboyj> If you have a spec that is in there and have reviews being put up, please update the list so we can be focusing on those reviews.
16:06:49 * abishop is adding his reviews
16:06:51 <jungleboyj> Would really like to be able to get the code to go with the specs in.
16:06:54 <jungleboyj> abishop:  Thank you!
16:07:09 <jungleboyj> A reminder on the Queens schedule ...
16:07:15 <jungleboyj> Milestone 2 is tomorrow.
16:07:26 <jungleboyj> #link https://releases.openstack.org/queens/schedule.html
16:07:45 <jungleboyj> That leaves us with a month and a half until feature freeze.
16:08:03 <jungleboyj> With holidays and stuff that makes knowing what we are trying to get merged important.  So, see request above.  :-)
16:08:22 <jungleboyj> I am planning to propose the milestone 2 branch later this afternoon.
16:08:41 <jungleboyj> Any questions around all of that fun?
16:09:20 <Swanson> Hello.
16:09:22 <hemna_> mep
16:09:31 <jungleboyj> hemna_:  There you go   :-)
16:09:41 <jungleboyj> Moving on.
16:09:50 <jungleboyj> #topic Drivers Merged in Queens
16:10:11 <jungleboyj> Just wanted to note that we have gotten the DataCore and Inspur drivers merged for queens.
16:10:24 <jungleboyj> Thank you to everyone who did reviews and helped get those in place.
16:11:10 <jungleboyj> With watching CIs and stuff it takes a lot of work to guide those in.
16:11:21 <jungleboyj> Ok, so on to the rest of the agenda:
16:11:26 <jungleboyj> #topic Nominate volume bulk create for Spec Freeze Exception
16:11:32 <jungleboyj> walshh: and tommylikehu
16:11:48 <tommylikehu> jungleboyj:  thanks
16:11:53 <e0ne> do we have implementation proposal?
16:12:06 <hemna_> so we are doing bulk create now?
16:12:20 <jungleboyj> hemna_: e0ne  That is what this discussion is for.
16:12:29 <hemna_> oh :)
16:12:30 <e0ne> if there is a patch with implementation spec freeze exceptions could be reasonable
16:12:44 <tommylikehu> jungleboyj:  we just wondering if we can give more time on this
16:13:24 <tommylikehu> e0ne:  I guess walshh  is working on this these days
16:13:51 <jungleboyj> So, first question is based the notes from Denver:
16:13:53 <erlon> hey
16:13:56 <jungleboyj> #link https://wiki.openstack.org/wiki/CinderQueensPTGSummary#Discuss_Bulk_Volume_Create
16:13:57 <e0ne> #link https://review.openstack.org/#/c/514196/
16:14:34 <jungleboyj> Has the Nova team been approached about adding Bulk Attach to the API?
16:15:15 <walshh> Matt Riedemann has commented on the review and is not prepared to support bulk attaches at this point
16:15:15 <tommylikehu> walshh:  can you share the progress you have made with Nova?
16:16:41 <jungleboyj> walshh: Ok, so I think that ends up being a non-starter for us at this point based on the discussion we had in Denver.
16:17:28 <jungleboyj> jgriffith: Had some strong feelings about that being required for this to move forward.
16:18:46 <jungleboyj> Unfortunately he is not here.
16:18:52 <tommylikehu> jungleboyj:  understood
16:19:09 <jungleboyj> So, tommylikehu walshh What is the urgency for getting this in for Queens?
16:19:29 <walshh> I was initially thinking Rockies timeframe
16:19:48 <jungleboyj> walshh:  As was I, at best.
16:20:03 <walshh> I just don't know will we get the nova buy in
16:20:13 <walshh> even in Rockies
16:20:21 <jungleboyj> tommylikehu: So, why the push for Queens?
16:20:43 <jungleboyj> walshh: If there is not bulk attach what is the use case?
16:20:55 <tommylikehu> jungleboyj:  I just want to get more team's attention on this
16:21:20 <jungleboyj> tommylikehu:  Fair enough, but don't need a freeze exception for that.  :-)
16:21:47 <tommylikehu> jungleboyj:  and would like to help on this feature if we have the chance to have this feature approved
16:21:51 <tommylikehu> jungleboyj:  ok
16:22:01 <jungleboyj> Understood.
16:22:29 <jungleboyj> So here is my proposal ... I think that walshh has been making good progress on the spec.
16:22:42 <jungleboyj> e0ne: Notes that it might help to see code associated with this.
16:22:52 <jungleboyj> I agree.
16:23:15 <jungleboyj> I feel that walshh 's target for Rockie is more appropriate.
16:23:21 <walshh> I have a POC started, but I will need to amend bases on Tommy's feedback
16:23:30 <jungleboyj> walshh:  Cool.
16:23:31 <walshh> based*
16:23:33 <jungleboyj> Link?
16:23:55 <e0ne> walshh: any early PoC on the gerrit will be very helpful
16:24:00 <walshh> not submitted yet, but I can get it there soon
16:24:09 <jungleboyj> walshh: Cool.
16:24:50 <jungleboyj> Lets get those pieces in place and then plan a cross project meeting with Nova in Dublin to see if we can make progress there.
16:25:05 <jungleboyj> I know they aren't going to consider anything right now.
16:25:09 <e0ne> jungleboyj: +1, sounds reasonable
16:25:49 <jungleboyj> Depending on how that discussion goes we can readdress if we are going to move on this for the R release.
16:26:04 <jungleboyj> That sound good for everyone?
16:26:09 <tommylikehu> jungleboyj: fair enough
16:26:26 <walshh> Sounds good to me
16:26:36 <jungleboyj> #action walshh to continue to respond to comments on the spec
16:26:48 <jungleboyj> #action walshh to put up a PoC of the code for Cinder
16:26:57 <jungleboyj> #action team to review and comment
16:27:13 <tommylikehu> jungleboyj:  thanks!
16:27:16 <jungleboyj> #action jungleboyj  to schedule cross-project session with Nova in Dublin on this.
16:27:29 <jungleboyj> tommylikehu: No problem.
16:27:40 <jungleboyj> We will keep this moving but don't need a spec freeze for it.
16:28:02 <jungleboyj> walshh: Once we start R you will need to move the spec forward to there.
16:28:18 <walshh> ok, will do
16:28:26 <jungleboyj> :-)  Cool.
16:28:29 <e0ne> I think, we can start accept specs for R starting tomorrow
16:28:40 <jungleboyj> e0ne:  Oh, good point.
16:28:53 <jungleboyj> Once we close out Q.  I think you are right.
16:29:10 <tommylikehu> e0ne:  that's great!
16:29:14 <smcginnis> Yeah, no reason we can't get those going already.
16:29:24 <jungleboyj> smcginnis:  Good.  Thanks for the input.
16:29:51 <jungleboyj> Anything else on this topic?
16:30:36 <jungleboyj> #topic Open Discussion
16:30:46 <jungleboyj> Anything else we need to discuss today?
16:31:56 <e0ne> #link https://review.openstack.org/526120 :)
16:32:18 <e0ne> I hope, CI will pass in this ^^
16:32:18 <jungleboyj> e0ne:  Nice.
16:32:19 <tommylikehu> e0ne:  lol
16:32:23 <jungleboyj> Thank you.
16:32:41 <jungleboyj> Was going to go look at doing that but now I don't need to.  :-)
16:33:03 <e0ne> jungleboyj: :)
16:33:40 <e0ne> smcginnis, jungleboyj: do you know anything about Rocky schedule?
16:33:55 <jungleboyj> It should be out there.  Hold on.
16:34:23 <smcginnis> e0ne: I don't think everything is finalized yet, but should be soon.
16:34:37 <e0ne> smcginnis: ok, thanks
16:34:39 <jungleboyj> Hmmm yeah, not there yet.
16:35:01 <jungleboyj> I will let everyone here know when it is out.
16:36:24 <jungleboyj> Ok.  If there is nothing else we can wrap up.
16:36:35 <e0ne> see you next week
16:37:03 <jungleboyj> Yep.  Thank you everyone for coming and for your work on Cinder!
16:37:11 <jungleboyj> #endmeeting