16:00:16 <jungleboyj> #startmeeting Cinder
16:00:19 <openstack> Meeting started Wed Dec 13 16:00:16 2017 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:23 <openstack> The meeting name has been set to 'cinder'
16:00:38 <smcginnis> o/
16:00:44 <tommylikehu> hey
16:00:46 <jungleboyj> courtesy ping:  jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro
16:00:49 <xyang1> Hi
16:00:50 <jungleboyj> @!
16:00:50 <_pewp_> jungleboyj (。・д・)ノ゙
16:00:56 <e0ne> hi
16:00:57 <Swanson> heyump!
16:00:58 <jungleboyj> xyang1:  Yay!  Welcome!
16:01:04 <cleong> hi
16:01:07 <gouthamr> o/
16:01:08 <xyang1> :)
16:01:12 <felipemonteiro_> o/
16:01:24 <jungleboyj> felipemonteiro_:  Welcome.
16:01:30 <jungleboyj> Agenda for today:  https://etherpad.openstack.org/p/cinder-queens-meeting-agendas
16:02:00 <bswartz> ./o
16:02:03 <bswartz> .o/
16:02:15 <smcginnis> bswartz: Kinda turned into a mutant for a second there.
16:02:25 <jungleboyj> bswartz:  Ouch.
16:03:01 <jungleboyj> Ok, we have a good number of people here and have a few topics to cover today.
16:03:06 <Swanson> bswartz, dislocate your head?
16:03:26 <jungleboyj> #topic Announcements
16:03:40 <jungleboyj> #link  https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:03:47 <bswartz> I'm okay -- just typing too fast
16:04:13 <jungleboyj> We are working towards Queens-3 ...  So, lets keep the reviews going and please keep getting reviews for your sepcs into that file.
16:04:24 <jungleboyj> I have closed down the new driver reviews.
16:04:40 <jungleboyj> Unfortunately had a few drivers that missed, but they weren't ready.
16:04:57 <jungleboyj> Wanted to let everyone know that we have released Cinderclient 3.3.0 last week.
16:05:27 <jungleboyj> There were a number of missing microversions in the client and this release brings us up to date there so that we can keep tackling the multi-attach work.
16:05:51 <jungleboyj> In sad news we have had some Cores stepping down.
16:05:56 <e0ne> :(
16:06:05 <tommylikehu> :(
16:06:09 <jungleboyj> I started a discussion due to the disconnect in number of cores and actual activity.
16:06:24 <jungleboyj> Was wondering who would not be able to get back to Cinder.
16:06:38 <e0ne> dulek, scottda, we'll miss all of you
16:06:49 <jungleboyj> Unfortunately Michal Dulko and Scott D'Angelo needed to step back.
16:07:06 <jungleboyj> e0ne:  ++1000
16:07:08 <e0ne> seems that DuncanT will step down too:(
16:07:11 <tommylikehu> DuncanT: ?
16:07:28 <jungleboyj> DuncanT:  Yeah, he hadn't officially announced yet so I wasn't going to say anything.
16:07:40 <DuncanT> Yup, sadly, I'm not able to do any reasonable numbe rof reviews
16:07:53 <jungleboyj> DuncanT: :-(
16:07:56 <smcginnis> DuncanT: You can do an unreasonable number if you want. :)
16:08:07 <jungleboyj> smcginnis:  Hey, I like that idea.
16:08:13 <jungleboyj> DuncanT:  You always found such good stuff.
16:08:16 <e0ne> DuncanT: :( I hope you'll find some time for specs reviews. they were extremly useful
16:08:25 <jungleboyj> e0ne:  ++
16:08:31 <DuncanT> smcginnis: Jay's email made it clear that reviews are needed by cores. It's fair enough but means I have to step down
16:08:45 <tommylikehu> e0ne: +1
16:09:17 <DuncanT> I'll keep my eye on specs when I can for sure... if I ever come back to cinder I don't want ot find it full of things I don't like ;-)
16:09:18 <jungleboyj> I think it is important that the number of cores we have accurately reflects activity.  That, however, doesn't mean that I don'
16:09:29 <e0ne> DuncanT: :)
16:09:39 <smcginnis> DuncanT: ;)
16:09:54 <jungleboyj> t greatly appreciate any input that people can give and obviously we can add people back in, in the future.
16:10:05 <jungleboyj> Another option is to keep more cores on cinder-specs.
16:10:07 <e0ne> jungleboyj: +2
16:10:35 <e0ne> jungleboyj: for both your messages above
16:10:45 <smcginnis> Just checked, and cinder-spec-core includes cinder-core, but explicitly has DuncanT. You're a double core there.
16:10:52 <DuncanT> cinder-specs is the only thing I have any input on these days, and would probably work for some of the cores who were avoiding +2s due to being out of touch with the code
16:11:10 <DuncanT> Double core? Awesome! /me updates his CV
16:11:13 <jungleboyj> smcginnis:  Cool.
16:11:19 <jungleboyj> DuncanT:  Is hard core.
16:11:44 <jungleboyj> I would be fine with Leaving DuncanT as specs core given the help you have been giving there.
16:11:57 <e0ne> jungleboyj: +1
16:12:15 <smcginnis> ++
16:12:33 <tommylikehu> +1
16:12:34 <jungleboyj> DuncanT:  How does that sound?
16:12:42 <DuncanT> Sounds great to me. Cheers.
16:13:02 <jungleboyj> DuncanT:  Cheers!  Would appreciate if you can continue to help with Specs.
16:13:03 <e0ne> DuncanT: hope to see you at PTG
16:13:32 <jungleboyj> e0ne:  ++
16:13:42 <DuncanT> e0ne: Definitely, it's only up the road
16:13:47 <e0ne> :)
16:14:08 <jungleboyj> Anyway, for those stepping down, thank you for letting us know where your work has taken you.
16:14:18 <smcginnis> ++
16:14:20 <jungleboyj> Thank you for all of your previous contributions and time on Cinder!
16:14:42 <jungleboyj> And as said before, we can always bring cores back in if priorities change.
16:15:02 <e0ne> and we'll be happy once you return to Cinder
16:15:09 <jungleboyj> e0ne:  +_
16:15:12 <jungleboyj> ++
16:15:42 <jungleboyj> I am still waiting to hear back from a few people.  Will keep you all updated.
16:16:05 <jungleboyj> Anymore questions/comments on this topic?
16:16:45 <jungleboyj> Ok, moving on.
16:17:10 <jungleboyj> #topic Potential bug in API Return Values
16:17:22 <jungleboyj> #link https://bugs.launchpad.net/cinder/+bug/1737609
16:17:23 <openstack> Launchpad bug 1737609 in Cinder "Some APIs return None when missing permissions instead of raising 403" [Undecided,New]
16:17:28 <jungleboyj> felipemonteiro_:
16:17:58 <jungleboyj> felipemonteiro_:  You still there?
16:18:01 <felipemonteiro_> Thanks, provided launchpad link which should go into all necessary detail. Just want others' opinion before starting on the work.
16:18:09 <erlon> hey
16:18:14 <felipemonteiro_> I can summarize here too.
16:18:21 <e0ne> looks like we need to fix it
16:18:23 <jungleboyj> erlon:  Wlecome.
16:18:32 <jungleboyj> felipemonteiro_:  Thank you for opening the bug.
16:18:32 <smcginnis> felipemonteiro_: A quick summary would be good.
16:18:34 <erlon> thanks
16:18:43 <tommylikehu> it's a bug
16:19:17 <felipemonteiro_> For two endpoints, policy enforcement is done with fatal=False; if it passes, a response body is returned.
16:19:18 <jungleboyj> tommylikehu:  That was my feeling as well.
16:19:28 <felipemonteiro_> If it fails, None is returned. Usually the behavior is raise 403.
16:19:51 <felipemonteiro_> And fatal=False is mostly reserved for adding additional attributes to a response body... as far as *I* can tell
16:21:04 <smcginnis> So the problem is if policy does not allow it, we return None.
16:21:14 <smcginnis> I agree it's a bug. We should return {}
16:21:27 <felipemonteiro_> This behavior is currently caught by Tempest since the rules are admin_or_owner rather than admin_only. But it is detected when you override the defaults to admin_only
16:21:35 <felipemonteiro_> currently _not_ caught
16:22:19 <jungleboyj> smcginnis:  Shouldn't we return a 403?
16:23:42 <smcginnis> jungleboyj: Oh, right. Still need to really look at it, but yes, if they don't have permission, 403 would be accurate.
16:23:52 <jungleboyj> smcginnis: Ok, good.
16:24:44 <jungleboyj> felipemonteiro_:  You mean not caught by tempest.
16:25:02 <felipemonteiro_> Yes, sorry. not caught
16:25:17 <jungleboyj> felipemonteiro_:  Ok good.
16:25:31 <felipemonteiro_> Stacktrace in launchpad link was generated in my local env after changing the rules to admin_only
16:25:57 <jungleboyj> felipemonteiro_: Ok.
16:26:13 <jungleboyj> So, I think the concensus is that it would return a 403 and that that is a valid bug.
16:26:23 <e0ne> jungleboyj: +1
16:26:28 <smcginnis> jungleboyj: +1
16:26:42 <tommylikehu> +1
16:26:42 <felipemonteiro_> Only two questions I had were: does the fix need a new microversion
16:26:43 <jungleboyj> Cool.  Do we have someone to assign the bug to?
16:26:51 <felipemonteiro_> And: I can pick it up if need be, but don
16:27:01 <felipemonteiro_> 't mind letting someone else do it either
16:27:13 <smcginnis> felipemonteiro_: No, shouldn't need a microversion since it is a bug.
16:27:23 <jungleboyj> smcginnis:  *phew*  Good answer.
16:27:26 <smcginnis> ;)
16:27:47 <jungleboyj> We do need to make sure that the documentation matches.
16:28:26 <jungleboyj> felipemonteiro_:  If you are able to pick this up that would be great.
16:28:51 <felipemonteiro_> jungleboyj: np, I'll assign it to myself
16:29:20 <jungleboyj> felipemonteiro_:  Already done.
16:29:21 <jungleboyj> :-)
16:29:27 <felipemonteiro_> thanks :)
16:29:36 <jungleboyj> #action jungleboyj  to update bug with notes from today's discussion.
16:29:47 <jungleboyj> #action felipemonteiro_  To work on fixing the bug.
16:29:59 <jungleboyj> felipemonteiro_:  Thank you for bringing this up and fixing it!
16:30:08 <jungleboyj> Glad to have your help.
16:30:24 <felipemonteiro_> np, we each have to chip in from time to time
16:30:38 <jungleboyj> Indeed.  A community.
16:31:01 <jungleboyj> Ok, so I think we are closed on that one.
16:31:10 <jungleboyj> #topic NVMET target
16:31:15 <jungleboyj> #link https://review.openstack.org/#/c/505556/10
16:31:25 <jungleboyj> e0ne: ...
16:31:28 <e0ne> thanks
16:31:50 <e0ne> so, moshele is working on NVMeT target driver and CI
16:32:09 <smcginnis> e0ne: What is the state of the CI?
16:32:48 <e0ne> smcginnis: I saw it reported so some patches for os-brick
16:33:11 <e0ne> smcginnis: honestly, I'm not the right contact person to ask about CI
16:33:44 <e0ne> as I know, Mellanox team wants to get CI for it too
16:33:53 <smcginnis> So I do want this feature. But we've previously stated something like this is considered a new driver, and it has definitely not met the deadline to be included in Queens.
16:34:24 <jungleboyj> smcginnis:  Yeah.  I wasn't even aware this was coming along.
16:34:26 <e0ne> smcginnis: fair enough
16:34:48 <jungleboyj> e0ne:  Can we get this on the 'new driver' list ?
16:35:02 <jungleboyj> #link:  https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:35:08 <e0ne> jungleboyj: sure, I'll add it there
16:35:44 <e0ne> and I still have some concerns about implementation
16:35:56 <jungleboyj> e0ne:  Thank you.
16:36:08 <e0ne> the patch proposes 2 new config options: target_type and nvmeof_helper
16:36:19 <jungleboyj> #action e0ne to add the NVMeT support as a new driver in the spec-review-tracking etherpad.
16:36:43 <e0ne> what do you thing about changing current 'iscsi_helper ' option to target_helper' or 'target_driver'?
16:37:08 <e0ne> of course, with following of all depecation policies
16:37:32 <jungleboyj> e0ne:  Wow, that would be quite the impact.
16:38:02 <smcginnis> e0ne: We could probably get those config deprecation/changes in this cycle, then pick up in Rocky for the rest of it.
16:38:11 <e0ne> jungleboyj: I was afraid of it:(
16:38:33 <jungleboyj> smcginnis: Yeah, if we are going to go that way, that would make sense.
16:38:51 <e0ne> smcginnis: we can start work on it early in Rocky to get more time to fix is something will be brokeb
16:39:21 <smcginnis> Works for me.
16:39:38 <jungleboyj> e0ne:  I think that sounds like the best plan.  We should be stabilizing and it sounds like this could be destabilizing.
16:39:40 <e0ne> @action e0ne to propose a patch with deprecation to see what will be broken. e.g. grenade
16:39:45 <e0ne> #action e0ne to propose a patch with deprecation to see what will be broken. e.g. grenade
16:40:08 <e0ne> jungleboyj: thanks
16:41:09 <jungleboyj> #action driver to be targeted to merge early in Rocky
16:41:41 <jungleboyj> In the interest of continuing to reduce option sprawl it does make sense to rename the option.
16:41:58 <smcginnis> ++
16:42:15 <jungleboyj> Though I don't know where that work is at.  I am guessing we will need someone to pick that work up from diablo_rojo
16:42:41 <jungleboyj> e0ne:  Anything more on that topic ?
16:42:54 <e0ne> jungleboyj: no, that's all from my side
16:43:10 <e0ne> thank you for feedback
16:43:15 <jungleboyj> e0ne:  Great.  Thank you for being willing to let that go to Rocky.
16:43:37 <jungleboyj> I do think it will be good to get that support in.  I know we are interested in it.
16:43:42 <e0ne> jungleboyj: I don't have an option. it's a cinder rules and deadlines :)
16:43:47 <smcginnis> :)
16:43:49 <jungleboyj> :-)
16:44:20 <jungleboyj> #open discussion.
16:44:29 <jungleboyj> #topic open discussion
16:44:32 <smcginnis> I want to make sure everyone is aware of this:
16:44:34 <smcginnis> #link http://lists.openstack.org/pipermail/openstack-dev/2017-December/125473.html
16:44:55 * e0ne didn't read it yet
16:45:12 * jungleboyj hasn't either
16:45:12 <smcginnis> We've been having discussions with a few vendors and users, but want to get this out there into the broader community.
16:46:16 <smcginnis> I'll take the silence to mean that everyone is reading it. :)
16:46:35 <smcginnis> Please feel free to respond to that thread or hit me up with any questions or concerns.
16:47:20 <tommylikehu> including summit?
16:47:31 <smcginnis> The biggest one has been devs not wanting to lose the chance to get together as often. So just want to point out that this does bring back the option for midcycles.
16:47:31 * jungleboyj is reading.
16:47:40 <smcginnis> And they would actually be encouraged for some teams.
16:47:55 <smcginnis> tommylikehu: Summits and the Forum would still be twice yearly. At least for now.
16:48:02 <Swanson> Cool. So next release after queens is March 2019?
16:48:19 <smcginnis> Swanson: If we can get buy in on this, yes.
16:48:43 <smcginnis> Well, I should kind of correct that actually.
16:48:55 <smcginnis> Next *coordinated* release would be March 2019.
16:49:08 <smcginnis> But we would actually be encouraging teams to release more frequently.
16:49:20 <smcginnis> Just not necessarily as a coordinated release across all projects.
16:49:40 <Swanson> smcginnis, Nice. Should mean that I have 11 1/2 months of what they want me on before frantically powering hardware back on.
16:49:46 <DuncanT> Lack of coordinated release is likely to shake up downstreams, but that is likely not a bad thing
16:49:47 <smcginnis> So March 2017 will be Cinder 13.0.0 I think. We could potentially have a 13.1.0 release a few months later that adds some drivers.
16:50:18 <jungleboyj> You mean March 2018?
16:50:21 <smcginnis> DuncanT: Agreed. But we have spoken to several of the big distros, and so far at least most are happy with this change.
16:50:29 <smcginnis> jungleboyj: Bah! Yep.
16:50:35 <jungleboyj> :-)
16:51:03 <jungleboyj> So, this really starts a process that has been in the making where the projects are more under their own control.
16:51:20 <smcginnis> jungleboyj: Exactly! At least that's one big aspect of it.
16:51:20 <jungleboyj> swift has been doing this for a while and they seem to do fine.
16:51:49 <xyang1> Users will be happy with less number of upgrades to do
16:51:50 <jungleboyj> I would miss having two PTGs, but we can then address that as a team.
16:51:54 <jungleboyj> xyang1:  ++
16:51:59 <smcginnis> So we would at least have once a year sync up points for all the projects, but in the mean time, projects have more control over what they want to do.
16:52:02 <jungleboyj> We are growing up.
16:52:10 <e0ne> I like this proposal from vendor's side. need to think a bit more from the developer's perspective
16:52:14 <DuncanT> I'm always a fan of loser coupling between projects, though it makes nova/keystone depreciations more complex
16:52:36 <smcginnis> jungleboyj: We just need someone to host a midcycle in Ft Collins in Aug/Sept now.
16:52:38 <jungleboyj> DuncanT:  Yeah, I am worried about the impact this will have on integration with Nova.
16:53:03 <jungleboyj> smcginnis:  :-)  Well, I am sure I can get Lenovo to host if we can't get anyone in Ft Collins
16:53:15 <jungleboyj> Wait, where is jgriffith !?!
16:53:28 * jungleboyj takes the crew to his farm
16:53:31 <smcginnis> jgriffith's barn should be big enoug for us all.
16:53:38 <e0ne> :)
16:53:39 <jungleboyj> smcginnis:  ++
16:53:53 <jungleboyj> He isn't here to fight ...
16:54:52 <jungleboyj> smcginnis:  Thank you for bringing this up.  I thought it was kind of silly at first but when it is put down this way it seems like it could be a good thing.
16:55:00 <smcginnis> 5 minute warning.
16:55:12 <smcginnis> jungleboyj: Yeah, the more we talked about it, the more it's made sense to me.
16:55:25 <jungleboyj> Cool.
16:55:33 <jungleboyj> Anything else to cover?
16:55:43 <jungleboyj> e0ne:  What was your comment about Mellanox?
16:55:54 <jungleboyj> They want the NVMeT driver in as well?
16:56:23 <e0ne> jungleboyj: yes. actually, they are working on nvme target driver now
16:56:40 <jungleboyj> e0ne:  Ok, so you are just supporting that effort?
16:56:41 <smcginnis> They make NVMe adaptors, so yes, they want it in. :)
16:56:47 <jungleboyj> smcginnis:  Makes sense.
16:56:54 <e0ne> jungleboyj: unfortunately, moshele didn't manage to attend this meeting and ask me to help him
16:56:59 <jungleboyj> e0ne:  Is that moshele ?
16:57:10 <jungleboyj> e0ne:  Ok, where is he based?
16:57:13 <jungleboyj> or she
16:57:16 <jgriffith> I have zero concerns about integerations including Nova
16:57:22 <e0ne> jungleboyj: moshele is from Mellanox Tel Aviv team
16:57:27 <jgriffith> irrelevant
16:57:53 <jungleboyj> Ok.  Hopefully moshele can attend the meeting more as we get closer to integrating .
16:57:59 <e0ne> jungleboyj: few years ago, I started work on NVMe PoC for Barcelona summit, so I just want to finish this :)
16:58:03 <smcginnis> jgriffith: You mean as far as NVMe support on the nova side?
16:58:17 <jungleboyj> jgriffith: Good.  And about hosting the mid-cycle?  ;-)
16:58:32 <jgriffith> no, sorry.. the looser coupling/scheduling thing
16:58:44 <smcginnis> :)
16:58:54 <e0ne> smcginnis:  here is a patch to nova https://review.openstack.org/#/c/482640/
16:58:56 <jungleboyj> jgriffith: With how long it takes to get things in, it will probably be no different.
16:59:11 <smcginnis> Theoretically, now that we have microversions it shouldn't really matter about coordinated releases for some of those kinds of things.
16:59:17 <smcginnis> Either the support is there or not.
16:59:23 <jgriffith> jungleboyj: that and the fact that things usually are driven the opposite direction
16:59:32 <e0ne> smcginnis:  and os-brick part https://review.openstack.org/#/c/482642/
16:59:34 <smcginnis> Time check.
16:59:35 <jgriffith> and hey... that's why we have mv's :)
16:59:36 <smcginnis> e0ne: Thanks
16:59:37 <Swanson> You'll probably have to do something different for adding drivers.
16:59:41 <smcginnis> jgriffith: :)
16:59:44 <jgriffith> which I will propose again we abandon :)
17:00:03 * jgriffith ducks
17:00:12 <jungleboyj> :-)  Ok.  That is time.  I am stopping this while I can.
17:00:16 <jungleboyj> Thanks for a good meeting all.
17:00:18 <jgriffith> haha
17:00:23 <Swanson> toodles
17:00:26 <smcginnis> Swanson: We will need to discuss that some more. But we could theoretically just include drivers whenever they are ready. If thats what we want.
17:00:28 <jungleboyj> Thanks for bringing up the new schedule Sean.  Good stuff.
17:00:37 <jungleboyj> smcginnis:  ++
17:00:45 <jungleboyj> #endmeeting