16:00:18 <jungleboyj> #startmeeting cinder
16:00:19 <openstack> Meeting started Wed Dec 20 16:00:18 2017 UTC and is due to finish in 60 minutes. The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:22 <openstack> The meeting name has been set to 'cinder'
16:00:39 <jungleboyj> courtesy ping: jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro
16:00:47 <e0ne> hi
16:00:49 <tommylikehu> hi
16:00:51 <xyang> hi
16:00:58 <felipemonteiro> o/
16:01:03 <jungleboyj> @!
16:01:03 <_pewp_> jungleboyj (^▽^)/ ʸᵉᔆᵎ
16:01:13 <tbarron> hi
16:01:22 <jungleboyj> Hey tbarron
16:01:43 <gouthamr> o/
16:02:23 <Guest37178> hi!
16:02:26 <e0ne> #link https://etherpad.openstack.org/p/cinder-queens-meeting-agendas
16:02:39 <jungleboyj> Give people another minute to get here.
16:03:07 <jungleboyj> e0ne: Thanks!
16:03:11 <e0ne> :)
16:03:18 <jungleboyj> Waiting for smcginnis since he has a topic on there.
16:03:24 <smcginnis> ༼⍤༽
16:04:26 <jungleboyj> smcginnis: Yay! and I guess Gorka is just a Guest now.
16:04:36 * smcginnis tries to remember what I wanted to talk about
16:05:07 <jungleboyj> Ok, so we might as well get started.
16:05:15 <jungleboyj> #topic announcements
16:05:28 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:05:47 <jungleboyj> I haven't seen too many reviews added to the tracking etherpad.
16:05:56 <jungleboyj> Please take some time to do that if you can please.
16:06:21 <jungleboyj> With Queens-2 passing I have moved all the new driver proposals to a -2 for now.
16:06:48 <jungleboyj> Trying to get caught up on reviews. Will keep working on that through Christmas.
16:07:13 <jungleboyj> #topic Plan for up-coming meetings
16:07:30 <jungleboyj> That leads me to the next topic which is what we want to do about our up-coming meetings.
16:07:43 <jungleboyj> I know a lot of people are on vacation next week.
16:08:14 <jungleboyj> Would anyone be opposed to skipping the 12/27 meeting?
16:08:22 <smcginnis> I'm probably around on Wednesday, but I will be travelling the next two weeks.
16:08:29 <smcginnis> Skipping sounds good to me.
16:09:00 <jungleboyj> smcginnis: Will you be around on 1/3/18 ?
16:09:14 <e0ne> what about meeting on Jan, 3rd?
16:09:26 <jungleboyj> Yeah, that was the next question e0ne
16:09:29 <smcginnis> jungleboyj: That one is less likely for me. I think I will be in Portland.
16:10:02 <jungleboyj> smcginnis: Ok, I am going to be in workshops in RTP and am not sure that I will be able to run the meeting.
16:10:18 <smcginnis> jungleboyj: We can skip two weeks.
16:10:28 <jungleboyj> The agendas have been pretty light.
16:10:32 <smcginnis> jungleboyj: Or have a quick one next week for those around, then skip the next one.
16:10:38 <smcginnis> I'd be fine skipping two.
16:10:45 <ildikov> I don't think too much is going to happen during these two weeks
16:10:46 <smcginnis> We can always bring up issues in channel.
16:10:58 <jungleboyj> ildikov: True.
16:11:01 <tommylikehu> smcginnis: that's true
16:11:04 <jungleboyj> :-)
16:11:06 <smcginnis> ildikov: You don't think multiattach will land in the next two weeks? :)
16:11:17 <jungleboyj> He he he.
16:11:20 <jungleboyj> We can dream.
16:11:22 <e0ne> any options are good for me
16:11:35 <ildikov> We should get the multiattach spec landed though but I believe jgriffith needs to update it first
16:11:54 <smcginnis> ildikov: Good point.
16:11:59 <jungleboyj> ildikov: Right. I have been wanting to merge it. Not sure if it has been updated. I need to look at that.
16:12:00 <ildikov> smcginnis: I will be already happy if the spec does...
16:12:09 <jungleboyj> Lets move that to Open Discussion.
16:12:21 <jungleboyj> So, I think we have landed on skip two weeks.
16:12:35 <smcginnis> +1
16:13:20 <jungleboyj> #agreed Skip 12/27 and 1/3/18 .
16:13:30 <jungleboyj> #action jungleboyj to send an e-mail to the mailing list.
16:13:45 <ildikov> It looks like we want to skip those days :)
16:14:12 <jungleboyj> Okie dokie.
16:14:22 <jungleboyj> #topic LVM Extend Issues
16:14:30 <smcginnis> #link https://bugs.launchpad.net/cinder/+bug/1731984 Extend bug report
16:14:31 <openstack> Launchpad bug 1731984 in Cinder "LVM: iSCSI tgts not refreshed after volume extend" [Undecided,New]
16:14:31 <jungleboyj> #link https://bugs.launchpad.net/cinder/+bug/1731984
16:14:53 <smcginnis> So I was doing some bug triaging the last few days and came across this.
16:15:09 <jungleboyj> smcginnis: Thank you.
16:15:10 <smcginnis> And I'm not sure if it's valid or not, so I wanted to get it out to more folks that might have some experience there.
16:15:29 <smcginnis> It surprised my a bit, because I thought we had tests for this that are passing with LVM.
16:15:54 <smcginnis> So checking to see if anyone knows anything about the need to refresh iSCSI targets after extending a volume.
16:16:39 <jungleboyj> smcginnis: Is this talking about on the host or in the VM?
16:17:03 <smcginnis> jungleboyj: I believe it's on the host exposing the LV.
16:17:13 <smcginnis> And the iSCSI targets it presents.
16:17:43 <jungleboyj> Oh ....
16:17:48 <smcginnis> The paste included in the bug seems to indicate a difference, but not sure if that's really what the nova host sees.
16:17:49 <jungleboyj> Yeah, I see that now.
16:18:02 <smcginnis> Though maybe I'm wrong about having test coverage here. I should double check that.
16:18:23 <jungleboyj> I am not totally sure that we do.
16:18:35 <smcginnis> If no one has any background on this, that's OK. Just thought I would raise it in case someone knew something about it.
16:18:51 <smcginnis> Seems easy enough to add the call they mention in the bug.
16:20:00 <jungleboyj> smcginnis: It sounds like it may be a valid but. I think with the extend in-use we had thought that there might be a driver impact and it just didn't get followed up upon.
16:20:37 <jungleboyj> No one is jumping up and down with input.
16:20:40 <smcginnis> jungleboyj: Yeah, I suppose. We can move on. Doesn't sound like anyone knows this bit. :)
16:21:00 <jungleboyj> smcginnis: I would think that eharney or hemna might have input.
16:21:21 <jungleboyj> They seem to know something about iSCSI. :-)
16:21:42 <smcginnis> Maybe they'll chime in later.
16:21:44 <jungleboyj> smcginnis: Are you going to follow through with the bug then?
16:22:05 <smcginnis> jungleboyj: If no one else grabs it before me I can. Need to wrap up a couple other things first.
16:22:18 <jungleboyj> Ok ... sounds good.
16:22:46 <jungleboyj> #topic Open Discussion
16:23:07 <jungleboyj> ildikov: smcginnis jgriffith Ok, back to the multi-attach spec
16:24:16 <smcginnis> #link https://review.openstack.org/#/c/523608/ Multiattach spec
16:24:32 <jungleboyj> smcginnis: Thank you, was just trying to find that.
16:25:00 <ildikov> It's still set to WIP
16:25:19 <jungleboyj> Yeah.
16:25:29 <jungleboyj> So it looks like we need John to update it.
16:26:10 <ildikov> I think we're mainly in an agreement on the points though, so maybe on the meeting tomorrow the latest someone can update it if jgriffith will not do it by then
16:26:25 <smcginnis> Good plan.
16:26:58 <jungleboyj> Agreed. I will review before tomorrow's meeting. If we are all in agreement and if John can't get to it I can do an update.
16:27:14 <ildikov> ok, we can stick with that then as I guess one day doesn't count by now
16:27:27 <ildikov> jungleboyj: sounds good, thanks
16:28:39 <jungleboyj> #agreed Finish up review at 12/21 meeting and jungleboyj will update the spec if jgriffith is unavailable.
16:28:52 <jungleboyj> Do we agree we need to get that in before the holiday?
16:29:00 <smcginnis> Would be good to have that done.
16:29:08 <jungleboyj> Cool.
16:29:19 <jungleboyj> #agreed Should merge the spec before the holiday break.
16:29:20 <ildikov> yes
16:29:31 <ildikov> we need to set the base for code changes
16:29:43 <jungleboyj> Agreed.
16:29:49 <ildikov> and jgriffith said we shouldn't have too much up before having the spec merged
16:29:52 <jungleboyj> ildikov: Thanks for bringing that up.
16:30:28 <jungleboyj> So we have a plan there.
16:30:32 <ildikov> and as I need to make my hands dirty here as well and I'm slow the earliest we could have it land the better
16:30:53 <jungleboyj> :-) Yeah. Really want to get that done.
16:31:19 <jungleboyj> Any other topics for today?
16:31:29 <smcginnis> Yeah, I have one more...
16:31:36 <jungleboyj> smcginnis: Go ahead sir.
16:32:10 <smcginnis> So cinder repo reviews are... what they are. But also wanted to point out we have os-brick, python-cinderclient, python-brick-cinderclient-ext, and now cinder-tempest-plugin.
16:32:17 <smcginnis> We need reviews on those patches as well.
16:32:33 <smcginnis> There's not a ton out there, but they haven't been getting much attention lately.
16:32:57 <smcginnis> That's it, just wanted to give that public service announcement.
16:33:21 <jungleboyj> smcginnis: Thank you. Good point.
16:33:56 <jungleboyj> smcginnis: I need to add cinder-tempest-plugin to my list of things I get e-mail for.
16:34:14 * jungleboyj also needs to clean out my review inbox.
16:34:46 <smcginnis> Oh, on that point too, make sure we don't add any more tempest tests to the cinder repo. They should be going in the new repo now.
16:35:01 <smcginnis> I have a patch to remove the cinder tests, but I think that's still out there.
16:35:19 <jungleboyj> smcginnis: If you point me to that patch we can try to get it through.
16:36:15 * jungleboyj waits for smcginnis to think of something else...
16:36:37 <smcginnis> jungleboyj: Nothing else from me.
16:36:50 <e0ne> :)
16:37:07 <jungleboyj> :-) Ok. Then I think we can wrap the meeting up.
16:37:19 <e0ne> have a good holidays!
16:37:36 <jungleboyj> I wish everyone a Merry Christmas and a safe and Happy New Year!
16:37:38 <smcginnis> #link https://review.openstack.org/#/c/487144/ Tempest removal
16:37:52 <jungleboyj> Look forward to continuing to work with everyone in the new year!
16:38:00 <smcginnis> THanks!
16:38:06 <jungleboyj> smcginnis: Thank you.
16:38:15 <jungleboyj> Later.
16:38:18 <jungleboyj> @!
16:38:18 <_pewp_> jungleboyj ヽ(´・ω・`)、
16:38:28 <jungleboyj> #endmeeting