16:00:33 <jungleboyj> #startmeeting Cinder
16:00:35 <openstack> Meeting started Wed Feb  7 16:00:33 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:39 <openstack> The meeting name has been set to 'cinder'
16:00:49 <smcginnis> o/
16:00:52 <e0ne> hi
16:00:55 <tommylikehu> hi
16:00:55 <jungleboyj> courtesy ping:  jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon tpsilva patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro lpetrut
16:00:59 <smcginnis> Hey jungleboyj, how's it going?
16:01:11 <tpsilva> hy o/
16:01:12 <xyang> hi
16:01:13 <jungleboyj> @!
16:01:13 <tpsilva> hey
16:01:14 <_pewp_> jungleboyj (*´・д・)ノ
16:01:17 <walshh> hi
16:01:21 <abishop> o/
16:01:40 <geguileo> hi! o/
16:02:02 * e0ne waits for Thursday  discussion
16:02:22 <smcginnis> Oh right, tomorrow is Thursday.
16:02:43 <e0ne> smcginnis: are you sure about this week? :)
16:02:48 <jungleboyj> What?  It is Thursday!?!
16:02:56 * smcginnis checks calendar
16:02:58 <smcginnis> Yep
16:03:06 <smcginnis> :)
16:03:07 <e0ne> :)
16:03:10 <tbarron> hi
16:03:24 * e0ne sync calendar...
16:04:02 <jungleboyj> Ok, before Sean continues to make fun of me I will move on.
16:04:19 <jungleboyj> #topic announcements
16:04:46 <jungleboyj> So, as we were just discussing, tomorrow is Thursday which means it is time to cut RC-1 for Queens.
16:04:53 <jungleboyj> Not sure how we have gotten there already.
16:05:00 <jungleboyj> Time flies when you are having fun.
16:05:20 <jungleboyj> Does anyone have anything urgent that needs to get in before RC?
16:05:53 <jungleboyj> I will take that as a good sign.
16:06:10 <smcginnis> I just have my one that is deprecating a config option I would like to see land yet, but it's not critical.
16:06:16 <smcginnis> Does improve our testing through.
16:06:19 <jungleboyj> So, I will plan to make the cut later today then.
16:06:33 <jungleboyj> smcginnis:  Ok, can you share that link here and see if we can get eyes on it today.
16:06:49 <smcginnis> https://review.openstack.org/#/c/541061/
16:06:50 <patchbot> patch 541061 - cinder - Make CinderException format errors fatal for tests
16:07:08 <smcginnis> I assume you just wanted to wait for eharney e0ne?
16:07:41 <e0ne> smcginnis: you asked Eric for review it, so I hold my +A
16:07:42 <eharney> i'll look over this one right after this meeting, but it looked good so far
16:07:52 <smcginnis> OK, great.
16:07:57 <smcginnis> jungleboyj: That's all I've got.
16:08:01 <jungleboyj> eharney:  Awesome.  Thanks.
16:08:17 <e0ne> I always OK with code removal
16:08:20 <jungleboyj> I will wait for that if all looks good before doing the RC.
16:08:31 <jungleboyj> smcginnis:  Loves to remove code.
16:08:58 <jungleboyj> A reminder about PTG planning:
16:09:06 * smcginnis is guilty
16:09:21 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-ptg-rocky
16:09:34 <jungleboyj> tommylikehu:  Thanks for getting topics out there.
16:09:46 <jungleboyj> Looks like we are going to have a good crowd in Dublin.
16:09:47 <tommylikehu> jungleboyj:  :)
16:10:18 <jungleboyj> Please add more topics as appropriate.  I am going to work on going through what was discussed at the last PTG and pull topics forward today.
16:10:56 <jungleboyj> Also, just a note that PTL voting will open though I haven't seen anyone else nominated for Cinder.
16:10:59 <jungleboyj> #link https://governance.openstack.org/election/
16:11:19 <e0ne> jungleboyj: we all believe in you!
16:11:40 <smcginnis> Jay! Jay! Jay!
16:11:41 <e0ne> jungleboyj: thanks a lot for your hard job as PTL
16:11:46 <jungleboyj> e0ne:  Thank you.
16:12:03 <jungleboyj> Done the best I could and hope to do even better for Rocky.  :-)
16:12:09 <e0ne> :)
16:12:16 <smcginnis> 7 hours left if anyone wants to challenge jungleboyj. ;)
16:12:24 <jungleboyj> :-)
16:12:40 <jungleboyj> Ok, that was all I had for announcements.
16:12:54 <jungleboyj> Next topic.
16:13:08 <jungleboyj> #topic Volume HostAPI
16:13:19 <e0ne> a special to whom loves to delete a code
16:13:22 <jungleboyj> e0ne:  ?
16:13:40 <e0ne> we've got this API introduced in 2012
16:14:05 <e0ne> but it still doesn't work
16:14:35 <e0ne> jgriffith: are you around?
16:14:40 <jungleboyj> #link https://review.openstack.org/#/c/16001/
16:14:41 <jgriffith> aye
16:14:41 <patchbot> patch 16001 - cinder - Add hosts extension to Cinder. (MERGED)
16:15:03 <smcginnis> So we either need to fix it or remove it. But not sure now with MV contraints.
16:15:12 <smcginnis> Is that an extension?
16:15:15 <e0ne> jgriffith: I think, you aren't going to fix this
16:15:17 <jgriffith> it is
16:15:22 <e0ne> smcginnis: yes, it is
16:15:33 <tommylikehu> oh
16:15:40 <jgriffith> e0ne: haha; Actually I did propose a fix but it was "denied" IIRC
16:15:49 <e0ne> I thinks we can safely deprecate it and remove in Rocky
16:15:57 <smcginnis> jgriffith: Did you forget a period in a log.debug?
16:15:57 <jgriffith> e0ne: we had a bit of a back and forth about "cinder-manage" vs putting this in Cinder
16:16:04 <Swanson> hi
16:16:08 <jgriffith> smcginnis: probably :)
16:16:08 <eharney> if it doesn't work, i'm not sure microversions are too important?  (what do we mean by it doesn't work?)
16:16:10 <e0ne> jgriffith: oh..
16:16:29 <smcginnis> If it's an extension and it has never worked, yeah, let's deprecate and remove it.
16:16:36 <e0ne> smcginnis: +1
16:16:48 <jgriffith> I'm not sure about the "never worked"part
16:16:54 <jungleboyj> Oh, that is right.  We did talk about that.  I guess we forgot to resolve things.
16:17:18 <smcginnis> We could try to fix it, but I guess if we have cinder-manage functionality, I'd rather not duplicate the capability unless an operator is here saying they need it.
16:17:32 <smcginnis> jgriffith: Does it work. Or are you saying it did work at one point?
16:17:48 <jgriffith> smcginnis: dude, it was like 6 years ago I can't remember :)
16:17:55 <jgriffith> I'm looking now :)
16:18:00 <jgriffith> trying to dust off the cob webs
16:18:17 <e0ne> jgriffith: I just checked for a git log and it has NotImplemented from the begining
16:18:23 <smcginnis> jgriffith: You don't remember? What's wrong with you man!
16:18:25 <smcginnis> :)
16:18:40 <jgriffith> I know right!?!
16:18:47 <jungleboyj> Honestly, it seems like cinder-manage is not always installed by default so I don't like having to count on it being available.
16:19:04 <e0ne> https://github.com/openstack/cinder/blame/master/cinder/volume/api.py#L2210
16:19:34 <e0ne> jungleboyj: good point
16:20:02 <eharney> not always installed?  huh?
16:20:24 <jgriffith> eharney: I think he means may not be running on a control node
16:20:26 <jungleboyj> eharney:  Yeah, on the RHOSP install we ahve it isn't there.
16:20:27 <jgriffith> or something like that
16:20:45 <jungleboyj> jgriffith:  Right.
16:21:10 <jgriffith> "They/User" may not be on the control node that is
16:22:14 <jgriffith> anyway... e0ne it doesn't appear that there's anything in the client for it; and to your point I'm not sure it's even being called anywhere (still looking to verify)
16:22:38 <jgriffith> if it's not then I think it's fine if we want to mark it deprecated and remove it
16:22:51 <jgriffith> if it's valuable to have something we can start over and move it out of contrib
16:23:15 <smcginnis> +1 for moving it out of contrib if needed.
16:23:23 <jungleboyj> smcginnis:  ++
16:23:23 <e0ne> jgriffith: I didn' find anything in the cinderclient
16:23:25 <smcginnis> We've wanted to get rid of those anyway.
16:24:01 <jgriffith> e0ne: affirmative, there's nothing there
16:24:06 <jungleboyj> So, is the purpose of this to be able to get more detailed information on a host than you can get from service-list?
16:24:43 <jgriffith> e0ne: jungleboyj looks like dead code
16:26:17 <jgriffith> Like I said; I seem to recall that when I was implementing the client side of this (or finishing it up) that there was some debate around it.  Which I think was my fault because I also seem to recall that at the time I deprecated the cinder-manage equivalents
16:26:31 <jgriffith> So knowing me; I probably got distracted and just never did *anything* after that
16:27:11 <jgriffith> So we can deprecate/remove and re-raise the discussion more formally with a spec and bp as to whether we want to add something or not; seem reasonable?
16:27:30 <smcginnis> Sounds reasonable.
16:27:44 <e0ne> +1
16:27:46 <smcginnis> And believable.
16:27:47 <jgriffith> smcginnis: Well in that case; let me propose something different
16:27:47 <jgriffith> :)
16:27:52 <smcginnis> :P
16:27:58 <jungleboyj> :-)
16:27:59 <jgriffith> Can't be accused of being *reasonable* :)
16:28:14 <smcginnis> Hah
16:28:20 <jgriffith> Oh, wait... the proposal was reasonable; not "I" was reasonable :)
16:28:23 <jgriffith> ok, we're good
16:28:25 <jungleboyj> e0ne:  Do you want to put this on the PTG discussion?
16:29:05 <e0ne> jungleboyj: I have nothing to add. deprecation and removal is OK for me
16:29:46 <smcginnis> Let's do it.
16:29:59 <smcginnis> Folks can always comment in the patch if there is a reason not to proceed.
16:30:01 <jungleboyj> e0ne:  Ok, so if anyone is interested in re-raising it they can.
16:30:07 <e0ne> smcginnis: in Queens or in Rocky?
16:30:24 <smcginnis> e0ne: I would say if you can get this up right away, let's get it in Queens.
16:30:35 <smcginnis> We can always undo the deprecation in Rocky if we find a reason to not do it.
16:30:36 <jungleboyj> smcginnis:  Loves to remove code.
16:30:41 <smcginnis> Yes indeed.
16:30:54 <e0ne> I can propose a patch later tonight. in ~2-3 hours
16:31:44 <smcginnis> e0ne: We might be cutting it close, but if we can't get it in queens, at least it will be ready in Rocky.
16:31:59 <jgriffith> e0ne: I already started it if you want
16:32:08 <smcginnis> Oh, there you go.
16:32:10 <jgriffith> I'll ping you in main Cinder channel later
16:32:17 <jungleboyj> Ok.  Sounds good.
16:32:20 <e0ne> jgriffith: great, thanks!
16:32:43 <jungleboyj> Ok, so I think we are done with that.
16:32:52 <jungleboyj> We don't have any other agenda items today.
16:32:54 <jgriffith> I'm assuming just add the versionutils.repord_deprecated_feature stanza on each method in the api
16:33:02 <jungleboyj> #topic Open Discussion
16:33:28 <smcginnis> jgriffith: Sounds reasonable. What's wrong with you today?
16:33:36 <e0ne> jgriffith: I think  so, just need to head off right after the meeting
16:33:45 <e0ne> smcginnis: :)
16:34:07 <jungleboyj> Anything else that people want to discuss today?
16:34:35 <jgriffith> e0ne: I'll ping you when the patch is up and you can add to it or give me a -2 :)
16:34:35 <jungleboyj> #topic Cinder Outing in Dublin
16:34:55 <jungleboyj> So, I am assuming that people would be interested in doing an outing like we have done in the past?
16:35:01 <Swanson> Who are we outing in dublin? Dish!
16:35:02 <e0ne> jgriffith: :)
16:35:42 * jungleboyj in a saucy voice ... Well, I have been meaning ....
16:36:08 <smcginnis> Swanson: Did you hear about the center module landing? It wa a smash.
16:36:19 <smcginnis> *was
16:36:28 <Swanson> #justiceforcentercore
16:36:41 <tommylikehu> outing? when?
16:37:21 <jungleboyj> Anyway, so I will look into planning something.
16:37:42 <jungleboyj> Look for a pub where we can get reservations somewhere near the Convention Center.
16:37:49 <jungleboyj> I was thinking that Thursday would be good.
16:37:54 <smcginnis> I'm sure we'll have a few options.
16:37:56 <jungleboyj> Does anyone know that won't work for them?>
16:38:34 <smcginnis> ++
16:39:09 <jungleboyj> Cool.  I am going to add to the etherpad we are planning for Thursday.
16:39:39 <jungleboyj> I am getting to town early so I can scout and get reservations.  Please add your name to the list if you are interested in going so I know how many people to plan for please.
16:40:03 <jungleboyj> #action Everyone to indicate interest in joining Cinder Team Outing in Dublin.
16:40:22 <smcginnis> jungleboyj: How do you want us to indicate that interest?
16:40:31 <smcginnis> Oh, nevermin.
16:40:32 <tommylikehu> lol
16:40:33 <jungleboyj> I will put a list in the etherpad.
16:40:33 <smcginnis> d
16:41:14 <ildikov> smcginnis: I think you can send smoke signs too :)
16:41:29 <smcginnis> ildikov: Ah, good plan. ;)
16:41:35 <jungleboyj> Send me a Valentine.
16:41:51 <smcginnis> I was going to do that anyway jungleboyj/
16:42:06 <jungleboyj> smcginnis:  Awwwww.  *Warm fuzzies*
16:42:18 <jungleboyj> Ok.  Anything else for today?
16:42:53 <smcginnis> Nope
16:43:05 <e0ne> jungleboyj: I hope be there. I'm still waiting for visa:(
16:43:18 <jungleboyj> e0ne:  Get that figured out man!  ;-)
16:43:27 <smcginnis> e0ne: Wow, didn't think it would be that hard to get a visa. Just taking a long time?
16:43:55 <e0ne> smcginnis: it takes few weeks. I hope to get it tomorrow
16:44:00 <jungleboyj> smcginnis:  Yeah, my co-worker from India has been having issues as well.
16:44:39 <e0ne> smcginnis: the hardest part was to get budget approval from my manager
16:44:39 <smcginnis> e0ne: I hope it goes through.
16:45:18 * jungleboyj will keep my fingers crossed for e0ne
16:45:30 <e0ne> smcginnis, jungleboyj: thanks
16:45:33 <jungleboyj> If not, I we will have hemna doing the video stream.
16:46:27 <jungleboyj> Ok.  I am going to call it a meeting.
16:46:33 <e0ne> jungleboyj, hemna : please, do not do stream form pub
16:46:39 <Swanson> The Ed Wood of conference video streaming.
16:46:46 <jungleboyj> e0ne:  Why not!?!
16:47:23 <jungleboyj> Thanks team.  Look forward to seeing you all in Dublin.
16:47:28 <smcginnis> o/
16:47:31 <jungleboyj> #endmeeting