16:00:01 <jungleboyj> #startmeeting cinder
16:00:02 <openstack> Meeting started Wed Mar 14 16:00:01 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'cinder'
16:00:10 <jungleboyj> courtesy ping:  jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlontpsilva patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro lpetrut
16:00:19 <Swanson> Hello.
16:00:24 <jungleboyj> @!
16:00:24 <_pewp_> jungleboyj ( ・_・)ノ
16:00:28 <eharney> hi
16:00:35 <tbarron> hey
16:00:36 <tommylikehu> hi
16:00:42 <walshh> hi
16:00:42 <jungleboyj> @!b
16:00:43 <_pewp_> jungleboyj (╯°□°)╯︵ ┻━┻ ︵ ╯(°□° ╯)
16:00:54 <jungleboyj> walshh:  Welcome!
16:01:05 <jungleboyj> Has the snow melted yet?
16:01:29 <walshh> yes it has, back to 10 celsius again
16:01:32 <e0ne> hi
16:01:38 * jungleboyj shakes my head
16:01:53 <jungleboyj> Certainly timed that wrong.
16:02:01 <xyang> hi
16:02:01 <DuncanT> jungleboyj: Still a few traces around Dublin airport yesterday
16:02:01 <abishop> o/
16:02:02 <geguileo> hi o/
16:02:35 <amito> hello o/
16:02:35 <jungleboyj> DuncanT:  Interesting.  Still knee deep in my front yard here.  Should get some melting this week though.
16:02:36 <walshh> We may have more for St. Patricks day!!!!
16:02:53 <jungleboyj> walshh: Well, the bars better stock up on beer and food then.
16:03:16 <jungleboyj> Ok, looks like we have a decent number here.  Lets get started.
16:03:31 <jungleboyj> #topic announcements
16:03:50 <jungleboyj> So, I have started targeting patches as we discussed at the PTG.
16:04:09 <jungleboyj> I am using the format 'target-rocky-<milestone number>'
16:04:19 <smcginnis> o/
16:04:29 <jungleboyj> If you have a patch you are submitting that you feel should be targetted, please add it.
16:04:34 * jungleboyj marks smcginnis tardy
16:04:48 <jungleboyj> Core reviewers, please add the tag where appropriate.
16:05:13 <jungleboyj> You can then search for target-rocky- comments and get a start on review priorities.
16:05:35 <jungleboyj> I have also added notes to our 'Contributor Guide' on how to use the tag.  I think that patch merged.
16:06:07 <jungleboyj> No, it didn't.  Need review.  https://review.openstack.org/#/c/552094/
16:06:28 <jungleboyj> #link https://review.openstack.org/#/c/552094/
16:06:55 <DuncanT> https://review.openstack.org/#/q/project:openstack/cinder+status:open+comment:target-rocky-
16:07:01 <jungleboyj> Next announcement is that we have started our move to Storyboard ... in a small way.
16:07:13 <jungleboyj> A test migration for os-brick has been run:
16:07:22 <jungleboyj> #link https://storyboard-dev.openstack.org/#!/project_group/23
16:07:44 <amito> ouch, self-signed cert?
16:07:54 <eharney> will the official location of os-brick when it's done for real be "/23"?
16:08:14 <jungleboyj> I haven't looked through the full result and how it maps from Launchpad to Storyboard but I would encourage everyone to take a look at that result and make sure it looks good.
16:08:30 <jungleboyj> It is also a place for us to start familiarizing ourselves with it.
16:08:48 <jungleboyj> amito:  This is just a development location that infra was nice enough to set up for us.  Not the final location.
16:08:57 <jungleboyj> eharney:  I am not sure about that.
16:09:09 <smcginnis> I think it may change when imported into the official instance.
16:09:18 <jungleboyj> smcginnis:  That is my thought too.
16:10:07 <jungleboyj> smcginnis:  Actually no, other ones that are out in storyboard.openstack.org use that format:  https://storyboard.openstack.org/#!/project_group/73
16:10:11 <jungleboyj> :-(
16:10:24 <geguileo> that's quite bad  :-(
16:10:33 <jungleboyj> Suppose we could open an item on that and see if it can be fixed?
16:10:53 <jungleboyj> diablo_rojo:  diablo_rojo_phon ^^^
16:11:24 <eharney> yeah, having random numbers in the url instead of a name is terrible
16:11:42 <jungleboyj> I will follow up on that question.
16:11:50 <e0ne> eharney: +1
16:12:24 <eharney> will this handle bugs that span multiple projects?
16:12:35 <jungleboyj> eharney:  Yes.
16:12:45 <jungleboyj> smcginnis:  Was asking about that yesterday I believe.
16:13:01 <smcginnis> Why is our number bad?
16:13:37 <jungleboyj> smcginnis:  I think the comment is more that it is numerical.  You can't do storyboard.openstack.org/cinder
16:14:02 <smcginnis> Could probably request aliases, but that's just how storyboard works. Each group has a number.
16:14:04 <Swanson> Odd
16:14:18 <eharney> yeah... odd
16:14:28 <smcginnis> Swanson: Could see if /24 is taken. Then it would be even. :P
16:14:32 <jungleboyj> @!h
16:14:33 <_pewp_> jungleboyj (/ .□.) ︵╰(゜Д゜)╯︵ /(.□. )
16:14:49 * jungleboyj hates odd numbers
16:15:17 <smcginnis> At least it's a prime.
16:15:30 <Swanson> smcginnis, If /24 isn't taken up my a dummy Kiefer Sutherland page I don't know what you're doing.
16:15:42 <smcginnis> Hah
16:16:04 <jungleboyj> So, please take a look at the os-brick migration.  If there are questions or concerns please raise them so we can't make an informed decision about moving os-brick in the next few weeks.
16:16:11 <jungleboyj> :-)  / 24 ...
16:16:23 <eharney> i think the import didn't work right with large blocks of text
16:16:30 <eharney> compare https://storyboard-dev.openstack.org/#!/story/1754303 to launchpad
16:16:36 * jungleboyj pictures Keifer riding our Cinder horse.
16:16:58 <eharney> it's missing line breaks and therefore unreadable?
16:17:26 <jungleboyj> Yeah, that isn't good.
16:17:28 <smcginnis> Oh yeah, that's not good.
16:17:43 <eharney> at least part of it is... in bold
16:17:52 <eharney> i guess **kwargs got markdown'd
16:18:03 <jungleboyj> We should open a story for that.
16:18:24 <persia> Yes.  LP interprets things as text by default, Storyboard interprets things as markdown by default.  The importer could presumably block things, if that seems better.
16:18:32 <jungleboyj> #action jungleboyj to open a story to address missing newlines in stories migrated.
16:18:46 <jungleboyj> Hi persia ...
16:19:17 <jungleboyj> persia:  Can it fix the missing newlines in traceback output, etc?
16:20:01 <persia> jungleboyj: Theoretically, it can do anything.  Creating a parser that comprehends tracebacks and does the right markdown thing may be a challenge.
16:20:20 <jungleboyj> :-)
16:20:20 <eharney> are all new bug reports going to be written in markdown?
16:20:40 <geguileo> that will be problematic for sure
16:20:44 <eharney> er, "story" reports?
16:20:50 <geguileo> lol
16:21:05 <jungleboyj> Ok, so we should get a story opened for this as when it comes to migrating Cinder, Nova, etc.  That is going to be an issue.
16:21:24 <eharney> migration is not that hard, you can just shove all imported fields into a markdown plain-text block etc...
16:21:26 <jungleboyj> story == bug ??? novel
16:21:36 <eharney> but what happens for people filing bug reports expecting it to be plain text like every other bug tracker?
16:22:00 <persia> eharney: There is a "preview" button during story creation that may help with that, but yeah, it is a transition.
16:22:23 <smcginnis> Yeah, seems like a good idea that maybe wasn't fully thought through for implications.
16:23:32 <jungleboyj> :-\
16:23:45 <jungleboyj> So, I don't want to get wrapped around the axel on this today.
16:23:58 <geguileo> Is there no way to set the default to text instead of markdown?
16:24:10 <persia> jungleboyj: If you create stories about problems with migration, please add the "blocking-storyboard-migration" tag to make them easy to find.
16:24:21 <jungleboyj> I will get a bug opened.  Please take a look at what is out there and put together concerns and we can raise them to the storyboard team.
16:24:26 <jungleboyj> persia:  Cool.  Will do.
16:25:13 <SotK> https://review.openstack.org/#/c/548342/ at least fixes the "missing newlines" part :)
16:25:44 <jungleboyj> SotK:  Oh, so that has been resolved?
16:26:27 <SotK> somewhat yes
16:26:33 <jungleboyj> I will have diablo_rojo or fungi  Rerun the os-brick test migration after that has merged then.
16:26:35 <eharney> the imports will still be a mess due to ** being translated to bold
16:26:53 <SotK> that patch at least makes pasted logs mostly readable, but as eharney says there are other issues it doesn't address
16:27:11 <jungleboyj> Ok.
16:27:24 <DuncanT> JIRA does non-standard markdown parsing, and it's a giant pain in the proverbial
16:27:25 <SotK> jungleboyj: you won't need to re-run the migration, the text is rendered by the webclient when its viewed
16:27:49 <jungleboyj> SotK:  Oh, interesting.  Ok.
16:27:51 <smcginnis> DuncanT: Not just their parsing. :)
16:28:18 <DuncanT> smcginnis: No, but it is one (of many) annoyances that we should possibly not copy
16:28:26 <jungleboyj> Anyway, this will be an ongoing discussion and transition.  We ahve a lot more to talk about so I would like to move on.
16:28:30 <smcginnis> DuncanT: Very true.
16:28:38 <smcginnis> jungleboyj: ++
16:28:47 <jungleboyj> #topic Rocky Priorities Review
16:28:58 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:29:19 <jungleboyj> So, this is me being more leaderly and annoying.
16:29:50 <jungleboyj> I have all the info from the PTG in our approved/specs work section here and the specs we are working on approving below.
16:30:10 <jungleboyj> Please add your reviews here as we go.
16:30:22 <jungleboyj> I don't think we are missing anything at the moment based on the reviews I ahve seen.
16:30:29 <jungleboyj> I have updated the new drivers at the bottom.
16:30:53 <jungleboyj> I have targeted them to target-rocky-2
16:31:07 <jungleboyj> The Lustre driver was removed.  They abandoned it when we talked.
16:31:43 <jungleboyj> I am going to be bringing this up weekly and asking about it, so help keep it curated please.
16:32:04 <jungleboyj> Any comments or concerns on that?
16:32:36 <jungleboyj> #topic HA development progress
16:32:44 <eharney> i suspect generic backup needs spec updates after the PTG, since it was already merged
16:33:05 <jungleboyj> geguileo:   We talked about the fact we would touch on this weekly to keep it moving along.
16:33:19 <jungleboyj> geguileo:  Any progress with HA documentation development, etc?
16:33:26 <geguileo> jungleboyj: not really  :-(
16:33:37 <geguileo> I'll try to get something started on the documentation
16:33:44 <geguileo> this week
16:34:10 <jungleboyj> geguileo:  Ok, sounds good.
16:34:25 <jungleboyj> eharney:  Good point.  Should take a look at that spec again and make sure it is still accurate.
16:34:30 <jungleboyj> e0ne:  ?
16:34:42 <eharney> it needs a lot of details added based on the discussion we had at PTG afaict
16:35:18 <e0ne> eharney, jungleboyj: I'll update both a  spec  and a patch early next week
16:35:27 <jungleboyj> Paging e0ne  ... Dr. e0ne  to openstack-meeting stat
16:35:55 <jungleboyj> #action e0ne to update the spec and associated patch(es) .
16:36:22 <jungleboyj> eharney: e0ne  Thank you.
16:36:29 <e0ne> jungleboyj: np
16:36:50 <jungleboyj> Any other comments on those general topics?
16:37:10 <jungleboyj> #topic On-boarding session in Vancouver.
16:37:19 <jungleboyj> We will be doing this again for Cinder.
16:37:28 <jungleboyj> Hope to have it co-scheduled with our project update.
16:37:48 <jungleboyj> I have asked for a double (80 minute) session as we have fully used the time in the past.
16:37:53 <jungleboyj> Will see what happens.
16:38:01 <jungleboyj> Is there anyone will/able to co-present with me?
16:38:09 <jungleboyj> *willing
16:38:42 <jungleboyj> Let me know if you are.  Just want to make people aware of this now.
16:38:44 <smcginnis> jungleboyj: So you're thinking having an update followed immediately by onboarding?
16:39:04 <jungleboyj> smcginnis:  Yeah, that is an idea we have had to try to draw more people in.
16:39:27 <smcginnis> jungleboyj: I wonder how much of an overlap there actually is between those audiences.
16:39:29 <jungleboyj> Give the project update.  You have people there and let them know what you are doing next ... onboarding.  Hope you might get a few more people to stick around.
16:39:40 <jungleboyj> smcginnis:  Good question.
16:39:48 <smcginnis> Yeah, might be a way to pick up a few extra people maybe.
16:39:58 <jungleboyj> smcginnis:  Think it is worth a try.
16:40:27 <smcginnis> jungleboyj: It at least makes it easier for you as presenter, so there's at least that. ;)
16:40:39 <jungleboyj> :-)  Until my voice dies.
16:41:14 <jungleboyj> Ok,
16:41:26 <jungleboyj> #topic forum topic proposals
16:41:38 <jungleboyj> #link https://etherpad.openstack.org/p/YVR-cinder-brainstorming
16:42:10 <jungleboyj> I have started our etherpad.  We need to official submit topics in a week or two.
16:42:22 <jungleboyj> Please add topics that might be appropriate for the forum.
16:42:39 <jungleboyj> Remembering this is a chance to interact with consumers/operators.
16:42:42 <smcginnis> That tempest one might be good to try to get QA involved and have a more general cross-project discussion.
16:42:48 <smcginnis> But still good if it's just Cinder.
16:43:21 <jungleboyj> smcginnis:  ++
16:44:00 <e0ne> smcginnis: +1
16:44:14 <jungleboyj> #action Team to add topic ideas
16:44:46 <jungleboyj> Ok, final topic.
16:44:55 <jungleboyj> #topic Policy checking conerns.
16:44:59 <jungleboyj> We have a bug:
16:45:10 <jungleboyj> #link https://bugs.launchpad.net/cinder/+bug/1714858
16:45:11 <openstack> Launchpad bug 1714858 in Cinder "Some APIs doesn't check the owner policy" [Critical,In progress] - Assigned to TommyLike (hu-husheng)
16:45:16 <jungleboyj> and a proposed patch
16:45:25 <jungleboyj> #link https://review.openstack.org/#/c/548650/
16:45:58 <jungleboyj> eharney:  Has concerns about the security aspect of this bug and the fact that no one really fully understands it or how to resolve it.
16:46:12 <jungleboyj> We need to address this and figure out how we move forward.
16:46:30 <jungleboyj> tommylikehu: Thoughts?
16:46:45 <tommylikehu> I think the thing that we are not sure about this is how many APIs are affected
16:46:59 <tommylikehu> and which one is really have security issue
16:47:28 <e0ne> tommylikehu: you we have a list of affected APIs now?
16:47:38 <e0ne> *do we have
16:48:06 <tommylikehu> e0ne:  all I found are in the patches
16:48:06 <tommylikehu> patch
16:49:11 <jungleboyj> Is there any way to ensure that we have found all the places where we have an issue?
16:49:13 <tommylikehu> I agree with smcginnis we can fix this progressively and maybe that's the reason eharney  pointed it out I should remove the close bug tag.
16:49:31 <jungleboyj> tommylikehu:  ++
16:49:40 <jungleboyj> I would like to start getting patches for this in.
16:49:58 <smcginnis> I'd rather see most cases fixed now, and we can watch for other instances going forwarded.
16:50:09 <jungleboyj> Make it a Partial-Bug and then continue to fix isses as we find them.
16:50:14 <jungleboyj> smcginnis:  ++
16:50:40 <eharney> fixing it progressively is maybe ok, if we know the full list of issues... but we, at some point, have to be able to write a statement of what the impact is on people who deployed this code
16:50:54 <smcginnis> jungleboyj: That sounds good. And maybe add notes to the bug that we've addressed the list of calls we found in the one patch and note that we are just not sure all cases are addressed.
16:51:25 <smcginnis> If we go a year or something without seeing any more, then we can just close the bug with a note saying we think it's addressed and new bugs will be filed if we find any more cases.
16:51:40 <tommylikehu> jungleboyj: it's more complicated than we thought as some of the API resource or part of the policy enforcement code do not need this change because they can not have owner policys.
16:51:45 <eharney> the commit message calls out an issue with reset_status but doesn't really explain what it is
16:52:58 <tommylikehu> eharney:  the issue for that one is I can reset any volume's status if the corrsponding policy has been changed into admin_or_owner
16:53:42 <jungleboyj> tommylikehu:  That is fixed with the patch?
16:53:49 <eharney> then that info needs to be provided in the bug for an ossa/ossn, even if it's a lower priority vulnerability
16:53:55 <geguileo> tommylikehu: can you really change it? won't the get method fail based on the project/user filtering on the DB?
16:54:27 <tommylikehu> geguileo:  where
16:54:39 <geguileo> tommylikehu: don't we do a get of the volume?
16:54:57 <tommylikehu> jungleboyj:  I guess so.
16:55:14 * jungleboyj would like a more confident response.
16:55:23 <jungleboyj> That seems like a problem that we need to get fixed.
16:55:52 <jungleboyj> Confidently.
16:56:30 <eharney> so, we're now at about two weeks of a public security bug report for this
16:56:51 <eharney> we need to really close in on describing the problem adequately at least
16:57:23 <jungleboyj> eharney:  ++
16:57:34 <jungleboyj> We only have 3 minutes left here.
16:57:43 <jungleboyj> Can we at least agree on a plan going forward in that time?
16:58:24 <jungleboyj> I agree with getting the patch that is out there merged with it marked as 'Partial-Bug;.
16:58:30 <tommylikehu> I should update the commit message and the bug fix tag before going forward?
16:58:37 <tommylikehu> ok
16:58:48 <jungleboyj> tommylikehu:  Yes.
16:58:53 <eharney> what about the whole claim that some issues predated the changes in queens?  i'm not sure if we should merge the current patch without understanding that part too
16:59:01 <jungleboyj> I also think we need to be confident that the reset status problem is fixed.
16:59:10 <eharney> and that it's the only one...
17:00:01 <eharney> snapshot reset state didn't have a similar issue?
17:00:24 <jungleboyj> We are out of time.  Lets take this over to the Cinder channel while we have tommylikehu
17:00:37 <tommylikehu> ok
17:00:37 <jungleboyj> Thanks everyone for a good meeting and for your work on Cinder!
17:00:43 <jungleboyj> #endmeeting