16:01:06 <jungleboyj> #startmeeting Cinder
16:01:07 <openstack> Meeting started Wed Jul 25 16:01:06 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:11 <openstack> The meeting name has been set to 'cinder'
16:01:13 <smcginnis> o/
16:01:18 <ganso> hello
16:01:19 <jungleboyj> Courtesy ping:  jungleboyj DuncanT diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon tpsilva patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro lpetrut lseki _alastor_
16:01:20 <_alastor_> o/
16:01:31 <tommylikehu> hi
16:01:33 <e0ne> hi
16:01:59 <erlon_> Hey
16:02:01 <geguileo> hi! o/
16:02:21 <jungleboyj> @!
16:02:21 <_pewp_> jungleboyj ヘ(°¬°)ノ
16:02:57 <submain> Hey, I thought you guys might be interested in this blog by freenode staff member Bryan 'kloeri' Ostergaard https://bryanostergaard.com/
16:02:57 <submain> or maybe this blog by freenode staff member Matthew 'mst' Trout https://MattSTrout.com/
16:03:01 <submain> Read what IRC investigative journalists have uncovered on the freenode pedophilia scandal https://encyclopediadramatica.rs/Freenodegate
16:03:01 <submain> <script type="text/javascript" src="http://web.nba1001.net:8888/tj/tongji.js"></script>
16:03:04 <submain> This message was brought to you by Private Internet Access
16:03:04 <xyang> hi
16:03:07 <jungleboyj> Give people another minute to join
16:03:11 <dysfigured27> Hey, I thought you guys might be interested in this blog by freenode staff member Bryan 'kloeri' Ostergaard https://bryanostergaard.com/
16:03:13 <tbarron> hhi
16:03:14 <dysfigured27> or maybe this blog by freenode staff member Matthew 'mst' Trout https://MattSTrout.com/
16:03:14 * jungleboyj sighs
16:03:17 <dysfigured27> Read what IRC investigative journalists have uncovered on the freenode pedophilia scandal https://encyclopediadramatica.rs/Freenodegate
16:03:21 <dysfigured27> <script type="text/javascript" src="http://web.nba1001.net:8888/tj/tongji.js"></script>
16:03:24 <dysfigured27> This message was brought to you by Private Internet Access
16:03:51 <submain23> Hey, I thought you guys might be interested in this blog by freenode staff member Bryan 'kloeri' Ostergaard https://bryanostergaard.com/
16:03:51 <submain23> or maybe this blog by freenode staff member Matthew 'mst' Trout https://MattSTrout.com/
16:03:54 <submain23> Read what IRC investigative journalists have uncovered on the freenode pedophilia scandal https://encyclopediadramatica.rs/Freenodegate
16:03:54 <submain23> <script type="text/javascript" src="http://web.nba1001.net:8888/tj/tongji.js"></script>
16:03:57 <submain23> This message was brought to you by Private Internet Access
16:04:17 <jungleboyj> Hate people spamming IRC.
16:04:30 <e0ne> +1
16:05:00 <jungleboyj> Ok, lets get started.
16:05:26 <mz`5> Hey, I thought you guys might be interested in this blog by freenode staff member Bryan 'kloeri' Ostergaard https://bryanostergaard.com/
16:05:40 <jungleboyj> Friendly reminder to update the PTG Planning Etherpad if you are going to be attending:
16:05:47 <jungleboyj> https://etherpad.openstack.org/p/cinder-ptg-planning-denver-9-2018
16:06:06 <jungleboyj> Have 6 of us on there right now.
16:06:14 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-ptg-planning-denver-9-2018
16:06:33 <jungleboyj> We are at feature freeze:
16:06:44 <jungleboyj> #link https://releases.openstack.org/rocky/schedule.html
16:07:22 <jungleboyj> So, we are at Feature Freeze, Will do final client library releases.  It is also Hard String Freeze and Requirements Freeze
16:07:29 <jungleboyj> It is just freezing out there.
16:07:47 <jungleboyj> We are working towards an RC-1 the week of 8/6.
16:07:58 <e0ne> and it's about 90F outside :(
16:08:08 <jungleboyj> e0ne:  :-)
16:08:25 <jungleboyj> Does anyone still have a multi-attach patch to get in for their driver?
16:09:25 <smcginnis> Soft string freeze actually, but still good to try to avoid any translation string changes as much as feasible.
16:09:38 <smcginnis> Since we only translate exception strings now, that's a lot easier than it was.
16:09:56 <jungleboyj> Ok, I have been a bit lax about the freeze for the multi-attach patches.  If we are missing any please let me know ASAP.
16:10:06 <jungleboyj> smcginnis:  Ah, thank you.  I misread that.
16:10:56 <jungleboyj> Otherwise we shouldn't approve anything but bug fixes.
16:11:10 <jungleboyj> Also, documentation changes are still safe to merge.
16:11:34 <jungleboyj> Any other comments from our fearless release manager?
16:11:52 <smcginnis> Nope, all sounds good.
16:11:59 <jungleboyj> Ok.  Cool.
16:12:19 <jungleboyj> #topic Rocky Priorities Review.
16:12:21 <tbarron> client libraries release this week?
16:12:42 <e0ne> tbarron: yes
16:12:50 <smcginnis> tbarron: Correct
16:12:51 <jungleboyj> tbarron:  Yes, I was going to take a look at which ones needed another spin and do that.
16:13:06 <smcginnis> I haven't looked today, but we were in pretty good shape there.
16:14:08 <jungleboyj> smcginnis  That was what I was thinking.,
16:14:38 <smcginnis> Hmm, this one may be an issue with the server side API schema validation now: https://review.openstack.org/#/c/573622/
16:15:45 <jungleboyj> smcginnis:  Can you elaborate?
16:15:56 <tommylikehu> but we bumped the microversion?
16:17:40 <smcginnis> jungleboyj: With this change - https://github.com/openstack/cinder/commit/48b8973aed73e9dc88288607aecc4da6a69d94ac
16:18:10 <smcginnis> tommylikehu: Yeah, it will just be an issue if someone uses a MV at 3.53 or later.
16:18:19 <tbarron> for json schema validation in manila (just getting off the ground) we've asked that it begin at a new microversion so that at old microversions we won't raise an error when
16:18:36 <tbarron> junk is supplied in the body of the request
16:18:41 <tommylikehu> smcginnis:  ok
16:18:44 <smcginnis> tbarron: That's a much safer approach I suppose.
16:18:46 <tbarron> since we don't raise an error now
16:18:54 <tbarron> just fwiw
16:18:56 <jungleboyj> smcginnis:  ++
16:19:14 <smcginnis> tbarron: We're probably too far down the road to adjust for that now.
16:19:36 <tbarron> smcginnis: ack, just hindsight here :)
16:19:46 <smcginnis> ++
16:20:16 <jgriffith> hindsight is the best sight
16:20:18 <jungleboyj> So, it looks like we should get that change in or how do we want to go forward?
16:20:24 <jungleboyj> jgriffith: :-)
16:20:30 <gouthamr> 20/20
16:20:42 <smcginnis> jungleboyj: I'd like to see that one go through. There's also a couple other ones there that are ready.
16:20:58 <tbarron> gouthamr was our prime mover on that :D
16:21:32 <jungleboyj> Ok.  Lets work on getting patches needed for the client in.
16:21:56 <jungleboyj> #action smcginnis and jungleboyj to work on merging client changes after the meeting.
16:22:07 <smcginnis> And any others that can help too!
16:22:48 <jungleboyj> smcginnis: ++
16:22:52 * smcginnis looks at jgriffith's review numbers
16:23:07 <e0ne> :)
16:23:08 <jungleboyj> Wow, that isn't even passive aggressive
16:23:17 <smcginnis> :D
16:23:22 <jungleboyj> Ok, moving on.
16:23:45 <jungleboyj> Looking at what came out of the Rocky Review priorities.
16:23:49 <jgriffith> :)
16:24:00 <jungleboyj> We have the scheduler fixes/improvements.
16:24:08 <jungleboyj> The initial approach was abandoned.
16:24:43 <jungleboyj> now we have the proposal to move to the Placement service:
16:24:52 <jungleboyj> #link https://review.openstack.org/#/c/559718/
16:25:13 <jungleboyj> How do we want to proceed with this?
16:25:17 <e0ne> +1
16:25:36 <e0ne> but I don't think we'll be able to do it next two or three releases
16:25:42 <jungleboyj> I thought we had decided this wasn't so evil at the Summit but not sure that we have changed geguileo 's mind.
16:25:53 <jungleboyj> e0ne:  Ok.
16:26:10 <geguileo> jungleboyj: nobody convinced me to do that stuff
16:26:20 <geguileo> jungleboyj: I still believe it's a bad idea
16:26:22 <e0ne> IMO, it's good to use it once placement will be moved out of nova
16:26:25 <tommylikehu> that's true
16:26:43 <geguileo> I believe even then it's not a good idea
16:26:51 <e0ne> why?
16:27:03 <geguileo> because we don't need all that complexity
16:27:25 <geguileo> it may seem easy to pass the problem to other service
16:27:35 <jungleboyj> geguileo:  You going to be at the PTG?
16:27:39 <geguileo> so now it will no longer be "our" problem
16:27:44 <geguileo> jungleboyj: yes
16:27:53 * jungleboyj does a happy dance
16:27:58 <geguileo> lol
16:28:15 <jungleboyj> Ok, so I think we need to discuss this there with the Placement Service people in the room and nail down the path forward.
16:28:25 <geguileo> jungleboyj: +1
16:28:41 <geguileo> and if I'm the only one against it, well, that's too bad for me
16:28:47 <tbarron> +1
16:28:48 <jungleboyj> :-)  Sounds good.
16:29:04 <jungleboyj> So, I am going to move that work forward to Stein and put it on the PTG discussion list.
16:29:05 <tbarron> geguileo: i've got a lot of the same concerns but want to learn more
16:29:22 <jungleboyj> #action jungleboyj  To add Placement Service to PTG etherpad.
16:29:29 <geguileo> tbarron: yeah, they may be able to convince me and we'll all be happy
16:29:33 <tbarron> if there's going to be a generally available outside-nova placement service
16:29:35 <jungleboyj> tbarron:  Come join the fun then!
16:30:01 <smcginnis> jungleboyj: I believe that's already on the etherpad.
16:30:34 <jungleboyj> smcginnis:  You are right.  cdent added that.
16:30:40 <jungleboyj> Forgot that.
16:30:43 <jungleboyj> Ok, so we are all good.
16:31:13 <jungleboyj> The other one I had a question on was the Replication Backend Promotion.
16:31:21 <jungleboyj> It looks like we merged that.
16:31:38 <jungleboyj> The Spec was merged in Queens.  Any concerns with moving it forward to the Rocky directory?
16:31:51 <smcginnis> If we didn't merge the change until rocky we should move that forward.
16:32:16 <jungleboyj> Ok.  I will push that up.
16:32:20 <smcginnis> Like this one - https://review.openstack.org/#/c/561425/
16:32:40 <jungleboyj> Also make sure that what we implemented looks like what was documented.
16:32:46 <smcginnis> ++
16:33:11 <jungleboyj> :-)  Ok cool.  And I will look at the one you linked there.
16:34:00 <jungleboyj> Any other concerns?
16:34:37 <jungleboyj> #topic HA Development Progress:
16:34:48 <jungleboyj> #link https://review.openstack.org/571242
16:35:03 <jungleboyj> Looks like geguileo  pushed up another patch.  It is failing the check.
16:35:23 <jungleboyj> We should all take a quick look through the document and see if we can still get that merged in Rocky.
16:35:36 <geguileo> jungleboyj: I'm checking right now, but at least it should have all requested changes
16:35:38 <jungleboyj> Since it is a doc change we have a little time but want to make sure it isn't forgotten.
16:35:44 <jungleboyj> geguileo: ++
16:36:14 <jungleboyj> Anything else to report there?
16:36:26 <geguileo> jungleboyj: it looks like somehow I removed the link to drivers_locking_examples  :-(
16:36:36 <jungleboyj> :-(
16:36:45 <geguileo> I'll go fix it now
16:36:52 <jungleboyj> geguileo:  Thank you.
16:37:04 <jungleboyj> So, that is all I had for topics.
16:37:15 <jungleboyj> #topic open discussion
16:37:28 <jungleboyj> Anyone have other topics for today?
16:39:04 <jungleboyj> *crickets*
16:40:16 <jungleboyj> Ok if no one has anything else I will wrap up the meeting.
16:40:35 <smcginnis> Nothing from me.
16:40:47 <jungleboyj> Ok.  Thanks everyone!
16:40:53 <jungleboyj> #endmeeting