16:00:48 <jungleboyj> #startmeeting Cinder
16:00:48 <openstack> Meeting started Wed Sep  5 16:00:48 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:52 <openstack> The meeting name has been set to 'cinder'
16:01:15 <e0ne> hi
16:01:15 <smcginnis> o/
16:01:17 <ganso> hello
16:01:22 <geguileo> hi! o/
16:01:57 <jungleboyj> I just realized that I had been kicked out of channels for a couple days now.
16:02:03 <erlon> hey
16:02:05 <jungleboyj> Yikes.
16:02:20 <smcginnis> jungleboyj: Welcome back. ;)
16:02:28 <woojay> Morning.
16:02:56 <jungleboyj> Thanks.  Desk is set up and I am trying to get settled in.
16:03:42 <jungleboyj> Ok.  Lets get started.
16:03:49 <jungleboyj> #topic announcements
16:03:59 <jungleboyj> Not a lot to announce.
16:04:28 <jungleboyj> The usual note about the PTG planning etherpad:  https://etherpad.openstack.org/p/cinder-ptg-planning-denver-9-2018
16:04:58 <gouthamr> o/
16:05:21 <jungleboyj> Have a good list of topics there.  I will work tomorrow on trying to schedule times for the discussion.
16:06:13 <smcginnis> Really good list.
16:06:19 <jungleboyj> Should the Placement discussion be during the Nova cross project discussion or just something for Cinder and we pull cdent jaypipes and efried in?
16:06:48 <smcginnis> If we can fit it in before the cross project session, and those folks are available, that might be useful.
16:06:48 <e0ne> smcginnis: +1
16:07:03 <erlon> jungleboyj, I thought we should do a pre discussion before
16:07:15 <efried> for sake of our schedules, might be better during cross-project
16:07:23 <efried> is there a consideration of doing it M/T?
16:07:44 <jungleboyj> M/T ?
16:07:49 <efried> Monday or Tuesday
16:07:58 <efried> as opposed to when you know the Nova folks are going to be glued to the Nova room.
16:08:00 <jungleboyj> efried:  Oh.  :-)
16:08:03 <geguileo> erlon: a pre discussion would be good, to see what we think the benefits are or could be in the future
16:08:08 <erlon> It would be good to  line up things before putting it to a more broad audience
16:08:19 <smcginnis> ++
16:08:56 <jungleboyj> geguileo: erlon  Yeah, we definitely want to have it as a Cinder only discussion for some period of time.
16:09:28 <smcginnis> Are folks around Tuesday that we could try to pull something together before the project vertical stuff starts?
16:09:50 <geguileo> I'll be around
16:10:01 <jungleboyj> smcginnis:  I will be around.
16:10:10 <jungleboyj> geguileo: and e0ne ?
16:10:23 <erlon> smcginnis, from the list of attendees, most people will be since from Monday
16:10:28 <e0ne> Monday will be better for me
16:10:29 <jungleboyj> Looks like it.
16:10:51 <e0ne> I'll have a lot of horizon-specific things on Tuesday
16:11:12 <smcginnis> erlon: Yeah, the question is if they will actually be available. Monday is already crazy for me. I can probably make Tuesday, but we can try to find a time that works best for everyone.
16:11:32 <jungleboyj> Would have to be Monday afternoon for me as I am flying in Monday morning.
16:11:35 <erlon> smcginnis, hmm, got it
16:11:36 <smcginnis> jungleboyj: Maybe get a schedule poll to see what times work the best overall for placement folks and interested Cinder folks?
16:12:00 <smcginnis> It's a crazy week. ;)
16:12:08 <efried> I know cdent is unavailable Monday
16:12:14 <jungleboyj> smcginnis:  Ok, I will put that together and send out an e-mail to the mailing list.
16:12:54 <efried> And we have a different cross-projecty thing (placement/blazar) scheduled for Tuesday at 10am
16:14:01 <jungleboyj> Does anyone have a link to how you reserve another room on Monday/Tuesday?
16:15:05 <jungleboyj> If not I will try to find it.
16:15:11 <smcginnis> Not sure how far ahead you can do that. It's through the ptgbot.
16:15:25 <jungleboyj> Oh ... Wah Wah Wah.
16:15:33 <smcginnis> jungleboyj: https://git.openstack.org/cgit/openstack/ptgbot/tree/README.rst#n67
16:15:39 <smcginnis> Looks like maybe you can already?
16:16:26 <jungleboyj> smcginnis:  Ok, I will play with it.
16:17:34 <jungleboyj> Anything more on PTG planning?
16:18:40 <jungleboyj> Ok, moving on.
16:19:06 <jungleboyj> I assume everyone saw that Rocky was officially released.  Thank you to everyone who participated and helped make the release happen.
16:19:19 <smcginnis> \o/
16:19:25 <jungleboyj> :-)
16:19:29 <jungleboyj> @!
16:19:29 <_pewp_> jungleboyj ( *՞ਊ՞*)ノ
16:19:48 <jungleboyj> That is really all I had for today.
16:19:59 <jungleboyj> #topic Open Discussion
16:20:11 <smcginnis> Skipping some things?
16:20:25 <jungleboyj> What?
16:20:31 <geguileo> jungleboyj: mmmm I did have a couple of topics on the agenda...
16:20:33 <geguileo> lol
16:20:46 <e0ne> #link https://etherpad.openstack.org/p/cinder-stein-meeting-agendas
16:20:48 <e0ne> :)
16:20:49 <ganso> I have one too (for open discussion)
16:21:00 <jungleboyj> Oh, that is where the Agenda went.
16:21:06 <geguileo> rofl
16:21:32 <jungleboyj> I thought I had set up the Agenda at the end of the last meeting and didn't realize it got moved to a Stein etherpad.
16:21:42 <jungleboyj> Sorry, been lost in moving the last week.
16:21:43 <jungleboyj> Ok.
16:21:55 <jungleboyj> #topic Berlin Forum Sessions
16:22:29 <geguileo> Maybe we should start creating an etherpad for this and brainstorm ideas for it?
16:23:07 <jungleboyj> geguileo: Not a bad idea.
16:23:18 <jungleboyj> Perhpas a topic we can have for the PTG?
16:23:22 <jungleboyj> Start creating that.
16:23:35 <smcginnis> It's coming up quick.
16:23:51 <smcginnis> Might be nice to have something started at least so we can add things during the PTG that we know we will need to follow up on.
16:24:03 <geguileo> smcginnis: +1
16:24:10 <erlon> smcginnis, +1
16:24:19 <e0ne> smcginnis: +1
16:24:24 <jungleboyj> smcginnis:  ++
16:25:48 <jungleboyj> geguileo:  Thanks for bringing that up.  Good idea.
16:26:45 <jungleboyj> Anything else on that topic?
16:27:33 <jungleboyj> #action jungleboyj to add a reminder to the PTG etherpad to do this.
16:27:48 <jungleboyj> #topic Cinderlib functional tests at the gate
16:28:20 <geguileo> In a previous meeting: http://eavesdrop.openstack.org/meetings/cinder/2018/cinder.2018-06-06-16.00.log.html#l-273
16:28:51 <geguileo> we said people would start having a look into cinderlib and I would start looking at adding it to some of our jobs
16:28:58 <geguileo> in the least obstrussive way
16:29:12 <geguileo> non voting, and not consuming much time on the gate
16:29:19 * jungleboyj vaguely remembers that.
16:29:33 <geguileo> Yeah, it has been a while since that
16:29:35 <geguileo> XD
16:29:49 <geguileo> So I would like to bring it up on the meeting to see how people felt
16:30:08 <geguileo> The idea is that some jobs (ie: LVM and Ceph) would clone cinderlib
16:30:17 <geguileo> and run its functional tests
16:30:23 <smcginnis> Just for the record, I'm still opposed to it.
16:30:40 <geguileo> they take less than a minute to run on an already deployed system
16:30:50 <e0ne> I still doesn't understand a value of it without scheduler and manager
16:30:52 <jungleboyj> smcginnis:  To Cinderlib or to running its tests?
16:30:53 <geguileo> smcginnis: your opposition is against the idea of cinderlib or something else?
16:31:16 <e0ne> at least, volume manager does a lot of thing before ad after calling drivers
16:31:19 <smcginnis> jungleboyj: cinderlib and our making it semi-"official" by running gate tests with it.
16:31:45 <jungleboyj> Ok ...
16:31:54 <geguileo> smcginnis: so you would be against making it official then?
16:32:37 <smcginnis> Yes
16:33:13 <geguileo> then I guess that is a bigger topic, and probably better discussed during the PTG
16:33:26 <jungleboyj> geguileo: ++
16:33:33 <e0ne> geguileo: why not to try use api-scheduler-volume with in-memory queue or something else instead of rabbitmq?
16:33:45 <jungleboyj> We touched on that issue at the Forum I think but need to get all of us in the same room to discuss it sounds like.
16:33:52 <e0ne> geguileo: +1, it would be good to discuss it at the PTG
16:34:05 <geguileo> e0ne: that would mean actually running the full Cinder service
16:34:10 <e0ne> yep
16:34:26 <geguileo> e0ne: which isn't so great for other things like ansible, a CSI plugin, custom applications...
16:35:45 <jungleboyj> I have very mixed feelings about this.  Can see the benefits but also have concerns.
16:36:19 <geguileo> jungleboyj: smcginnis any chance you could air your biggest concerns now?
16:37:07 <jungleboyj> My concern is the lack of control over what other consumers could do with cinderlib.
16:37:10 <e0ne> geguileo: honestly, it doesn't use cinder. it uses only cinder drivers and few more things
16:37:24 <smcginnis> There was another meeting that wasn't linked to where we talked about this and I did. But basically I don't think cinderlib is the right approach and is exposing our driver interface and making an internal thing public.
16:37:41 <e0ne> smcginnis: +1
16:37:47 <smcginnis> And containerizing cinder is easier and safer than extracting bits and pieces.
16:39:04 <geguileo> OK, I remember that discussion and I think I presented some counter arguments, but we can discuss it more at the PTG
16:39:16 <erlon> geguileo, I think that if we could have more use cases and pratical examples would help to make it have more sense
16:39:36 <geguileo> erlon: custom applications, ansible, Ember-CSI, ovirt...
16:39:45 <erlon> my first reaction and still, is that it is something nice to have
16:40:07 <erlon> but, I still couldnt thing in the real scenarios
16:40:17 <jungleboyj> erlon:  ++
16:40:51 <jungleboyj> #chari smcginnis
16:40:56 <jungleboyj> #chair smcginnis
16:40:57 <openstack> Current chairs: jungleboyj smcginnis
16:41:03 <geguileo> I think we can leave the topic until the PTG
16:41:13 <jungleboyj> Just had some people show up to work on the house so I will be in and out a bit.
16:41:16 <smcginnis> I've been drafted!! :D
16:41:24 <geguileo> lol
16:41:30 <jungleboyj> smcginnis:  Yep.  So I can make sure they don't drop the hot tub through the roof.
16:41:44 <jungleboyj> So, I think we are in agreement to discuss this more at the PTG?
16:41:58 <smcginnis> OK, I think we've probably gotten as far as we can today. Let's talk at the PTG.
16:42:04 <erlon> jungleboyj, +1
16:42:10 <smcginnis> geguileo: I haven't checked, but can you make sure it's on the planning etherpad?
16:42:42 <geguileo> smcginnis: it is, but I'll add as the first sub-topic this discussion
16:42:52 <smcginnis> ++
16:42:54 <smcginnis> geguileo: Thanks
16:43:02 <smcginnis> #topic Open discussion
16:43:11 <smcginnis> e0ne: Did you say you had something for now?
16:43:34 <e0ne> smcginnis: no, it was jungleboyj
16:43:38 <ganso> I have
16:43:46 <smcginnis> ganso: OK, go ahead.
16:44:04 <ganso> does everybody agree we can move forward with https://review.openstack.org/#/c/578463 and https://review.openstack.org/#/c/572188/ ?
16:45:18 <jungleboyj> geguileo:  Thanks for adding it to the etherpad.
16:45:27 <e0ne> ganso: it makes sense
16:45:29 <smcginnis> Looks like the work was done on the cinder side. Need a show of support on those other patches?
16:45:50 <ganso> yes
16:46:04 <smcginnis> ganso: What is the tempest job failure about?
16:46:18 <e0ne> ganso: this one https://review.openstack.org/#/c/578463  has -1 from CI :(
16:46:44 <ganso> cinder side is ready. We've agreed last release to enable the online extend test to be able to see which backends report that they support (by default) but they actually don't
16:46:52 <erlon> smcginnis, e0ne, I think that is something not related to the patch
16:47:18 <erlon> have rechecked it, lets see if pass
16:47:27 <ganso> e0ne: yea I may need to recheck that, possibly was a random failure
16:47:37 <erlon> logs are gone :(
16:47:48 <e0ne> erlon, smcginnis: there are no logs already :(
16:47:51 <smcginnis> I think https://review.openstack.org/#/c/572188/ probably should not happen. The only safe default is LVM, and if other backend the user can override TEMPEST_EXTEND_ATTACHED_VOLUME.
16:48:34 <ganso> smcginnis: do you think it shouldn't happen because it will break LVM?
16:48:35 <jungleboyj> smcginnis:  That makes sense.
16:48:50 <e0ne> smcginnis: good catch
16:49:04 <erlon> smcginnis, the idea there was to broadly test attached_extend support on other backends
16:49:15 <smcginnis> No, existing code it checks that it is using LVM and libvirt.
16:49:17 <erlon> which currently are not tested
16:49:48 <ganso> I am not sure I follow
16:49:54 <smcginnis> I suppose this does make third party CI automatically start testing this unless they explicitly disable the new config options, but they can also do that with TEMPEST_EXTEND_ATTACHED_VOLUME.
16:50:42 <erlon> smcginnis, yes, that is the point, if they fail the tests, they will have the ability to disable
16:50:42 <smcginnis> ganso: It already tests extend_attached if LVM is the backend and libvirt is being used.
16:50:43 <ganso> smcginnis: I'm assuming we want to start testing this automatically for 3rd party CI
16:50:58 <erlon> but currently, people not even know if that really works
16:51:24 <smcginnis> erlon: Will they know after this when third party CIs just disable the test?
16:52:07 <erlon> smcginnis, yes, the operators will have the option to just disable the test or go and fix it
16:52:32 <ganso> smcginnis: if their CI start failing after that patch lands they just have to disable the test or fix their reporting capabilities (which is the ideal fix) and all is fine
16:52:56 <jungleboyj> Seems like that is likely to just cause issues.
16:53:18 <jungleboyj> Seems like we should start by having them explicitly enable it and then re-address after we do or don't see people start enabling it.
16:53:24 <smcginnis> So if they are using devstack, they can just set TEMPEST_EXTEND_ATTACHED_VOLUME=False, but if they are just running tempest against a full deployment to test their own stack then the operator can set the config option.
16:53:24 <erlon> jungleboyj, you mean 'show issues' :)
16:53:48 <jungleboyj> erlon:  Maybe.
16:53:51 <smcginnis> Is my last summary right? ^^
16:54:03 <ganso> smcginnis: yes
16:54:16 <ganso> smcginnis: what you said is addressed here https://review.openstack.org/#/c/578463/1/tempest/config.py
16:54:35 <smcginnis> So the second patch doesn't really make any difference for third party CI, just for someone just running it themselves.
16:55:23 <ganso> smcginnis: no, it does. The test does not run automatically today
16:55:31 <ganso> smcginnis: the 2nd patch makes it run automatically
16:55:47 * ganso hopes is not confusing the 1st with the 2nd
16:56:04 <smcginnis> ganso: Actually, the second patch defaults it to false, so the first patch makes it run automatically, but then the introduction of the additional config option disables it, right?
16:56:13 <smcginnis> Maybe I have the order of patches confused.
16:56:41 <ganso> lol yea I was referring the 1st one as the tempest one that adds the config option, and the 2nd one would be the devstack one
16:57:29 <smcginnis> ganso: OK, thanks. I think I've got it now.
16:57:40 <smcginnis> * <3 minutes left
16:58:40 <smcginnis> Shouldn't https://review.openstack.org/#/c/572188/ depends-on https://review.openstack.org/#/c/578463/ ?
16:59:01 <jungleboyj> Down to 2 minutes.
16:59:16 <smcginnis> We can probably wrap.
16:59:17 <ganso> smcginnis: no, they are not handled by the same config option
16:59:24 * erlon is lost
16:59:35 <jungleboyj> smcginnis:  Are your questions answered or do we need to work this offline?
16:59:53 <ganso> smcginnis: one is "extend_attached_volume_support", which relates to the new capabilities
17:00:13 <ganso> smcginnis: the other is "extend_attached_volume" which dictates if the tests should be run
17:00:18 <ganso> so they are independent
17:00:21 <jungleboyj> And that is time.
17:00:33 <jungleboyj> Lets wrap up the discussion in the channel.
17:00:43 <jungleboyj> #endmeeting