16:00:23 <jungleboyj> #startmeeting Cinder
16:00:24 <openstack> Meeting started Wed Sep 19 16:00:23 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:28 <openstack> The meeting name has been set to 'cinder'
16:00:29 <smcginnis> o/
16:00:45 <whoami-rajat> Hi
16:01:07 <jungleboyj> @!
16:01:07 <_pewp_> jungleboyj (=゚ω゚)ノ
16:01:29 <walshh_> Hi
16:01:35 <woojay> Hello
16:02:09 <erlon> hey
16:02:16 <geguileo> hi! o/
16:03:33 <jungleboyj> Okie dokie.
16:03:40 <jungleboyj> Looks like we have a decent number of people here.
16:04:02 <jungleboyj> #topic announcements
16:04:21 <jungleboyj> So, we have the etherpad for the Berlin Forum.
16:04:32 <jungleboyj> Unfortunately I hadn't seen that one was already created by geguileo
16:04:44 <jungleboyj> geguileo:  Did you ever send your's to the mailing list?
16:04:47 <geguileo> because I didn't tell anyone  lol
16:04:58 <geguileo> jungleboyj: no I didn't
16:04:58 <jungleboyj> Ok.  Good.  So it wasn't me then.  :-)
16:05:08 <geguileo> nop, it was me
16:05:20 <geguileo> I assumed the next one would check the wiki
16:05:25 <geguileo> my bad  :-(
16:05:32 <jungleboyj> Ok, so are you ok with moving your content over to the one I created and I will update the link in the Wiki to point to the one I created?
16:05:47 <geguileo> jungleboyj: I moved the contents and updated the wiki
16:05:55 <geguileo> so we are good now
16:06:00 <jungleboyj> geguileo:  Oh sweet.  Thanks buddy!
16:06:05 <geguileo> np
16:06:55 <jungleboyj> So, please add your topics in there.  I have at least one to add based on PTG discussions.
16:07:42 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-berlin-forum-proposals
16:08:09 <jungleboyj> Also, wanted to announce that the driverfixes/ocata branch has been removed.
16:08:17 <jungleboyj> smcginnis:  Thanks for the clean-up there.
16:09:02 <jungleboyj> If you all remember we did work to get things from driverfixes/ocata to stable/ocata
16:09:24 <geguileo> smcginnis: thanks for synchronizing the branches
16:09:26 <jungleboyj> We verified that everything had been moved.
16:09:51 <jungleboyj> So, determined it was safe to remove driverfixes and avoid the chances for future confusion.
16:09:59 <smcginnis> Scripting FTW. :)
16:10:06 <jungleboyj> smcginnis:  Anything you want to add on that topic?
16:10:20 <smcginnis> I added something for later related to ocata, but that can wait.
16:10:29 <jungleboyj> Ok.  Sounds good.
16:11:02 <jungleboyj> Last announcement is that I have gotten the summary of discussions from the Stein PTG put together in our Wiki:
16:11:05 <jungleboyj> #link https://wiki.openstack.org/wiki/CinderSteinPTGSummary
16:11:27 <jungleboyj> I hope I got the action item assignments correct for everyone.
16:11:36 <jungleboyj> The video links should be correct.  :-)
16:11:49 <jungleboyj> And I recovered the lost Thursday etherpad.  Thank goodness.
16:12:15 <jungleboyj> Well, I didn't, the awesome Infra team did, but I created a new version of that etherpad with the content they recovered.
16:13:17 <jungleboyj> So, please review and let me know if there is anything I got wrong in there.
16:13:27 <erlon> jungleboyj, thanks for that Jay, helps a lot
16:13:48 <jungleboyj> erlon:  No problem.  Made yesterday a long day but I know it is helpful for everyone.
16:14:47 <jungleboyj> Last note of follow up from the PTG.  I have started reaching out to some of the Core team members that have been less active.  Watch for an e-mail to the mailing list as follow up to that.
16:15:06 <jungleboyj> So, that was all I had for announcements.
16:15:20 <jungleboyj> #topic stable/ocata maintenance mode
16:15:26 <jungleboyj> smcginnis:
16:15:54 <smcginnis> So we passed the EM date for ocata.
16:16:23 <smcginnis> Which means teams have to decide if they want to continue maintaining stable/ocata and means no more official releases will be done.
16:16:33 <smcginnis> Matt wrote up some of this changes on the ML:
16:16:40 <smcginnis> #link http://lists.openstack.org/pipermail/openstack-dev/2018-September/134810.html Extended maintenance discussion
16:16:58 <smcginnis> I haven't checked, but I think we probably have unreleased commits in stable/ocata.
16:17:09 <smcginnis> We should quick do a final stable release with whatever we have.
16:17:34 <smcginnis> We can still backport fixes, but in extended maintenance there will not be any official releases.
16:17:48 <smcginnis> Just a place for distros to pick up anything they want to roll into their packaging.
16:18:11 <jungleboyj> smcginnis: ++
16:18:18 <jungleboyj> I can propose a release.
16:19:15 <jaypipes> erlon: you're welcome.
16:19:23 <jaypipes> :P
16:19:34 <smcginnis> Yeah, looks like a few commits since the last release - https://github.com/openstack/cinder/compare/10.0.7...stable/ocata
16:19:41 <jungleboyj> jaypipes: :-p
16:19:50 <jungleboyj> I never get thanked for you.  :-(
16:20:37 <jaypipes> BTW, while I'm here, I should mention that I still owe geguileo and erlon an email detailing the strategy for taking advantage of a "record generation marker" DB query approach. Just noting that's still on my to-do list.
16:20:48 <erlon> jaypipes, hey np :p
16:20:55 <geguileo> jaypipes: thanks
16:20:56 <jungleboyj> smcginnis:  Ok, will propose that yet today.
16:21:21 <jungleboyj> jaypipes:  Cool.  Thanks.  erlon and geguileo were asking about that earlier this week.
16:21:25 <erlon> jaypipes, that would be great thanks
16:22:40 <jungleboyj> #action jungleboyj to propose one last stable/ocata release.
16:23:14 <jungleboyj> smcginnis:  Anything else to propose/discuss on that topic?
16:23:34 <smcginnis> No, I think that's it. Just raising awareness of the change there mostly.
16:23:45 <jungleboyj> smcginnis:  Cool.  Thank you.
16:24:10 <jungleboyj> That was all we had on the agenda.
16:24:33 <jungleboyj> whoami-rajat:  You had a todo to pick out a few bugs for triage that came out of the PTG.
16:24:43 <jungleboyj> Did you get a chance to do that?
16:25:14 <whoami-rajat> jungleboyj: yes, i picked some
16:25:20 <jungleboyj> whoami-rajat:  Cool.
16:25:27 <jungleboyj> #topic Bug Triage
16:25:49 <jungleboyj> whoami-rajat:  All yours.
16:26:40 <whoami-rajat> so the first bug i found was this https://bugs.launchpad.net/cinder/+bug/1790840
16:26:40 <openstack> Launchpad bug 1790840 in Cinder "Multiattach - multiattach is set to false after retype operation" [Undecided,New] - Assigned to Rajat Dhasmana (whoami-rajat)
16:27:26 <whoami-rajat> there had been a long chain of commits but still none of them fixed it, still reproducible.
16:28:14 <jungleboyj> Looking.
16:29:44 <jungleboyj> whoami-rajat:  Good catch.  That looks like an important one to fix  given the interest in multi-attach.
16:30:20 <jungleboyj> Marking it confirmed if you have been able to reproduce.
16:30:38 <jungleboyj> Looks like you have assigned that to yourself.
16:30:52 <walshh_> The manage use case was addressed https://bugs.launchpad.net/cinder/+bug/1783790
16:30:52 <openstack> Launchpad bug 1783790 in Cinder "Multiattach - the multiattach is still set to False after a Manage and Retype operation" [Undecided,Fix released] - Assigned to TommyLike (hu-husheng)
16:30:59 <whoami-rajat> jungleboyj: thanks, thought will give it a try so assigned myself.
16:31:30 <jungleboyj> walshh_:  Saw that.
16:31:39 <walshh_> the retype usecase still remains unfixed hense https://bugs.launchpad.net/cinder/+bug/1790840
16:31:39 <openstack> Launchpad bug 1790840 in Cinder "Multiattach - multiattach is set to false after retype operation" [High,Confirmed] - Assigned to Rajat Dhasmana (whoami-rajat)
16:32:16 <jungleboyj> whoami-rajat:  Ok.  Sounds good.  If you need help pull in tommylike since he fixed the manage case.
16:32:17 <whoami-rajat> walshh_: yea there are multiple bugs reported for different scenarios.
16:32:33 <jungleboyj> whoami-rajat:  What are the other bugs?
16:32:35 <whoami-rajat> jungleboyj: ok sure.
16:32:50 <whoami-rajat> https://bugs.launchpad.net/cinder/+bug/1788619
16:32:50 <openstack> Launchpad bug 1788619 in OpenStack Compute (nova) "disk cachemodes should be restricted with multiattached volumes" [Undecided,New]
16:33:24 <whoami-rajat> no updates since a month on this
16:33:27 <jungleboyj> Looks like this was marked as a duplicate:  https://bugs.launchpad.net/cinder/+bug/1778525
16:33:27 <openstack> Launchpad bug 1770671 in Cinder "duplicate for #1778525 multiattach is not enabled consistently when the default volume type supports multiattach" [Undecided,Fix released] - Assigned to TommyLike (hu-husheng)
16:34:54 <jungleboyj> whoami-rajat:  Yuck.  the cacemodes issue doesn't look good.
16:35:37 <jungleboyj> I didn't know that there was a way to set cachemodes.
16:36:52 <jungleboyj> Ah, it is a nova configuration option.
16:36:54 <whoami-rajat> jungleboyj: i also don't have deep understanding of the bug, eric doesn't seem to be here to address it.
16:37:09 <jungleboyj> whoami-rajat:  Right.  He is out for the next two weeks.
16:37:44 <jungleboyj> Let me update that bug and save that one for discussion when he returns.
16:37:56 <whoami-rajat> whoami-rajat: ok, seems like we should move on the next bug?
16:38:06 <jungleboyj> Agree that is one that should be given some attention though.
16:39:16 <jungleboyj> whoami-rajat: Sure.
16:39:17 <whoami-rajat> jungleboyj: yes.
16:39:42 <jungleboyj> whoami-rajat:  What else you got for us?
16:40:36 <whoami-rajat> so i've an old one but the change seems to be abandoned and was never fixed, or maybe addressed by some other bug i may not be aware of,
16:40:42 <whoami-rajat> https://bugs.launchpad.net/cinder/+bug/1648885
16:40:42 <openstack> Launchpad bug 1648885 in Cinder "ceph: TestVolumeBootPattern.test_create_ebs_image_and_check_boot times out failing to delete volume due to snapshot is busy" [Undecided,In progress]
16:42:05 <jungleboyj> Well that is an old one.
16:43:12 <jungleboyj> smcginnis:  unassigned it and the change was abandoned due to inactivity.
16:43:28 <jungleboyj> jbernard isn't here.  :-(
16:43:56 <jungleboyj> Given that really hasn't been touched in over a year and a half is there any reason to not close this?
16:44:18 <smcginnis> Probably good to close at this point.
16:44:23 <whoami-rajat> yeah, i guess.
16:44:55 <jungleboyj> If we start seeing failures again there is no reason we can't open a new bug or re-open.
16:45:07 <smcginnis> Exactly
16:47:38 <jungleboyj> There was hit on that in the last 4 months.
16:48:34 <jungleboyj> Ok.  I am going to close that one out then.
16:49:50 <jungleboyj> Any other bugs to discuss?
16:50:27 <whoami-rajat> i've a last one, didn't get time to reproduce the issue but seems quite bad, https://bugs.launchpad.net/cinder/+bug/1782714
16:50:27 <openstack> Launchpad bug 1782714 in OpenStack Compute (nova) "Properties of an attached volume are lost after live migration" [Undecided,New]
16:52:56 <jungleboyj> Hmmm.  That looks like one that is worth investigating further.
16:54:19 <jungleboyj> Anyone able to try to recreate that one?
16:55:01 <whoami-rajat> the author has provided most of the logged details for the issue about the point when the metadata seems to be lost.
16:55:31 <tbarron> jaypipes: would you copy 'tpb@dyncloud.net' on that "record generation marker" DB mail?  we need to use the same technique in manila
16:55:54 <jaypipes> tbarron: yes sir!
16:56:01 <jungleboyj> tbarron: ++
16:56:04 <tbarron> jaypipes: thanks!
16:56:20 <jungleboyj> smcginnis:  geguileo Thoughts on this last bug?
16:56:30 <jungleboyj> I wonder if it is specific to Ceph.
16:57:43 <jungleboyj> I seem to have lost the room.
16:58:10 <jungleboyj> So, I will put this on the follow up list for next week and we will go from there.
16:58:13 <smcginnis> Looks like an issue, but don't really have much more on it than that.
16:58:37 <jungleboyj> smcginnis:  Ok.  Not sure if I have a place to recreate it right now.
16:58:52 * jungleboyj has never done live migration.  :-)
16:59:08 <jungleboyj> Maybe time to get my other systems set up.
16:59:33 <geguileo> jungleboyj: I haven't looked at the bug, but that's weird...
16:59:42 <jungleboyj> geguileo:  Agreed.
16:59:53 <jungleboyj> Ok.  Well, we should wrap up.  I will keep this in follow up.
17:00:05 <jungleboyj> whoami-rajat:  Good first stab a bug triage.  Thank you!
17:00:17 <geguileo> I think I know where that issue could be...
17:00:17 <jungleboyj> Close one and bring attention to a couple others.
17:00:31 <geguileo> it's probably in the swap of the DB entries
17:00:46 <jungleboyj> geguileo:  Cool.  Ok.
17:00:47 <smcginnis> Time
17:00:56 <jungleboyj> Yep.  Thanks for a good meeting team.
17:01:01 <jungleboyj> #endmeeting