16:00:12 <jungleboyj> #startmeeting Cinder
16:00:13 <openstack> Meeting started Wed Sep 26 16:00:12 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:16 <openstack> The meeting name has been set to 'cinder'
16:00:26 <whoami-rajat> Hi
16:00:39 <xyang> hi
16:00:49 <tbarron> hi
16:00:56 <yikun> hi
16:01:03 <jungleboyj> @!
16:01:03 <_pewp_> jungleboyj (✧∇✧)╯
16:01:14 <ganso> hello
16:01:18 <woojay> hello
16:01:19 <jungleboyj> _hemna:  You going to join us?
16:01:50 <geguileo> hi! o/
16:02:10 <jungleboyj> geguileo:  Welcome.
16:02:28 <geguileo> thanks  :-)
16:02:30 <jungleboyj> smcginnis: Is at a conference so I am guessing he won't be here.
16:02:56 <jungleboyj> Give people one more minute.
16:03:44 <jungleboyj> Ok, lets get started.
16:03:49 <jungleboyj> #topic announcements
16:03:54 <e0ne> hi
16:03:59 <_alastor_> o/
16:04:01 <jungleboyj> Not a lot in the way of announcements this week.
16:04:18 <jungleboyj> I did push up a patch to propose our last Ocata release.
16:04:46 <jungleboyj> #link https://review.openstack.org/603882
16:05:00 <jungleboyj> Sean has given it a thumbs up.  Hopefully that will merge before too long.
16:06:15 <jungleboyj> Also a reminder that we have the Priorities etherpad:
16:06:20 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:06:36 <jungleboyj> If you are working on specs or reviews for items in that pad, please add your links.
16:06:54 <jungleboyj> I think that is all I have for announcements.
16:07:05 <jungleboyj> #topic Mid-Cycle planning:
16:07:48 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-stein-mid-cycle-planning
16:08:11 <jungleboyj> Looks like we have 3 people interested in joining.
16:08:47 <jungleboyj> As I mention in there, Lenovo would be willing to host in RTP, but if there are others that want to offer.  That would be fine.
16:08:59 <whoami-rajat> can we join remotely?
16:09:20 <jungleboyj> If anyone wants to come to Rochester, MN in February I have room to host at my house.  :-)
16:09:32 <jungleboyj> whoami-rajat:  Yes, we will enable that again.  Just like we did for the PTG.
16:09:35 <geguileo> jungleboyj: eharney is on PTO, but I think he was also interested
16:09:47 <whoami-rajat> jungleboyj: ok, thanks
16:09:56 <jungleboyj> The format is much the same as the PTG but it is just Cinder meeting up.
16:10:02 <e0ne> +1 for remote
16:10:03 <jungleboyj> geguileo:  Ah, that is right.
16:10:11 * geguileo is interested but is unlikely that he'll go
16:10:23 <jungleboyj> geguileo:  It seems like there is always so much for him after the PTG and he disappears for two weeks.  :-)
16:10:38 <jungleboyj> geguileo:  Would you join remotely if we timed the topics appropriately?
16:10:55 <geguileo> jungleboyj: I'm going to dissapear for 3 weeks starting next week, holidays at last!!
16:11:06 <jungleboyj> geguileo:  NOOOOO!!!!!
16:11:09 <jungleboyj> ;-)
16:11:10 <geguileo> jungleboyj: yes, I would join remotely
16:11:18 <geguileo> lol
16:11:27 <jungleboyj> geguileo:  Ok.  Cool.  Let me add a remote section here.
16:12:38 <geguileo> e0ne: You can add your name to the remote list now  ;-)
16:13:03 * jungleboyj doesn't know what I will do without geguileo next to me giving me the 'don't look at me' look.
16:13:20 <geguileo> rofl rofl rofl
16:13:21 <e0ne> geguileo: thanks :)
16:13:32 <geguileo> jungleboyj: And the don't ask me to introduce myself look
16:13:44 <jungleboyj> Ok, good.  See people that would participate remotely too.
16:14:04 <jungleboyj> geguileo:  :-)
16:14:18 <jungleboyj> You are much less shy than you used to be.  ;-)
16:15:16 <jungleboyj> Ok.  so, now that everyone is aware of this.  Please consider it.  Is there anyone who knows this date won't work right now?
16:15:57 <jungleboyj> Cool.
16:15:59 <jungleboyj> Ok.
16:16:09 <jungleboyj> Moving along.
16:16:18 <jungleboyj> I need to submit Forum Topics today:
16:16:26 <jungleboyj> #topic Forum Topic Planning
16:16:38 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-berlin-forum-proposals
16:17:23 <jungleboyj> Looks like we have 5 useful topics there.
16:17:40 <jungleboyj> Anyone have objections to those being submitted?
16:18:23 <tbarron> note that sig-k8s proposal already has cinder/manila CSI in it: https://www.openstack.org/summit/berlin-2018/vote-for-speakers#/22752
16:18:30 <tbarron> so vote for it too
16:19:00 <jungleboyj> tbarron:  Cool.  Thank you for making note of that.
16:19:10 <jungleboyj> #link https://www.openstack.org/summit/berlin-2018/vote-for-speakers#/22752
16:19:29 <_hemna> here
16:20:11 * jungleboyj marks _hemna tardy
16:20:19 <_hemna> :P
16:20:21 <jungleboyj> @!j
16:20:21 <_pewp_> jungleboyj (._.) ~ ︵ ┻━┻
16:20:43 <tbarron> forum topics are in the regular summit CFP and vote format now
16:20:53 <jungleboyj> _hemna:  We need _pewp_ back in the cinder channel by the way.
16:21:01 <_hemna> oh, he's not there?
16:21:06 <_hemna> I'll check into it
16:21:07 <jungleboyj> tbarron:  That is so weird.
16:21:22 <jungleboyj> Nope.  No pewp there.
16:21:32 <rajinir> o/
16:21:34 <tbarron> made me consolidate more ...
16:22:07 <jungleboyj> I suppose.
16:22:11 <jungleboyj> How long is the voting open for?
16:23:13 <jungleboyj> tbarron: ^
16:23:15 <jungleboyj> Do you know?
16:23:31 * tbarron hunts
16:23:37 <jungleboyj> Thanks.
16:23:42 <jungleboyj> Ok, so we have:
16:23:56 <jungleboyj> #action jungleboyj to submit topics from the etherpad
16:24:06 <jungleboyj> #action team to vote on our topics
16:24:34 <jungleboyj> Any other comments there?
16:25:08 <e0ne> jungleboyj: https://wiki.openstack.org/wiki/Forum looks like today it the deadline for submissions
16:25:34 <jungleboyj> e0ne:  Yes, that is why we need to get things submitted today.
16:25:50 <e0ne> +1
16:26:03 <jungleboyj> Anyway, I think we can move on.
16:26:18 <tbarron> jamesmcarthur: can you tell us how long the voting period is open for Forum submissions?
16:26:28 <jungleboyj> #topic Will cinderlib follow the same release cycle as Cinder?
16:26:44 <jungleboyj> walshh_:  All yours.
16:27:02 <jungleboyj> tbarron:  I wondered if he was on IRC.  Hiding under a formal name.  ;-)
16:27:33 <jungleboyj> walshh_:  Are you here?
16:27:34 <tbarron> jungleboyj: I'm not finding the answer right off in my email but I just presumed that jimmy==james
16:27:47 <jungleboyj> tbarron: Safe guess.
16:28:02 <jungleboyj> It isn't clear to me if it is actually going through the voting process.
16:28:12 <jungleboyj> Guess we will see.
16:28:32 <jungleboyj> Looks like walshh_ isn't here.
16:28:47 <e0ne> we can ask geguileo :)
16:28:48 <jungleboyj> geguileo:  I think we discussed this at the PTG.  Right?
16:28:58 <walshh_> Hi guys
16:29:01 <jungleboyj> I think it was implied that it would follow the same release schedule.
16:29:19 <tbarron> jungleboyj: well jamesmcarthur did point mriedem to
16:29:24 <walshh_> apologies if it was already discussed, just brought it up for clarification
16:29:26 <geguileo> jungleboyj: that was my understanding from the PTG as well
16:29:30 <tbarron> https://www.openstack.org/summit/berlin-2018/vote-for-speakers
16:30:03 <jungleboyj> tbarron:  Ok.  Good to know.
16:30:05 <tbarron> And when I went there I was able to vote for and comment in favor of the sig-k8s proposal
16:30:05 <geguileo> jungleboyj: as cinderlib and cinder would be included in the same package
16:30:12 <LiangFang_> sorry to quit now, too late in prc
16:30:19 <tbarron> dunno if anyone consumes that info though
16:30:26 <jungleboyj> So, Vote Early and Vote Often then.
16:30:29 <mriedem> no idea how the voting works
16:30:41 <mriedem> if there are 80 blocks and 40 submissions, everything probably gets approved
16:30:49 <tbarron> mriedem: i vote for yours if you vote for mine :)
16:30:50 <jungleboyj> :-)
16:30:53 <jamesmcarthur> tbarron: the Forum selection period is meant to be from September 27-October 9.
16:30:59 <mriedem> in years past, sdague always told me to just submit stuff since there was always more room than content
16:31:11 <jamesmcarthur> there is no voting on Forum submissions
16:31:26 <mriedem> jamesmcarthur: oh, well the 'cast your vote' is misleading then
16:31:28 <jamesmcarthur> I just pointed mriedem (and others) there b/c it's an easy way to review submissions as they roll in
16:31:34 <jungleboyj> jamesmcarthur:  Ok.
16:31:39 <mriedem> are my snarky comments on some of them still public?
16:31:46 <jamesmcarthur> Right, I think I pointed that out at the time.
16:31:49 <tbarron> jamesmcarthur: ok, I voted and commented fwiw
16:31:58 <jamesmcarthur> mriedem: if you left snarky comments, they are still public :)
16:32:01 <mriedem> jamesmcarthur: i will revise history based on memory thank you very much
16:32:04 <tbarron> jamesmcarthur: not complainiing :)
16:32:13 <jamesmcarthur> It's fine for people to vote... it's not going to hurt anything.
16:32:22 <jamesmcarthur> It's just not something that normally happens in the Forum selection process.
16:32:40 <jamesmcarthur> This is the first time we've repurposed the CFP tool for Forum, so we have some growing pains.
16:32:41 * jungleboyj is laughing
16:32:54 <jungleboyj> Change is hard.
16:33:05 <jamesmcarthur> I guess the old tool wasn't performing very well and it was difficult to move sessions into the main Summit CMS
16:33:21 <jungleboyj> Makes sense.
16:33:30 <mriedem> i'll be very interested to see numbers of submissions before and after this
16:33:35 <mriedem> the old tool was very dead simple for submitters
16:33:46 <jungleboyj> Ok, so, moving on.
16:33:52 <jamesmcarthur> to mriedem: comment earlier, we typically have more space that submissions
16:33:56 * mriedem is going to squat and derail this meeting
16:34:17 <jamesmcarthur> It's looking like this time will be no exception. So unless there is some obvious product pitch, it will likely be included.
16:34:21 <jungleboyj> @!h mriedem
16:34:22 <_pewp_> jungleboyj (/ .□.) ︵╰(゜Д゜)╯︵ /(.□. )
16:35:00 <jungleboyj> walshh_:  Did you question get answered?
16:35:05 <jungleboyj> *your
16:35:18 <jungleboyj> I believe the plan is that it will follow the same release schedule.
16:35:21 <walshh_> yes I did, thank you
16:35:48 <jungleboyj> walshh_:  Excellent.  Anything more on that geguileo ?
16:36:00 <geguileo> not really
16:36:12 <geguileo> if we need backports we'll do them like with Cinder
16:36:15 <jungleboyj> Ok.  Good.
16:36:26 <jungleboyj> #topic Bug Triage
16:36:49 <e0ne> will it be the same as 'Final release for non-client libraries' ?
16:37:07 * jungleboyj laughs again
16:37:29 <jungleboyj> e0ne: Hmmm, good question.
16:37:35 <geguileo> e0ne: I think it should have the same cut as Cinder
16:37:46 <jungleboyj> I am not sure that it would fall into that category because it will be in Cinder.
16:37:49 <e0ne> geguileo: sounds reasonable
16:37:51 <_hemna> isn't it going to be part of cinder repo?
16:37:52 <jungleboyj> geguileo: ++
16:37:57 <geguileo> _hemna: yes
16:38:00 <jungleboyj> Yeah.
16:38:13 <_hemna> ok, so why would it have a separate release cycle than cinder?
16:38:33 <jungleboyj> _hemna:  Exactly.
16:39:51 <jungleboyj> Ok.  So moving on.
16:39:56 <jungleboyj> Bug Triage
16:40:02 <whoami-rajat> My turn?
16:40:23 <jungleboyj> So this bug kind-of is stuck without input from Eric.
16:40:27 <jungleboyj> #link https://bugs.launchpad.net/cinder/+bug/1788619
16:40:27 <openstack> Launchpad bug 1788619 in Cinder "disk cachemodes should be restricted with multiattached volumes" [High,New]
16:40:35 <jungleboyj> Will move that forward to next week.
16:40:52 <jungleboyj> whoami-rajat: I think you have a patch up for this one:
16:40:55 <jungleboyj> #link https://bugs.launchpad.net/cinder/+bug/1782714
16:40:56 <openstack> Launchpad bug 1782714 in OpenStack Compute (nova) "Properties of an attached volume are lost after live migration" [Undecided,New]
16:41:52 <jungleboyj> whoami-rajat:  Oh, maybe not.  At least it isn't associated with the bug.
16:41:57 <jungleboyj> geguileo:  Did comment though.
16:42:38 <whoami-rajat> jungleboyj: yep, i was waiting for the response from the author
16:42:55 <jungleboyj> whoami-rajat:  Where was that patch?
16:43:11 <geguileo> I talked with imacdonn yesterday about that one
16:43:20 <jungleboyj> geguileo:  Ok.
16:43:26 <whoami-rajat> its for multiattach, let me find it
16:43:37 <geguileo> oh, wait, maybe I'm wrong and it's another one
16:44:00 <geguileo> yeah, my bad, it's a different one
16:44:04 <jungleboyj> whoami-rajat:  Is there an issue for multiattach as well?
16:44:24 <geguileo> it looks like the reported issue is just about where they are looking at it
16:44:35 <whoami-rajat> https://review.openstack.org/#/c/604040/
16:44:41 <geguileo> but we may have a real bug, as we seem to be ignoring the original attach mode after the migration
16:45:23 <jungleboyj> whoami-rajat:  Oh, that is a different issue.  Ok.  But that too is a good one to fix.
16:45:56 <whoami-rajat> jungleboyj: multiattach setting to false after retype, seems like the CI is breaking,couldn't find a relation,
16:46:12 <geguileo> this should be an easy one for someone to fix
16:46:28 <geguileo> I think that's the RCA in the bug
16:46:53 <jungleboyj> whoami-rajat:  Yeah, I saw that CIs are failing there.  So, that isn't good.
16:47:22 <whoami-rajat> asked tommylikehu in the morning for a look, seems like he was busy today!
16:47:37 <jungleboyj> geguileo: which one are you talking about.  Sorry, we have got multiple signals going.
16:47:44 <geguileo> rofl
16:47:53 <geguileo> I was referring about the attach mode
16:47:58 <jungleboyj> whoami-rajat:  Yeah, I have heard he is going to have other distractions happening.
16:48:02 <geguileo> which one were we talking about now?
16:48:09 <jungleboyj> geguileo: Ok.  Good.
16:48:57 <jungleboyj> So, it appears we need to figure out why that is making CI fail.
16:49:26 <whoami-rajat> jungleboyj: since i don't have much of the CI backends configured, couldn't debug the problem from the gate failure. looks like the backends that doesn't support retype seems to fail but i maybe wrong.
16:49:58 <whoami-rajat> checked the flow on lvm and nfs, works fine.
16:49:59 <jungleboyj> whoami-rajat:  That shouldn't be the case for the IBM ones.  They support retype.
16:50:04 <geguileo> whoami-rajat: what case are we discussing now?  r:-??
16:50:44 <whoami-rajat> geguileo: lol, i think we should finish one topic first. i'm discussing the multiattach one.
16:51:30 <jungleboyj> whoami-rajat:  The Pure CI is failing in a volume types test:
16:51:30 <imacdonn> multiattach one is https://review.openstack.org/604040
16:51:31 <jungleboyj> u'message': u'Invalid volume: Volume status must be available or error or error_restoring or error_extending or error_managing and must not be migrating, attached, belong to a group, have snapshots or be disassociated from snapshots after volume transfer.', u'code': 400}, <traceback object at 0x7f8f0f8474d0>), (<class 'tempest.lib.exceptions.BadRequest'>, Bad request
16:52:48 <jungleboyj> Ok, looks like a common tempest case failing:
16:52:50 <jungleboyj> tempest.api.volume.admin.test_volume_types.VolumeTypesTest
16:52:58 <whoami-rajat> jungleboyj: yes i checked the same error for multiple CI's.  also retype without migration is failing.
16:53:06 <jungleboyj> That is the eternus results.
16:53:50 <jungleboyj> So, more work required there.
16:54:05 <whoami-rajat> jungleboyj: i wrote that test but seems like it differs from the retype tests in cinder.
16:54:29 <jungleboyj> Ok.
16:54:31 <whoami-rajat> jungleboyj: yes. :(
16:54:39 <jungleboyj> :-(
16:54:40 <geguileo> is it just me or that seems kind of wrong?
16:55:11 <geguileo> never mind I'll review the patch and add my comments there
16:55:19 <jungleboyj> geguileo:  Ok.  Sounds good.
16:55:23 <whoami-rajat> geguileo: sure, thanks
16:55:27 <jungleboyj> We only have 5 minutes left.
16:55:45 <jungleboyj> geguileo:  You commented on https://bugs.launchpad.net/cinder/+bug/1782714 last week.
16:55:45 <openstack> Launchpad bug 1782714 in OpenStack Compute (nova) "Properties of an attached volume are lost after live migration" [Undecided,New]
16:55:59 <whoami-rajat> actually i
16:56:13 <geguileo> yeah that's the one I was discussing earlier
16:56:18 <jungleboyj> Looks like you left a question and didn't get a response.
16:56:44 <geguileo> yeah, because it looks like for RW it will work, you just have the info somewhere else
16:56:53 <geguileo> (which is not a good user experience)
16:57:06 <jungleboyj> geguileo:  Yeah, that doesn't sound good.
16:57:11 <geguileo> but we may have bugs for non RW volumes, as we seem to have hardcoded it on the re-attach
16:57:39 <jungleboyj> geguileo: That may be left over from the fact that we used to really just have RW ?
16:58:16 <geguileo> could be
16:58:56 <jungleboyj> Ok.  Well, lets see if there is any response in the next week.
16:59:04 <jungleboyj> Re-address next week.
16:59:25 <jungleboyj> Triaging bugs may be a slower process than I thought.  Some progress is better than none.
17:00:05 <jungleboyj> Ok.  So, we need to wrap up.
17:00:10 <jungleboyj> Thank you team!
17:00:15 <jungleboyj> #endmeeting