16:00:15 <jungleboyj> #startmeeting Cinder
16:00:16 <openstack> Meeting started Wed Oct 24 16:00:15 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:20 <openstack> The meeting name has been set to 'cinder'
16:00:25 <smcginnis> o/
16:00:25 <jungleboyj> @!
16:00:25 <_pewp_> jungleboyj (^-^*)/
16:00:26 <geguileo> hi! o/
16:00:43 <rosmaita> o/
16:00:49 <jungleboyj> This week's agenda:  https://etherpad.openstack.org/p/cinder-stein-meeting-agendas
16:00:55 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-stein-meeting-agendas
16:01:18 <_alastor_> ol
16:01:40 <yikun> hello
16:02:10 <jungleboyj> Give people another minute to collect.
16:02:18 <e0ne> hi
16:02:19 <ganso> hello
16:02:25 <geguileo> jungleboyj: we miss the pings  ;-)
16:02:31 <walshh_> hi
16:02:37 <jungleboyj> geguileo:  I know.  Is it safe to do again?
16:02:49 <geguileo> no idea, you can always try....  };-)
16:03:34 <jungleboyj> courtesy ping:  erlon tpsilva ganso patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro lpetrut lseki _alastor_ whoami-rajat yikun
16:03:45 <jungleboyj> Oooh, am I still alive?
16:03:49 <geguileo> yay!!!!
16:03:54 <jungleboyj> \o/
16:03:56 <geguileo> you are!!
16:04:23 <jgriffith> maybe they turned that off?
16:04:25 <jungleboyj> Ok, I guess I can ping people again if people would like that back.
16:04:35 <rosmaita> jungleboyj: ++
16:04:45 <jungleboyj> rosmaita:  And now you are on the list.
16:04:50 <jungleboyj> jgriffith:  Hey buddy!
16:04:59 <jgriffith> jungleboyj: maybe log in with a dummy account for the ping just in case ;0
16:04:59 <jungleboyj> Ok.  Lets get started.
16:05:06 <jungleboyj> #topic announcements
16:05:40 <jungleboyj> First announcement Happy Birthday to _hemna  or hemna Which ever gets his attention.  :-)
16:06:22 <jungleboyj> I have gotten the Berlin Forum Etherpads put together:
16:06:35 <jungleboyj> #link https://wiki.openstack.org/wiki/Forum/Berlin2018
16:06:59 <jungleboyj> Right now the etherpads are just a copy of what we put down for our proposals.
16:07:40 <jungleboyj> If you have anything on the topcs:  Data Service, Role in Edge Computing or User Survey Feedback.  Please add something.
16:08:02 <jungleboyj> Who all is going to be in Berlin?
16:08:10 <e0ne> +1
16:08:11 <jungleboyj> I will be.  I know smcginnis  will be.
16:08:15 <smcginnis> Yep
16:08:19 <jungleboyj> e0ne:  Excellent!
16:08:26 <rosmaita> i am staying home and having a jelly doughnut
16:08:43 <jungleboyj> rosmaita: Ich be ein berlinner?  ;-)
16:08:45 <geguileo> jungleboyj: I'll be there
16:08:50 <jungleboyj> geguileo:  Yay!
16:08:58 <jungleboyj> eharney:  I think is also going to be there.
16:09:35 <geguileo> jungleboyj: I think so
16:09:37 <jungleboyj> Ok, so we have at least a few of us there for the technical talks.
16:09:48 <jungleboyj> Otherwise I will just fake it.
16:09:58 <smcginnis> :)
16:10:21 <jungleboyj> Anyway, please go update the etherpads with thoughts whether you will be there or not.
16:10:37 <jungleboyj> I will record the sessions like I did in Vancouver.
16:10:46 <jungleboyj> Does anyone want me to do hangouts for these?
16:11:23 <jungleboyj> Most of the sessions are on Tuesday afternoon.
16:11:38 <rosmaita> i'm ok with just recordings
16:12:01 <jungleboyj> Ok, if no one is jumping up and down for hangouts I won't plan to do that.
16:12:24 <jungleboyj> Moving on.
16:12:36 <jungleboyj> I have proposed stable/rocky release 13.0.1 .
16:12:47 <jungleboyj> Lots of good bug fixes backported so it will be good to get that out.
16:13:19 <jungleboyj> So, I think that is all I have on for announcements.
16:13:45 <jungleboyj> #topic Review of responses to User Survey Feedback
16:14:10 <jungleboyj> So, I was hoping to get some thoughts organized this week.  I did not so my goal is to start getting some info into the etherpad.
16:14:21 <jungleboyj> #link https://etherpad.openstack.org/p/BER-Cinder_User_Survey_Responses
16:14:44 <jungleboyj> Hopefully more to discuss here next week.
16:15:18 <jungleboyj> #topic Volume Revert-Snapshot Follow-up
16:15:27 <jungleboyj> erlon:  You around?
16:16:22 <jungleboyj> yikun:  Looks like you have actually been tackling this.
16:16:29 <jungleboyj> So, a little explanation ...
16:16:45 <jungleboyj> tommylike has unfortunately been moved on to other responsibilities.
16:16:56 <yikun> yeah, see https://bugs.launchpad.net/cinder/+bug/1798503/comments/2
16:16:56 <openstack> Launchpad bug 1798503 in Cinder "When reverting volume to smaller snapshot size is incorrect" [High,In progress] - Assigned to Yikun Jiang (yikunkero)
16:17:01 <jungleboyj> yikun:  Is going to be helping backfill his Cinder responsibilities.
16:17:08 <yikun> : )
16:17:16 <jungleboyj> So, a warm welcome to yikun
16:17:22 <yikun> ha, thanks.
16:17:32 <jungleboyj> Welcome.
16:17:36 <_hemna> jungleboyj: thanks man :)
16:17:37 <geguileo> welcome!!
16:18:19 <jungleboyj> So, it looks like we were in agreement that there is a bug and the fix is in process.
16:18:20 <yikun> geguileo: thanks, :)
16:18:34 * jungleboyj sings Happy Birthday to _hemna
16:18:40 <smcginnis> hemna: 🎂
16:18:59 <jungleboyj> :-)
16:19:06 <_hemna> :)
16:19:09 <smcginnis> jungleboyj: Yep, I think that was an oversight that we didn't prevent that from happening. We talked about preventing it during the spec review.
16:19:38 <yikun> jungleboyj: yes, and I think @erlon know and agree it, and I find his +1 on the patch.
16:20:03 <jungleboyj> #link https://review.openstack.org/#/c/611491/  Ok, see the review.
16:20:07 <jungleboyj> Will take a look at it.
16:20:17 <jungleboyj> Think it is good to go with what the Spec designed.
16:21:42 <jungleboyj> Ok.  So, I think we can move on.
16:21:59 <jungleboyj> #topic Automate Generation of api-ref sample files in Cinder
16:22:13 <jungleboyj> #link https://docs.openstack.org/nova/latest/contributor/api.html#functional-tests-and-api-samples
16:22:26 <jungleboyj> I am not sure who added this topic.
16:22:47 <jungleboyj> I think it might have been whoami-rajat but he doesn't seem to be here.
16:23:34 <smcginnis> I haven't looked over the link, but I think the gist of it is Nova generates api-ref samples using a job that extracts actual response bodies.
16:23:44 <smcginnis> If that's the proposal, I'm all for doing the same.
16:24:01 <jungleboyj> smcginnis:  Yeah.  That was the goal.
16:24:03 <e0ne> +1
16:24:13 <jungleboyj> I think gmann was the one noting that it is something we could do.
16:25:32 <jungleboyj> I didn't think anyone would have a problem with that approach.  Also good to keep parity between Cinder and Nova where possible.
16:26:01 <jungleboyj> Just a matter of getting someone to implement it which I think whoami-rajat was going to look into.
16:26:06 <jungleboyj> So, I will follow up with him.
16:26:33 <jungleboyj> #action jungleboyj  to follow up with whoami-rajat
16:26:48 <jungleboyj> #topic Improve volume transfer records
16:26:49 <smcginnis> I assume we have to manually update the parameter list with descriptions still though.
16:26:56 <smcginnis> But at least if the examples are accurate, that helps.
16:27:03 <jungleboyj> smcginnis:  ++
16:27:07 <rosmaita> i like this comment, "The functional API samples tests are not the simplest thing in the world to get used to, and can be very frustrating at times when they fail in not obvious ways"
16:27:18 <rosmaita> something to look forward to
16:27:23 <jungleboyj> *smh*
16:27:25 <smcginnis> Hah
16:27:37 <jungleboyj> At least they are honest.
16:27:56 <jungleboyj> yikun:  Your topic.
16:28:09 <yikun> thanks, and this spec want to add ``original_project_id`` and ``current_project_id``, ``accept`` fields to
16:28:09 <yikun> ``transfer`` table to help admins trace the owner info and the transfer accepted info.
16:28:21 <yikun> and the spec is just an initial draft, and some more detail needs to be completed.
16:28:31 <yikun> If you guys are interested, you could take a look and give us some suggestion. :)
16:28:46 <yikun> #link https://review.openstack.org/#/c/612866/
16:29:20 <smcginnis> I think that could be useful.
16:29:35 <jungleboyj> Sounds like something to consider to me.
16:29:39 <smcginnis> We may need to think about that data growth if we don't get rid of those records though.
16:29:54 <smcginnis> Not sure how much transfers are used in some clouds, but that would grow over time.
16:30:07 <_hemna> seems like a good idea
16:30:30 <jungleboyj> Is it something that could be added to the DB cleaning process?
16:32:09 <jungleboyj> So, doesn't seem to be any immediate concerns.  Just need to get reviews on the Spec?
16:32:41 <jungleboyj> Ok. So.
16:32:48 <yikun> yeah, just want your idea on it, :)
16:32:51 <jungleboyj> #action team to review the spec.
16:33:28 <jungleboyj> Anything else yikun ?
16:33:38 <yikun> ok, thanks, that's all. :)
16:33:49 <jungleboyj> Thanks yikun .
16:34:19 <jungleboyj> #topic Explicit disable volume creation with multiattach=True for Ocata and Pike releases
16:34:25 <jungleboyj> e0ne:  Your floor.
16:34:33 <e0ne> jungleboyj: thanks :)
16:35:03 <e0ne> so, we've got multiattach released in Queens
16:35:16 <e0ne> but there is some code in older versions too
16:35:19 <e0ne> e.g.:
16:35:38 <e0ne> in pike we check multiattach capability in a shceduler
16:35:48 <jungleboyj> Right.
16:36:12 <e0ne> in ocata - everybody can pass '--allow-multiattach` flag to volume
16:37:29 <e0ne> but we don't officially support this before Queens
16:37:39 <e0ne> it confuse users
16:38:01 <e0ne> they are trying to create volume for multiattach
16:38:06 <jungleboyj> Yeah.  That is kind of confusing.
16:38:30 <e0ne> and I do understand, that in ideal world everybody should upgrade their clouds to the latest version
16:38:40 <e0ne> but it doesn't work :(
16:38:42 <jungleboyj> He he he.
16:38:58 <geguileo> e0ne: should we just modify the client to only pass that when the server supports the microversion?
16:39:28 <geguileo> Or is it that the API is accepting it even though the feature is not completed?
16:39:46 <jungleboyj> geguileo:  I don't think it is something that we want to silently ignore.
16:39:51 <smcginnis> I do remember hearing one or two users that somehow were using the multiattach flag with those older releases. I think maybe with their own hacks.
16:39:58 <e0ne> IMO, if we can return 400 Bad request Multiattach isn't supported until Q - it'll help users to understand what's going
16:40:05 <smcginnis> But I don't think we have to support private hacks at the expense of confusing everyone else.
16:40:15 <geguileo> e0ne: that sounds reasonable to me
16:40:20 <jungleboyj> smcginnis:  Yeah, I think PowerVC customers were using that.
16:40:24 <smcginnis> e0ne: Yeah, I think that's OK.
16:40:25 <geguileo> smcginnis: +1
16:40:42 <jgriffith> smcginnis: +2
16:40:46 <e0ne> great to know that we're on the same page
16:40:53 <jungleboyj> e0ne:  I think that is good.
16:41:07 <jungleboyj> And if the people who hacked it in need it they can remove that check too.
16:41:16 <smcginnis> jungleboyj: Exactly.
16:41:23 <e0ne> I'll provide a patch for Ocata and maybe for Pike this week
16:41:26 <e0ne> jungleboyj: +1
16:41:33 <geguileo> e0ne: thanks
16:41:35 <jgriffith> Just to play devils advocate...
16:41:46 <smcginnis> Uh oh. :)
16:41:55 <jgriffith> does that mean that any "unsupported" type/extra-spec entry should have a similair check?
16:42:04 <e0ne> I'm afraid, that it'll affect our customers too, but It's better to get this move explicit
16:42:28 <smcginnis> jgriffith: This one wasn't the extra spec approach though, right. Just the explicit flag on create.
16:42:34 <jungleboyj> I think it is better to improve the user experience.
16:42:43 <e0ne> jgriffith: TBH, I didn't dig intho tthis part for Pike yet
16:42:52 <e0ne> jungleboyj: +1
16:42:54 <jgriffith> :)
16:43:21 <smcginnis> It's the boolean parameter to the create call here - https://developer.openstack.org/api-ref/block-storage/v3/index.html?expanded=create-a-volume-detail#id87
16:43:46 <smcginnis> We should probably improve that description.
16:43:58 <smcginnis> And by approve, I think I mean delete the whole thing.
16:44:04 <jgriffith> LOL
16:44:27 <jungleboyj> smcginnis:  Loves deleting code.
16:44:30 <e0ne> smcginnis: AFAIR, this option is already deprecated
16:44:36 <smcginnis> jungleboyj: Yes I do!
16:44:54 <e0ne> #link https://github.com/openstack/cinder/blob/master/cinder/api/v3/volumes.py#L342
16:44:56 <smcginnis> e0ne: Yeah, we just don't indicate that in the api-ref. So maybe just removing it would cause less confusion.
16:45:14 <e0ne> smcginnis: good point, I agree with you
16:45:20 <jgriffith> The only problem is that IIRC folks like gophercloud may be exploiting that flag in older versions... let me look
16:45:23 <smcginnis> I think in the last major version bump of cinderclient we removed it too.
16:45:48 <e0ne> jgriffith: I'm afraid that you're right :(
16:46:30 <smcginnis> Ah, marked deprecated in the client - https://review.openstack.org/#/c/586296/
16:46:34 <e0ne> jgriffith: I just hit this issue with Ocata and Gophercloud (K8S)
16:46:41 <jgriffith> LOL
16:47:34 <jgriffith> good enough
16:49:08 <jungleboyj> So, how do we want to go forward here?
16:49:14 <smcginnis> Anything we need to do for gophercloud?
16:49:34 <jungleboyj> Can we gopher it?
16:50:04 <smcginnis> https://media.giphy.com/media/vkS5sVdreVWUg/giphy.gif
16:50:06 <jgriffith> I think it's probably ok; my only thing is going back versions and changing behaviors typically doesn't end well
16:50:10 <jgriffith> even if it's the right thing to do
16:50:22 <smcginnis> jgriffith: Yeah, this is kind of iffy as far as stable policy goes.
16:50:46 <e0ne> that's why I bring this topic to meeting before I proposed a patch
16:51:12 <jgriffith> e0ne: so refresh my memory, what horrible fate awaits those on O that try this?
16:51:26 <jungleboyj> Good question.
16:51:58 <smcginnis> I thought it set the property of the volume object, but didn't actually do anything.
16:52:12 <e0ne> jgriffith: you can create a volume with multiattach=True but it wont work as expected
16:52:20 <jgriffith> so clearly going forward we've deprecated it and should remove it clearly
16:53:05 <smcginnis> So we don't normally remove features in stable branches. But this "feature" doesn't actually do anything, so...
16:53:11 <jgriffith> e0ne: My vote would be to log an error and leave it; if somebody is using it they can ignore the error.  But removing it from old versions is out of policy IMO
16:53:20 <jgriffith> smcginnis: yeah, I hear ya
16:53:30 <smcginnis> jgriffith: Yeah, I think you're right.
16:53:35 <jgriffith> Ok, I'll shut up now and go with what the smart people in the room decide :)
16:54:08 <e0ne> :)
16:54:08 <smcginnis> I think to follow stable policy, we need to leave it in the older releases, even if it doesn't do anything.
16:54:18 <jungleboyj> So maybe the best answer is to just make it clear that nothing is happening in the logs?
16:54:21 <jgriffith> smcginnis: I'm afraid so
16:54:26 <jgriffith> jungleboyj: +1
16:54:30 <jungleboyj> smcginnis:  ++
16:54:32 <_hemna> sounds reasonable
16:54:39 <e0ne> ok, fair enough
16:54:46 <jungleboyj> We at least leave them bread crumbs
16:55:10 <smcginnis> Toasty, with a hint of garlic.
16:55:31 <e0ne> smcginnis: :)
16:55:45 <jungleboyj> Mmmmmm.
16:55:57 <jungleboyj> Outback Croutons.
16:56:33 <jungleboyj> So, I think the answer is that we add a log message that clearly indicates that the option you are using is doing nothing.
16:56:39 <jungleboyj> Everyone in agreement?
16:56:45 <smcginnis> That works for me.
16:57:02 <jungleboyj> Do our best to improve UX without breaking policy.
16:57:06 <smcginnis> And if someone is doing something funky downstream, they can just remove that logging.
16:57:24 <jungleboyj> smcginnis:  ++
16:57:29 <e0ne> jungleboyj, smcginnis : +1
16:58:21 <jungleboyj> Ok.  Good.  So that gets us through the agenda with 2 minutes left.
16:58:31 <jungleboyj> Should we wrap up a little early?
16:58:51 <e0ne> open discussion?
16:59:02 * e0ne is joking
16:59:03 <jungleboyj> #topic open discussion
16:59:07 <e0ne> :)
16:59:10 <jungleboyj> You have less than one minute.  Go.
16:59:16 <jungleboyj> :-)
16:59:24 <jungleboyj> Ok, thanks everyone for joining.
16:59:31 <smcginnis> Thanks!
16:59:32 <jungleboyj> Have a great week and talk to you all next week!
16:59:33 <e0ne> see you next week
16:59:41 <jungleboyj> #endmeeting