16:00:18 <jungleboyj> #startmeeting Cinder
16:00:19 <openstack> Meeting started Wed Nov 21 16:00:18 2018 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:23 <openstack> The meeting name has been set to 'cinder'
16:00:27 <whoami-rajat> Hi
16:00:29 <yikun> hello
16:00:38 <rosmaita> o/
16:00:41 <jungleboyj> Courtesy ping:  jungleboyj diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon tpsilva ganso patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro lpetrut lseki _alastor_ whoami-rajat yikun rosmaita
16:00:51 <e0ne> hi
16:00:53 <xyang> hi
16:01:18 <jungleboyj> @!
16:01:19 <_pewp_> jungleboyj (◍˃̶ᗜ˂̶◍)ノ”
16:01:32 <walshh_> hi
16:01:43 <enriquetaso> o/
16:01:54 <geguileor> o/
16:02:15 <jungleboyj> geguileo:  Make your flight last week?
16:02:30 <geguileo> jungleboyj: yup, I did :-)
16:02:38 <jungleboyj> :-)  Good.
16:03:05 <jungleboyj> Ok.  smcginnis Is on a plane somewhere.  So, we have everyone else I expect today.
16:03:09 <jungleboyj> So, lets get started
16:03:18 <jungleboyj> #topic Announcements
16:03:33 <jungleboyj> I have the Cinder on-boarding presentation posted:
16:03:44 <jungleboyj> #link https://www.slideshare.net/JayBryant2/cinder-onboarding-room-berlin-11132018
16:04:00 <jungleboyj> Thank you to rosmaita who reviewed it and found some mistakes.
16:04:11 <rosmaita> :)
16:04:11 <jungleboyj> I have fixed those so they will be right when I start with that for Denver.  :-)
16:04:43 <jungleboyj> rosmaita:  That was after I fixed other issues found during the presentation.  Ooops.
16:04:43 <jungleboyj> Might have phoned that one in.
16:04:54 <jungleboyj> There was good turnout for it and good questions so I think it was worth the time to do.
16:05:34 <jungleboyj> So, that is all I have there.
16:05:58 <jungleboyj> I am working on getting the audio from the forum sessions posted.  I would like to say I will have that done today, but we will see.
16:06:09 <jungleboyj> I will work to get it posted soon.
16:06:34 <rosmaita> just out of curiosity, have we gotten any contributors in the past from the onboarding sessions?
16:07:46 <jungleboyj> rosmaita:  Yes, a couple.
16:07:53 <rosmaita> great!
16:08:11 <jungleboyj> I think that Brian Pawlik started with an on-boarding session.
16:08:24 <jungleboyj> Same for the DRBD driver developers.
16:08:29 <rosmaita> that's about 200% better than glance
16:08:50 <jungleboyj> So, not a lot, but something.
16:09:16 <jungleboyj> Also the group working on the encryption changes sat in on the session in Berlin so I think that was helpful for them.
16:09:32 <jungleboyj> We had a good discussion around their needs and actually may have solved their issues.
16:09:57 <jungleboyj> :-)  So ... it has been useful time.
16:10:36 <jungleboyj> Ok.  Moving on:
16:10:39 <geguileo> jungleboyj: yeah, they did
16:10:50 <geguileo> jungleboyj: because they talked with the Oslo team
16:10:57 <jungleboyj> geguileo:  Awesome.
16:11:00 <geguileo> which is what we recommended they should do
16:11:12 <jungleboyj> And then they spent some time talking to eharney as well.
16:11:14 <geguileo> they'll be proposing a new olso project
16:11:25 <jungleboyj> geguileo:  Good news.
16:11:37 <rosmaita> that's good news
16:12:15 <jungleboyj> That makes more sense than the SDK idea.
16:12:30 <rosmaita> jungleboyj: ++
16:13:01 <jungleboyj> Anyway ...
16:13:16 <jungleboyj> #topic Paying attention to Bugs
16:13:40 <jungleboyj> Ok, so this was smcginnis but I think what he is trying to say is pretty obvious.
16:14:02 <jungleboyj> If you look at the link 3Par has a lot of bugs that haven't been addressed.
16:15:00 <jungleboyj> The contribution wiki clearly says that bugs need to be addressed.
16:15:19 <jungleboyj> Is there anyone here that works with 3Par?
16:15:21 <jungleboyj> _hemna: ^^
16:15:27 <jungleboyj> hemna^^
16:15:50 <enriquetaso> jungleboyj: to be addressed is to be confirmed?
16:16:17 <jungleboyj> enriquetaso:  Confirmed, responded to and a plan to mitigate the issue.
16:16:53 <whoami-rajat> i see some of them assigned long ago but no progress since a year.
16:17:13 <jungleboyj> whoami-rajat:  Right.
16:17:49 <enriquetaso> jungleboyj: thanks
16:18:07 <jungleboyj> Some of them have had no response.
16:18:16 <whoami-rajat> https://bugs.launchpad.net/cinder/+bug/1645136 this can be closed i think
16:18:17 <openstack> Launchpad bug 1645136 in Cinder "create_cloned_volume of HPE 3PAR Cinder Driver has a performance bottleneck when source/target volume size are different" [Undecided,New]
16:18:19 <jungleboyj> I am sure that 3Par is not the only example here.
16:19:25 <jungleboyj> whoami-rajat:  True.  I will close that one out.
16:20:26 <jungleboyj> Anyway, we don't need to go through all of these right now.
16:20:37 <whoami-rajat> jungleboyj:  how can we proceed for these driver specific bugs?
16:21:20 <jungleboyj> Point is, if you are a driver maintainer, please take some time to review the list of bugs and respond to any bugs that may be filed against your driver.
16:21:40 <jgriffith> jungleboyj: whoami-rajat the policy is that if there's not an active maintainer of the driver then it gets deprecated
16:22:00 <jgriffith> actively maintaining means dealign with bugs in LP related to said driver
16:22:04 <jungleboyj> I am going to follow up with a note to the mailing list and indicate that this is required.
16:22:29 <whoami-rajat> jgriffith: ok. Thanks for the info.
16:22:36 <jungleboyj> jgriffith:  I am thinking I should indicate that drivers that are not dealing with their bugs will be marked unsupported just like not having CI running.
16:22:50 <jgriffith> In other words how you deal with the driver related bugs is by maintaining your driver.  The Cinde repo isn't a dumping ground for stuff
16:23:05 <jungleboyj> jgriffith:  ++
16:23:12 <jgriffith> jungleboyj: yeah, we've done that before actually
16:24:08 <jungleboyj> Ok.  So...
16:24:30 <jungleboyj> #action jungleboyj to e-mail ml about keeping up with bugs and that if you don't you will be marked unsupported.
16:24:47 <jungleboyj> #action jungleboyj and smcginnis to review open bugs to figure out who the offenders are.
16:25:38 <jungleboyj> Everyone ok with the plan above?
16:25:59 <enriquetaso> +1
16:26:02 <whoami-rajat> +1
16:26:04 <e0ne> +1
16:26:08 <yikun> ++
16:26:25 <walshh_> +1
16:26:28 <jungleboyj> Excellent.
16:26:36 <jungleboyj> #topic User Survey Feedback Blog Post
16:26:48 <jungleboyj> #link https://docs.google.com/document/d/1d4_nUfuZacGABG2hqqCz3hC238uoVqdloi_qVGRNoRY/edit?usp=sharing
16:27:09 <jungleboyj> I have created a blog post to respond to our user survey feedback based on discussion we had at the Forum.
16:27:27 <jungleboyj> I would appreciate the rest of the team taking a look at it and making comments/updates.
16:27:44 <e0ne> jungleboyj: I read it really fast, could miss something. but it looks great! I'll read it more carefully after later today
16:27:56 <jungleboyj> I would like to get it sent off to SuperUser soon so that it is still fresh.
16:28:01 <jungleboyj> e0ne: Awesome.  Thank yoU!
16:28:26 <jungleboyj> jgriffith and geguileo I would appreciate your input as well.
16:28:27 <geguileo> jungleboyj: thanks for writting it !
16:28:46 <jungleboyj> geguileo:  No problem.  I have wanted to start doing that kind of thing.  So, it was a good time to do it.
16:30:15 <jungleboyj> Any comments or questions to address on the document now?
16:31:07 <rosmaita> ++ on keeping backups scheduling out of cinder
16:31:26 <jungleboyj> rosmaita:  :-)  Yeah, so many people asked for that and it is just not what we do.
16:32:02 <jungleboyj> Anyway, please review and leave your comments.  I will get it updated and have one last call on it next week before submission.
16:32:40 <jungleboyj> That was all I had on the agenda for topics.  Anything else to discuss or should we talk quickly about bugs?
16:32:53 <enriquetaso> I have something for "Ceph driver should respect the `--incremental` option for backups", but I'm not sure if this is the place to ask for more opinions about the bug.
16:33:03 <enriquetaso> #link https://review.openstack.org/#/c/612503/
16:33:38 <jungleboyj> enriquetaso:  I think we could talk about that.
16:34:01 <jungleboyj> #topic Ceph driver should respect the `--incremental` option for backups
16:34:12 <whoami-rajat> jungleboyj: Looks good. i will read it in detail.i found some minor spelling mistakes, can we correct them ourselves to not to bother you with it?
16:34:26 <jungleboyj> whoami-rajat:  Go ahead and fix them.
16:34:34 <enriquetaso> :)
16:34:59 <whoami-rajat> jungleboyj: i've requested edit access.
16:35:37 <jungleboyj> Granted.
16:35:50 <enriquetaso> I'll appreciate any opinions about changing the default behavior of the backups and reviews of course :)
16:35:52 <jungleboyj> enriquetaso:  Go ahead.
16:35:53 <whoami-rajat> jungleboyj: Thanks!
16:37:52 <geguileo> enriquetaso: you have to explain on what you want us to give you feedback here
16:38:03 <jungleboyj> geguileo:  Thank you.  :-)
16:38:49 <jungleboyj> enriquetaso:  Are you just looking for follow-up reviews?
16:39:51 <enriquetaso> oh, i'm looking for reviews u.u geguileo and jungleboyj
16:40:09 <jungleboyj> Ok.  Can take a look and review.
16:40:21 <geguileo> enriquetaso: only for reviews? or do you want to hear about keeping backward compatibility?
16:40:27 <jungleboyj> Just wanted to make sure you weren't looking for something more specific.
16:40:50 <geguileo> jungleboyj: there is an issue with keeping it backward compatible
16:41:01 <geguileo> or making it behave like the other drivers that support incremental backup
16:41:03 <jungleboyj> Doh.  Ok.  What is the issue?
16:41:30 <geguileo> ceph backups cannot create full backups (except the first one)
16:41:37 <geguileo> since they are doing incremental by default
16:41:40 <geguileo> the patch fixes this
16:41:50 <geguileo> but if it behaves like other drivers
16:41:54 <jungleboyj> Right.  Remember that discussion.
16:42:10 <geguileo> only doing incremental when requested, then it's not backward compatible
16:42:21 <geguileo> and if it's backward compatible, then it's not consistent with other drivers
16:42:39 <e0ne> :(
16:42:41 <jungleboyj> Hmmm.
16:42:52 <jungleboyj> :-(  Indeed.
16:43:06 <geguileo> so it's a matter of preference/choosing our favourite evil
16:43:11 <e0ne> I'm wondered I we didn't catch anything of this on our gates
16:43:33 <enriquetaso> thanks geguileo, yup. So my patch make the driver consistent with other drivers
16:43:59 <jungleboyj> What are other drivers doing?
16:44:09 <geguileo> they create full by default
16:44:21 <geguileo> if you specify incremental, then they do incremental using the latest full as the base
16:44:22 <jungleboyj> geguileo:  Ok.  Makes sense.
16:44:30 <geguileo> sorry, latest full, or latest incremental
16:44:50 <jungleboyj> And I forget, why can't we make Ceph do the same?
16:44:51 <geguileo> but ceph just tries to do incremental if it can, and does full if it can't
16:45:00 <e0ne> I'm +1 for consistency even if we have to change our default behaviour
16:45:02 <geguileo> jungleboyj: we can do it, but then we change the default behavior
16:45:49 <geguileo> maybe it's enough to add an upgrade note
16:45:59 <jungleboyj> e0ne:  Yeah.
16:46:02 <geguileo> to make sure that any automation is changed
16:46:05 <jungleboyj> I think consistency is best.
16:46:54 <geguileo> enriquetaso: looks like what you have is OK, maybe update the release note, and change the "features" section for an upgrade one
16:47:26 <enriquetaso> great!
16:47:31 <jungleboyj> geguileo: ++
16:47:31 <enriquetaso> thanks!!
16:47:38 <enriquetaso> geguileo++
16:47:55 <jungleboyj> Honestly, it seems like a bug that it didn't work the same as other drivers in the first place.
16:48:12 <enriquetaso> It's reported as a bug
16:48:13 <whoami-rajat> https://bugs.launchpad.net/cinder?field.searchtext=ceph+incremental&search=Search&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.assignee=&field.bug_reporter=&field.omit_dupes=on&field.has_patch=&field.has_no_package
16:48:13 <whoami-rajat> =
16:48:13 <whoami-rajat> looks like many people want the incremental functionality with ceph.
16:48:30 <whoami-rajat> full backup*
16:48:44 <geguileo> jungleboyj: it's not a real bug
16:48:54 <geguileo> jungleboyj: Ceph was the first backup driver that did incremental
16:49:05 <jungleboyj> Oh ... ok.  :-)
16:49:08 <geguileo> jungleboyj: then we introduced incremental, but the driver was not updated
16:49:16 <geguileo> jungleboyj: so it was inconsistent with the others
16:49:33 <jungleboyj> geguileo:  Gotcha.  Ok.  So, I think it is good to get it caught up.
16:49:34 <geguileo> in any case, this will fix it, and our drivers will be more consistent  :-)
16:49:44 <jungleboyj> \o/
16:50:05 <jungleboyj> Moving on
16:50:11 <jungleboyj> #topic Bug Triage
16:50:21 <jungleboyj> So, I wanted to bring up the following bug:
16:50:31 <jungleboyj> #link https://bugs.launchpad.net/openstack-ansible/+bug/1802070
16:50:32 <openstack> Launchpad bug 1802070 in openstack-ansible "Add resource_filter field in cinder.conf for non-admin user can retrieve volume & snapshot volume" [Undecided,In progress] - Assigned to KimMinsik (for-beatitudo)
16:50:48 <jungleboyj> OpenStack Ansible needed to make a change to fix an issue they were seeing.
16:51:01 <jungleboyj> It seems to me, however, they are working around a Cinder bug.
16:51:32 <jungleboyj> I don't remember who was working on the resource_filter stuff.  I am thinking it might have been tommylike ?
16:52:39 <e0ne> jungleboyj: I agree that we need to fix it in cinder too
16:53:07 <jungleboyj> e0ne:  That was my thought as well.
16:53:59 <jungleboyj> It seems like there should be some default behavior if the file doesn't exit.
16:54:10 <e0ne> jungleboyj: +1
16:54:20 <jungleboyj> A 400 isn't right.
16:54:58 <jungleboyj> e0ne:  Are you familiar enough with that code path to fix it up?
16:55:12 <jungleboyj> Since this was causing issues for Horizon it would be up your alley to fix/test.
16:55:21 <e0ne> jungleboyj: at lease I think so:)
16:55:36 <e0ne> I'll take it as my priority for tomorrow morning
16:55:38 <jungleboyj> :-)
16:56:05 <jungleboyj> e0ne:  Ok.  Cool.  I can open a bug based on the one in OpenStack ansible to track it against Cinder.
16:56:09 <jungleboyj> Make sense?
16:56:24 <e0ne> I just add Cinder project to the existing bug
16:56:39 <e0ne> *added
16:56:45 <jungleboyj> Oh ... yeah.  That probably makes more sense.
16:57:15 <jungleboyj> e0ne:  Cool.  Thanks for taking that one.
16:57:35 <e0ne> jungleboyj: np. I'm happy to be useful for the team :)
16:58:28 <jungleboyj> geguileo: Did you open a follow up bug to
16:58:29 <jungleboyj> #link https://bugs.launchpad.net/cinder/+bug/1782714
16:58:30 <openstack> Launchpad bug 1782714 in Cinder "Properties of an attached volume are lost after live migration" [Medium,New]
16:58:30 <jungleboyj> e0ne:  You are always useful to the team.  :-)
16:58:41 <e0ne> jungleboyj: thanks, Jay!
16:59:05 <geguileo> jungleboyj: yes, and I proposed a fix
16:59:28 <jungleboyj> Ok.  Cool.
16:59:28 * jungleboyj is behind on reviews.  :-(
16:59:41 <geguileo> jungleboyj: it's in the last comment of the bug for reference
16:59:49 <geguileo> it's a 4 lines patch
16:59:50 <geguileo> lol
17:00:01 <jungleboyj> Nice!  Ok.  I will follow up on that.
17:00:05 <geguileo> thanks
17:00:11 <whoami-rajat> jungleboyj: Sorry for interrupting, there is a frequent gate failure that yikun and I have been looking at, https://bugs.launchpad.net/cinder/+bug/1803648 . can the cinder team take a look at the patches for it? Thanks.
17:00:12 <openstack> Launchpad bug 1803648 in Cinder "gate failure : testtools.matchers._impl.MismatchError: 'volume.retype' != 'backup.createprogress'" [Undecided,In progress] - Assigned to Rajat Dhasmana (whoami-rajat)
17:00:14 <jungleboyj> And on that note.  We are out of time.
17:00:39 <jungleboyj> whoami-rajat:  Sure.  Can look at that as well.
17:00:39 <jungleboyj> Ok.  Lets wrap up.
17:00:42 <jungleboyj> Thanks team for a good meeting.
17:00:53 <jungleboyj> Hope those of you in the US have a Happy Thanksgiving!
17:01:00 <jungleboyj> Talk to you all next week.
17:01:06 <whoami-rajat> jungleboyj: Thanks! :)
17:01:25 <enriquetaso> Happy thanksgiving!
17:01:27 <jungleboyj> #endmeeting