16:00:46 <jungleboyj> #startmeeting cinder
16:00:47 <openstack> Meeting started Wed Feb 20 16:00:46 2019 UTC and is due to finish in 60 minutes.  The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:50 <openstack> The meeting name has been set to 'cinder'
16:01:09 <jungleboyj> Courtesy ping:  jungleboyj diablo_rojo, diablo_rojo_phon, rajinir tbarron xyang xyang1 e0ne gouthamr thingee erlon tpsilva ganso patrickeast tommylikehu eharney geguileo smcginnis lhx_ lhx__ aspiers jgriffith moshele hwalsh felipemonteiro lpetrut lseki _alastor_ whoami-rajat yikun rosmaita enriquetaso hemna _hemna
16:01:17 <gouthamr> o/
16:01:20 <geguileo> hi! o/
16:01:20 <eharney> hi
16:01:21 <rosmaita> o/
16:01:22 <yikun> o/
16:01:29 <whoami-rajat> Hi
16:01:47 <smcginnis> o/
16:01:53 <jungleboyj> @!
16:01:53 <_pewp_> jungleboyj (。・∀・)ノ
16:02:38 <enriquetaso> o/
16:02:43 <ganso> hello
16:03:08 <jungleboyj> Hello from Snowy Minnesota.
16:03:27 <rosmaita> hello from snowy Virginia :)
16:03:40 * jungleboyj is getting very tired of this winter
16:03:44 * jungleboyj waves
16:03:49 <e0ne> hi
16:05:03 <tbarron> jungleboyj: :) just remembering 12 years in Minneapolis
16:05:21 <jungleboyj> Ok, should probably get started as we have a good number of topics today.
16:05:32 <e0ne> jungleboyj: it's in Kharkiv, my home city about month ago https://www.objectiv.tv/wp-content/uploads/2018/01/1-239.jpg
16:05:37 <xyang> hi
16:05:51 <smcginnis> e0ne: Haha, that looks fun.
16:05:54 <jungleboyj> xyang:  ?  Who is xyang ?  ;-)
16:06:02 <xyang> :)
16:06:36 <jungleboyj> Ok.
16:06:42 <jungleboyj> #topic Announcements
16:06:44 <rosmaita> e0ne: i am ashamed to have mentioned the 2 inches of snow i shoveled this morning
16:07:24 <jungleboyj> e0ne:  Yikes, thanks for putting it in perspective.  :-)
16:07:31 <e0ne> :)
16:07:48 <jungleboyj> #link https://releases.openstack.org/stein/schedule.html
16:08:35 <jungleboyj> So, the week of 3/4 is feature freeze.  So we should be winding down development and starting to focus on testing and bug fixes.
16:09:02 <smcginnis> Don't forget that next week is non-client lib freeze too (os-brick).
16:09:08 <jungleboyj> Which leads into the first topic I have below.
16:09:13 <jungleboyj> smcginnis:  Ah, thank you.
16:09:35 <smcginnis> https://review.openstack.org/#/q/project:openstack/os-brick+status:open
16:10:57 <jungleboyj> I will take a look at those open reviews.
16:11:16 <jungleboyj> geguileo: and hemna_  it would be good to have your input as well.
16:12:04 <geguileo> jungleboyj: ok
16:12:06 <jungleboyj> smcginnis:  Anything more on that topic from you?
16:12:28 <smcginnis> No, just that client lib freeze is soon after that.
16:12:39 <smcginnis> So don't forget those python-cinderclient patches either.
16:12:43 <jungleboyj> Ok.  Cool.
16:13:10 <jungleboyj> Yeah, would be good to make sure we get everything merged that go along with server changes.  We have been bad about that in the past.
16:13:55 <e0ne> there is nothing important to release in https://review.openstack.org/#/q/project:openstack/python-brick-cinderclient-ext++status:open
16:13:56 <jungleboyj> Ok.  Moving on.
16:14:40 <jungleboyj> e0ne: Good.
16:15:07 <jungleboyj> #topic checkup on feature implementation
16:15:20 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-spec-review-tracking
16:15:40 <jungleboyj> So, we didn't do the best job of keeping the spec tracking list updated this time around.  :-(
16:16:08 <jungleboyj> Want to just ask about a few of the things that were of higher priority.
16:16:20 <e0ne> jungleboyj: can we switch to priorities dashboard in gerrit in the next release?
16:16:39 <jungleboyj> smcginnis:  We talked about the upgrade checker goal in RTP.
16:16:40 <smcginnis> e0ne: ++
16:16:56 <jungleboyj> e0ne:  ++
16:17:05 <jungleboyj> Yes, I think that would help.
16:17:09 <smcginnis> Yep. We've met the goal requirement, but would still be great if someone could look through upgrade release notes to see if there's anythign important we should add to that.
16:18:06 <jungleboyj> smcginnis:  That is right.  That was where that was left.
16:18:23 <jungleboyj> smcginnis:  I will take the TODO there.  I think I might have done that at the PTG.
16:18:49 <jungleboyj> #action jungleboyj to review release notes for appropriate checks
16:19:48 * jungleboyj put it on my whiteboard
16:20:07 <e0ne> jungleboyj: did you mean snowboard?
16:20:08 <jungleboyj> e0ne:  Looks like you moved out the Generic Backup Implementation
16:20:14 <jungleboyj> e0ne:  :-p
16:20:27 <jungleboyj> @!j
16:20:28 <_pewp_> jungleboyj (._.) ~ ︵ ┻━┻
16:20:47 <e0ne> jungleboyj: TBH, I didn't push https://review.openstack.org/#/c/630305/ to get everything ready for generic backups this release :(
16:21:24 <jungleboyj> e0ne:  Yeah.  I think it is something we want to push in the future though because people are interested in it.
16:21:39 <e0ne> jungleboyj: I'll finish with unit tests asap and propose generic backup patch but obviously it's too late in a release cycle for such change
16:22:21 <e0ne> I have to propose a spec movement to Train
16:22:44 <jungleboyj> e0ne:  Ok.  Fair enough.
16:23:40 <jungleboyj> e0ne:  Anything more on that?
16:24:07 <e0ne> I'll be glad to have some feedback on https://review.openstack.org/#/c/630305/ and https://review.openstack.org/#/c/620881/
16:24:25 <e0ne> I rebased these patches against master
16:24:34 <e0ne> (just before I read meeting agenda)
16:25:00 <jungleboyj> But we want to hold those two for Train?
16:25:29 <e0ne> https://review.openstack.org/#/c/620881/ looks pretty safe but it's up to the team
16:26:09 <jungleboyj> Ok.  Well, we can work that through the review.
16:26:18 <e0ne> jungleboyj: thank you!
16:26:39 <jungleboyj> e0ne:  No problem.  Thanks for continuing to push stuff in Cinder.  :-)
16:26:55 <jungleboyj> eharney:  Drivers Capability Reporting ...
16:26:58 <e0ne> I'll do my best to finally finish this effort in Train
16:27:12 <jungleboyj> Think based on the discussion at the mid-cycle this should be a priority in Train.
16:27:14 <eharney> i'm working on a spec for this but it's definitely not going very far for Stein
16:27:24 <eharney> yeah
16:27:38 <jungleboyj> eharney:  Actually, that would be a good topic for the Forum with follow up at the PTG.
16:28:07 <eharney> i will probably miss the forum part, but, yes
16:28:11 <jungleboyj> Get input on what users might really want there.
16:28:35 <jungleboyj> Ok, I have a good enough idea of what I would like to see that I could run the session.  Just make sure to get on the same page with you before the forum.
16:28:42 <jungleboyj> I will champion that topic.
16:29:27 <jungleboyj> Ok.  So that makes sense.
16:29:48 <jungleboyj> Looks like the API to re-image an attached volume will also need to move to train?
16:30:39 <jungleboyj> yikun: ^^
16:30:39 <e0ne> +1
16:30:53 <smcginnis> mriedem: If you're around - anything going on with that boot volume reimage work on the nova side?
16:31:15 <yikun> you mean re-image available/reserved volume?
16:31:48 <jungleboyj> yikun:  I thought it was an attached volume.
16:32:08 <mriedem> it's attached
16:32:21 <mriedem> well, technically reserved, but yes we're splitting hairs
16:32:27 <jungleboyj> :-)
16:32:31 <mriedem> smcginnis: the original dev working on the nova changes dropped off
16:32:32 <yikun> we were prepared to only support reseved/available volume in Stein release.
16:32:58 <mriedem> Kevin_Zheng was working on updating the nova side stuff but it's not a priority for him since he has other stuff he was originally assigned to
16:33:28 <mriedem> smcginnis: so with 2 weeks left, i'm not holding out much hope that everything will be merged without some major help and review on the nova side
16:33:28 <jungleboyj> mriedem:  Ok, so not something we should be trying to push to get into Stein.
16:33:35 <mriedem> i don't think so
16:34:14 <jungleboyj> Ok.  We will keep pulling that along.
16:34:58 <jungleboyj> geguileo: I think you got changes for shared_targets improvements in and they didn't get recorded in the etherpad.
16:35:06 <jungleboyj> geguileo:  Is there more that needs to be done there?
16:35:33 <geguileo> jungleboyj: Once we release os-brick I need to land the Nova patch
16:36:02 <geguileo> but nothing more afaik
16:36:22 <jungleboyj> geguileo:  Ok.  Cool.  Any concerns with getting the Nova patch landed?
16:36:35 <geguileo> jungleboyj: not really, it's a trivial patch
16:36:51 <geguileo> removes code with a context manager, cleaning their code
16:36:58 <jungleboyj> geguileo:  Ok.  Cool.  So mriedem shouldn't harass us.  ;-)
16:37:06 <geguileo> XD
16:37:27 <jungleboyj> 👮‍♀️
16:38:14 <jungleboyj> Ok.  I think we are good there so we should move on as we have more to cover.
16:38:27 <jungleboyj> #topic Adding similar type of functionalities under one mv before release
16:38:32 <jungleboyj> whoami-rajat:
16:38:40 <jungleboyj> We talked about this a bit in channel before the meeting.
16:39:18 <jungleboyj> Anyone have concerns with updating a MV ed change without incrementing the MV given that we haven't released it yet.
16:39:52 <e0ne> ay concerns from my side
16:39:59 <whoami-rajat> jungleboyj: also the changes are almost serving similar functionalities.
16:40:00 <eharney> we should probably revise our microversion rules doc a bit to cover this case of small adjustments for changes we've made recently
16:40:10 <smcginnis> My take is, we've never stated we would support continuous deployment, so we should be fine.
16:40:11 <e0ne> it could affect only if somebody uses cinder from master in a production
16:40:29 <e0ne> eharney: +1
16:40:36 <eharney> the current doc indicates we should bump mv again for this, but i agree it's better to be pragmatic here
16:40:39 <jungleboyj> eharney:  ++
16:41:36 <eharney> https://git.openstack.org/cgit/openstack/cinder/tree/doc/source/contributor/api_microversion_dev.rst
16:41:43 <jungleboyj> Ok, does anyone want to take the TODO to update the doc?
16:41:59 <jungleboyj> If not I can take a stab at it.
16:42:03 <jungleboyj> Should be a simple change.
16:42:22 <whoami-rajat> jungleboyj:  i will do it.
16:42:31 <jungleboyj> whoami-rajat:  Awesome.  Thanks.
16:42:32 <whoami-rajat> since i'm the one violating it :)
16:43:23 <jungleboyj> #action whoami-rajat to update documentation on micro version policies.
16:43:38 <smcginnis> whoami-rajat: Thanks!
16:43:56 <whoami-rajat> smcginnis:  np :)
16:44:01 <jungleboyj> whoami-rajat: Yes,  Thank you.  Your contributions are greatly appreciated.
16:44:36 <jungleboyj> #topic Denver Forum and Summit Planning
16:44:48 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-denver-forum-brainstorming
16:44:49 <whoami-rajat> jungleboyj:  wouldn't be possible with all the great help i get here. Thanks for that :)
16:45:00 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-train-ptg-planning
16:45:08 <jungleboyj> whoami-rajat:  Awwww shucks.  :-)
16:45:31 <jungleboyj> So, I have put together etherpads for the Forum and PTG planning.
16:45:59 <jungleboyj> Figured we should create both etherpads now as there are going to be topics that are appropriate for each venue brought up.
16:46:40 <jungleboyj> The Forum ones are reviewed first though, so please take a few minutes to add anything in there that may be appropriate to discuss with operators.
16:46:53 <jungleboyj> I will be adding the capabilities topic in there.
16:48:01 <jungleboyj> Appreciate your attention to the etherpads.
16:48:19 <jungleboyj> I think that is all I have to say there.
16:48:53 <jungleboyj> #topic Continued discussion with regards to Storyboard ...
16:49:13 <e0ne> I'm OK to use storyboard now
16:49:24 <jungleboyj> e0ne:  Ok.
16:49:38 <e0ne> we're using it in vitrage since Rocky release and it works good
16:49:52 <jungleboyj> The issue I saw during the mid-cycle was resolved.
16:50:11 <e0ne> we can't use it in horizon now because it doesn't support attachements
16:50:31 <rosmaita> that's going to be a problem for security bugs, too
16:50:42 <jungleboyj> e0ne:  The attachments stuff is being fixed right now.
16:50:54 <enriquetaso> where can I find the link to the storyboard?
16:51:01 <e0ne> jungleboyj: oh.. thanks for letting me know
16:51:10 <jungleboyj> I have gotten feedback from diablo_rojo on the design we talked about at the mid-cycle
16:51:14 <e0ne> enriquetaso: https://storyboard.openstack.org
16:51:20 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-launchpad-design
16:51:33 <enriquetaso> e0ne++
16:51:37 <jungleboyj> The test migration is here:  https://storyboard-dev.openstack.org/#!/project/473
16:52:05 <jungleboyj> So, that is the current status.
16:52:36 <jungleboyj> Now we have Cinderlib coming into place and we need to decide if it will use Storyboard for the bug tracking or not.
16:52:58 <jungleboyj> smcginnis:  Raised concerns that Cinder is still using Launchpad.
16:53:30 <jungleboyj> Though, the bug tracking for os-brick has been in its own part of launchpad.
16:53:43 <smcginnis> Yeah, fine I guess if we just have the one using SB.
16:53:58 <jungleboyj> We could use cinderlib and os-brick as the starting points for migration.
16:54:02 <smcginnis> But with the tight coupling between cinderlib and the drivers in openstack/cinder, I was concerned there would be a lot of overlap.
16:54:24 <jungleboyj> Start with cinderlib and then re-address as we go forward.
16:55:08 <geguileo> I think we can start with cinderlib
16:55:16 <geguileo> then migrate os-brick
16:55:30 <geguileo> and then we can continue with others...
16:55:31 <rosmaita> only problem i see is if we want to use the "also affects project" in launchpad
16:55:37 <smcginnis> Any reason to wait on os-brick? Or want to get one there and figure out usage first?
16:55:57 <geguileo> I think we can also move os-brick now
16:56:03 <smcginnis> rosmaita: Exactly. I was thinking we may have a few of those when it comes to this.
16:56:11 <geguileo> I was just mentioning in case we wanted to be extra careful
16:56:34 <jungleboyj> smcginnis:  I would like to get how we want to use Storyboard actually documented and mocked out in the test migration.
16:56:49 <smcginnis> Or... we just rip off the bandaid and migrate everything over and not have to be concerned about which ones are where.
16:56:55 <geguileo> jungleboyj: then I can just change the cinderlib project to use launchpad
16:57:19 <geguileo> and then we continue with our current plan
16:57:32 <jungleboyj> The process will be a bit of overkill for cinderlib but I think it is a good way for us to get used to launchpad and propose fixes.
16:57:43 <jungleboyj> I am fine with moving os-brick as well.
16:57:57 <enriquetaso> Should we add the storyboard's number to gerrit's patchs?
16:58:09 <whoami-rajat> one query. how will the migration process work exactly? will it automatically report all the existing bugs from launchpad to storyboard or is there any manual intervention?
16:59:01 <jungleboyj> enriquetaso:  For os-brick or cinderlib patches, yes.
16:59:04 <smcginnis> enriquetaso: Yes, once a project is migrated we will want to link patches to the story like we currently do with launchpad bugs.
16:59:05 <jungleboyj> Not for CInder yet.
16:59:29 <jungleboyj> whoami-rajat:  It is an automatic migration they run.
16:59:38 <geguileo> jungleboyj: I think I'm getting more and more convinced by smcginnis' idea of adding cinderlib to launchpad
16:59:39 <geguileo> XD
16:59:49 <jungleboyj> geguileo:  Wait, what?
17:00:06 <geguileo> lol
17:00:14 <rosmaita> i vote we wait to move until nova has migrated
17:00:17 <geguileo> jungleboyj: if you want to have things documented before migrating os-brick
17:00:35 <geguileo> then it makes sense to have cinderlib together with the other projects
17:00:40 <jungleboyj> geguileo: :-p  I am trying to push myself to make some progress here.
17:01:07 <geguileo> jungleboyj: me too, I want to get the cinderlib project in
17:01:13 <smcginnis> ++
17:01:17 <geguileo> and it looks like launchpad is easier, and it makes more sense
17:01:21 <geguileo> in the cinder context
17:01:23 <jungleboyj> Ok.  We are supposed to wrap up here .  Lets finish in the cinder channel.
17:01:24 <geguileo> rosmaita: ++
17:01:34 <smcginnis> Getting it in is more important than us using storyboard, IMO.
17:01:35 <geguileo> rosmaita: sounds like a good idea, wait until Nova!!!!!!!
17:01:36 <rosmaita> i'm worried that since we had to move cinderlib to its own repo and don't have cross-project testing set up/possible, don't want to have another place where bugs can fall through the cracks
17:02:07 <jungleboyj> Lets finish this in channel.
17:02:11 <jungleboyj> #endmeeting