16:01:12 <jungleboyj> #startmeeting Cinder
16:01:13 <openstack> Meeting started Wed Jul 3 16:01:12 2019 UTC and is due to finish in 60 minutes. The chair is jungleboyj. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:16 <openstack> The meeting name has been set to 'cinder'
16:01:31 <jungleboyj> Courtesy ping: jungleboyj whoami-rajat rajinir lseki carloss pots woojay erlon geguileo eharney rosmaita enriquetaso e0ne smcginnis davidsha walshh_ xyang hemna _hemna
16:01:39 <rosmaita> o/
16:01:45 <lseki> \o
16:01:51 <eharney> hi
16:02:04 <e0ne> hi
16:02:46 <xyang> Hi
16:02:49 <smcginnis> ./
16:02:52 <jungleboyj> @!
16:02:52 <_pewp_> jungleboyj (;-_-)ノ
16:02:58 <davidsha> Hey
16:03:25 <jungleboyj> Give people one mor eminute to join.
16:04:15 <jungleboyj> Ok, guessing that may be all that we get given that it is a holiday week in the US.
16:04:23 <jungleboyj> #topic announcements
16:04:26 <_erlon_> hey
16:04:53 <jungleboyj> We have Milestone 2 coming up in just a couple of weeks.
16:04:59 <jungleboyj> July 22nd.
16:05:07 <jungleboyj> #link https://releases.openstack.org/train/schedule.html
16:05:45 <jungleboyj> That is our Spec and New Driver freeze.
16:06:22 <jungleboyj> So, just a reminder in this case.
16:07:11 <rosmaita> ok
16:07:13 <jungleboyj> Also, a reminder that we will start looking to see if the 3rd Party CIs are running Py3.
16:07:57 <jungleboyj> If not around MS2, right after and then patches to unsupport drivers that aren't in compliance will happen soon.
16:08:39 <jungleboyj> Any questions around those two announcements?
16:08:59 <jungleboyj> Ok.
16:09:00 <eharney> well, the volume-rekey spec has been up for weeks with 0 feedback... is someone going to review it? :)
16:09:19 <jungleboyj> eharney: Great, that leads into my next topic. :-)
16:09:30 <jungleboyj> #topic reviews for MS 2
16:10:05 <jungleboyj> So, I went through the open spec reviews and listed the ones that I remembered being discussed at the PTG.
16:10:16 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-train-meetings
16:10:43 <jungleboyj> A few of the specs are waiting on user feedback. If they are yours, please address.
16:11:02 <rosmaita> ok
16:11:03 <jungleboyj> eharney: I can removed the Backend Capabilities one.
16:11:28 <jungleboyj> eharney: Did you mean to have a -2 on the Image Encryption one?
16:11:31 <e0ne> jungleboyj: I'll add few minor changes to my spec this week
16:11:39 <eharney> until some questions got sorted out, yes
16:11:54 <e0ne> jungleboyj: btw, thanks for your changes! I appreciate it
16:12:24 <jungleboyj> Ok. Doesn't look like luzi is here. I will ping her in the review.
16:12:33 <eharney> they may have been answered already
16:12:45 <eharney> i'm still fairly concerned about that whole feature, but i seem to be the only one, so... i dunno
16:13:36 <jungleboyj> eharney: Looks like they have responded if you can take a look.
16:14:57 <jungleboyj> I will look at the Volume Rekey spec and catch up on the other ones in there. Would appreciate help from the rest of the team to do the same.
16:15:34 <jungleboyj> There is also the Tengling driver to look at.
16:16:04 <jungleboyj> They haven't responded since may though.
16:16:06 <smcginnis> Did they respond to comments yet?
16:16:35 <smcginnis> Great if someone can go through and list more of the issues on that one, but probably not worth spending much time on, IMO.
16:17:04 <smcginnis> The chances of that being anywhere ready by the deadline are extremely low with the lack of repsonse there.
16:17:23 <jungleboyj> smcginnis: Agreed.
16:18:36 <jungleboyj> So, if there is no more on the specs.
16:18:49 <jungleboyj> That was all I had for today's agenda.
16:19:42 <jungleboyj> #topic Open Discussion
16:20:22 <jungleboyj> Is there anything else that people wanted to talk about today?
16:20:51 <rosmaita> i have a quick question about a backport
16:21:03 <jungleboyj> Okie dokie.
16:21:07 <rosmaita> this is proposed for queens: https://review.opendev.org/#/c/668353/
16:21:20 <rosmaita> it fixes a py37 tests problem
16:21:47 <rosmaita> i guess it's harmless, but do we care about py37 that far back?
16:21:57 <jungleboyj> Ah, Didn't realize that was for py37
16:22:04 <clarkb> Not sure if you've seen my email to openstack-discuss about tempest jobs swapping but cinder-backup seems to be at least part of the problem
16:22:08 <rosmaita> just asking because maybe there's a stable gate problem i'm not aware of
16:22:08 <jungleboyj> Not really. But it is harmless.
16:22:32 <clarkb> It appears that there are plans to remove cinder-backup from default test jobs (which is probably fine) but you may want to invenstigate why cinder-backup might be using more memory than expected anyway
16:23:20 <jungleboyj> clarkb: Interesting.
16:23:33 <jungleboyj> Has anyone on the team looked into this?
16:24:00 <rosmaita> not me ... clarkb do you mean this email: http://lists.openstack.org/pipermail/openstack-discuss/2019-July/007493.html
16:24:09 <clarkb> yes that one
16:24:12 <rosmaita> (just to get it into the log)
16:24:48 <jungleboyj> rosmaita: Thank you.
16:25:45 <jungleboyj> rosmaita: You said geguileo is on vacation?
16:26:10 <rosmaita> yes, though he is on a geguileo "vacation" (i.e., might show up randomly)
16:26:30 <jungleboyj> Ok. Just thinking he was the one to touch backup most recently. :-)
16:26:57 <smcginnis> Would be interesting to see if the change in threading changed that.
16:27:06 <jungleboyj> smcginnis: ++
16:27:13 <smcginnis> I wonder if each thread gets a full copy of everything loaded into memory or something?
16:27:25 <eharney> the threading changes in backup have been there for a while...
16:27:34 <clarkb> fwiw I'm not sure when this started
16:27:38 <clarkb> its been a while since I had to run tempest locally
16:27:45 <jungleboyj> I could see backup causing a lot of caching into memory happening.
16:27:56 <jungleboyj> But that shouldn't force things into swapping.
16:28:19 <clarkb> also the two different memory tracker tools we have disagree on memory useage
16:28:28 <clarkb> so I think the big value may be virtual and the smaller number resident
16:28:47 <clarkb> But that may indicate we use a lot of memory when cinder-backup is active then it goes virtual afterwards
16:28:57 <clarkb> (not sure, needs investigating)
16:29:21 <jungleboyj> Ok.
16:29:56 <jungleboyj> Do we know that we are covering the backup tests in another test run?
16:30:18 <e0ne> need to check it
16:30:37 <jungleboyj> e0ne: Oh, that is right, you have been working on backup as well.
16:30:40 <e0ne> I suppose it's only issue with swift and maybe nfs drivers
16:30:55 <e0ne> ceph driver should not have this issue but I didn't check
16:31:25 <e0ne> #action e0ne to check memory usage by backup drivers
16:31:46 <jungleboyj> e0ne: Thank you!
16:31:53 <e0ne> jungleboyj: np
16:33:15 <jungleboyj> Ok. So ... Any other topics for this week?
16:33:54 <smcginnis> nyet
16:33:59 <jungleboyj> :-)
16:34:00 <eharney> https://review.opendev.org/#/c/664430/ could use some review too
16:34:18 <eharney> cinderclient shell version negotiation
16:34:54 <jungleboyj> #link https://review.opendev.org/#/c/664430/
16:35:02 <jungleboyj> Ok. Yeah, that would be good to get reviewed.
16:35:34 <eharney> it needs some tweaking in tests, but, making sure the direction is right would be useful
16:35:43 <jungleboyj> :-)
16:36:47 <jungleboyj> Last call.
16:37:29 <jungleboyj> Ok. If no one has topics I will wrap things up so that you can all go review specs.
16:37:32 <jungleboyj> :-)
16:37:47 <jungleboyj> Hope everyone in the US has a safe and happy 4th of July.
16:38:02 <jungleboyj> Talk to everyone next week!
16:38:05 <rosmaita> and enjoy the parades :P
16:38:11 <whoami-rajat> Thanks jungleboyj
16:38:11 <jungleboyj> :-)
16:38:25 <jungleboyj> @!
16:38:25 <_pewp_> jungleboyj (ه’́⌣’̀ه )/
16:38:31 <jungleboyj> #endmeeting