16:00:01 <rosmaita> #startmeeting cinder
16:00:02 <openstack> Meeting started Wed Nov 20 16:00:01 2019 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'cinder'
16:00:08 <whoami-rajat> Hi
16:00:13 <davee_> Hi
16:00:13 <rosmaita> o/
16:00:20 <eharney> hi
16:00:25 <jungleboyj> @!
16:00:25 <_pewp_> jungleboyj ( ^_^)/
16:00:32 <rosmaita> #link https://etherpad.openstack.org/p/cinder-ussuri-meetings
16:00:35 <jungleboyj> Lets get this party started!
16:00:40 <jungleboyj> @!h
16:00:40 <_pewp_> jungleboyj (/ .□.) ︵╰(゜Д゜)╯︵ /(.□. )
16:00:41 <enriquetaso> hi
16:00:44 <bcm> hi o/ thought I might evesdrop on this meeting.
16:01:13 <jungleboyj> bcm:  Welcome.
16:01:29 <jungleboyj> Are you using Cinder or looking to contribute or ????
16:01:33 <rosmaita> we have no problem with eavesdroppers
16:01:47 <tosky> o/
16:01:57 <tosky> no ping?
16:02:05 <rosmaita> looks like a decent turnout, i will get started
16:02:20 <jungleboyj> tosky:  He did it in the Cinder channel.
16:02:22 <rosmaita> tosky: i did a ping in cinder channel
16:02:25 <jungleboyj> New PTL changing something esle too?
16:02:25 <tosky> ups
16:02:35 <rosmaita> tosky: btw thank you for your work on the gate yesterday
16:02:40 <bcm> thanks jungleboyj rosmaita tosky, i actually have a review i'd like to get some opinions on if time permits
16:02:49 <jungleboyj> tosky:  ++
16:02:59 <rosmaita> should be time, i saw you post it in open dicsussion
16:03:02 <tosky> :)
16:03:12 <bcm> cool thanks :)
16:03:20 <rosmaita> #topic announcements
16:03:31 <rosmaita> #topic announcements -- virtual ptg
16:03:46 <rosmaita> #link https://etherpad.openstack.org/p/cinder-ussuri-virtual-ptg-planning
16:04:00 <rosmaita> ok, about the days/times
16:04:18 <rosmaita> Cinder Ussuri Virtual PTG Poll had 13 responses
16:04:29 <rosmaita> Wednesday 1500-1700 UTC is OK for everyone except one person, so one session will happen on Wednesday
16:04:40 <rosmaita> The Thursday and Friday time slots: more than half can't attend, so both those days are out.
16:05:24 <rosmaita> Tuesday 1400-1600: 30% can't attend or not first choice
16:05:24 <rosmaita> Tuesday 1500-1700: 23% can't attend or not first choice
16:05:24 <rosmaita> Monday 1400-1600: 30% can't attend or not first choice
16:05:38 <rosmaita> Monday 1500-1700: only time slot where no one says they cannot attend
16:05:38 <rosmaita> 92% either "love it" or "works for me"
16:06:03 <rosmaita> So, we will use Monday 1500-1700 to kick off the virtual PTG
16:06:10 <rosmaita> and finish on Wednesday
16:06:27 <jungleboyj> Nice.
16:06:34 <rosmaita> i should be completely clear
16:06:37 <rosmaita> So, the Virtual PTG will be:
16:06:38 <rosmaita> Monday 25 November 1500-1700 UTC
16:06:38 <rosmaita> Wednesday 27 November 1500-1700 UTC
16:06:49 <rosmaita> and the planning etherpad is:
16:06:55 <rosmaita> https://etherpad.openstack.org/p/cinder-ussuri-virtual-ptg-planning
16:07:20 <rosmaita> We will do the usual thing, start at the beginning, give each topic what it takes, and finish when we are done
16:07:47 <rosmaita> i put some stuff on the planning pad already, mostly follow ups from the shanghai PTG
16:07:48 <jungleboyj> What is the meeting medium?
16:07:55 <jungleboyj> BlueJeans?
16:08:04 <rosmaita> yes, bluejeans
16:08:19 <jungleboyj> Ah, already in the etherpad.
16:08:20 <jungleboyj> Nice.
16:08:22 <rosmaita> link is on the etherpad unless i pasted it somewhere else by mistake
16:08:27 <rosmaita> ok, cool
16:08:42 <e0ne> :)
16:08:50 <rosmaita> if you haven't used bluejeans before, ping me in irc and i can do a quick meeting with you to make sure you can connect OK
16:08:54 * jungleboyj puts it on the calendar.
16:09:11 <rosmaita> i will also be online early on monday (at least 20 min early) if you want to try then
16:09:26 <rosmaita> i will put all this info into an email later today
16:09:47 <rosmaita> as far as topics go: feel free to propose anything
16:10:09 <rosmaita> also, if there's something you want to follow up from the Shanghai ptg that's not there, feel free to add it
16:10:30 <rosmaita> and, we will record these 2 sessions in case anyone can't make it
16:10:50 <rosmaita> though like i said earlier, there was good consensus on these times
16:11:02 <rosmaita> any questions?
16:11:32 <jungleboyj> Thanks for setting it up.
16:11:48 <whoami-rajat_> rosmaita: I think the extending default volume type for tenants topic isn't there, should I add it?
16:11:51 <rosmaita> np, i hope it goes smoothly!
16:12:16 <rosmaita> whoami-rajat_: sure
16:12:31 <whoami-rajat_> Ok
16:12:39 <rosmaita> would be good to get a quick discussion of that before gorka writes the spec
16:13:02 <rajinir> o/
16:13:20 <rosmaita> ok, we can discuss more in open discussion if anything else occurs to anyone
16:13:28 <whoami-rajat_> rosmaita: oh, I thought I volunteered for that :/
16:13:48 <rosmaita> whoami-rajat_: maybe you did, i may be thinking of something else
16:14:21 <whoami-rajat_> rosmaita: oh ok
16:14:51 <rosmaita> and even if gorka volunteered to do it, i am sure he will not mind the help
16:15:36 <whoami-rajat_> rosmaita: yep, surely, he proposed the topic and have better knowledge of it
16:15:47 <whoami-rajat_> I could share the workload
16:16:06 <rosmaita> that will be great
16:16:09 <rosmaita> #topic announcements -- spec repo maintenance
16:16:26 <rosmaita> ok, abhishek pointed out that there's no 'ussuri' directory yet
16:16:43 <rosmaita> i will rectify that this afternoone
16:16:48 <jungleboyj> rosmaita:  __
16:16:51 <jungleboyj> ++
16:17:04 <rosmaita> i was wondering what __ was !
16:17:30 <rosmaita> #topic announcements -- meeting time change
16:17:59 <rosmaita> ok, the poll doesn't close until 23:59 today, but i don't think anything is going to happen to change the current results
16:18:36 <rosmaita> i have no idea why i didn't make the deadline yesterday
16:18:46 <rosmaita> but i guess i'm stuck with that
16:19:06 <davee_> I demand a recount he he he
16:19:11 <rosmaita> so to be scrupulously fair, i will send out an email after the poll closes
16:19:31 <rosmaita> so, please look for the email so you are ready for the next meeting
16:19:37 <rosmaita> which will *not* be next week
16:19:40 <jungleboyj> I vote we throw the poll out due to mismanagement.
16:19:48 <rosmaita> we are having the virtual PTG at that time
16:20:29 <rosmaita> so the first meeting at possibly a new time will be 4 December
16:20:48 <rosmaita> depending on what the time is, it may also entail a change of location
16:20:59 <rosmaita> as there are conflicts in this channel
16:21:18 <rosmaita> but, #openstack-cinder is set up with the meetbot
16:21:41 <tosky> there are 4 general meeting rooms, no one is available?
16:21:47 <rosmaita> and a lot of projects are having their weekly meetings in their own channel these days
16:22:08 <rosmaita> tosky: i stopped looking once i found out we have the meetbot in #openstack-cinder
16:22:09 <tosky> but what is the time exactly? The virtual PTG uses 4 slots
16:22:25 <davee_> I accidentally made a #openstack-meeting4
16:22:52 <rosmaita> i guess i should ask, is there any reason *not* to have the weekly meeting in #openstack-cinder
16:23:12 <rosmaita> my thought was that if we have to move it, might as well just move it to our own channel
16:23:30 <davee_> easier not to be interrupted by people asking for support in the middle of the meeting and muddying up the meeting notes
16:23:32 <rosmaita> tosky: the virtual ptg will be in bluejeans
16:24:04 <rosmaita> davee_: i suppose that's true
16:24:27 <rosmaita> i know that #openstack-meeting-alt is not available
16:24:37 <tosky> rosmaita: yes, but what is the time? You only said that we are going to have the virtual PTG at that time, but the virtual PTG is spread over 4 hours :)
16:24:49 <tosky> unless I missed something from the logs
16:25:05 <rosmaita> tosky: i am being cagy about the meeting time because the poll is still open
16:25:16 <tosky> oh, I see
16:25:43 <davee_> There's a new sheriff in town
16:25:53 <rosmaita> jungleboyj: what do you think about having the meeting in #openstack-cinder ?
16:25:53 <jungleboyj> Yeeehaw!
16:25:59 <rosmaita> the weekly meeting, i mean
16:26:08 <tosky> (I just need to mention that the are also #openstack-meeting-3 and #openstack-meeting-4 , just in case)
16:26:21 <jungleboyj> davee_:  Has a decent point about people interrupting and muddying things up.
16:26:41 <jungleboyj> I don't have a strong preference though.  We can try it.
16:26:55 <rosmaita> ok, then i will follow up on tosky's suggestion
16:27:06 <jungleboyj> Oslo has been just using their channel and that seems to work fine.
16:27:08 <rosmaita> tosky: who reserves the rooms ? infra team?
16:27:16 <tosky> but of course it can be on the channel as well
16:27:28 <rosmaita> yeah, oslo, airship, a whole bunch of other teams
16:27:50 <tosky> I think the procedure is the same regardless of the chosen room: a patch to the repository which regenerates eavesdrop.openstack.org
16:28:00 <whoami-rajat> Additionally, there will be patch proposal messages between the meeting notes
16:28:01 <rosmaita> i was thinking of using #openstack-cinder because no one can reserve it away from us
16:28:06 <bnemec> The downside IMHO is that it makes pinging people from other projects harder because they're not necessarily in your channel.
16:28:32 <bnemec> We don't tend to have a big problem with interruptions, but then the oslo channel is pretty dead in general so YMMV. :-)
16:29:02 <tosky> so opendev/irc-meetings, this file: https://opendev.org/opendev/irc-meetings/src/branch/master/meetings/cinder-team-meeting.yaml
16:29:15 <rosmaita> tosky: ty
16:29:42 <rosmaita> ok, the key point is that everyone needs to watch for an email about the new time and location
16:29:51 <enriquetaso> rosmaita++
16:29:58 * jungleboyj waits with baited breath
16:30:20 <whoami-rajat> rosmaita, ++
16:31:52 <rosmaita> ok, i guess that's it for announcements
16:32:01 <rosmaita> #topic python 2 testing situation
16:32:23 <rosmaita> tosky can answer questions, but nova broke the gates yesterday
16:32:42 <rosmaita> it could not be installed under py2
16:32:55 <rosmaita> because of https://review.opendev.org/#/c/687954/
16:33:10 <rosmaita> so this patch is a partial reversion: https://review.opendev.org/#/c/695007/
16:33:47 <rosmaita> but the key thing is, we need to remove our py2 jobs, i think
16:33:51 <rosmaita> this is what i propose:
16:34:02 <rosmaita> - for all components, remove the Py 2 support from the classifiers in setup.cfg
16:34:02 <tosky> the problem in that case that not only they removed the py2 testing, but also prevented others from installing nova with py2
16:34:02 <rosmaita> - remove py2 tests from tox.ini
16:34:02 <rosmaita> - remove the explicit py2 jobs from .zuul.yaml
16:34:27 <rosmaita> what tosky said
16:34:38 <rosmaita> Nova had "python-requires = >=3.6" in setup.cfg, but that's what was breaking everything, so we should wait until January to make that change
16:34:58 <tosky> also, they removed the py2-specific items from *requirements.txt
16:35:30 <tosky> so as long as requirements.txt is untouched and there are no strange conditions like that forced python version in the setup, it should be fine
16:36:32 <eharney> neat
16:36:39 <tosky> implementing the steps rosmaita listed above should be fine
16:36:47 <rosmaita> ok, cool
16:37:15 <whoami-rajat> https://review.opendev.org/#/c/649097/ this might allow the requirements change?
16:37:45 <eharney> so we can probably start killing off python-six during U, too
16:37:51 <rosmaita> how about i put up the patch for cinder this afternoon (i am on New York time), tosky can review it tomorrow, and if it looks fine, i'll pathch the other components
16:37:55 <tosky> just one thing about explicit py2 jobs: the devstack default is going to switch to py3 (if the patch passes, I think it was merged), so that should help as well (we may want to remove the explicit py3 jobs and switch the py2 jobs to explicitly use py3)
16:38:18 <rosmaita> eharney: yeah, smcginnis and e0ne are fighting over who gets to remove six
16:38:20 <tosky> whoami-rajat: that's the "py3 by default on devstack", correct
16:38:39 <jungleboyj> He he.
16:38:39 <e0ne> rosmaita: :)
16:38:50 <tosky> whoami-rajat: but I would play it safe and not break the py2 jobs for others (someone may have set it explicitly)
16:38:54 <eharney> i'm sure there will be plenty of patches for everyone to do some of it :)
16:39:15 <tosky> not now, at least; there is a deadline where everyone is supposed to switch (with one exception, swift)
16:39:19 <rosmaita> it's on the agenda for the virtual PTG, so maybe we can divide up the work
16:39:45 <whoami-rajat> tosky, ++, making safe changes is better than breaking gate
16:39:51 <tosky> I would advise to not rip out six until the official deadline for killing py2, but that should be in a month or so
16:39:57 <rosmaita> #action rosmaita review this discussion and put up a patch to remove py2 testing from cinder in an excellent way
16:40:00 <tosky> the patches could be prepared anyway
16:40:08 <tosky> but up to you, and let's see the general status
16:40:38 <rosmaita> Ok, that's all i had on that topic
16:40:46 <rosmaita> #topic open discussion
16:41:00 <rosmaita> ok, we need reviews on https://review.opendev.org/#/c/685914/
16:41:13 <rosmaita> it's a patch making volume type non nullable in the db
16:41:25 <whoami-rajat> rosmaita, thanks for putting up the RP+1
16:41:39 <rosmaita> np, i think we should get it in early
16:41:50 <rosmaita> bcm: you had something for us?
16:41:52 <jungleboyj> That looks like a decent idea.  :-)
16:42:02 <whoami-rajat> for volumes, snapshots and encryption table (where volume_type_id) is used
16:42:22 <bcm> hey - so I was waning to get some feedback on https://review.opendev.org/#/c/579004/
16:42:53 <rosmaita> wow, that's been around for a while
16:43:17 <bcm> I might be asking in the wrong place, I understand its nova code, but my question is basically what is/should be the best practice/ best way to handle stale connection info, and does cinder have an opinion on that?
16:44:15 <bcm> my understanding from the feedback on the review is that this code does the thing (CI issues aside) but its doing it "the old way"
16:47:02 <bcm> so I'm weighing up if its worth going to the CI issues and trying to merge this or look into an alternate path.
16:51:12 <rosmaita> looks like everyone is speechless
16:51:36 <rosmaita> i think we'll have to look at this offline and get back to you on the review
16:52:57 <rosmaita> anything else for open discussion?
16:53:05 <bcm> ok no problem, I might bring this up on the ML/ nova/nova meeting. Thanks
16:53:37 <rosmaita> bcm: sounds good
16:54:35 <rosmaita> ok, don't forget virtual PTG monday and wednesday next week, details on https://etherpad.openstack.org/p/cinder-ussuri-virtual-ptg-planning
16:55:17 <rosmaita> watch the ML for an announcement about the next cinder meeting time/location, which will be on 4 December
16:55:29 <rosmaita> that's all i've got, anything else?
16:57:09 <rosmaita> ok, thanks everyone, you can have a few minutes back today
16:57:12 <rosmaita> #endmeeting