14:00:01 <rosmaita> #startmeeting cinder
14:00:02 <openstack> Meeting started Wed Mar 24 14:00:01 2021 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <openstack> The meeting name has been set to 'cinder'
14:00:12 <rosmaita> #topic cinder roll call
14:00:15 <whoami-rajat> Hi
14:00:16 <enriquetaso> hi
14:00:24 <eharney> hi
14:00:28 <jungleboyj> o/
14:00:42 <e0ne> hi
14:01:40 <geguileo> hi! o/
14:02:24 <walshh_> hi
14:02:31 <rosmaita> hello everyone
14:02:31 <rosmaita> let's get started
14:02:31 <rosmaita> #link https://etherpad.openstack.org/p/cinder-wallaby-meetings
14:02:44 <rosmaita> #topic announcements
14:03:03 <rosmaita> RC-1 for wallaby will be released tomorrow
14:03:19 <rosmaita> and at that point the stable/wallaby branch will be cut
14:03:28 <rosmaita> master will become xena development
14:03:43 <enriquetaso> \o/
14:04:14 <rosmaita> any release-critical bugs will have to merge to master and then be backported to stable/wallaby to be in RC-2
14:04:50 <rosmaita> so, any non-release-critical stuff must be merged by early tomorrow
14:05:15 <rosmaita> so, people need to review like crazy today, and people with patches need to revise and resubmit quickly
14:05:34 <rosmaita> i sent out an email yesterday about the major priorities
14:06:03 <rosmaita> or at least i think i did
14:06:26 <e0ne> rosmaita: :)
14:06:40 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-March/021256.html
14:06:51 <rosmaita> major stuff there are the follow-ups to features
14:07:08 <rosmaita> and geguileo has a stack of quotas fixes for your reviewing pleasure
14:07:35 <geguileo> most of them are trivial, though there's at least one that is a bit painful
14:07:58 <whoami-rajat> rosmaita: not sure how important it is but volume show doesn't work for non-admins (for mv>3.31) https://review.opendev.org/c/openstack/cinder/+/778373
14:08:10 * jungleboyj will make review time today
14:08:17 <geguileo> whoami-rajat: whaaaaat?
14:08:37 <e0ne> whoami-rajat: seems like a critical thing
14:08:48 <geguileo> e0ne: +1
14:09:23 <rosmaita> i didn't know you could show a volume by name
14:09:35 <geguileo> oooooooh, reading the comment, that's not a Cinder issue, it's the client
14:09:51 <tosky> cinderclient one? Does it need more functional tests there?
14:09:54 <geguileo> cinder should fail on that request
14:10:10 <rosmaita> and it does!!! problem solved!!!
14:10:15 <geguileo> if the client asks for all_tenants info and it doesn't have access, it should fail
14:10:36 <geguileo> imo
14:10:40 <whoami-rajat> geguileo:  yeah but client doesn't know if the user is admin or not, we fixed similar issues before for revert to snapshot and transfer show by name
14:11:01 <geguileo> whoami-rajat: I hope I didn't review those patches, because I think the approach is wrong
14:11:11 <geguileo> we should not be passing client problems into the REST API
14:11:19 <rosmaita> it's a relatively new bug, so let's discuss at the bug squad meeting
14:11:20 <whoami-rajat> geguileo: i think you provided the fix for revert to snapshot
14:11:28 <enriquetaso> #link https://bugs.launchpad.net/cinder/+bug/1917574
14:11:38 <openstack> enriquetaso: Error: Could not gather data from Launchpad for bug #1917574 (https://launchpad.net/bugs/1917574). The error has been logged
14:11:38 * geguileo dies inside
14:12:03 <geguileo> rosmaita: +1
14:12:09 <whoami-rajat> +1
14:12:10 <rosmaita> ok, whoami-rajat brings up a good point about how we will be determining release-critical bugs
14:13:17 <rosmaita> i guess i should continue that thought
14:14:34 <rosmaita> i guess an etherpad?
14:14:55 <whoami-rajat> +1 for etherpad
14:15:05 <jungleboyj> +1
14:15:07 <rosmaita> i am very inarticulate this morning
14:15:12 <rosmaita> ok, etherpad it is
14:15:35 <rosmaita> #link https://etherpad.opendev.org/p/cinder-wallaby-release-critical-bug-nominations
14:16:12 <rosmaita> so, if you are working on something you think may be release critical, add it ^^ and i will decide & raise priority accordingly
14:16:33 <rosmaita> reviewers, you can work from the dashboard
14:16:35 <rosmaita> #link http://tiny.cc/CinderPriorities
14:18:14 <rosmaita> ok, announcements continued
14:18:30 <rosmaita> next week is last week of the month, so time for a video meeting
14:18:54 <rosmaita> connection info will be on the agenda and i will try to remember to send out a reminder email
14:19:21 <rosmaita> and, we now have two more "official" meetings
14:19:35 <rosmaita> sofia is leading the bug squad, right after this meeting
14:19:42 <enriquetaso> \ΓΈ/
14:19:46 <rosmaita> #link http://eavesdrop.openstack.org/#Cinder_Bug_Squad_Meeting
14:20:07 <rosmaita> and we decided last week to hold the festival of reviews the third friday of each month
14:20:17 <rosmaita> #link http://eavesdrop.openstack.org/#Cinder_Festival_of_XS_Reviews
14:20:38 <rosmaita> if you go to those links, you can find a handy ICS file to add them to your calendar
14:21:15 <rosmaita> ok, that's all from me ... anyone else have an announcement to share with the team?
14:21:26 <jungleboyj> Nice.
14:22:24 <rosmaita> ok, moving on
14:22:32 <rosmaita> #topic lower constraints job
14:22:51 <rosmaita> the TC has decided that the lower-constraints job is optional
14:23:07 <rosmaita> and that even if you do run it in master, it is *really* optional in the stable branches
14:23:34 <rosmaita> so, there are a few issues we should consider as a team, but we will do that at the PTG
14:24:03 <rosmaita> so we'll keep it as is for the wallaby release (it's working!), because it will be removed from stable/wallaby anyway
14:24:18 <rosmaita> and we can decide later how to handle it in the development branch
14:24:37 <rosmaita> but on that note, i have a patch up to tell cinder to use wallaby os-brick
14:24:57 <rosmaita> and that patch adjusts the requirements and lower-constraints to match os-brick
14:25:10 <rosmaita> so that does need to merge soon (like today?)
14:25:27 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/779646
14:25:52 <rosmaita> btw, other than that, i will not be adjusting requirements or lower-constraints
14:26:22 <rosmaita> i looked last night, and the change in february caused by pip 20+ brought us pretty close to reality
14:26:42 <rosmaita> but take a look, and if you have questions, please leave them on the review
14:26:51 <rosmaita> unless someone has a question now?
14:27:58 <rosmaita> yeah, i know, the excitement of lower constraints has everyone speechless
14:28:07 <rosmaita> #topic cgroups in cinder
14:28:21 <rosmaita> ok, this one is from zigo who said he couldn't be here
14:28:38 <rosmaita> so he left a big message in the agenda
14:28:52 <eharney> well, the proposal to move to cgroups v2 makes sense, and we should do it
14:29:04 <enriquetaso> is it related to https://bugs.launchpad.net/cinder/+bug/1920912 ?
14:29:05 <openstack> Launchpad bug 1920912 in Cinder "add of volume to a group which was created from group snapshot of another consistency group fails and group goes into error state" [Undecided,New]
14:29:05 <eharney> i haven't yet looked into how much work that involves
14:29:12 <enriquetaso> oh, OK it's not
14:29:17 <eharney> no
14:29:26 <rosmaita> i noticed by the way that we don't have cgroup-tools or whatever it's called in our bindep file
14:29:27 <enriquetaso> sorry about that
14:29:34 <eharney> cgroups is a linux process/resource management feature
14:30:53 <rosmaita> seems like cgroups v2 has been around a while, i guess there's support in all the other distros?
14:31:22 <eharney> yeah fedora did it in 2019 or so
14:32:01 <rosmaita> ok, key issue at the moment is whether this is wallaby release critical
14:32:24 <rosmaita> i am thinking no
14:32:25 <eharney> unless i'm mistaken the cgroups commands aren't used unless you enable throttling in cinder.conf  (should probably confirm this)
14:32:33 <rosmaita> eharney: that is correct
14:32:41 <rosmaita> (i was looking at that yesterday)
14:33:07 <rosmaita> i think zigo's suggestion of mentioning this in a release note is probably a good one
14:33:13 <eharney> and i assume we could backport this, so it's probably not release critical
14:33:21 <rosmaita> that was my thought too
14:33:57 <rosmaita> ok, i will write up a release note and people can comment on it, and we can talk more at the PTG
14:34:25 <rosmaita> but from what i was looking at yesterday v1 and v2 are like completely incompatible
14:34:37 <eharney> yes
14:35:01 <rosmaita> ok, in the meantime, anyone who wants to get up to speed on cgroups, please do!
14:35:17 <rosmaita> zigo says he won't have time to work on it himself
14:35:27 <rosmaita> but thanks to him for bringing this to our attention
14:35:44 <rosmaita> #topic stable branch release update
14:35:51 <rosmaita> whoami-rajat: you have the floor
14:35:56 <whoami-rajat> thanks
14:36:15 <whoami-rajat> Hi, so we are remaining with train release and we still have unmerged patches
14:36:39 <whoami-rajat> although a lot of patches were merged last week so thanks to everyone who reviewed
14:36:52 <whoami-rajat> we currently have 3 patches, 2 from netapp and 1 from SVF
14:37:20 <whoami-rajat> the SVF patch author hasn't replied or updated on my comment since 15th march so not sure what to do about it
14:37:44 <rosmaita> #link https://etherpad.opendev.org/p/stable-releases-review-tracker-22-02-2021
14:38:15 <whoami-rajat> rosmaita: I've a question for you, can we propose the release without the SVF patches? they're included in victoria and ussuri release
14:38:50 <rosmaita> yes
14:39:34 <whoami-rajat> great, i will put up a release after the 2 netapp patches merge which might soon since sfernand  updates patches quickly
14:40:08 <jungleboyj> Sounds good.
14:40:34 <whoami-rajat> that's all from my side
14:40:38 <rosmaita> what's the deal with SVF?  that train patch has a dependency  patch that has not been proposed to train?
14:40:54 <whoami-rajat> yes
14:41:15 <whoami-rajat> if we wait for it then we might release train after wallaby...
14:41:16 <rosmaita> and it looks like you mentioned that over a week ago
14:41:38 <whoami-rajat> yep
14:41:43 <jungleboyj> Strange that they haven't responded.  They were very active for a while.
14:42:01 <rosmaita> yes, and also extremely annoying asking for reviews
14:42:07 <rosmaita> (did i say that out loud?)
14:42:20 <jungleboyj> rosmaita:  I didn't hear anything.  ;-)
14:42:43 <jungleboyj> *Sigh*  That used to be part of my team.  Don't have anyone to mentor them anymore I guess.
14:43:16 <sfernand> sorry folks I will update all netapp patches right after this meeting
14:43:54 <rosmaita> how about we say aim for releasing train next week
14:43:56 <rosmaita> tuesday maybe
14:44:25 <whoami-rajat> works for me
14:44:36 <rosmaita> that will give SVF team time to respond, and sfernand you may need to work on the wallaby feature bug patches ... keep an eye on those
14:44:46 <rosmaita> ok, thanks whoami-rajat
14:44:57 <rosmaita> #topic open discussion
14:45:44 <sfernand> ack
14:46:44 <eharney> a few folks are already tracking this, but https://review.opendev.org/c/openstack/cinder/+/781788 seems to help with our lio-barbican gate failures, so reviews there would be helpful
14:47:05 <jungleboyj> eharney:  Oooh, good news.
14:48:24 <rosmaita> yes, it would be a good idea to get that patch merged
14:48:30 <rosmaita> and the one that depends on it
14:49:18 <eharney> i need to go figure out which third party CIs are interesting for the second patch (remove_export_snapshot) and look at their results
14:49:41 <rosmaita> oh, ok
14:50:40 <rosmaita> the first patch seems pretty safe, though
14:51:15 <jungleboyj> Yeah.  Can't make things worse.  :-)
14:54:43 <rosmaita> anything else for open discussion?
14:55:03 <rosmaita> #action rosmaita add cgroup v2 topic to PTG etherpad
14:55:11 <rosmaita> actually, that reminds me
14:55:18 <rosmaita> don't forget to register for the PTG
14:55:26 <jungleboyj> Oh yeah.
14:55:30 <rosmaita> and add topics to the etherpad if you have them
14:56:04 <jungleboyj> I have had a tab open for that since last week.
14:56:13 <eharney> any hopes of getting https://review.opendev.org/c/openstack/cinder/+/766751 at this point?
14:57:06 <rosmaita> that has been sitting a long time
14:59:02 <jungleboyj> Looks like a good idea to me.
14:59:11 <jungleboyj> I am all for making failures more obvious.
14:59:35 <rosmaita> i agree
14:59:35 <eharney> yeah, when this happens, it makes a mess and isn't terribly clear to an admin looking at the logs
14:59:45 <geguileo> yeah, that's one that's tricky to see in the logs for non developers
14:59:53 <rosmaita> ok, we are out of time
14:59:56 <rosmaita> thanks everyone!
15:00:04 <whoami-rajat> thanks!
15:00:15 <rosmaita> #endmeeting