14:00:06 <rosmaita> #startmeeting cinder
14:00:06 <openstack> Meeting started Wed May  5 14:00:06 2021 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'cinder'
14:00:14 <rosmaita> #topic roll call
14:00:34 <eharney> hi
14:00:41 <tosky> hi (around a bit, I may have to drop)
14:01:11 <whoami-rajat> Hi
14:02:00 <jungleboyj> Hello.
14:02:08 <rosmaita> hello everyone
14:02:21 <rosmaita> #link https://etherpad.opendev.org/p/cinder-xena-meetings
14:02:27 <walshh_> hi
14:02:32 <rosmaita> #topic announcements
14:03:00 <rosmaita> i posted a summary of our discussions at the PTG
14:03:04 <rosmaita> #link https://wiki.openstack.org/wiki/CinderXenaPTGSummary
14:03:21 <jungleboyj> 👍
14:03:22 <rosmaita> you should take a look at your discussion and check it for accuracy
14:03:33 <enriquetaso> hi
14:03:34 <rosmaita> it's a wiki, so you should be able to make correctinos
14:03:54 <rosmaita> (that's a typo, i'm not trying to be cute)
14:04:00 <enriquetaso> :P
14:04:08 <jungleboyj> LOL
14:04:21 <rosmaita> i was a bit consistent about using irc nicks and real first names throughout the doc
14:04:40 <rosmaita> one thing i do want to point out are the cycle priorities
14:04:50 <rosmaita> #link https://wiki.openstack.org/wiki/CinderXenaPTGSummary#Xena_Cycle_Priorities
14:05:21 <rosmaita> there are some priorities addressing stability that don't really have a deadline
14:05:34 <rosmaita> and those tend to get lost
14:05:47 <rosmaita> but they can be done in small pieces
14:06:18 <rosmaita> what i'd like you to do is to use the gerrit topic listed so we can keep visibility on them
14:06:30 <rosmaita> that is, so you can get quick review of your patches
14:07:21 <rosmaita> that's all from me, anyone else have an announcement?
14:08:21 <rosmaita> guess not
14:08:30 <rosmaita> #topic midcycle meeting times
14:08:56 <rosmaita> last week i asked you to check on whether the dates are ok
14:09:05 <rosmaita> i haven't heard anything
14:09:20 <jungleboyj> Oops.  :-(
14:09:25 <rosmaita> so i am assuming that wednesday 2 june and wednesday 4 august are unobjectionable?
14:09:26 <enriquetaso> sorry about that..
14:09:53 <rosmaita> well, it won't hurt to wait one more week to schedule these
14:09:56 <rosmaita> so
14:10:01 <jungleboyj> At the usual cinder meeting time plus an hour?
14:10:07 <whoami-rajat> the timing and dates work for me
14:10:10 <rosmaita> or minus an hour
14:10:19 <whoami-rajat> rosmaita: was there a poll for this?
14:10:32 <rosmaita> no we were going to vote in the meeting
14:10:36 <jungleboyj> Yeah.  That is as good a time as any for me.
14:10:42 <rosmaita> that is, this meeting
14:11:00 <whoami-rajat> ok cool
14:11:55 <rosmaita> so, to summarize, the midcycle will be on a wednesday and will overlap with the normal cinder meeting time
14:12:22 <rosmaita> so the only question is whether people are planning to be on vacation those weeks, or if there is a major opensource/python event those weeks
14:12:33 <rosmaita> i don't know of any major events
14:13:22 <rosmaita> so my question right now is, are people ready to vote to pick the times for those days?
14:13:39 <rosmaita> maybe we need to vote on that!
14:14:13 <rosmaita> Are you ready to vote on the time for the midcycles today?
14:14:20 <rosmaita> #startvote yes, no
14:14:21 <openstack> Unable to parse vote topic and options.
14:14:26 <rosmaita> :D
14:15:05 <rosmaita> #startvote Are you ready to vote on the time for the midcycles today? yes, no
14:15:06 <openstack> Begin voting on: Are you ready to vote on the time for the midcycles today? Valid vote options are yes, no.
14:15:07 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:15:16 <rosmaita> #vote yes
14:15:17 <whoami-rajat> #vote yes
14:15:19 <enriquetaso> #vote yes
14:15:22 <eharney> #vote maybe
14:15:23 <openstack> eharney: maybe is not a valid option. Valid options are yes, no.
14:15:26 <eharney> #vote yes
14:15:32 <walshh_> #vote yes
14:15:41 <jungleboyj> #vote yes
14:16:33 <rosmaita> i thought i was committed to democracy, so it's kind of disconcerting to see that i don't know how to use the voting feature of the meetbot
14:16:52 <jungleboyj> #fail
14:16:56 <jungleboyj> ;-)
14:17:25 <rosmaita> that seems to be everyone, will close the vote in 20 seconds
14:17:53 <rosmaita> #endvote
14:17:54 <openstack> Voted on "Are you ready to vote on the time for the midcycles today?" Results are
14:17:55 <openstack> yes (6): enriquetaso, walshh_, whoami-rajat, jungleboyj, rosmaita, eharney
14:18:03 <rosmaita> ok, guess we are ready
14:18:40 <rosmaita> the R-18 midcycle will be held on Wednesday 2 June 2021
14:18:40 <rosmaita> we need to pick a time
14:18:40 <rosmaita> options are:
14:18:40 <rosmaita> A 1300-1500 UTC
14:18:40 <rosmaita> B 1400-1600 UTC
14:18:41 <rosmaita> C need more options
14:18:47 <rosmaita> #startvote time for the 2 June midcycle? A, B, C
14:18:48 <openstack> Begin voting on: time for the 2 June midcycle? Valid vote options are A, B, C.
14:18:49 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:19:22 <jungleboyj> #vote B
14:19:33 <whoami-rajat> #vote A, B
14:19:34 <openstack> whoami-rajat: A, B is not a valid option. Valid options are A, B, C.
14:19:44 <rosmaita> #vote B
14:19:48 <whoami-rajat> #vote A
14:19:48 <walshh_> #vote B
14:19:54 <eharney> #vote B
14:20:03 <enriquetaso> #vote B
14:21:29 <rosmaita> i think that's everyone ... will wait 20 sec
14:21:57 <tosky> (I always vote "it will conflict with something anyway")
14:22:06 <rosmaita> #endvote
14:22:07 <openstack> Voted on "time for the 2 June midcycle?" Results are
14:22:08 <openstack> A (1): whoami-rajat
14:22:09 <openstack> B (5): jungleboyj, enriquetaso, eharney, rosmaita, walshh_
14:22:22 <rosmaita> ok 1400-1600 it is
14:22:29 <rosmaita> next one
14:22:46 <rosmaita> the R-9 midcycle will be held on Wednesday 4 August 2021
14:22:46 <rosmaita> let's pick a time
14:22:46 <rosmaita> options are:
14:22:46 <rosmaita> A 1300-1500 UTC
14:22:46 <rosmaita> B 1400-1600 UTC
14:22:47 <rosmaita> C either one of the above
14:22:47 <rosmaita> D need more options
14:22:55 <rosmaita> #startvote time for the 4 August midcycle? A, B, C, D
14:22:56 <openstack> Begin voting on: time for the 4 August midcycle? Valid vote options are A, B, C, D.
14:22:57 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:23:13 <eharney> #vote C
14:23:20 <tosky> #vote C
14:23:23 <rosmaita> #vote C
14:23:27 <jungleboyj> #vote B
14:23:32 <whoami-rajat> #vote C
14:23:42 <enriquetaso> #vote C
14:23:47 <walshh_> #vote C
14:24:27 <rosmaita> i think that's everyone .... will close the vote in 20 sec
14:25:07 <rosmaita> #endvote
14:25:08 <openstack> Voted on "time for the 4 August midcycle?" Results are
14:25:09 <openstack> C (6): tosky, eharney, walshh_, whoami-rajat, rosmaita, enriquetaso
14:25:10 <openstack> B (1): jungleboyj
14:25:23 <rosmaita> OK, that makes 1400-1600 the winner
14:25:55 <rosmaita> ok, thanks everyone, i will send out an email for the benefit of people who weren't here
14:26:10 <rosmaita> #action rosmaita announce midcycle date/times
14:26:26 <rosmaita> #topic final train release status
14:26:39 <rosmaita> whoami-rajat: you have the floor
14:26:48 <rosmaita> #link https://etherpad.opendev.org/p/train-final-release
14:27:18 <whoami-rajat> So rosmaita updated the tracker with patches to be included in final train release (thanks!)
14:27:30 <whoami-rajat> We currently only have open patches in cinder train
14:27:38 <whoami-rajat> os-brick patches merged
14:28:07 <whoami-rajat> and other branch doesn't have new patches, we did a release recently so no need to release them this time
14:28:24 <rosmaita> someone (tosky?) put a question about the stabilization fix
14:28:39 <rosmaita> that is, backport https://review.opendev.org/c/openstack/cinder/+/785970 to train
14:28:52 <eharney> we should do that, i'll propose it
14:29:04 <whoami-rajat> rosmaita: there's one patch from SVF failing because of other patch dependency, I've backported the other one so we can review it and fix the gate on first one?
14:29:08 <rosmaita> i have no objection
14:29:33 <whoami-rajat> sounds good
14:29:36 <rosmaita> whoami-rajat: sure, i was hoping that the SVF team would do it
14:29:51 <rosmaita> my "no objection" was in response to eharney
14:30:15 <whoami-rajat> rosmaita: they haven't responded to my comment since a long time so i wasn't sure they're going to do it
14:30:17 <tosky> that was me, yes, thanks
14:30:27 <rosmaita> whoami-rajat: i agree about your proposal, though, it is probably better to have both fixes together
14:31:01 <tosky> do we have any contact for that team? Maybe a direct email?
14:31:26 <rosmaita> well, they are usually making pests of themselves asking for reviews :P
14:31:41 <whoami-rajat> rosmaita: i didn't understand, the second one needs to be merged to pass gate on first one? then we can merge first one
14:31:43 <rosmaita> so i'm kind of surprised that they've gone silent
14:32:11 <rosmaita> whoami-rajat: i meant it is better to have both those fixes in train
14:32:26 <whoami-rajat> rosmaita: yes, agree
14:33:01 <rosmaita> so what you said .... we merge the patch you just proposed first, which will allow us to rebase the current failing patch
14:33:16 <whoami-rajat> yes
14:33:34 <whoami-rajat> atleast that's what we did in other branches
14:34:07 <eharney> IMO we should also get https://review.opendev.org/c/openstack/cinder/+/783204 in which is currently languishing on stable/ussuri review
14:34:49 <jungleboyj> eharney:  ++ Have a few things languishing.
14:35:21 <whoami-rajat> can anyone propose the backports (or i can do) and we can add them to the etherpad
14:35:29 <eharney> i'll propose that one
14:35:39 <whoami-rajat> ok thanks
14:36:05 <rosmaita> ok, i just approved https://review.opendev.org/c/openstack/cinder/+/783204
14:36:38 <rosmaita> i think it makes sense to get it into train, too
14:37:17 <rosmaita> anything else anyone is aware of?
14:37:33 <whoami-rajat> that's all from me
14:38:28 <rosmaita> ok, thanks
14:38:35 <rosmaita> tosky: are you available now?
14:39:09 <enriquetaso> should we backport to train this https://review.opendev.org/c/openstack/cinder/+/785223 too?
14:39:53 <tosky> rosmaita: zep
14:40:13 <eharney> enriquetaso: we could, but i don't know that it's too crucial since it seems to mostly only hit CI jobs and not users
14:40:22 <rosmaita> just moved you up in the agenda
14:40:30 <enriquetaso> sure, thanks
14:41:03 <whoami-rajat> eharney:  but we've faced consistent lvm-lio job failures on train gate before
14:41:34 <tosky> whoami-rajat: iirc that fix is for the LVM version in focal, which is only supported in victoria and newer releases
14:41:48 <eharney> will there still be lvm-lio train jobs..?
14:42:05 <tosky> until we support train, yes (but based on bionic)
14:42:23 <enriquetaso> ++
14:42:26 <tosky> stein, train and ussuri (maybe also rocky, don't remember) are bionic
14:42:51 <eharney> ok, well, i'm not opposed to backporting it, for sure
14:43:03 <rosmaita> ok, we can always backport it later if necessary, doesn't really affect the release
14:43:25 <rosmaita> (unless we're seeing gate failures that prevent other stuff from merging)
14:43:52 <rosmaita> #topic some gate-related issues
14:44:05 <tosky> very quick, two fixes for jobs:
14:44:14 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/789717
14:44:24 <rosmaita> i think that one looks fine
14:44:53 <rosmaita> #link https://review.opendev.org/c/openstack/cinder-tempest-plugin/+/786755
14:45:08 <rosmaita> i wasn't sure where to see this one is affecting stein?
14:45:43 <tosky> iirc because we haven't submitted new stein patch recently
14:46:35 <tosky> I've noticed while working on https://review.opendev.org/c/openstack/os-brick/+/786737 (which is worth considering too, low prio as it's stein)
14:47:00 <tosky> the first revision of the patch failed because of that; the current revision works because it depends on the cinder-tempest-plugin fix
14:47:53 <rosmaita> ok, i was looking at a brick patch, not cinder
14:48:15 <rosmaita> all stable cores: give ^^ some attention
14:48:21 <rosmaita> thanks, Luigi
14:48:35 <rosmaita> #topic interop guidelines review
14:48:47 <rosmaita> hopefully we can get through this really quick
14:49:08 <rosmaita> this is what we are talking about:
14:49:10 <rosmaita> #link https://wiki.openstack.org/wiki/CinderXenaPTGSummary#The_Interoperability_Working_Group
14:49:24 <rosmaita> "Cinder team: will review mv changes between 3.0 and 3.64 to see if any "advisory" tests should be added"
14:49:40 <rosmaita> just so you know where to look
14:49:48 <rosmaita> this is the next set of capabilities:
14:50:02 <rosmaita> #link https://opendev.org/osf/interop/src/branch/master/next.json#L151-L163
14:50:04 <whoami-rajat> rosmaita: IIRC these are only related to third party CI ?
14:50:23 <rosmaita> no, kind of a separate issue
14:50:50 <rosmaita> this is the specification of what we think must be included for a cloud to be running OpenStack
14:50:55 <tosky> whoami-rajat: guidelines/testing for interoperability of (vendored) openstack implementation
14:51:20 <rosmaita> we also get indirectly included in this nova capability:
14:51:25 <whoami-rajat> ok
14:51:29 <rosmaita> #link https://opendev.org/osf/interop/src/branch/master/next.json#L133
14:51:55 <rosmaita> and here's where you can see what that capability "means", in terms of what tempest tests it matches to:
14:52:04 <rosmaita> #link https://opendev.org/osf/interop/src/branch/master/next.json#L1103-L1130
14:52:33 <rosmaita> the volumes-* capability definitions start here (and go on and on):
14:52:41 <eharney> i'm curious to know what tests exist for "volumes-v3-readonly"
14:52:44 <rosmaita> #link https://opendev.org/osf/interop/src/branch/master/next.json#L2378
14:53:25 <eharney> ah, https://opendev.org/osf/interop/src/branch/master/next.json#L2830
14:53:35 <eharney> yeah that test doesn't validate that readonly actually works
14:54:00 <rosmaita> yeah, these will only be API tests
14:54:23 <rosmaita> by the way, that stuff you can't read in the description of all these tests says:
14:54:32 <rosmaita> "This is being added as advisory to highlight the transitition from  v2 to v3."
14:54:49 <rosmaita> i will put up a patch to remove that sentence
14:55:09 <rosmaita> #action rosmaita interop patch removing transition v2->v3 language
14:55:21 <rosmaita> ok, so i looked over our microversions
14:55:30 <rosmaita> #link https://docs.openstack.org/cinder/latest/contributor/api_microversion_history.html
14:55:39 <rosmaita> i only found two candidates
14:55:48 <rosmaita> well, actually 3
14:55:58 <rosmaita> mv 3.3, User Messages
14:56:12 <rosmaita> i forgot to check whether there are existing tempest tests for ^^
14:56:21 <rosmaita> because if they aren't we will need to write them
14:56:43 <rosmaita> the second is mv 5.55, 3.57, "New Transfer API"
14:56:48 <eharney> i don't recall any user message tests existing
14:56:51 <whoami-rajat> from the quick find, i can't find anything saying message there
14:56:55 <rosmaita> use /volume-transfers instead of /os-volume-transfer in the URL
14:57:32 <rosmaita> i started looking into this one, but got lost in the tempest clients and couldn't figure out whether they are using the os- version or not when making the calls
14:57:41 <rosmaita> because transfers actually are tested
14:58:19 <tosky> the tests can set the specific microversion used by the tempest client (if that's the question)
14:58:36 <eharney> a quick grep says that tempest is probably only testing the old one
14:58:46 <rosmaita> ok, thanks
14:58:59 <rosmaita> so if we care about this, we can update the tempest tests first
14:59:07 <rosmaita> probably worth doing anyway?
14:59:11 <eharney> yes
14:59:52 <rosmaita> so this is only an issue if we intend on removing the os-volume-transfer urls
15:00:00 <whoami-rajat> rosmaita: what about default volume types? (I'm trying to write tests for it but lacking the endpoint support for the unique url)
15:00:35 <rosmaita> well, i don't know if we want to require that people make those accessible to end users
15:00:41 <rosmaita> actually , i guess we don't
15:01:10 <rosmaita> ok, we are out of time, i will pick this up next week
15:01:19 <whoami-rajat> thanks!
15:01:26 <rosmaita> sorry about no open discussion, we spent all our time voting
15:01:47 <rosmaita> #endmeeting