14:00:01 <rosmaita> #startmeeting cinder
14:00:01 <openstack> Meeting started Wed May 19 14:00:01 2021 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <openstack> The meeting name has been set to 'cinder'
14:00:12 <rosmaita> #topic roll call
14:00:16 <hemna> mep
14:00:20 <e0ne> hi
14:00:26 <whoami-rajat> Hi
14:00:52 <walshh_> Hi
14:01:02 <tosky> hi
14:01:15 <eharney> hi
14:01:50 <rosmaita> hello everyone
14:01:53 <rosmaita> #link https://etherpad.openstack.org/p/cinder-xena-meetings
14:01:56 <jungleboyj> o/
14:02:01 <geguileo> hi! o/
14:02:08 <rosmaita> light agenda today
14:02:11 <enriquetaso> hi
14:02:23 <rosmaita> and a good turnout
14:02:38 <rosmaita> #topic announcements
14:02:50 <rosmaita> Festival of XS Reviews on Friday, 1400-1600 UTC
14:02:58 <rosmaita> we will meet in meetpad:
14:03:06 <rosmaita> #link https://meetpad.opendev.org/cinder-festival-of-reviews
14:03:32 <rosmaita> these festivals have been very productive, so please plan to attend if you can
14:03:44 <rosmaita> next item
14:03:53 <rosmaita> next week is Xena Milestone 1
14:04:12 <rosmaita> and the week after that is our first xena virtual midcycle
14:04:34 <rosmaita> please add topics if you got 'em
14:04:38 <rosmaita> #link https://etherpad.opendev.org/p/cinder-xena-mid-cycles
14:05:16 <rosmaita> that's it ... anyone else have an announcement?
14:06:45 <rosmaita> guess not
14:07:08 <rosmaita> around now the release team puts up auto patches to release os-brick and cinderclient
14:07:34 <rosmaita> #action rosmaita check for release patches
14:07:47 <rosmaita> ok, on to the real topics
14:07:59 <rosmaita> #topic Block Storage API v2 removal update
14:08:16 <rosmaita> so, stuff is happening
14:08:26 <rosmaita> so far, there's a devstack and tempest patch up
14:08:43 <rosmaita> the move to Focal seems to have borked some devstack gate jobs, though
14:09:09 <rosmaita> these are just points of information, because we can't +2 them
14:09:20 <rosmaita> devstack: https://review.opendev.org/c/openstack/devstack/+/791842
14:09:26 <rosmaita> tempest: https://review.opendev.org/c/openstack/tempest/+/792025
14:09:40 <rosmaita> but, i do have the first python-cinderclient patch up
14:09:48 <rosmaita> #link https://review.opendev.org/c/openstack/python-cinderclient/+/791834
14:09:57 <rosmaita> it removes the v2 shell
14:10:20 <rosmaita> you may remember that we'll be handing the cinderclient in a series of changes
14:10:57 <rosmaita> removing the v2 client class makes a bit of a mess, so that will happen a bit later
14:11:12 <rosmaita> instead i've been working on removing the v2 API from cinder
14:11:28 <rosmaita> my status is that I updated the versions controller and broke half of the api.contrib tests
14:11:41 <rosmaita> the good news is that we have *a lot* of contrib tests
14:11:46 <rosmaita> but that is also the bad news
14:12:22 <rosmaita> it's mostly just replacing v2 in the path with v3 in request blanks, so i will hopefully have that finished today
14:12:41 <rosmaita> although i haven't looked at the functional tests yet, i am kind of afraid to
14:12:55 <rosmaita> i do have a question for the team, though
14:13:04 <rosmaita> namely, what to do about the api-ref ?
14:13:13 <tosky> isn't it branched?
14:13:20 <rosmaita> only in the code
14:13:25 <tosky> uhm, right
14:13:46 <rosmaita> but, v2 has been deprecated so long, maybe we can assume nobody uses it anymore?
14:13:51 <tosky> ahahaha
14:13:53 <tosky> (sorry)
14:14:04 <rosmaita> :)
14:14:24 <rosmaita> when glance removed the v1 api a few years ago, they did this:
14:14:32 <rosmaita> #link https://opendev.org/openstack/glance/commit/012cce529f9201124ca864a9bca205df4db7296f
14:14:36 <tosky> it may be still useful for comparison - maybe we can ask the right someone to have a separate directory on the api-ref server and publish it from wallaby
14:14:48 <rosmaita> basically, just left a note saying how you can generate it yourself
14:15:10 <rosmaita> tosky: that's what i was wondering, that it could be useful for people
14:15:28 <rosmaita> we could put a notice on the page saying that it is no longer supported
14:15:40 <rosmaita> but the separate directory is a better idea
14:16:13 <rosmaita> #action rosmaita check with opendev team about having a separate api-ref directory for historical purposes
14:16:20 <rosmaita> thanks tosky
14:16:30 <rosmaita> anyone else have feedback about this?
14:16:40 <jungleboyj> No, I think that makes sense.
14:17:10 <rosmaita> ok, i'll check with opendev and we can talk about plan B next week if necessary
14:17:34 <rosmaita> btw, in case i was too subtle, please review the cinderclient patch i mentioned earlier :D
14:17:50 <rosmaita> #topic "Toggle CI" in gerrit web UI
14:18:13 <rosmaita> i went the opendev office hours yesterday to ask about this
14:18:25 <rosmaita> but i guess i should say what "this" is
14:18:51 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/790796/
14:19:02 <rosmaita> that's a sample review of ours, go ahead and open it
14:19:16 <rosmaita> when you open that review, click on the "Zuul Summary" tab
14:19:27 <rosmaita> if you scroll down, you can see the 3rd party CI results
14:19:43 <rosmaita> that's based on the Full Name of the CI, namely it matches the pattern
14:19:53 <rosmaita> Name Of Vendor CI
14:20:10 <rosmaita> and since our CIs are named like that, gerrit pulls them into that tab
14:20:20 <rosmaita> now click on the "Files" tab
14:20:30 <rosmaita> and also click on "Show All 68 Messages"
14:20:41 <rosmaita> if you use the "Only Comments" slider, you can see the Zuul comments disappear
14:20:55 <rosmaita> this is because Zuul is adding a tag to its comments that the UI can use to exclude them
14:21:07 <rosmaita> if our 3rd party CIs add the tag, then the slider will hide our CI comments too
14:21:32 <rosmaita> the advice I got from the opendev team is that if your CI adds comments in Zuul format, the tag you want to use is
14:21:45 <rosmaita> autogenerated:zuul
14:21:56 <rosmaita> and if you use some other format, use the tag
14:21:57 <jungleboyj> Nice.
14:22:04 <whoami-rajat> I'm not able to find Zuul Summary tab...
14:22:06 <rosmaita> autogenerated:yourcisystemhere
14:22:56 <rosmaita> whoami-rajat: it's about halfway down the page
14:22:59 <eharney> interesting
14:23:04 <rosmaita> under the review priority label
14:23:22 <rosmaita> there's a bar with "files" "zuul summary" "findings"
14:23:37 <rosmaita> (i forgot to ask what "findings" is for or how to get stuff in there)
14:23:47 <rosmaita> this would have been better to do in video
14:24:06 <rosmaita> which reminds me, next meeting is the last meeting of April, so it will be in video and irc
14:24:17 <whoami-rajat> i can only see files and findings, maybe it's my browser
14:24:29 <rosmaita> could be
14:24:50 <geguileo> rosmaita: should we send and email to tell vendors about that tag?
14:24:51 <whoami-rajat> yeah i can see it in chrome
14:24:52 <whoami-rajat> thanks
14:24:57 <rosmaita> ok, cool
14:25:09 <eharney> Findings is actually a gerrit feature made to hold things like CI results, i think
14:25:11 <rosmaita> geguileo: i think so
14:25:15 <geguileo> because it's painful to see comments with all those interlaced CI comments
14:25:36 <rosmaita> so just to get this into the meeting log
14:25:49 <rosmaita> if your CI uses ssh to connect to gerrit, you can use the --tag TAG option to set the tag
14:25:56 <rosmaita> #link https://review.opendev.org/Documentation/cmd-review.html
14:26:01 * jungleboyj is disturbed by how many CIs fail.
14:26:06 <rosmaita> if your CI uses http to connect to gerrit, you can send the tag in the body of the request
14:26:16 <rosmaita> #link https://review.opendev.org/Documentation/rest-api-changes.html#set-review
14:26:30 <rosmaita> and here's the info about the 'tag' field:
14:26:39 <rosmaita> #link https://review.opendev.org/Documentation/rest-api-changes.html#review-input
14:26:53 * rosmaita shares jungleboyj's disturbance
14:27:23 <jungleboyj> :-)
14:28:17 <rosmaita> i will be optimistic and hope that our vendors comply and add the tag
14:28:43 <rosmaita> the opendev team prefers to use functionality already in gerrit instead of writing custom stuff
14:28:48 <rosmaita> (like "Toggle CI")
14:28:55 <geguileo> rosmaita: it will be easy to tell which one don't ;-)
14:29:00 <rosmaita> which piles up technical debt and breaks on upgrade
14:29:07 <rosmaita> geguileo: no kidding!
14:29:23 <geguileo> rosmaita: thank you very much for looking into this
14:29:36 <jungleboyj> rosmaita:  Yeah, I would say send something to the mailing list and see what level of action we get.  Then start targeting the vendors that don't make a change.
14:29:57 <rosmaita> jungleboyj: sounds good
14:30:17 <rosmaita> #action rosmaita email to ML targeting vendors to add the autogenerated:XXX tag
14:30:28 <whoami-rajat> thanks rosmaita  !
14:30:42 <rosmaita> what do we put in the subject line to get vendors to pay attention?
14:30:44 <tosky> isn't there a list of emails of maintainers for each CI?
14:30:49 <tosky> (I hope, at list)
14:31:13 <rosmaita> tosky: no
14:31:18 <rosmaita> at least, i don't know of one
14:31:32 <rosmaita> there are emails, but not all are attended
14:31:35 <jungleboyj> rosmaita:  Their e-mails are in the CI listing.
14:31:51 <jungleboyj> There isn't a mailing list but we do have a way to try to directly ping them.
14:32:55 <rosmaita> anyway, what i would like to do is an email to the ML to start with
14:33:18 * jungleboyj can't find it.
14:33:47 <rosmaita> anyone here who's a driver maintainer, is there a specific tag in the ML subject line that you look for about driver issues?
14:35:12 <rosmaita> by the way, the opendev team said that modern zuul adds the "autogenerated:zuul" tag automatically
14:35:42 <rosmaita> but i know Pure is using zuul>=v3, and their CIs comments aren't affected by the "comments only" slider
14:35:54 <jungleboyj> rosmaita: https://wiki.openstack.org/wiki/ThirdPartySystems
14:36:03 <rosmaita> so maybe that's a zuul v4 thing
14:36:29 <rosmaita> jungleboyj: thanks
14:36:53 <rosmaita> i will compile that into a big list of emails and see how many bouncebacks i get
14:37:16 <rosmaita> ok, that's all i got
14:37:21 <rosmaita> #topic open discussion
14:40:18 <tosky> 3 minutes an no comments? Then I can spam a few cinder-tempest-plugin reviews :)
14:40:35 <rosmaita> go ahead!
14:40:39 <tosky> - fixing stein jobs: https://review.opendev.org/c/openstack/cinder-tempest-plugin/+/786755
14:41:01 <tosky> - "administrative" change (adding a wallaby job): https://review.opendev.org/c/openstack/cinder-tempest-plugin/+/788846
14:41:34 <tosky> - cinder-backup/s3, new job, pre-reviewed by rosmaita and now tuned to run all (I think) backup tests: https://review.opendev.org/c/openstack/cinder-tempest-plugin/+/772085
14:41:55 <tosky> - and then, the groundwork for RBAC testing (no testing, just a few basic classes): https://review.opendev.org/c/openstack/cinder-tempest-plugin/+/772915
14:42:58 <whoami-rajat> cinder-tempest-plugin reminded me of my patch, since tempest has declared tempest scenario manager stable in their 27.0.0 release, I've removed it's copy and directly imported it from there in this patch https://review.opendev.org/c/openstack/cinder-tempest-plugin/+/790942
14:43:31 <tosky> whoami-rajat: right, I'd just wait a few days for that, until the last version of tempest for train is tagged (just in case)
14:43:42 <tosky> just a matter of few days
14:44:03 <tosky> finally, an os-brick change which may have been relevant for train, but oh well (now in victoria, needs further backports): https://review.opendev.org/c/openstack/os-brick/+/779461
14:44:20 <whoami-rajat> sure
14:46:16 <whoami-rajat> tosky: i see the master patch merged recently (6th May) so it was kind of hard already, maybe we could've made it but it's too late now
14:46:36 <tosky> whoami-rajat: oh, I see
14:46:42 <tosky> well, it can still be backported
14:47:04 <whoami-rajat> yep, it's worth backporting for other stable releases (and also to train)
14:51:35 <tosky> I hope everyone is busy reviewing those :)
14:52:09 <enriquetaso> tosky++
14:52:11 <jungleboyj> I am.  :-)
14:54:34 <enriquetaso> I'd like to spam too, remember bug meeting at #openstack-cinder after this meeting :P
14:54:38 <rosmaita> tosky: now that train is in EM, can we drop the train jobs from cinder-tempest-plugin
14:55:25 <tosky> rosmaita: I will that when the the last tempest version that works on train is tagged
14:55:32 <tosky> in a few days (see above)
14:55:36 <tosky> I will do*
14:55:55 <rosmaita> ok
14:58:25 <rosmaita> guess we can wrap things up here
14:58:39 <tosky> thanks!
14:58:40 <whoami-rajat> thanks!
14:59:12 <rosmaita> thanks everyone, and if you know (or are) a driver vendor, spread the word about adding the autogenerated:XXX tag to CI
14:59:20 <rosmaita> #endmeeting