14:00:33 <rosmaita> #startmeeting cinder
14:00:33 <opendevmeet> Meeting started Wed Sep 22 14:00:33 2021 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:33 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:33 <opendevmeet> The meeting name has been set to 'cinder'
14:00:39 <rosmaita> #topic roll call
14:00:41 <simondodsley> Hi
14:00:58 <e0ne> hi
14:00:59 <eharney> hi
14:00:59 <enriquetaso> hi
14:01:01 <walshh_> Hi
14:01:26 <whoami-rajat> Hi
14:02:09 <fabiooliveira> hi
14:02:09 <TusharTgite> hi
14:02:29 <tosky> hi
14:02:38 <rosmaita> hello everyone
14:02:42 <rosmaita> let's get started
14:02:51 <rosmaita> #link https://etherpad.opendev.org/p/cinder-xena-meetings
14:03:01 <rosmaita> #topic announcements
14:03:10 <rosmaita> we will be doing an RC-2
14:03:33 <rosmaita> there are some requirements changes that we needed to make, and some release critical bugs
14:03:45 <rosmaita> we'll go over those in a few minutes
14:03:55 <rosmaita> i'll just continue with the announcements
14:04:10 <hemna> hi
14:04:11 <rosmaita> next week is the final Release Candidate
14:04:23 <rosmaita> traditionally on Thursday
14:04:54 <rosmaita> we'll talk about whether we should do an RC-2 quickly and then possibly another, or just do an RC-2
14:05:05 <rosmaita> next announcement:
14:05:17 <rosmaita> next week's meeting is the last of the month, so will be our usual video meeting
14:05:52 <rosmaita> next, the Outreachy proposal deadline is 29 September
14:06:06 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-September/024992.html
14:06:17 <rosmaita> you can read ^^ to see what that's about
14:06:46 <rosmaita> i don't know whether i will put in a proposal or not
14:07:14 <rosmaita> it's a good mentoring opportunity, if you would like to do that
14:07:25 <rosmaita> and might get some work done on cinder
14:07:46 <rosmaita> let me know if you are interested, and i will work with you to get a proposal together
14:08:01 <rosmaita> but think about it fast, because the proposal is due in one week
14:08:18 <rosmaita> finally, the Yoga PTG is the week of 18 October
14:08:28 <rosmaita> #link https://etherpad.opendev.org/p/yoga-ptg-cinder-planning
14:08:33 <rosmaita> add topics to ^^
14:08:43 <rosmaita> also, info is on the etherpad for registering for the PTG
14:09:01 <rosmaita> it's free, but the foundation asks you to register
14:09:22 <rosmaita> i guess so that they can remind you about the code of conduct
14:09:33 <rosmaita> i think that's all
14:10:03 <rosmaita> #topic RC-2
14:10:09 <rosmaita> #link https://etherpad.opendev.org/p/cinder-xena-final-patches-for-RC
14:10:15 <rosmaita> ok, please open ^^
14:10:49 <rosmaita> since the stable/xena branch has been cut, everything must merge first to master and then be backported to stable/xena
14:11:21 <rosmaita> there are a few requirements changes we have to make
14:11:36 <rosmaita> namely, raising the minimum in requirements.txt
14:12:07 <rosmaita> i think everything has merged to master at this point, but we need to get teh backports merged too
14:12:22 <rosmaita> so stable cores, please note the etherpad and keep an eye on it
14:13:05 <rosmaita> after we found a few minimum versions of some requirements that broke tests, i put together a quick lower-constraints kind of job
14:13:16 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/810131
14:13:26 <rosmaita> ^^ if anyone wants to check my work
14:13:51 <rosmaita> all the tests passed with the current xena backports and the generated lower constraints file
14:14:17 <rosmaita> so, everything seems to work with the current requirements minima (after the patches on lines 1-18 on the etherpad merge)
14:14:35 <rosmaita> but, i noticed a few things that might be a bit out of whack:
14:14:46 <rosmaita> #link https://paste.opendev.org/raw/809501/
14:14:56 <rosmaita> so, please open ^^ so we can discuss
14:15:32 <rosmaita> btw, i did not check all our requirements against current upper constraints, just some that i thought might be worth looking at
14:16:08 <rosmaita> you can see that for pretty much all the oslo stuff, there are only minor version changes, so i don't think we need to worry about them
14:16:19 <rosmaita> the exceptions are oslo.db and PyMySQL
14:16:45 <eharney> i think our PyMySQL req is only for tests so it's not very interesting
14:16:46 <rosmaita> here's the change log for oslo.db:
14:16:49 <rosmaita> #link https://paste.opendev.org/raw/809503/
14:17:48 <rosmaita> there doesn't look like a lot in there, but i wonder whether we should raise the min to the xena release of oslo.db ?
14:17:55 <rosmaita> to remind you what this means:
14:18:12 <rosmaita> we are testing (usually) with whatever is in upper constraints
14:18:29 <rosmaita> so all the recent jobs are using oslo.db 11.0.0
14:18:33 <rosmaita> for the past few weeks
14:19:05 <rosmaita> but if the min in requrements is 8.4.0, then we are saying that it's ok to package cinder with oslo.db 8.4.0
14:19:26 <rosmaita> and that may be fine, all our unit tests pass with that version
14:19:33 <eharney> we should raise it IMO
14:19:59 <rosmaita> eharney: ty, i agree
14:20:02 <rosmaita> anyone else?
14:20:05 <e0ne> +1
14:20:11 <rosmaita> thanks ivan
14:20:19 <rosmaita> ok, i will put up a patch
14:20:39 <rosmaita> #action rosmaita patch to raise oslo.db min in requirements to 11.0.0
14:20:49 <rosmaita> ok, the other one is PyMySQL
14:20:55 <rosmaita> the changelog is here:
14:21:09 <rosmaita> #link https://github.com/PyMySQL/PyMySQL/blob/main/CHANGELOG.md
14:21:36 <rosmaita> it looks to me like the major changes are to remove py2.7 and py3.5 support
14:22:10 <rosmaita> and stop supporting MySQL 5.5 (which we talked about last week!)
14:23:36 <rosmaita> i think we should probably raise this one too ... any thoughts?
14:24:33 <eharney> i'm not sure we should depend on it directly
14:24:35 <eharney> see https://opendev.org/openstack/oslo.db/src/branch/master/setup.cfg#L25
14:24:45 <e0ne> what version of mysql is available in official repos of supported OSes?
14:25:07 <rosmaita> e0ne: not sure
14:26:06 <rosmaita> eharney: you have a good point, we should probably let oslo.db set the version
14:29:25 <rosmaita> ok, so for pymysql i propose to do nothing
14:29:42 <rosmaita> not as big a deal, it's in test-requrements whereas oslo.db is in real requirements.txt
14:29:55 <eharney> sounds good
14:30:03 <rosmaita> ok, thanks
14:30:09 <rosmaita> on to some release critical bugs
14:30:24 <rosmaita> line 23 in https://etherpad.opendev.org/p/cinder-xena-final-patches-for-RC
14:31:03 <rosmaita> this was reported for nova, but since we have a lot of the same changes for the sqlalchemy-migrate -> alembic transition, it probably applies to us too
14:31:35 <enriquetaso> #link https://review.opendev.org/c/openstack/cinder/+/810288
14:31:35 <enriquetaso> #link https://review.opendev.org/c/openstack/cinder/+/810000
14:31:42 <rosmaita> the two patches for master look ok, one is in recheck
14:31:45 <rosmaita> thanks enriquetaso
14:32:12 <rosmaita> so i think we need to get these reviewed, merged, and backported befor RC2
14:32:54 <rosmaita> next one is the cgroupv2 thing: https://bugs.launchpad.net/cinder/+bug/1942203
14:33:09 <rosmaita> i will try to get a patch up for that one in the next day or two
14:33:28 <rosmaita> i'm not sure how many people actually use the throttling
14:33:43 <rosmaita> but it would be better to have it fixed for the release than not
14:34:07 <rosmaita> next one is a bug that maybe requires a "known issue" release note
14:34:17 <rosmaita> #link https://bugs.launchpad.net/cinder/+bug/1909207
14:35:13 <rosmaita> i think at one point we were thinking this might not be a bug?
14:35:47 <enriquetaso> 1909207 i think this issues isn't a rbd problem so far
14:36:20 <eharney> this probably does need more investigation
14:36:33 <eharney> it was on my list at one point but clearly i lost track of it
14:36:54 <enriquetaso> maybe we can ask for the backend xuanyandong  is using
14:37:24 <eharney> we can just try to reproduce it
14:37:46 <eharney> and investigate if this is a thing that can happen
14:37:51 <rosmaita> does anyone have time to look at this before the next meeting?
14:39:00 <rosmaita> we can always have in "known issues" that this has been reported and may affect some backends
14:39:25 <enriquetaso> sounds good, I'm going PTO but I can try to reproduce it for next meeting.
14:39:40 <rosmaita> merging a release note is pretty fast, so we can decide next week
14:39:44 <rosmaita> thanks enriquetaso
14:40:09 <rosmaita> since enriquetaso will be on pto, though, if anyone else is interested in this, would be good to help out
14:40:46 <rosmaita> ok, we have another known issue that we discussed at the midcycle
14:40:58 <rosmaita> #link https://wiki.openstack.org/wiki/CinderXenaMidCycleSummary#what_to_do_about_qcow2-v2_support_being_yanked_from_various_linux_distros
14:41:10 <rosmaita> there was an action item to look into this
14:41:33 <rosmaita> what i found out is that we do look at whether the volume being managed is actually a qcow2
14:41:44 <rosmaita> but we only reject it if it has a backing file
14:41:51 <rosmaita> (because that's a security issue)
14:42:26 <rosmaita> i will write up a release note patch and bug people to review it
14:42:55 <rosmaita> as far as issues for the xena release, that's all i'm aware of
14:43:02 <rosmaita> anyone here run into anything?
14:44:05 <rosmaita> enriquetaso: that rbd trash bug might be a candidate
14:44:48 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/810402
14:45:19 <enriquetaso> yes
14:45:26 <enriquetaso> I think we may want ^ merged before RC1
14:45:46 <rosmaita> well, RC2, anyway
14:46:03 <rosmaita> let's discuss at the bug meeting, then
14:46:14 <enriquetaso> sure
14:46:30 <rosmaita> #topic deprecations
14:46:45 <rosmaita> I forgot to bring up the RateLimitingMiddleware deprecation last week, but since we're doing an RC-2, we still have time to decide for Xena
14:47:03 <rosmaita> i sent an email to the ML aimed at operators
14:47:10 <rosmaita> the response was ... nothing
14:48:01 <jungleboyj> So, it would be nice to assume that means it isn't being used.
14:48:32 <rosmaita> my feeling is that since nova doesn't have it any more, anyone interested in this is using a different solution for nova, and probably that same solution for any other services that need rate limiting
14:49:11 <jungleboyj> ++
14:49:15 <jungleboyj> That makes sense to me.
14:49:17 <rosmaita> i think eharney was skeptical about removing this, anyone else?
14:50:10 <rosmaita> one thing that did come up is that sfinucane had a docs patch up for this that's been sitting for a while
14:50:26 <rosmaita> which we don't need if we deprecate the rate limiting middleware
14:50:51 <rosmaita> but made me think that we are missing some docs patches in the Festival of Reviews
14:51:19 <rosmaita> so we may want to start emphasizing that
14:51:44 <rosmaita> anyway, i guess my ask is that if we are going to deprecate this, we need to do it this week
14:51:57 <rosmaita> so please leave comments on the patch:
14:52:04 <rosmaita> https://review.opendev.org/c/openstack/cinder/+/807469
14:52:37 <rosmaita> #topic stable release update
14:52:40 <rosmaita> whoami-rajat: that's you
14:52:46 <whoami-rajat> thanks
14:53:22 <whoami-rajat> so there's a patch up for victoria release, which i had to revise since it had some patches that doesn't exist in wallaby
14:53:47 <whoami-rajat> and in Ussuri, there was one patch left which is approved and in gate, so I've proposed the ussuri release patch as well
14:54:09 <whoami-rajat> victoria
14:54:10 <whoami-rajat> #link https://review.opendev.org/c/openstack/releases/+/809892
14:54:17 <whoami-rajat> ussuri
14:54:20 <whoami-rajat> #link https://review.opendev.org/c/openstack/releases/+/810442
14:54:35 <whoami-rajat> since train is EM, we won't be doing any release for it
14:54:57 <whoami-rajat> thanks everyone who helped with the reviews and made these releases possible!
14:55:00 <rosmaita> for victoria, you mean there were patches that are in stable/wallaby, but were not included in the most recent wallaby release?
14:55:21 <rosmaita> so you couldn't include them in the victoria release, either?
14:55:31 <whoami-rajat> yes, (I always word it wrong), they are merged in wallaby but not there in recent wallaby release 18.1.0
14:55:47 <rosmaita> ok, cool, just wanted to be clear
14:56:17 <whoami-rajat> I've recently updated the hash for the victoria release patch so would be great if you can take a look
14:56:30 <rosmaita> ok, will do
14:56:34 <whoami-rajat> that's all from me
14:56:35 <whoami-rajat> thanks
14:56:48 <rosmaita> thanks whoami-rajat
14:56:52 <hemna> fwiw I think we are using the rate limit middleware
14:57:08 <rosmaita> hemna: ok, that is good to know
14:57:14 <rosmaita> please leave a comment on that review
14:57:28 <hemna> sorry about the late response, too dang busy to follow everything
14:57:28 <rosmaita> #topic os-brick bug ?
14:57:36 <rosmaita> simondodsley: that's you
14:57:53 <simondodsley> thanks - we can take this to the cinder channel due to time constraints if you want.
14:58:05 <rosmaita> hemna: np, glad you brought i up because i was inclined to deprecate and remove
14:58:24 <rosmaita> simondodsley: that's a good idea, since the bug squad meeting is in cinder channel in 2 minutes!
14:58:32 <rosmaita> #topic open discussion
14:58:44 <rosmaita> 90 seconds for anything on anyone's mind
14:58:54 <eharney> i started poking at volume manage + encryption re: the bug earlier -- think i already found an issue in there, will probably write up a new, specific, bug report
14:59:16 <enriquetaso> maybe we can use the recording of the bug meeting for the os-brick bug so keep track somewhere simondodsley
14:59:20 <rosmaita> eharney: sounds good, ty
15:00:13 <rosmaita> well, that's all we have time for
15:00:15 <rosmaita> thanks everyone
15:00:23 <rosmaita> don't forget, video meeting next week
15:00:34 <jungleboyj> Thanks!
15:00:45 <e0ne> see you next week
15:00:51 <simondodsley> ttfn
15:00:58 <rosmaita> #endmeeting