14:00:30 <rosmaita> #startmeeting cinder
14:00:30 <opendevmeet> Meeting started Wed Nov  3 14:00:30 2021 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:30 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:30 <opendevmeet> The meeting name has been set to 'cinder'
14:00:36 <rosmaita> #topic roll call
14:00:42 <eharney> hi
14:00:42 <enriquetaso> o/
14:00:45 <jungleboyj> o/
14:00:49 <fabiooliveira> o/
14:01:00 <pots> \o
14:01:08 <nahimsouza[m]> o/
14:01:12 <LeoCampelo> o/
14:01:16 <angiolucci> o/
14:01:16 <walshh_> hi
14:01:53 <rosmaita> sorry about the late reminder ... my wall clock runs slow, but i don't want to replace it because where am i going to find another "Greetings from Grover's Mill New Jersey" clock?
14:02:18 <jungleboyj> :-)
14:02:27 <jungleboyj> You can reset it.  :-)
14:03:00 <rosmaita> jungleboyj: yeah, that's what i do, but i only notice that it's slow when i'm late for something
14:03:23 <rosmaita> anyway, looks like a good turnout ... hello everyone
14:03:42 <rosmaita> #link https://etherpad.openstack.org/p/cinder-xena-meetings
14:03:55 <rosmaita> #topic announcements
14:04:36 <rosmaita> ok, hopefully our European people remembered that today's meeting is an hour earlier than last week for htem
14:04:43 <rosmaita> now it's the USA's turn
14:05:15 <geguileo> daylight savings fun
14:05:17 <rosmaita> daylight saving time ends this weekend, so if you are in a region that observes it, the meeting will still be at 1400 utc, but that will happen an hour earlier for you
14:05:38 <rosmaita> next up
14:05:55 <rosmaita> you may remember that we spent a large part of the last day of the PTG at the TC meeting
14:05:58 <jungleboyj> This week has been so confusing thanks to the change in Europe and not China.
14:06:00 <rosmaita> about the secure rbac community goal
14:06:18 <rosmaita> there's a meeting about it immediately following this one
14:06:28 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-November/025619.html
14:06:35 <rosmaita> connection info in that email
14:06:45 <rosmaita> so if you are interested, feel free to attend
14:06:59 <rosmaita> we have a light agenda today, so maybe we can have the bug squad meeting early
14:07:11 <rosmaita> final announcement is:
14:07:19 <jungleboyj> rosmaita:  I wanted to attend but had another meeting scheduled over it.  So, will join if I am able to.
14:07:22 <enriquetaso> i'm interested.. but we have the bug meeting, should we postpone it?
14:07:35 <enriquetaso> oh cool
14:07:47 <enriquetaso> sounds fine
14:07:56 <rosmaita> great
14:08:11 <rosmaita> i never finished my sentence
14:08:28 <rosmaita> the final announcement is that the final ussuri release is supposed to happen next week
14:08:39 <rosmaita> we have an etherpad tracking patches
14:08:49 <rosmaita> #link https://etherpad.opendev.org/p/ussuri-final-release
14:10:06 <rosmaita> ok, looks like we got the multipath/iscsi not initiated after reboot patch merged into ussuri
14:10:17 <rosmaita> the other 2 are still at master
14:11:05 <rosmaita> i will review them this afternoon
14:11:15 <rosmaita> but will need other volunteers
14:11:28 <jungleboyj> rosmaita:  I will look.
14:11:39 <rosmaita> jungleboyj: ty
14:12:07 <rosmaita> for the cinderclient patch, someone other than jungleboyj needs to look
14:12:28 <enriquetaso> I'll review it
14:12:47 <enriquetaso> oh, it's stable/ussuri of course
14:12:49 <rosmaita> enriquetaso: ty, but it will also need a stable core
14:12:51 <rosmaita> :)
14:13:16 <rosmaita> enriquetaso: could definitely use your opinion on whether it should go into ussuri or not, though
14:13:40 <rosmaita> this is probably a good reminder about stable branch patches
14:14:05 <rosmaita> a -1 on those saying why it's not an appropriate backport carries a lot of weight
14:14:34 <enriquetaso> :)
14:14:51 <rosmaita> so don't leave those only to the stable core team, otherwise stuff occasionally slips through
14:15:04 <jungleboyj> ++
14:15:18 <rosmaita> because in addition to the code being good, it is also supposed to be an important fix, unlikely to destabilize the release
14:16:24 <rosmaita> ok, so for the cinderclient patch, let's see what sofia thinks, and then a stable core who's not me or jay can follow up
14:16:28 <rosmaita> before next week
14:17:03 <rosmaita> one last thing
14:17:16 <rosmaita> you probably saw the email, but i posted a summary of the ptg: https://wiki.openstack.org/wiki/CinderYogaPTGSummary
14:18:05 <rosmaita> any other announcements?
14:18:35 <rosmaita> ok, moving on then
14:18:43 <rosmaita> #topic six and drivers
14:19:19 <rosmaita> so, our policy has been that it's ok for drivers to continue to use the six library, though we have removed it from most of main cinder
14:19:28 <rosmaita> #link https://docs.openstack.org/cinder/latest/contributor/gerrit.html#python-2-to-python-3-transition-guidelines
14:19:42 <rosmaita> someone posted a patch to remove it from drivers
14:19:53 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/780759
14:20:28 <rosmaita> but before we do that, we should probably revise the policy
14:20:52 <rosmaita> also, simondodsley made the point on that review that maybe we should have the driver maintainers do it themselves
14:21:08 <rosmaita> as a check-in to make sure that drivers are actually being maintained
14:21:17 <rosmaita> which i think is a good idea
14:21:44 <rosmaita> also, i think someone said python 3.10 won't be compatible with six
14:22:01 <rosmaita> so we should probably start moving in this direction anyway
14:22:17 <rosmaita> at this point, i will shut up and see if anyone has an opinion on this issue
14:23:51 <rosmaita> apparently not
14:24:07 <enriquetaso> regarding python2 support, i found this yesterday https://opendev.org/openstack/cinder/src/branch/master/cinder/image/image_utils.py#L893
14:24:37 <enriquetaso> maybe we can do the six removed and that shutil as well
14:25:17 <rosmaita> good find, you are right
14:25:41 <rosmaita> we should broaden this to remove any py 2.7 detrius remaining in the code
14:25:56 <jungleboyj> rosmaita:  I think it would be an interesting exercise to see what driver maintainers do engage and remove six.
14:26:06 <jungleboyj> What do we do for the maintainers that don't?
14:26:23 <rosmaita> probably mark the drivers unsupported
14:26:46 <jungleboyj> Fair enough.  Hopefully that will then get some attention.
14:26:47 <rosmaita> we can make the change ourselves to keep the drivers in tree for now, but mark them as unsupported
14:26:50 <eharney> it's generally pretty easy for us to remove where we want to go ahead and do that
14:27:45 <rosmaita> ok, i will put up a patch to revise our six statement, and then send something to the ML
14:28:02 <rosmaita> to get comments on the patch, but also to float the idea that maintainers should do this
14:28:12 <jungleboyj> Ok  I think that makes sense.
14:28:22 <rosmaita> #action rosmaita revise six-and-drivers statement
14:28:43 <rosmaita> ok, that's all i had about that
14:28:57 <rosmaita> #topic mypy patch of the week
14:29:06 <rosmaita> i am happy to report that last week's patch merged!
14:29:19 <rosmaita> this week we have: https://review.opendev.org/c/openstack/cinder/+/788365/
14:29:24 <jungleboyj> \o/
14:29:33 <rosmaita> which already has a +2 and a +1
14:29:42 <rosmaita> so i will take this one
14:30:38 <eharney> thanks
14:30:43 <rosmaita> thanks to TusharTgite, he seems to have looked at a lot of these
14:31:21 <rosmaita> btw, eric has the patches stacked, so you can always find the next one and review it early, you don't have to wait for it to be announced
14:31:30 <jungleboyj> ++
14:31:39 <rosmaita> just look at the "Relation chain" in the gerrit interface
14:32:13 <rosmaita> #topic volume driver API
14:32:41 <rosmaita> geguileo has a few patches up addressing what we discussed at the ptg
14:32:51 <rosmaita> they all need reviews
14:33:15 <rosmaita> so rather than starting on a new function to document this week, i will request that people (including me) review them
14:33:31 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/814898
14:33:40 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/815660
14:33:49 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/815659
14:34:07 <rosmaita> they are stacked, too, so please review from the bottom up in the "Relation chain"
14:34:19 <rosmaita> (i'm not sure that i have the ordering correct above)
14:34:47 <rosmaita> #topic open discussion
14:36:17 <rosmaita> ok, i have something
14:37:09 <rosmaita> i've got a patch that autogenerates a lower-constraints file and then runs our tests with it to make sure that the min in our requirements is actually valid
14:37:17 <rosmaita> problem is, it uses 2 tox environments
14:37:33 <rosmaita> one to generate the file, and the second to use that file to run the tests
14:37:57 <rosmaita> i know how to map 1 tox testenv to a zuul job, but am not sure how to make it run 2 back to back
14:38:11 <rosmaita> so if anyone knows how to do that, i am all ears
14:39:11 <rosmaita> feel free to ping me in irc
14:39:26 <rosmaita> ok, sounds like nobody has any general discussion topics
14:39:32 <jungleboyj> *crickets*
14:40:16 <rosmaita> i propose that we adjourn early so that people have time to review the volume driver API patches
14:40:36 <rosmaita> so, thanks for attending everyone, and let's start the bug squad meeting early
14:40:51 <jungleboyj> Thanks!
14:40:54 <enriquetaso> Thanks
14:41:06 <rosmaita> #endmeeting