14:01:10 <rosmaita> #startmeeting cinder
14:01:10 <opendevmeet> Meeting started Wed Jan 19 14:01:10 2022 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:10 <opendevmeet> The meeting name has been set to 'cinder'
14:01:18 <rosmaita> #topic roll call
14:01:20 <whoami-rajat> Hi
14:01:35 <rosmaita> looks like i am at least in the correct channel this week
14:01:48 <fabiooliveira> hi
14:01:49 <whoami-rajat> :D
14:01:54 <walshh_> Hi
14:01:58 <jungleboyj> o/
14:02:00 <eharney> hi
14:02:11 <rosmaita> #link https://etherpad.openstack.org/p/cinder-xena-meetings
14:02:41 <sfernand> hi
14:02:49 <enriquetaso> hi
14:02:52 <eharney> https://etherpad.opendev.org/p/cinder-yoga-meetings
14:03:04 <jungleboyj> :-)
14:03:17 <simondodsley> hi
14:03:22 <raghavendrat_> hi
14:03:37 <caiquemello[m]> hi
14:03:55 <rosmaita> hello everyone, looks like a good turnout
14:04:02 <rosmaita> let's get started
14:04:11 <rosmaita> #topic announcements
14:04:32 <rosmaita> First, a reminder about the Festival of XS reviews on Friday 1400-1600 UTC
14:04:48 <rosmaita> the video link is https://meetpad.opendev.org/cinder-festival-of-reviews
14:05:03 <rosmaita> rumor is that some people have been having meetpad problems, so here is the etherpad link:
14:05:11 <rosmaita> https://etherpad.opendev.org/p/cinder-festival-of-reviews
14:05:39 <rosmaita> if you have meetpad problems, put a note on the etherpad on Friday, and we can communicate with you in IRC
14:05:55 <rosmaita> Next, "Z" release name nominations open until 24 January
14:06:04 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-January/026620.html
14:06:26 <rosmaita> this is your chance at immortality
14:06:45 <rosmaita> similarly, the release schedule for Z has been proposed:
14:06:53 <rosmaita> #link https://review.opendev.org/c/openstack/releases/+/824489
14:08:03 <rosmaita> if any of the milestones etc smack up against local holidays etc, it would be worth pointing out
14:08:36 <rosmaita> not that they will change, but it might be good for the release team to indicate that on the actual schedule so that people know when there will be review slowdowns
14:09:04 <rosmaita> next topic: Berlin Summit Call For Presentations
14:09:20 <rosmaita> the CFP closes on 9 February
14:09:29 <rosmaita> here's where you go to make a proposal:
14:09:39 <rosmaita> #link http://cfp.openinfra.dev/app/berlin-2022
14:09:55 <rosmaita> next item is on everyone's minds, i imagine
14:10:07 <rosmaita> New driver merge deadline is Friday (this week)
14:10:33 <rosmaita> another event sneaking up on us fast is
14:10:41 <rosmaita> The R-9 midcycle
14:10:52 <rosmaita> scheduled for next Wednesday (26 Jan)
14:11:04 <rosmaita> there is still room for topics
14:11:13 <rosmaita> #link https://etherpad.opendev.org/p/cinder-yoga-midcycles
14:11:23 <rosmaita> we will vote on the time in a few minutes
14:11:31 <whoami-rajat> There's a public holiday in India on 26th :/
14:11:42 <rosmaita> arrrrrgh!
14:11:50 <whoami-rajat> but i can try to attend
14:12:05 <whoami-rajat> don't know how i missed this before, anyway my bad
14:12:07 <rosmaita> ok, let's discuss in a minute
14:12:22 <whoami-rajat> ok
14:12:35 <rosmaita> final announcement is that vkmc posted a proposal for a pop-up team for using cephadm in devstack
14:12:43 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-January/026778.html
14:13:08 <rosmaita> you should read the email, but the tl;dr is that discussion will happen in #openstack-cephadm in OFTC
14:13:22 <rosmaita> including selecting when the popup team will meet
14:14:02 <rosmaita> that's all from me, anyone else have an announcement of general interest?
14:15:54 <rosmaita> ok, guess not
14:15:56 <sfernand> is this week the deadline for os-brick as well?
14:16:03 <rosmaita> #topic R-9 midcycle time
14:17:06 <rosmaita> ok, i guess the first question is ... do we want to postpone it for 1 week and hold it on 2 February?
14:18:04 <rosmaita> (please check your calendars!)
14:18:07 <jungleboyj> That is then part of the Spring Festival in China.  Does that impact anyone that was planning to attend?
14:18:22 <simondodsley> How do you know that??
14:18:40 <jungleboyj> Most of my team is in China.  :-)  They are gone for two weeks.
14:18:43 <sfernand> he works for a chinese company
14:18:45 * enriquetaso is on holiday on 2 Feb
14:18:49 <jungleboyj> So, it is a good time for me.
14:18:53 <jungleboyj> :-)
14:18:59 <jungleboyj> sfernand: Bingo!
14:19:13 <simondodsley> It's also Groundhog Day
14:19:22 <rosmaita> this gets better and better
14:19:22 <jungleboyj> Woo hoo!
14:19:22 <enriquetaso> (but it's okay if most of people wants to postpone)
14:19:36 <rosmaita> ok, i think we should keep it as is
14:19:38 <jungleboyj> simondodsley:  Now you are just googling.
14:19:46 <simondodsley> It's on my calender
14:20:05 <whoami-rajat> I will try to attend and if not will watch the recording later
14:20:09 <rosmaita> whoami-rajat: you can always watch the video
14:20:13 <whoami-rajat> yep
14:20:28 <rosmaita> yeah, if you don't have a topic you want discussed, you should take your holiday
14:20:40 <rosmaita> ok, so let's figure out the time
14:21:02 <rosmaita> first, to be completely clear, we are talking about Wednesday 26 January
14:21:21 <rosmaita> I'd like to do our usual thing where we use 1 hour from the weekly meeting time
14:21:21 <rosmaita> (since everyone has that blocked off already)
14:21:21 <rosmaita> and add an hour either before or after the meeting
14:21:52 <simondodsley> After is better for me
14:21:52 <rosmaita> we can vote on this right now
14:21:52 <rosmaita> options are:
14:21:52 <rosmaita> A 1300-1500 UTC
14:21:52 <rosmaita> B 1400-1600 UTC
14:21:52 <rosmaita> C either one of the above
14:21:54 <rosmaita> D need more options
14:22:02 <rosmaita> #startvote time for the R-9 (26 January) midcycle? A, B, C, D
14:22:02 <opendevmeet> Begin voting on: time for the R-9 (26 January) midcycle? Valid vote options are A, B, C, D.
14:22:02 <opendevmeet> Vote using '#vote OPTION'. Only your last vote counts.
14:22:15 <enriquetaso> #vote C
14:22:21 <simondodsley> #vote B
14:22:26 <rosmaita> #vote B
14:22:38 <jungleboyj> #vote B
14:22:39 <SachinMore> #vote C
14:22:40 <sfernand> #vote C
14:23:35 <fabiooliveira> #vote C
14:23:42 <felipe_rodrigues> #vote C
14:23:53 <caiquemello[m]> #vote C
14:24:06 <TusharTgite> #vote C
14:24:58 <rosmaita> voting will close in 1 minute
14:25:00 <mionsz> #vote B
14:25:04 <eharney> #vote C
14:25:57 <rosmaita> #showvote
14:25:57 <opendevmeet> C (8): sfernand, fabiooliveira, enriquetaso, caiquemello[m], TusharTgite, eharney, felipe_rodrigues, SachinMore
14:25:57 <opendevmeet> B (4): simondodsley, jungleboyj, rosmaita, mionsz
14:26:08 <rosmaita> last call ...
14:26:33 <rosmaita> #endvote
14:26:33 <opendevmeet> Voted on "time for the R-9 (26 January) midcycle?" Results are
14:26:33 <opendevmeet> C (8): sfernand, fabiooliveira, enriquetaso, caiquemello[m], TusharTgite, eharney, felipe_rodrigues, SachinMore
14:26:33 <opendevmeet> B (4): simondodsley, jungleboyj, rosmaita, mionsz
14:26:56 <rosmaita> OK, we'll meet from 1400-1600 UTC
14:27:42 <rosmaita> just as a reminder ... if you have a topic and only have 1400-1500 open, leave a note on the etherpad and we'll try to get to you during that time
14:27:53 <rosmaita> thanks everyone
14:27:58 <rosmaita> so to summarize:
14:28:16 <rosmaita> the R-9 Midcycle is on 26 January 2022 1400=1600 UTC
14:28:34 <rosmaita> #topic core reviewer situation
14:29:00 <rosmaita> ok, it will come as a surprise to no one that we are having review bandwidth problems
14:29:36 <rosmaita> i just want to mention that if anyone has interest in becoming a cinder core, please contact me or one of the other cores to discuss what it entails
14:29:57 <rosmaita> we may also be able to give you helpful arguments to use with your manager about why it is a good use of your time
14:30:33 <rosmaita> don't worry about your review count at the moment, we can discuss expectations and how to meet them
14:30:50 <rosmaita> that's all I have to say about that right now
14:30:55 <rosmaita> except for a related topic
14:31:14 <rosmaita> i am being PM'd on IRC, which is OK in general
14:31:32 <rosmaita> but i am being pinged about doing reviews ... which is sort of neutral
14:31:54 <rosmaita> you should definitely ping me if i left a comment on your patch and you have revised
14:32:07 <rosmaita> because i don't always get back to those quickly
14:32:32 <rosmaita> but if you do a cold IRC ping requesting a review, i would like you to also include links to 2 reviews you have done on other people's patches
14:32:54 <rosmaita> and these should be reviews that have a helpful comment or 2, not simply a +1
14:33:14 <rosmaita> that's my personal policy, just thought i should say it out loud
14:33:30 <rosmaita> #topic block-box situation
14:33:50 <rosmaita> first thing is that last week i learned that this thing was "block" box, not black box
14:33:53 <rosmaita> but i digress
14:34:03 <rosmaita> i sent an email to the ML
14:34:11 <rosmaita> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-January/026639.html
14:34:20 <rosmaita> the silence has been deafening
14:34:29 <rosmaita> so i think we can go ahead and remove it
14:34:39 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/824472
14:34:41 <eharney> removing it sounds good
14:34:54 <rosmaita> patch already has a +2!
14:34:54 <jungleboyj> Agreed.
14:35:22 <sfernand> +1 remove
14:35:41 <rosmaita> i think we are all in agreement there, so review at your leisure
14:36:00 <rosmaita> #topic allow driver feature backport?
14:36:09 <raghavendrat_> hi
14:36:11 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/820628
14:36:53 <jungleboyj> Oh boy.
14:37:13 <rosmaita> i'll give everyone time to look it over
14:37:14 <simondodsley> I see 2 issues here. One being Ussuri is EM and the othe ris IMHO I think this sia feature backport, but given it was approved as a backport for Victoria...
14:37:35 <rosmaita> well, we can revert it from Victoria
14:37:42 <rosmaita> so i don't see that as an issue
14:37:53 <whoami-rajat> I might be missing something here but we've allowed feature backports that are driver specific before right?
14:37:57 <rosmaita> my concern just has to do with setting expectations about when this will be allowed
14:37:58 <simondodsley> They also have a patch open for this in Train
14:38:04 <eharney> well, the code itself isn't much of a feature, it's just removing a restriction to not run against certain array versions, i think?
14:38:08 <rosmaita> whoami-rajat: i am not sure
14:38:17 <raghavendrat_> right eharney
14:38:41 <jungleboyj> Hmm, I reviewed and hadn't interpreted as a feature.
14:38:43 <simondodsley> simple code change I agree, but this is effectively adding a new driver by adding a new backplane
14:38:53 <raghavendrat_> Initially Primera hardware had only FC support... Later iSCSI support was added
14:39:06 <jungleboyj> I see it is kind of a feature though.
14:39:07 <whoami-rajat> rosmaita, i think we've had tons of backports that are driver specific since the changes are isolated to the driver itself and doesn't affect cinder as a whole
14:39:08 <rosmaita> eharney: yeah, but my concern is that there may be differences between master and older versions that make the change unproblematic in master but maybe not in older versions
14:39:09 <sfernand> I believe at least start talking about this possibility is important because some clouds just moved to Train due to OSP 16... We should have OSP 17 comming in a near future but adoption may be quite slow
14:39:24 <sfernand> and it is really a pain to deliver improvements to customers..
14:39:52 <simondodsley> For OSP16 RH will do downstream backports if you raise a BZ
14:40:03 <raghavendrat_> we got customer ask for Ussuri
14:40:22 <simondodsley> The Ussuri ask is for Canonical I think
14:40:34 <simondodsley> The Train is for RH - 2 customers
14:40:49 <raghavendrat_> in link: https://ubuntu.com/about/release-cycle ... pls search for "ussuri"
14:41:03 <raghavendrat_> it has extended support till 2030
14:41:13 <simondodsley> Ubunut's support is not the same as OpenStack support cycles
14:41:16 <sfernand> simondodsley: all bzs I've opneded was required to be merged in official repos first =x
14:41:18 <simondodsley> ussuroi is EM
14:41:27 <sfernand> even old backports such as queens...
14:41:33 <sfernand> for osp 13
14:41:37 <raghavendrat_> whereas V, W and X have support of 2 years.
14:41:54 <simondodsley> i have been told that downstream ports are possible - I'm doing one now for Manila
14:42:35 <rosmaita> yes, but upstream backports spread the goodness to everyone
14:42:38 <rosmaita> but also the risk
14:43:07 <rosmaita> we can talk about this next week at the midcycle
14:43:12 <sfernand> yep that is a nice approach in teory but impossible to mantain a CI running
14:43:23 <sfernand> for too many releases in the bast..
14:43:27 <sfernand> past*
14:43:38 <sfernand> that would be nice!
14:43:41 <rosmaita> our position could be that it's possible on a case-by-case basis
14:44:18 <raghavendrat_> ok. will wait for midcycle
14:44:21 <simondodsley> that could lead to many discussions whereas a blanket - no feature backports would be better
14:44:49 <rosmaita> but i think we want to require at least an assurance from the vendor that there have been clean CI runs for the appropriate branches
14:44:56 <simondodsley> even if this is backported to Ussuri, who is cutting a new release?
14:45:11 <raghavendrat_> we will definitely run CI
14:45:22 <raghavendrat_> and ensure that there is no regression
14:45:45 <rosmaita> raghavendrat_: yes, i am not saying that you wouldn't ... just that we should have some formal documentation of that
14:46:03 <raghavendrat_> ok
14:46:28 <rosmaita> ok, everyone please think about this, and we will discuss next week in video ... should be easier to have the discussion
14:46:59 <raghavendrat_> thanks everyone. Appreciate your feedback.
14:47:33 <rosmaita> #topic new driver questions/comments/etc
14:47:43 <rosmaita> #link https://etherpad.opendev.org/p/cinder-yoga-new-drivers
14:47:59 <rosmaita> ok, let's look at the etherpad
14:48:08 <rosmaita> so far we've had TOYOU merge
14:48:19 <rosmaita> i still haven't heard from YADRO
14:48:45 <rosmaita> the HPE X_ an dNEC Storage V require some patches to merge first
14:49:00 <rosmaita> lines 36-37 in the etherpad
14:49:22 <rosmaita> after that, the drivers themselves should be easy to review, assuming that the third party CI is running
14:49:31 <whoami-rajat> I see 3 drivers following the format of just inheriting all useful methods from existing drivers and not implementing anything
14:49:33 <simondodsley> just to let everyone know the Pure NVMe driver will miss the deadline as our Software Factory CI build has hit issues and we have no one with good SF knowledge to help out. We are looking for a short-term contractor with SF knowledge to help get this over the line if anyone knows of someone
14:49:56 <rosmaita> sorry to hear about missing the deadline
14:50:10 <rosmaita> but thanks for letting us know so we can focus review effort elsewhere
14:50:18 <yuval> Hey simon, we took the jenkins-gerrit-trigger path
14:50:22 <rosmaita> the Dell NFS Driver looks not ready for Yoga
14:50:29 <yuval> if you would like to setup this env, we can help
14:50:42 <simondodsley> we will refactor the driver to multiple files and add NVMe-FC and sync rep support for Z
14:50:57 <rosmaita> simondodsley: that sounds like a good plan
14:51:21 <rosmaita> ok, the big one then, is Lightbits
14:51:41 <rosmaita> we have the driver, an os-brick connector, and there's a nova driver too
14:51:41 <simondodsley> yuval: thanks for the suggestion. It might be something we can investigate, but we did want to do SF as that is the preferred way
14:51:58 <yuval> got it
14:52:22 <rosmaita> yeah, we were hoping that Software Factory would be a useful thing for all our third-party CIs
14:53:26 <yuval> as far as we know, the cinder driver is ready
14:53:34 <yuval> we upload yesterday updated code
14:53:47 <rosmaita> great, i will look at the most recent version today
14:53:59 <yuval> thanks
14:54:15 <rosmaita> thanks to Gorka and Simon for thorough reviews on the Lightbits driver
14:54:30 <yuval> right, that was very helpful!
14:55:02 <rosmaita> #topic open discussion
14:55:33 <rosmaita> review priorities: new drivers, and os-brick ... there are some important NVMe connector patches
14:55:47 <rosmaita> don't forget the Festival of XS reviews on Friday
14:56:24 <rosmaita> remember, if you want reviews it helps to do reviews
14:56:55 <rosmaita> i have a suspicion that i am forgetting something
14:57:24 <rosmaita> #action rosmaita reminder to the ML about R-9 midcycle next week
14:59:02 <bingyanh_> hi i have a question :which version will the master branch be released to? Y?
14:59:27 <rosmaita> yes, right now master branch is also known as the yoga development branch
14:59:47 <rosmaita> at release time, we will branch master to stable/yoga
14:59:57 <rosmaita> and then master will become the Z development branch
15:00:20 <bingyanh_> thanks
15:00:28 <rosmaita> ok, we are out of time
15:00:39 <rosmaita> thanks, everyone, and see you next week at the midcycle!
15:00:44 <bingyanh_> so how to merge the code of the master branch to other versions?
15:00:44 <bingyanh_> Cherry Pick?
15:00:44 <bingyanh_> when a driver have bug
15:00:52 <whoami-rajat> thanks!
15:00:56 <rosmaita> #endmeeting