14:00:22 <whoami-rajat> #startmeeting cinder
14:00:22 <opendevmeet> Meeting started Wed Apr 20 14:00:22 2022 UTC and is due to finish in 60 minutes.  The chair is whoami-rajat. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:22 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:22 <opendevmeet> The meeting name has been set to 'cinder'
14:00:28 <whoami-rajat> #topic roll call
14:00:50 <simondodsley> o/
14:00:51 <tosky> o/
14:00:53 <felipe_rodrigues> o/
14:01:02 <eharney> hi
14:01:06 <jbernard> o/
14:01:07 <jungleboyj> o/
14:01:19 <nahimsouza[m]> o/
14:01:21 <caiquemello[m]> o/
14:01:47 <whoami-rajat> #link https://etherpad.openstack.org/p/cinder-zed-meetings
14:02:21 <rosmaita> o/
14:02:56 <lucasmoliveira059> o/
14:03:12 <whoami-rajat> we've a good turnout
14:03:23 <whoami-rajat> so let's start
14:03:27 <whoami-rajat> #topic announcements
14:03:34 <whoami-rajat> first, Cinder mid cycle dates
14:03:36 <enriquetaso> hi
14:03:46 <whoami-rajat> #link https://de46dad8d0940c6cc81e-27618e467ab9b983fdfb7a89cc8b48ca.ssl.cf2.rackcdn.com/837494/3/check/openstack-tox-docs/e70ce68/docs/zed/schedule.html
14:03:48 <e0ne_> hi
14:04:01 <whoami-rajat> I've reproposed the Zed schedule for cinder to include midcycle 1 (at R-18) and midcycle 2 (at R-9)
14:04:19 <whoami-rajat> as a placeholder, I've marked the dates, 1st June (Wednesday) and 3rd August (Wednesday) 1400-1600 UTC as the proposed dates
14:04:31 <fabiooliveira> hi
14:04:50 <whoami-rajat> would like to know if there are any conflicts of the above dates with other events or country specific holiday
14:05:15 <whoami-rajat> also would like to know if the date/time is not comfortable and I should do a poll instead
14:05:47 <rosmaita> i won't be available for Aug 3, but that's just me
14:05:58 <whoami-rajat> I've proposed the timing overlapping with the cinder meeting (+ one extra hour) as it works for everyone
14:06:45 <whoami-rajat> oh, the idea is to have the midcycle at R-9 so we can schedule any day of the week
14:07:13 <rosmaita> i will just watch the video when i get back
14:07:41 <simondodsley> same for me
14:08:06 <whoami-rajat> sure, or we can do a poll as well, if others also feel more comfortable on another day
14:08:30 <whoami-rajat> ok, i guess we're going to do a poll for R-9 then
14:08:54 <whoami-rajat> any conflicts for R-18?
14:09:30 <rosmaita> no conflict for me
14:10:02 <simondodsley> no
14:10:17 <sfernand> both dates works fine for the netapp folks
14:10:33 <whoami-rajat> cool, I will change the release schedule to exclude R-9 for now and prepare a poll
14:10:42 <whoami-rajat> #action whoami-rajat to prepare a poll for R-9 midcycle
14:10:49 <whoami-rajat> great
14:10:55 <whoami-rajat> moving on
14:10:59 <whoami-rajat> second, Monkeypatching FIPS
14:11:04 <whoami-rajat> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-April/028250.html
14:11:14 <whoami-rajat> Ade lee sent out a mail regarding monkeypatching paramiko as paramiko uses md5 which makes it FIPS non complaint
14:11:31 <whoami-rajat> (the mail also mentions cinder)
14:11:47 <whoami-rajat> I still haven't looked at the cinder code for any occurrence but just for awareness, we need to wait for the fix to land in paramiko or adopt any other lib, until then projects are planning to monkeypatch it
14:11:52 <e0ne_> #link https://github.com/openstack/cinder/search?q=paramiko
14:12:08 <eharney> we have some drivers that use paramiko
14:12:16 <whoami-rajat> thanks e0ne_ , so we are using paramiko
14:12:26 <e0ne_> whoami-rajat: np
14:13:05 <whoami-rajat> so someone (probably me) will reply to the mail about cinder using paramiko
14:13:08 <eharney> AFAIK it is only used for a few drivers to talk to the backend, so one option is that those drivers won't work in FIPS mode until it's fixed
14:13:45 <whoami-rajat> ok
14:13:59 <simondodsley> some of those backends may not be FIPS compliant anyway so wouldn't be used in a FIPS environment
14:14:29 <whoami-rajat> i guess then it shouldn't be much of an issue since the FIPS jobs we will be running are mostly lvm, ceph, nfs related
14:14:35 <e0ne_> should we add t FIPS support requirement for new drivers?
14:14:47 <whoami-rajat> and third party CI still doesn't run on centOS
14:15:08 <whoami-rajat> so we need to wait for FIPS support in ubuntu to make it a requirement for drivers
14:15:20 <eharney> right
14:15:35 <rosmaita> we can strongly suggest that drivers keep it in mind
14:15:46 <whoami-rajat> ok, that's a relief
14:16:08 <simondodsley> something in the new drivers documentation?
14:16:19 <rosmaita> or the review checklist
14:16:21 <rosmaita> or both
14:16:24 <rosmaita> :)
14:16:51 <rosmaita> basically, don't use md5 and only use well-respected crypto libraries
14:17:00 <whoami-rajat> both sounds good, one cinder wide and one driver specific
14:17:03 <rosmaita> and don't implement your own crypto under any circumstances
14:17:28 <eharney> yeah, a review checklist for such things seems like a good idea
14:17:34 <e0ne_> rosmaita: :)
14:17:45 <rosmaita> whoami-rajat: you can give me an action item on this
14:18:04 <whoami-rajat> rosmaita, regarding documentation or replying to the email thread?
14:18:10 <whoami-rajat> or both :)
14:18:13 <rosmaita> docs
14:18:19 <whoami-rajat> ok
14:18:31 <whoami-rajat> i will reply to the email with our discussion
14:18:51 <whoami-rajat> #action rosmaita to include FIPS related documentation for new drivers
14:19:09 <whoami-rajat> #action whoami-rajat to respond to the mail thread with our discussion
14:19:18 <rosmaita> my personal opinion is that we should use something other than paramiko in ssh_utils
14:20:27 <whoami-rajat> maybe Ade has some idea about good alternatives, can discuss with him
14:20:48 <whoami-rajat> that's all for my announcements, does anyone have any other announcement?
14:22:01 <whoami-rajat> guess not, so let's move to topics
14:22:10 <whoami-rajat> #topic vote on NetApp proposal to backport ONTAP REST API support
14:22:26 <whoami-rajat> Fernando suggested that we should do this in the video + IRC meeting (that is next week) so everyone can express their opinions about it and then we can vote
14:22:49 <whoami-rajat> e0ne_, will you be available in next week's video + IRC meeting?
14:23:00 <e0ne_> whoami-rajat: I really hope so
14:23:13 <jungleboyj> :-)
14:23:35 <e0ne_> if I won't join, my current vote is to don't allow such backports
14:23:57 <geguileo> ok
14:24:14 <sfernand> e0ne_:  ok
14:24:28 <whoami-rajat> ok, so my personal opinion is it would make sense to have a discussion on it before voting else we will end up upvoting or downvoting it without any concrete conclusion
14:24:46 <eharney> yes, i think more discussion is needed
14:24:53 <simondodsley> I can't make the next meeting either and my vote would be to not allow these backports - specify supported ONTAP versions that drivers support instead
14:25:36 <rosmaita> right now, i'm with e0ne_ on this as well
14:26:50 <whoami-rajat> ok, so let's discuss it next week and maybe we can drag the discussion till mid cycle to properly finalize it, till then the netapp team can work on their patch for master
14:27:09 <sfernand> whoami-rajat: ++
14:27:39 <whoami-rajat> cool, anything else on this topic?
14:28:21 <whoami-rajat> guess not, moving on then
14:28:27 <whoami-rajat> #topic release notes with driver patches
14:28:30 <whoami-rajat> rosmaita, that's you
14:28:59 <rosmaita> basically, just what i said on the agenda
14:29:19 <geguileo> rosmaita: copy/paste then  };-)
14:29:19 <rosmaita> (which i will paste in here as soon as i find it)
14:29:34 <rosmaita> note to reviewers and driver maintainers: any driver fix that will be backported should have a release note
14:29:34 <whoami-rajat> note to reviewers and driver maintainers: any driver fix that will be backported should have a release note
14:29:46 <rosmaita> ok, we agree on this :)
14:30:05 <whoami-rajat> +1
14:30:30 <geguileo> rosmaita: in general ANY driver fix should have a release note
14:30:36 <geguileo> regardless of the backporting aspect
14:30:38 <jungleboyj> ++
14:30:42 <simondodsley> +1
14:30:44 <whoami-rajat> usually allowed backports are mostly bugfixes so it's rare I've seen one without a releasenote
14:31:00 <rosmaita> well, i was reviewing the other day, and this came up
14:31:28 <geguileo> rosmaita: and we should also say:  driver bug fixes MUST have a launchpad bug explaining what's fixing
14:31:28 <rosmaita> so maybe this is more for reviewers to keep in mind
14:31:39 <simondodsley> the huawei patches referenced later in this meeting are missing them
14:31:48 <e0ne_> geguileo: +1
14:31:55 <rosmaita> geguileo: and the commit message should make sense
14:32:03 <rosmaita> and the bug report should also make sense
14:32:06 <geguileo> rosmaita: oooooh, that's a good one ;-)
14:32:28 <rosmaita> and good engineering practices in the code
14:32:35 <whoami-rajat> so we already have an example
14:32:43 <e0ne_> rosmaita: and not include 'proprietary crypto algorithm for a driver'
14:32:45 <geguileo> rosmaita: that's sometimes subjective  ;-P
14:32:51 <geguileo> e0ne_: +1
14:33:21 <geguileo> whoami-rajat: you were working on a reviewer doc patch, these points can be added there
14:33:31 <e0ne_> oops... I missed 'implementation' word in my previous message:(
14:34:23 <whoami-rajat> geguileo, sure, these are some good ideas
14:34:40 <rosmaita> ok, for now, reviewers, please keep the above in mind
14:34:53 <e0ne_> rosmaita: +1
14:35:01 <rosmaita> and if you see a driver patch with no release note, that's an easy -1 !!!
14:35:47 <whoami-rajat> I'm happy rosmaita is providing lots of points for my review doc, probably rosmaita can co-author it as well!
14:36:19 <rosmaita> whoami-rajat: you can have those points for free :)
14:36:43 <whoami-rajat> :D
14:36:51 <whoami-rajat> ok, so i think the point is pretty straightforward here
14:36:57 <whoami-rajat> we can move on to the next topic then
14:37:06 <whoami-rajat> #topic fixing some DB API function signature inconsistencies
14:37:09 <whoami-rajat> rosmaita, that's you again
14:37:17 <rosmaita> i will be real quick (for a change)
14:37:20 <rosmaita> #link https://review.opendev.org/c/openstack/cinder/+/837542/3
14:37:51 <rosmaita> the question is, how far do we want to go in fixing this on this patch
14:38:10 <rosmaita> please take a look, i have comments and stephen has responses
14:38:27 <rosmaita> i have an opinion, but we should probably get some other people in on the action
14:38:48 <rosmaita> so if you are interested in consistency between the db api interface and the sqlalchemy implementation, take a look
14:38:56 <rosmaita> and if you don't care, something will happen
14:38:59 <rosmaita> that's it
14:39:30 <whoami-rajat> i can see 10 review comments, is there any one in specific or all are pointing to a general idea ?
14:40:46 <rosmaita> there are maybe 3 general issues
14:41:31 <geguileo> am I the only one that thinks we should completely drop that cinder/db/api.py file?
14:41:49 <whoami-rajat> ok, so we can take a look at rosmaita's comments
14:41:51 <eharney> geguileo: it's a reasonable idea
14:41:58 <geguileo> or is there somebody that thinks we'll ever support something different than SQLA?
14:42:34 <rosmaita> i suspect not
14:43:11 <eharney> geguileo: Nova did it here: https://review.opendev.org/c/openstack/nova/+/799524
14:43:56 <whoami-rajat> that sounds like a good idea for cinder midcycle
14:43:56 <geguileo> a pain to review, but makes sense to me
14:44:16 <whoami-rajat> that's a long list of file changes...
14:44:17 <rosmaita> then i guess it doesn't matter what happens in that patch
14:44:43 <rosmaita> because we will be making changes later anyway
14:44:55 <rosmaita> let's get rid of the legacy enginefacade first though
14:45:12 <rosmaita> i.e., do not stop reviewing the current patches!!!
14:45:29 <whoami-rajat> yep, that's a good reminder for a priority item ^^
14:45:55 <rosmaita> #link http://tiny.cc/cinder-legacyfacade
14:46:03 <whoami-rajat> anyway, we can discuss the merging of db/api and db/sqlalchemy/api later
14:46:04 <rosmaita> ^^ that's a handy review dashboard
14:46:12 <geguileo> it kills me a bit when somebody reorders methods in a file...
14:46:59 <rosmaita> yeah, but it is kind of nice to have the related ones together
14:47:16 <rosmaita> saves my control key from getting worn out in emacs
14:47:36 <whoami-rajat> so let's move on as we've other topics to cover as well (and less time)
14:47:47 <whoami-rajat> #topic EM release for Victoria is April 27
14:47:53 <whoami-rajat> jbernard, that's you
14:48:07 <jbernard> heya, last victoria release is next week
14:48:14 <jbernard> we have 6 outstanding patches: https://review.opendev.org/q/branch:stable/victoria+project:openstack/cinder+status:open
14:48:18 <whoami-rajat> so i forgot this in my announcement, jbernard has stepped up to take up stable release maintenance!
14:48:40 <enriquetaso> \o/
14:48:59 <rosmaita> jbernard: ++
14:49:05 <simondodsley> congrats
14:49:07 <eharney> excellent
14:49:18 <rosmaita> i guess i should drop my -2 on https://review.opendev.org/c/openstack/cinder/+/822939 ?
14:49:19 <whoami-rajat> jbernard++ thanks!
14:49:29 <jungleboyj> \o/
14:49:35 <jungleboyj> Thank you jbernard !
14:49:51 <rosmaita> not sure the issue has been settled yet, but i will leave it up to other reviewers
14:49:54 <jbernard> if im understanding the process correctly, I need some time for the release team to process the request, so we need the patches we care about merged by Monday (Apr 25) at the latest (i estimate)
14:50:09 <whoami-rajat> so stable cores can take a look at the open patches as we're nearing the final victoria release (mostly have votes as of now)
14:50:24 <simondodsley> rosmaita that one is abandoned anyway
14:50:43 <rosmaita> simondodsley: ty!
14:50:44 <eharney> rosmaita: i'll go fix up that whole thing after i fix master
14:50:52 <rosmaita> ok, cool
14:50:59 <whoami-rajat> rosmaita, eharney has abandoned it, so you can remove it when he restores?
14:51:14 <rosmaita> sure
14:51:17 <jbernard> ok, we're already down to 5, making progress ;)
14:51:46 <rosmaita> jbernard: you are already killing it as release manager!
14:51:53 <eharney> https://review.opendev.org/c/openstack/cinder/+/831188 is ineligible currently, so easy to skip that one
14:51:54 <whoami-rajat> jbernard, that's right, we should do our release before 27th so release team can get time to make the transition easier for victoria to EM
14:52:54 <whoami-rajat> eharney, yep, most probably it won't make to victoria in time
14:53:03 <whoami-rajat> so we can skip patches that are currently open in master
14:53:10 <whoami-rajat> or are far away from making it to victoria
14:53:29 <whoami-rajat> unless people want that change in
14:53:36 <whoami-rajat> and working towards getting it in
14:54:21 <whoami-rajat> so, stable cores, take a look at the open patches in victoria
14:54:36 <whoami-rajat> moving on
14:54:39 <whoami-rajat> #topic Replace distutils in drivers
14:54:47 <whoami-rajat> simondodsley, that's you
14:54:52 <simondodsley> as mentioned in the agenda I have a patch up to replace driver usage of distutils (https://review.opendev.org/c/openstack/cinder/+/832130) to stop any future bugs, but some of the affected drivers don't have CIs - can we just merge this patch without those CI, or does anyone know who owns these CI systems?
14:56:14 <eharney> unit tests should be sufficient for this change
14:56:15 <whoami-rajat> i can see there are 6 drivers using it
14:56:24 <eharney> CI results are not really interesting
14:56:36 <whoami-rajat> if those driver maintainers can take a look, would be good
14:56:39 <jbernard> the nature of the changes do not impact the driver logic itself, i would vote to merge personally
14:56:58 <simondodsley> finmding the CI maintainers is the biggest issue
14:57:05 <simondodsley> we need a list of current maintainers
14:57:07 <rosmaita> i think a message to the ML and then we mark all those as unsupported (if they aren't already)
14:57:31 <whoami-rajat> rosmaita, that sounds like a good idea
14:57:39 <rosmaita> well, the 3rd party CIs are supposed to keep their info in the wiki up to date
14:58:01 <simondodsley> but if there isn't even a CI...
14:58:12 <simondodsley> eg I cannot find an IBM DS8k CI
14:58:22 <rosmaita> i actually thought that driver had been removed
14:58:24 <simondodsley> or a powerflex
14:58:30 <whoami-rajat> this seems to be a concern with re-occurring changes that modify driver code
14:59:49 <eharney> i'm not sure why it's a concern with this change
14:59:54 <simondodsley> DS8k is still listed as supported as is powerflex
15:00:14 <whoami-rajat> eharney, not specifically this change but in general driver maintainers not being active
15:00:17 <whoami-rajat> i will send out a mail to the ML mentioning the drivers in question here, in the meantime if the team thinks this change is good with unit tests only then we can merge as well
15:00:20 <simondodsley> this change just highlights the lack of visibility on 3rd party CIs
15:00:22 <rosmaita> eharney: it's just a general erosion of standards
15:01:00 <rosmaita> but eharney has a good point, we shouldn't let it hold up this patch, i guess
15:01:31 <whoami-rajat> rosmaita, yep, as stated above, if people think the change is good with UTs then we can go ahead and merge
15:01:47 <whoami-rajat> but i will send out the mail anyway
15:01:56 <whoami-rajat> and we're out of time
15:02:00 <whoami-rajat> last topic
15:02:14 <whoami-rajat> #topic request for review of backports  -- i think we already got reviews on them
15:02:18 <whoami-rajat> to add releasenote
15:02:25 <simondodsley> OK - I guess I will have to work out how to do a UT for this - BTW I hate writing in mock :)
15:02:57 <whoami-rajat> so ganso you can make those changes and team can review again
15:03:20 <whoami-rajat> simondodsley, i think eharney means the current UTs should validate your change (or maybe i understood it wrong)
15:03:28 <simondodsley> and add a statement that this has been tested on the stable branch
15:03:40 <whoami-rajat> let's continue discussion in cinder channel (after bugsquad meeting)
15:03:41 <eharney> i don't know if the current ones do or not, they might, or coverage might need to be added
15:03:47 <simondodsley> whoami-rajat - ah, ok
15:03:50 <whoami-rajat> thanks everyone!
15:03:52 <whoami-rajat> #endmeeting