14:00:13 <whoami-rajat> #startmeeting cinder
14:00:13 <opendevmeet> Meeting started Wed Jun  8 14:00:13 2022 UTC and is due to finish in 60 minutes.  The chair is whoami-rajat. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:13 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <opendevmeet> The meeting name has been set to 'cinder'
14:00:18 <whoami-rajat> #topic roll call
14:00:38 <eharney> howdy
14:00:40 <tosky> hi
14:01:04 <fabiooliveira> hi
14:01:08 <simondodsley> hi from Berlinb
14:01:08 <felipe_rodrigues> o/
14:02:26 <whoami-rajat> I think Fernando is also in Berlin and was asking if someone else was there too from cinder team simondodsley
14:02:44 <simondodsley> Yuval from LightBits is also here
14:02:50 <enriquetaso_> hi
14:02:56 <whoami-rajat> oh cool
14:03:00 <enriquetaso> hi
14:03:05 <whoami-rajat> #link https://etherpad.openstack.org/p/cinder-zed-meetings
14:04:52 <whoami-rajat> we've a good amount of people and a long agenda today so let's get started
14:04:57 <whoami-rajat> #topic announcements
14:05:23 <whoami-rajat> first, Cinder midcycle-1 summary
14:05:31 <whoami-rajat> #link https://wiki.openstack.org/wiki/CinderZedMidCycleSummary
14:06:03 <whoami-rajat> I've prepared a summary of our first mid cycle held last week, it is quite a short one but has links to the recordings
14:06:24 <whoami-rajat> second, Release name change after Zed
14:06:38 <whoami-rajat> so the new release naming is official
14:06:40 <whoami-rajat> #link https://governance.openstack.org/tc/reference/release-naming.html
14:06:58 <whoami-rajat> I've taken an example from the above doc
14:07:09 <rosmaita> o/
14:08:32 <whoami-rajat__> hope I'm back
14:08:38 <whoami-rajat__> internet issue
14:08:44 <geguileo> whoami-rajat__: you are back
14:08:50 <whoami-rajat__> thanks!
14:09:04 <whoami-rajat__> so we were on the release naming
14:09:11 <whoami-rajat__> I've taken an example from the above doc
14:09:26 <whoami-rajat__> the first release after Zed will be named in this format -- OpenStack 2023.1 Axxxx
14:09:34 <whoami-rajat__> Where “2023” is the year of the release, “1” represents the first release of the year and “Axxxx” is the release name.
14:10:00 <whoami-rajat__> and this will continue for subsequent releases
14:10:04 <whoami-rajat__> more info is in the governance doc
14:10:20 <whoami-rajat__> next announcement, RBAC new design discussion
14:10:20 <geguileo> having the date there is nice
14:10:36 <whoami-rajat__> yeah would be easy to track releases
14:10:44 <whoami-rajat__> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-June/028878.html
14:10:59 <rosmaita> the big change is that the stable branch will use the date version, so stable/2023.1 for the Axxxxx release
14:11:28 <whoami-rajat__> ^^ everyone
14:12:20 <whoami-rajat__> so TC is rethinking the design of RBAC and there will be a discussion in summit in the ops meetup to get operators feedback
14:12:50 <geguileo> rosmaita: I don't like that :-(
14:12:56 <whoami-rajat__> we might see some changes after that so better to hold any RBAC related work but rosmaita is already aware
14:13:07 <whoami-rajat__> #link https://etherpad.opendev.org/p/ops-meetup-berlin-2022-planning#L74
14:13:18 <whoami-rajat__> #link https://etherpad.opendev.org/p/rbac-operator-feedback
14:13:30 <geguileo> new changes on the SRBAC work?  I can't believe it!   };-)
14:13:53 <rosmaita> and so early in the cycle :D
14:14:05 <geguileo> lol
14:14:17 <rosmaita> luckily, i have prepared for such a contingency by not working on it yet
14:14:25 <whoami-rajat__> no surprises there
14:14:29 <whoami-rajat__> rosmaita, :D
14:14:45 <whoami-rajat__> moving on to the final announcement
14:14:49 <geguileo> can we add something to the RBAC operator feedback?
14:14:49 <whoami-rajat__> Register blueprint for your new driver
14:14:55 <geguileo> or did that meeting already happen?
14:15:04 <rosmaita> meeting happens friday
14:15:08 <whoami-rajat__> it will happen on 16 or 17 june i guess
14:15:23 <rosmaita> as long as you say scope is a bad idea, feel free to leave comments :P
14:15:24 <whoami-rajat__> oh friday 10t
14:15:41 <rosmaita> sorry, Rajat, we are having an interleaved discussion
14:15:49 <geguileo> whoami-rajat__: yeah, sorry
14:16:32 <whoami-rajat__> no issues, good to have things cleared out
14:17:01 <whoami-rajat> finally able to change IRC nick!
14:17:06 <whoami-rajat> so last announcement
14:17:41 <whoami-rajat> I sent out a mail to the ML addressing driver vendors to register blueprints for the new drivers proposed to Zed
14:17:47 <whoami-rajat> for better tracking
14:17:48 <whoami-rajat> #link http://lists.openstack.org/pipermail/openstack-discuss/2022-June/028879.html
14:18:29 <whoami-rajat> I've mentioned the drivers we discussed during midcycle there, if there are more we will get a response on the thread which is good
14:19:14 <whoami-rajat> and request to the reviewers to focus on driver reviews as we've a bunch of drivers which will probably consume a lot of time to review
14:19:18 <rosmaita> whoami-rajat: ++
14:19:32 <whoami-rajat> and we might miss deadline otherwise
14:20:00 <whoami-rajat> that's all for announcements, anyone has anything else?
14:20:09 <rosmaita> about the drivers
14:20:34 <whoami-rajat> rosmaita, yes
14:20:47 <rosmaita> we should prioritize the YADRO driver, since it's been posted since the day before the yoga deadline
14:21:07 <rosmaita> looks like it is passing tests now (or the last time i looked)
14:21:37 <whoami-rajat> ack, sounds good
14:21:49 <whoami-rajat> tests I assume third party CI and not only Zuul?
14:21:52 <geguileo> should take this opportunity to take notes on mistakes people do when developing their new drivers to improve our docs?
14:22:27 <rosmaita> yuval had a bunch of suggestions from his driver whose name escapes me
14:22:31 <whoami-rajat> geguileo, +1 but I've seen mistakes that are already documented :( but good practice
14:22:36 <rosmaita> (he is at the summit, not here)
14:22:47 <whoami-rajat> lightbits lightos driver?
14:22:52 <geguileo> whoami-rajat: in that case the comment is just adding a link to the doc  ;-)
14:22:54 <rosmaita> that's it
14:23:10 <whoami-rajat> geguileo, yes!
14:23:30 <geguileo> rosmaita: the suggestions was for our docs or for our driver interface?
14:23:35 <geguileo> s/was/were
14:23:36 <whoami-rajat> good suggestions, I will prepare an etherpad with the BP links and driver patches to prioritize better
14:23:55 <rosmaita> geguileo: mostly docs, but possibly some interface suggestions too
14:23:59 <rosmaita> https://etherpad.opendev.org/p/cinder-drivers-documentation
14:24:23 <rosmaita> we can gather suggestions there and then put up a big patch ^^
14:25:16 <whoami-rajat> good idea
14:26:02 <simondodsley> I think the major miss is the Software Factory stuff
14:26:21 <simondodsley> there is nothing out there and yet it is the preferred method now (supposedly)
14:26:43 <geguileo> yeah, looks like the big pain is still the CI
14:26:50 <rosmaita> ++
14:27:17 <simondodsley> yep -also look slike the latest Zull is not consistent in the way it is assigning interfaces to vms
14:27:37 <simondodsley> so one day the iSCSI ports on on one interface and the next day they are on another.
14:27:42 <simondodsley> That causes all sorts of failures
14:27:50 <rosmaita> somehow datacore is running their CI jobs in 18 minutes
14:28:02 <geguileo> rosmaita: how????
14:28:05 <simondodsley> physically impossible
14:28:17 <whoami-rajat> devstack installation takes more time than that :D
14:28:22 <rosmaita> yes, we need to look more closely
14:28:23 <simondodsley> ++
14:28:26 <geguileo> whoami-rajat: that's what I was thinking
14:28:40 <enriquetaso> ++
14:28:40 <rosmaita> one result i saw was runnning tests in 40 cores
14:28:42 <geguileo> simondodsley: the interfaces issue sounds like a nightmare
14:28:58 * geguileo wants 40 cores
14:29:06 <simondodsley> yes it is, especially when I have multiple card types for different data planes
14:29:20 <rosmaita> cinder could use 40 cores! think of the review bandwidth
14:29:33 <simondodsley> lol
14:29:45 <geguileo> lol
14:29:59 <whoami-rajat> okay, so we can continue discussion on this later (in open discussion or cinder channel) and move on to topics (we've a bunch of them)
14:30:07 <geguileo> ok
14:30:21 <whoami-rajat> thanks!
14:30:25 <whoami-rajat> #topic Opinion on low attendance at mid cycle and how we can improve it in future
14:30:39 <whoami-rajat> So i was thinking about this and I've mentioned some possible reasons on the etherpad
14:31:05 <whoami-rajat> what i wanted to ask is, if the notifications are not clear (IRC, mail) and we should add additional things like a calendar invite?
14:31:50 <simondodsley> an invite would be good, but could the ML deal with that?
14:32:02 <rosmaita> i think the notificaions were clear, and it was listed on the openstack release schedule
14:32:14 <simondodsley> I think it was just too close to the summit IMHO
14:32:24 <rosmaita> calendar invite wouldn't hurt (don't know about simondodsley's email question, though)
14:32:45 <geguileo> the calendar invite could be like the ping
14:32:57 <whoami-rajat> simondodsley, yeah i mentioned that as a reason (people might be traveling to summit)
14:33:01 <geguileo> we have a list of  people who want the invite and we just create the invite for those instead of the mailing list...
14:33:31 <whoami-rajat> geguileo +1, we could create a special list of people who would like to receive a calendar invite
14:33:38 <simondodsley> maybe not travelling exactly, but prepping for the sumit and clearing backlog
14:33:54 <rosmaita> i think simondodsley is right though, people preparing for summit were probably distracted from participating
14:34:11 <whoami-rajat> yeah that too could be a reason
14:34:50 <rosmaita> i don't know how they pick the summit dates anymore
14:35:56 <whoami-rajat> so if this was a one time thing then we can continue with our current reminder system but if people are interested in getting calendar invites, they can provide their emails
14:36:25 <geguileo> whoami-rajat: I'd like the calendar invite, since I always create it myself
14:36:44 <geguileo> if it's not in my calendar, it's not happening. I even have this meeting in my calendar
14:36:46 <whoami-rajat> rosmaita, me neither, last time i attended it was summit + PTG ...
14:37:07 <simondodsley> speakng of PTG, do you all know its in Columbus in October?
14:37:21 <enriquetaso> cool
14:37:28 <zaitcev> News to me.
14:37:31 <rosmaita> Fabulous Columbus, Ohio
14:37:36 <simondodsley> Announced at Summit
14:37:54 <rosmaita> middle of the week because Ohio State plays at home at the end of the week
14:38:03 <simondodsley> I think 17-19
14:38:23 <simondodsley> clashes with an international trip for me sadly
14:38:28 <whoami-rajat> geguileo, cool, I've created this etherpad so people can write their emails and i will send a calendar invite from next time https://etherpad.opendev.org/p/cinder-calendar-invite-for-events
14:38:40 <whoami-rajat> everyone ^^
14:39:05 <enriquetaso> whoami-rajat++
14:39:30 <geguileo> whoami-rajat++
14:39:37 <whoami-rajat> There's an email also about the PTG with subject "Save the Date: PTG October 2022"
14:39:57 <geguileo> simondodsley: thanks for the heads up on the PTG
14:40:27 <whoami-rajat> simondodsley, thanks for providing summit announcements to us!
14:41:02 <whoami-rajat> this topic seems sorted so moving on to the next one
14:41:06 <whoami-rajat> #topic cinderlib status
14:41:07 <simondodsley> its why im here
14:41:16 <whoami-rajat> rosmaita, that's you
14:41:30 <rosmaita> ok, we have cinderlib release coming up
14:41:38 <geguileo> simondodsley: I thought you were here to talk about nvmeof over FC
14:41:52 <whoami-rajat> :D
14:41:55 <rosmaita> so was looking at the repo to see that everything is working correctly
14:41:57 <rosmaita> and
14:42:01 <simondodsley> no - just for the beer
14:42:05 <rosmaita> there are a few problems
14:42:35 <geguileo> simondodsley: lol
14:42:38 <geguileo> rosmaita: :-(
14:42:40 <rosmaita> first one is we are supposed to be running requirements-check, but we can't run the normal one because of our trailing deliverable status
14:42:48 <rosmaita> think i have that partially fixed
14:42:56 <rosmaita> #link https://review.opendev.org/c/openstack/cinderlib/+/845026
14:43:21 <rosmaita> problem now is that we have cinder in requirements.txt
14:43:29 <whoami-rajat> rosmaita, don't we have a template for projects that are cycle trailing ?
14:43:38 <rosmaita> don't think so
14:43:44 <whoami-rajat> ok
14:43:54 <rosmaita> i don't think there are enough of them
14:44:25 <rosmaita> anyway, what i want to ask geguileo is what would happen if we remove cinder from requirements.txt
14:44:46 <rosmaita> cinderlib tox doesn't use cinder from there, installs it from git
14:45:22 <geguileo> rosmaita: yes, but if cinder's not there then the pypi package won't have it as a dependency, right?
14:45:31 <rosmaita> right
14:45:37 <rosmaita> i think we probably need it
14:45:43 <geguileo> that's kind of a BIG THING
14:45:49 <rosmaita> just wanted to verify before i go talk to the requirements team
14:46:01 <rosmaita> we will need an exception to get cinder into global-requirements, i think
14:46:30 <rosmaita> #action rosmaita work out cinder in requirements.txt with requirements team
14:46:54 <rosmaita> ok, next item is weird cinderlib-tox-py36 job failures
14:47:01 <geguileo> rosmaita: thanks!
14:47:06 <whoami-rajat> thanks rosmaita
14:47:10 <rosmaita> "Task Install any sibling python packages  failed"
14:47:16 <rosmaita> https://zuul.opendev.org/t/openstack/builds?job_name=cinderlib-tox-py36&project=openstack%2Fcinderlib
14:47:34 <rosmaita> i have no idea, seems to be happening for cinderlib-lvm-functional job too
14:47:41 <rosmaita> https://zuul.opendev.org/t/openstack/builds?job_name=cinderlib-lvm-functional&project=openstack/cinderlib
14:47:52 <rosmaita> also seems to be happening on ubuntu and centos
14:48:11 <geguileo> rosmaita: you may need to add the required-projects part
14:48:11 <rosmaita> i was hoping tosky might have some ideas
14:48:26 <rosmaita> oh
14:48:39 <rosmaita> ok, i will take a look and see if that's an easy fix
14:48:53 <rosmaita> because the cinderlib-ceph-functional job is great!
14:49:13 <rosmaita> ok, last thing is cinderlib-tox-py39
14:49:20 <rosmaita> which i cannot reproduce locally
14:49:36 <rosmaita> but here's an example if someone wants to look
14:49:46 <geguileo> rosmaita: me should look
14:49:46 <rosmaita> #link https://zuul.opendev.org/t/openstack/build/3576fdbc672e4dbba200b832bfb122ea
14:50:05 <rosmaita> geguileo: ty
14:50:09 <rosmaita> ok, i lied
14:50:14 <rosmaita> here is the actual last item
14:50:28 <rosmaita> we don't seem to be using upper-constraints
14:50:38 <rosmaita> #link https://opendev.org/openstack/cinderlib/src/commit/82b8c25c973a25ee62c1121ce087ff095afc6961/tox.ini
14:50:46 <rosmaita> possibly i am missing something though
14:51:19 <geguileo> rosmaita: those are all related to the cinderlib database metadata plugin
14:51:21 <rosmaita> i was hoping the py39 failure was using a too new library or something (though not being able to reproduce it locally kind of nixes that idea)
14:51:41 <geguileo> which probably points to what you thought of the library
14:52:09 <rosmaita> ok
14:52:25 <geguileo> rosmaita: I'll look into it tomorrow, ping me again tomorrow end of day if I haven't gotten back to you
14:52:42 <rosmaita> geguileo: great!
14:52:59 <rosmaita> geguileo: should i try a patch changing the pip install command to use constraints?
14:53:22 <rosmaita> (independently of the db metadata plugin problem)
14:54:01 <geguileo> rosmaita: that's a good question
14:54:11 <geguileo> rosmaita: doesn't cinderlib use constraints?
14:54:20 <rosmaita> i don't think so
14:54:29 <rosmaita> https://opendev.org/openstack/cinderlib/src/commit/82b8c25c973a25ee62c1121ce087ff095afc6961/tox.ini
14:54:55 <geguileo> rosmaita: mmmm, only for reno and docs, that's unconventional
14:55:05 <rosmaita> yeah
14:55:26 <rosmaita> ok, let me see if the trick you came up with for cinder works for cinderlib
14:55:50 <geguileo> yeah, I think we should add it
14:56:12 <rosmaita> ok, i'll put up a patch after the meeting and let's see what happens
14:56:32 <whoami-rajat> cool, thanks rosmaita and geguileo
14:56:33 <rosmaita> ok, that's all, other than to remember that release must happen on or before 23 June
14:56:58 <whoami-rajat> sure
14:57:04 <whoami-rajat> let's quickly get over the last topic
14:57:13 <whoami-rajat> #topic Add some information file about how tempest works
14:57:16 <whoami-rajat> enriquetaso, that's you
14:57:45 <rosmaita> this sounds like a good idea, even before hearing enriquetaso's ideas!
14:57:50 <enriquetaso> :P
14:57:51 <enriquetaso> My original question was how do we track dependencies between tempest and the plugins? I know the CI uses the Tempest master branch to run tests, but maybe some users are using an old version of Tempest.
14:58:05 <enriquetaso> And tosky kindly answered me that you just assume that you always use tempest and all plugins from master.
14:58:15 <enriquetaso> So eharney  suggested I  add some kind of info that explains how this works.
14:58:16 <eharney> what's proposed there doesn't answer the question that i had in this area, i think
14:58:43 <eharney> it's not clear what the correct process is when we are adding tests to cinder-tempest-plugin that require newly landed changes in tempest
14:59:06 <eharney> just saying "assume it's all running master" means that people who want to install tempest and our plugin themselves from pip will just break
14:59:23 <tosky> I'm not sure
14:59:30 <rosmaita> maybe we can invite gmann to the next meeting to talk us through this
14:59:32 <geguileo> eharney: oh, right!
14:59:45 <eharney> this has come up twice recently w/ new test work, i think we need to understand it
14:59:46 <whoami-rajat> that's a good question for the QA team, maybe we can ask gmann and kopecmartin
14:59:47 <tosky> that's up the releasing process, usually tempest and the plugins are tagged together
14:59:48 <enriquetaso> good idea rosmaita
15:00:01 <eharney> tosky: and requirements.txt etc... which we are currently ignoring
15:00:01 <tosky> the answer from the QA team will be "use master"
15:00:15 <tosky> fine
15:00:23 <eharney> if the answer is "only the gate runs matter" we need to document that that is the case
15:00:28 <gmann> hi, i am in another meeting but I can check after meeting
15:00:43 <whoami-rajat> thanks gmann
15:00:47 <whoami-rajat> and we're out of time
15:00:49 <eharney> but i think this is supposed to be installable and used in other contexts
15:00:59 <enriquetaso> i've proposed a patch already but based on this conversation
15:01:00 <gmann> sure, we can discuss here after meeting
15:01:10 <enriquetaso> #link https://review.opendev.org/c/openstack/cinder-tempest-plugin/+/845050
15:01:12 <enriquetaso> sure
15:01:17 <rosmaita> gmann: actually, in #openstack-cinder
15:01:19 <whoami-rajat> we can continue discussion in cinder channel
15:01:27 <gmann> yes
15:01:27 <enriquetaso> sounds good to me!
15:01:29 <whoami-rajat> as rosmaita said
15:01:44 <whoami-rajat> thanks everyone for joining
15:01:46 <whoami-rajat> #endmeeting