14:00:16 <whoami-rajat> #startmeeting cinder
14:00:16 <opendevmeet> Meeting started Wed Sep  7 14:00:16 2022 UTC and is due to finish in 60 minutes.  The chair is whoami-rajat. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <opendevmeet> The meeting name has been set to 'cinder'
14:00:24 <enriquetaso> Hello
14:00:25 <simondodsley> o/
14:00:25 <whoami-rajat> #topic roll call
14:00:35 <jungleboyj> o/
14:00:40 <enriquetaso> oops lol
14:00:53 <rosmaita> o/
14:00:57 <eharney> o/
14:01:09 <simondodsley> o/
14:01:20 <sfernand> hi
14:01:22 <geguileo> hi! o/
14:01:49 <whoami-rajat> #link https://etherpad.openstack.org/p/cinder-zed-meetings
14:02:08 <TusharTgite> hi
14:02:11 <TusharTgite> hi
14:02:45 <felipe_rodrigues> hi
14:03:44 <whoami-rajat> hello everyone
14:03:46 <whoami-rajat> good turnout today
14:03:50 <whoami-rajat> let's get started
14:03:57 <whoami-rajat> #topic announcements
14:04:07 <whoami-rajat> first, oslo.db 12.1.0 issue
14:04:13 <whoami-rajat> #link https://lists.openstack.org/pipermail/openstack-discuss/2022-September/030317.html
14:04:50 <whoami-rajat> so there was an issue with oslo.db new release, due to which a lot of project jobs failed on the requirement gate
14:05:28 <whoami-rajat> Stephen worked on fixing all the gates and today everthing was fixed as I last checked
14:05:55 <whoami-rajat> in any case, Cinder wasn't affected, probably because of Stephen's work on our db patches (Thanks to him)
14:06:27 <whoami-rajat> so tl;dr we are going forward with oslo.db 12.1.0 release and not reverting anything there
14:06:38 <whoami-rajat> next, Operator hour
14:06:45 <whoami-rajat> #link https://lists.openstack.org/pipermail/openstack-discuss/2022-September/030301.html
14:07:00 <whoami-rajat> There was an email regarding an operator hour to be included in our PTG
14:07:05 <whoami-rajat> which seems like a very good idea
14:07:21 <whoami-rajat> so every project has to book 1 hour slot for project-operator discussion
14:07:31 <whoami-rajat> I think there are already placeholders in the PTG schedule page
14:07:49 <whoami-rajat> #link https://ptg.opendev.org/ptg.html
14:08:11 <whoami-rajat> so we will be having PTG from tuesday to friday, 1400-1700 UTC
14:08:29 <whoami-rajat> sorry 1300-1700UTC
14:08:42 <geguileo> sounds a good idea
14:08:51 <geguileo> s/sounds/sounds like/
14:08:59 <whoami-rajat> so we've a slot everyday at 1300 or 1400 UTC, but not sure which day would be best to discuss
14:09:10 <whoami-rajat> should we discuss it early in the PTG or towards the end?
14:09:38 <rosmaita> possibly early, so we can follow up if necessary
14:10:07 <whoami-rajat> that was my thought as well, also we can discuss topics with operator feedback in mind
14:10:13 <rosmaita> operators appear to be very excited to be invited to join the project teams, by the way
14:10:45 <whoami-rajat> that's a good thing
14:11:06 <jungleboyj> That is good!
14:11:06 <simondodsley> they like to get into the light occasionally
14:11:18 <enriquetaso> \o/
14:11:41 <whoami-rajat> so if everyone agrees early is good, I will try to book a slot on tuesday/wednesday
14:11:51 <geguileo> +1 to early
14:12:34 <whoami-rajat> great, will followup with infra team then
14:12:45 <jungleboyj> Makes sense.
14:13:08 <whoami-rajat> #action whoami-rajat to followup to book slot for operator hour early in the PTG
14:13:16 <whoami-rajat> okay moving on then
14:13:22 <whoami-rajat> next, Feature freeze extended deadline this week - 09 September 2022
14:13:37 <whoami-rajat> so we extended the feature freeze deadline last week to this week
14:14:01 <whoami-rajat> I will elaborate on this in the upcoming topic but this is just a reminder
14:14:28 <whoami-rajat> so everyone can get to reviewing things and authors to work on quick feedback
14:14:41 <whoami-rajat> next, RC1 - 16 September 2022
14:14:50 <whoami-rajat> so after we have sorted the features, we will focus on bug fixes
14:15:13 <whoami-rajat> there are quite a few I've been procrastinating for the final week
14:15:27 <whoami-rajat> but yeah, bug fixes would be our focus for next week
14:16:07 <whoami-rajat> so anything else anyone would like to share related to announcements?
14:16:57 <whoami-rajat> guess not
14:17:01 <whoami-rajat> so let's move to topics
14:17:06 <whoami-rajat> #topic Features update
14:17:17 <whoami-rajat> #link https://etherpad.opendev.org/p/cinder-zed-features
14:17:28 <whoami-rajat> so wanted to quickly discuss the current status of all the features proposed
14:17:34 <whoami-rajat> first, Reset state robustification
14:17:40 <whoami-rajat> #link https://review.opendev.org/q/topic:bp%252Freset-state-robustification
14:18:11 <whoami-rajat> the patches are ready for review
14:18:26 <whoami-rajat> honestly I don't have much idea about the area of code and would take a lot of time to review those
14:18:29 <TusharTgite> yes base patch already merged as well
14:19:09 <whoami-rajat> any takers that can help get this merged this week?
14:19:52 <whoami-rajat> also TusharTgite , if it's not critical for Zed, would you be OK to move it to next cycle?
14:20:03 <whoami-rajat> we can prioritize it that way early next cycle
14:21:05 * whoami-rajat hears crickets
14:21:17 <eharney> i think it's useful work but not critical for zed
14:21:20 <TusharTgite> it definitely going to take lot of time to review
14:21:37 <eharney> reviewing this is supposed to be on my list, but i haven't looked at it in a bit
14:22:25 <TusharTgite> if other feature r on priority then ok but could yo please try before relase as we also merge small patches after freez as well
14:23:23 <whoami-rajat> so this affects the core cinder code, other features are mostly driver features which doesn't require considering all cases that could cause problems in cinder
14:24:32 <whoami-rajat> so I think it would be realistic to move it to next cycle and eharney is also interested in taking a look at these
14:24:39 <TusharTgite> ok but can we make it a priority from start of next cycle then
14:24:55 <whoami-rajat> yes, will do that
14:25:13 <enriquetaso> shouldn't https://review.opendev.org/c/openstack/cinder/+/804035 have a release note?
14:25:37 <whoami-rajat> I've been dealing with deadlines since the beginning so it's my bad, will try to prioritize things better next cycle
14:25:52 <sfernand> enriquetaso: I think so
14:26:29 <eharney> i'm not sure we want a release note in each of the patches
14:26:57 <eharney> maybe one at/after the last one merged during a release
14:27:06 <whoami-rajat> I haven't looked at the whole series but one releasenote describing all the reset state changes should be good
14:27:14 <whoami-rajat> or as eharney said
14:27:20 <enriquetaso> sure
14:27:31 <jungleboyj> ++
14:28:19 <whoami-rajat> cool, so we cna move to next feature
14:28:24 <whoami-rajat> NetApp ONTAP: Implement support to ONTAP REST API
14:28:32 <whoami-rajat> #link https://review.opendev.org/q/topic:bp%252Fnetapp-ontap-rest-api-client
14:29:03 <whoami-rajat> NetApp team is moving their driver->backend communication from ZAPI to REST
14:29:12 <whoami-rajat> so there are a bunch of changes to support it
14:29:22 <whoami-rajat> I've taken a look at first two patches and currently both have +2s
14:29:47 <whoami-rajat> mostly it's addition of new interface and tests, haven't noticed any change in the driver as of now (but might be in later patches)
14:30:24 <whoami-rajat> they're quite big in terms of LOC but impact on cinder is minimal there so should be good for a quick look over the code
14:30:56 <sfernand> we tried to get changes separated in smaller patches so review attention can be splited, tho it will be a bit more difficult to merge since patches have a order
14:31:38 <felipe_rodrigues> thank you for your reviews, whoami-rajat :)
14:31:49 <sfernand> thanks whoami-rajat ! :D
14:31:54 <whoami-rajat> sfernand, yeah i see one patch was abandoned and the order doesn't show up correctly, maybe rebase the top changes after the first two changes merge
14:32:09 <whoami-rajat> no problem, thanks felipe_rodrigues sfernand for your reviews on other changes
14:32:31 <whoami-rajat> this was a very good example of you can do reviews on other patches to receive reviews
14:32:51 <rosmaita> \o/
14:33:05 <whoami-rajat> as originally stated by rosmaita :)
14:33:06 <sfernand> :)
14:33:24 <sfernand> we are working on the comments provided, all changes will be submitted by the end of the day
14:33:36 <whoami-rajat> great
14:33:54 <whoami-rajat> next is another feature by netapp, NetApp NFS: Clone image using copy file operation
14:34:08 <whoami-rajat> I've left a -1 since we're not deprecating the config option in the patch
14:34:12 <whoami-rajat> else it looks good
14:34:31 <felipe_rodrigues> actually, we are deprecating in a different patch: https://review.opendev.org/c/openstack/cinder/+/847733
14:34:39 <felipe_rodrigues> they should be merged together during this release
14:34:51 <sfernand> yep
14:34:58 <felipe_rodrigues> this patch that deprecates the old approach is pretty simple: just deprecate the config option
14:35:00 <sfernand> should we refer it in the commit message?
14:35:45 <whoami-rajat> hmm, yeah they should've been linked somehow by a dependency chain but mentioning in the commit message also sounds good
14:36:11 <sfernand> ack
14:36:52 <whoami-rajat> moving on, IBM SVf: Support for volumegroup functioanlity
14:36:57 <whoami-rajat> #link https://review.opendev.org/c/openstack/cinder/+/852364
14:37:14 <whoami-rajat> the CI hasn't reported and author said they're working on getting it configured
14:37:20 <whoami-rajat> else the changes look reasonable
14:37:50 <whoami-rajat> will upgrade my vote once the CI is functioning again
14:38:04 <whoami-rajat> next, Infinidat: support for revert to snapshot operation and Infinidat: support for manage/unmanage API
14:38:18 <whoami-rajat> there are 2 features by Infinidat team but my issue currently is
14:38:27 <whoami-rajat> they've rebased them on top of a bunch of bug fixes
14:38:56 <whoami-rajat> which is really not good if they want to merge their changes in time
14:39:24 <whoami-rajat> I've blocked one bugfix on which rosmaita and geguileo also has shared their comments
14:39:31 <whoami-rajat> is someone from Infinidat team here to discuss it?
14:40:10 <yuval__> what is the balance between multiple patches and different features/bugs
14:40:44 <whoami-rajat> we've the feature deadline this week but bugs can merge next week as well
14:41:19 <yuval__> I mean if I have 2 bugs - should I do a patch for each?
14:41:33 <yuval__> or merge them at 1 patch
14:41:45 <sfernand> yes
14:41:52 <sfernand> you should have 2 patches
14:41:57 <whoami-rajat> yuval__, if they're related you can do it in one patch but for different issues different patches are good
14:42:16 <yuval__> ok
14:42:17 <sfernand> it is much easier to review and to revert if necessary
14:42:34 <whoami-rajat> yep
14:42:35 <sfernand> whoami-rajat: ++
14:42:46 <whoami-rajat> looks like noone is here from Inifinidat team so we can move on
14:42:51 <yuval__> overall I agree, I reviewed some patches which were a mess and I was wondering if I should comment about it
14:43:20 <whoami-rajat> I've left a comment for them to separate out the features, let's see if it gets updated
14:43:34 <whoami-rajat> yuval__, would be good to leave comments there stating it
14:43:43 <yuval__> ok
14:43:55 <whoami-rajat> but there's no proper rule about it, just convention we follow to make the process easier
14:44:34 <whoami-rajat> next, Remove legacyfacade
14:44:46 <whoami-rajat> #link https://review.opendev.org/q/topic:remove-legacyfacade+project:openstack/cinder+is:open
14:45:08 <whoami-rajat> there are still changes left for our DB work (they never end)
14:45:33 <whoami-rajat> I'm not very positive about getting them in during the last minute, also since it affects DB
14:45:44 <whoami-rajat> I would probably move and retarget them for next cycle
14:46:13 <jungleboyj> That sounds safest if they changes aren't urgent.
14:46:48 <sfernand> is that really a feature? maybe we could try get them merged by the end of next week if not
14:46:57 <whoami-rajat> doesn't look urgent since cinder is compatible with new oslo.db release, which was the biggest concern with the legacy engine facade thing IIRC
14:47:28 <whoami-rajat> sfernand, can't really say a feature but I'm skeptical about getting them in so close to the releae
14:47:31 <whoami-rajat> release
14:47:53 <sfernand> got it
14:47:59 <whoami-rajat> rosmaita, what do you think about it? (you've already reviewed the last series)
14:48:43 <rosmaita> i was hoping we could get this out of our lives
14:48:58 <rosmaita> but it is getting awful close
14:49:34 <rosmaita> those remaining changes look mostly harmless, though
14:49:59 <whoami-rajat> okay, we can retrospect them after we're done with the features
14:50:27 <whoami-rajat> and if not feasible, we can target them next cycle M-1
14:50:52 <rosmaita> sounds good
14:50:56 <whoami-rajat> cool
14:51:02 <whoami-rajat> next, DEMC PowerMax: Unisphere 10 support
14:51:10 <whoami-rajat> it has 3 -1's and no update since 20 days
14:51:20 <whoami-rajat> so thinking about deprioritizing this and moving to next cycle
14:51:44 <whoami-rajat> and final one is New Quotas System
14:52:04 <whoami-rajat> which geguileo being so busy throughout the cycle is OK to continue the work next cycle
14:52:25 <geguileo> whoami-rajat: yeah, sorry about that, but with the latest spec changes
14:52:34 <geguileo> the code got more complicated than I anticipated
14:52:50 <geguileo> and the UT fixes delayed my work on quotas
14:52:51 <geguileo> :-(
14:53:08 <whoami-rajat> geguileo, no problem, you were already too occupied that this would've been impossible to complete
14:53:13 <whoami-rajat> can't even remember how many things geguileo worked on this cycle
14:53:33 <whoami-rajat> and that's a reminder to the UT fixes proposed by geguileo
14:53:35 <whoami-rajat> #link https://review.opendev.org/q/topic:rbd-native-treads
14:53:42 <whoami-rajat> this is one thing we need to target for next week
14:54:05 <whoami-rajat> as everyone is seeing failures (me as well) in unit tests
14:54:11 <whoami-rajat> s/failures/timeouts
14:54:37 <whoami-rajat> something urgent to get fixed before the release
14:55:14 <whoami-rajat> anyway, that's all from my side, sorry for taking the whole meeting time but this was kind of urgent
14:55:51 <whoami-rajat> we still have some time for open discussion
14:55:57 <whoami-rajat> #topic open discussion
14:56:07 <rosmaita> i've got something
14:56:29 <whoami-rajat> sure
14:56:29 <rosmaita> the everyone-must-use-openstackclient-cli is rearing its ugly head again
14:56:42 <rosmaita> may become a community goal for Antelope
14:56:42 <jungleboyj> :-)
14:56:59 <rosmaita> here is the latest situation, they've added a lot of support:
14:57:05 <rosmaita> #link https://docs.openstack.org/python-openstackclient/latest/cli/decoder.html#cinder-cli
14:57:17 <rosmaita> but there are still some weirdnesses
14:57:29 <rosmaita> i think mostly around volume/snapshot manage/unmanage
14:57:52 <rosmaita> and it's not clear how microversion support works
14:58:27 <whoami-rajat> yeah we will need to prioritize that next cycle since everyone is headed that way and we might be the only ones left blocking the effort ...
14:58:38 <enriquetaso> ++
14:58:47 <rosmaita> yeah, apparently even glance is getting on the osc train
14:59:19 <whoami-rajat> yeah, but looking at the glance gaps, the OSC support is mostly empty
14:59:19 <jungleboyj> Wow.  Well, I guess that is good we are all going that direction.
14:59:27 <whoami-rajat> so might take them more than a cycle to get there
14:59:39 <rosmaita> i guess my main ask here is if anyone is fundamentally philosophically opposed to osc replacing the cinder cli
15:00:16 <jungleboyj> I think the main issue in the past was the lack of parity.  Looks like they are getting much closer.
15:01:03 <rosmaita> that's all from me
15:01:10 <whoami-rajat> thanks rosmaita for bringing this up
15:01:27 <whoami-rajat> we need a closer look at the OSC equivalent to find any issues
15:01:34 <sfernand> time check
15:01:34 <whoami-rajat> but something we should prioritize
15:01:41 <whoami-rajat> and we're overtime
15:01:44 <whoami-rajat> thanks everyone for joining
15:01:53 <whoami-rajat> focus on feature reviews!
15:01:55 <whoami-rajat> #endmeeting