14:00:05 <rosmaita> #startmeeting cinder
14:00:05 <opendevmeet> Meeting started Wed Nov 15 14:00:05 2023 UTC and is due to finish in 60 minutes.  The chair is rosmaita. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <opendevmeet> The meeting name has been set to 'cinder'
14:00:08 <happystacker> Sorry for not being present sooner, but I was (I still do) firefighting...
14:00:18 <simondodsley> o/
14:00:30 <rosmaita> #topic roll call
14:00:30 <rosmaita> #link https://etherpad.opendev.org/p/cinder-caracal-meetings
14:00:32 <msaravan> o/
14:00:41 <rosmaita> i see some of you have anticipated the roll call!
14:00:43 <keerthivasansuresh> o/
14:00:43 <toheeb> o/
14:01:07 <rosmaita> Happy Diwali to anyone who celebrates, Rajat is off today, so I'll be running the meeting
14:01:17 <jbernard> o/
14:01:22 <Saikumar> o/
14:01:35 <akawai_> o/
14:02:22 <rosmaita> ok, let's get started
14:02:28 <rosmaita> #topic announcements
14:02:37 <eharney> o/
14:02:38 <rosmaita> gerrit offline for about an hour on Friday beginning 15:30 UTC
14:02:53 <rosmaita> #link https://lists.opendev.org/archives/list/service-announce@lists.opendev.org/thread/XT26HFG2FOZL3UHZVLXCCANDZ3TJZM7Q/
14:03:05 <rosmaita> those ^^ are  the details if you want 'em
14:03:21 <rosmaita> but supposed to be  a quick gerrit update
14:03:48 <rosmaita> next, call for proposals for FOSDEM
14:03:58 <rosmaita> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/AFQ2NKJFG3J64XE54JQQ22SXS2DWLT4U/
14:04:13 <gireesh> o/
14:04:17 <rosmaita> there's info in that email ^^ and also on todays meeting agenda
14:04:36 <rosmaita> key date is submission deadline is 8 December, so basically 3 weeks away
14:05:02 <rosmaita> next, results from the OpenStack user survey
14:05:10 <rosmaita> #link https://docs.google.com/spreadsheets/d/1ehlabuqOnNK4M7xtN1GXvhLoeHn4JBaISih6RuzLLyQ/edit#gid=0
14:05:26 <rosmaita> i haven't looked myself, but Rajat made some notes
14:05:34 <rosmaita> Most deployments seems to be using Ceph RBD storage -- also saw one instance of Ceph iSCSI
14:05:48 <rosmaita> Might be useful to discuss in the video meeting end of the month
14:06:20 <rosmaita> so take a look when you have a chance and we can talk about it in 2 weeks
14:06:24 <simondodsley> Which line shows the driver usage?
14:06:39 <rosmaita> don't know, i haven't looked
14:07:02 <rosmaita> if it's anything like the past survey results, the data is all over the place and you have to dig to find it
14:07:11 <simondodsley> oh - i see it - Colmn EF
14:07:13 <rosmaita> (but i may be maligning the foundation there)
14:07:51 <rosmaita> ok, next item
14:08:01 <rosmaita> tomorrow is the caracal-1 milestone
14:08:09 <rosmaita> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/ZRRI3A5PJFIHTM6GPUSYMJSTWMTWKYAI/
14:08:42 <rosmaita> this would be a good time to go back over the PTG summary and look for priorities/action items that were supposed to be done by M-1
14:09:05 <rosmaita> i think the sqlalchemy 2.0 patches are one item, jbernard has an item on the agenda for later
14:09:33 <rosmaita> the next item is a concern for all of openstack
14:09:40 <rosmaita> Eventlet not compatible with python 3.12
14:09:57 <rosmaita> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/YO5CZDVAJ6QSF734ALWSGNOQDDAIOXKI/
14:10:40 <rosmaita> something will have to be done by someone!
14:11:23 <rosmaita> at this point, i imagine that openstack will encourage contributions to eventlet to whip it into shape
14:11:46 <rosmaita> but we will probably also be looking for a better future solution
14:12:17 <rosmaita> it didn't come up at the TC meeting yesterday, so there's not an official position yet, other than start worrying
14:12:43 <rosmaita> something to keep an eye on
14:12:53 * jbernard activates worrying now
14:13:00 <rosmaita> :)
14:13:12 <tkajinam> it might be helpful if someone can do some PoC but I am (and I know we all) aware it's a huge effort to replace it now :-(
14:13:32 <tkajinam> it may have to be done in oslo.services first so it may take a while until the topic is actionable for cinder, though
14:13:47 <rosmaita> yes, i think repair + plan ahead for a replacement is the approach that we'll take
14:14:32 <rosmaita> ok, last item is about Unmaintained branches
14:14:42 <rosmaita> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/ZYAZG43BLJJVXCYZVPYQX5733BYDVVNL/
14:14:57 <rosmaita> Rajat put a summary of the key points on the agenda etherpad
14:15:44 <rosmaita> so basically, that email just summarizes how we're going to actually do the Unmaintained transition
14:16:02 <rosmaita> except for one point, it's the same proposal that was passed in July
14:16:42 <rosmaita> the one point is proposal that there be an openstack-wide group that has +2/+W powers on all unmaintained/* branches
14:16:52 <rosmaita> i mean, that's the change
14:17:14 <rosmaita> the original was that every project would have its own for example cinder-unmaintained-core group
14:17:45 <rosmaita> but it seems better to have a single group that can take care of this
14:17:52 <rosmaita> (at least to me)
14:17:52 <happystacker> question: what about releases on which OSP is based like wallaby for OSP 17.x which is before yoga
14:18:09 <happystacker> can we still do backport?
14:18:31 <rosmaita> yes, those will still be open, and the usual backport rules apply
14:18:40 <happystacker> ok
14:18:44 <rosmaita> (so no features, just low-risk bug fixes)
14:19:04 <simondodsley> if you want more than that, then you will have to raise a BZ
14:19:04 <rosmaita> Ericsson has volunteered to keep unmaintained/victoria open
14:19:49 <simondodsley> it is a crucual version for their 5G deployments
14:20:02 <simondodsley> s/crucual/crucial
14:20:11 <happystacker> thks
14:20:11 <rosmaita> happystacker: simondodsley is correct, downstream projects will continue to follow their own rules
14:20:26 <happystacker> ok perfect
14:20:32 <rosmaita> so for OSP, you'd have to do the Red Hat process
14:20:49 <happystacker> backport first, then a BZ
14:21:03 <rosmaita> in any case, we'll soon have victoria->yoga in Unmaintained status
14:21:12 <rosmaita> will be interesting to see how this works out
14:22:14 <rosmaita> oh, i should mention as a follow up, i abandoned the EOL patches for victoria, wallaby, and xena for cinder
14:22:25 <rosmaita> but train and ussuri are still ready to be EOL'd
14:22:51 <rosmaita> that's all the announcements ... anyone have something else to share?
14:23:42 <inori> I have another question about OSP
14:24:10 <rosmaita> sure
14:24:28 <inori> If I want to backport a patch to OSP17.X, which branch should I commit, wallaby or master?
14:25:22 <rosmaita> well, ideally you will fix something in master, and then backport it as far back as you can, which would be to wallaby
14:25:31 <rosmaita> all upstream
14:25:48 <inori> I see. Thank you!
14:25:52 <rosmaita> but to actually get the change into OSP, you would have to file a BZ with Red Hat
14:26:29 <rosmaita> if you have more questions, we should discuss offline, because our focus in this meeting is the upstream community
14:26:33 <inori> Thank you, rosmaita
14:26:59 <rosmaita> oh, one final item
14:27:18 <rosmaita> i just noticed that this friday, 17 November, is the third friday of the month
14:27:29 <rosmaita> does anyone know why that is important?
14:27:55 <happystacker> festival of review?
14:27:57 <eharney> reviews!
14:28:03 <happystacker> lol
14:28:04 <rosmaita> yes!!!
14:28:10 <happystacker> you beat me eharney
14:28:15 <rosmaita> #link https://meetings.opendev.org/#Cinder_Festival_of_XS_Reviews
14:28:32 <rosmaita> so, please mark your calendar, and I'll see you there!
14:28:56 <rosmaita> ok, on to the actual topics
14:29:13 <rosmaita> #topic Nova removing VMWare support
14:29:36 <tkajinam> Rajat added the topic but because I proposed the topic initially so I can provide some cntext
14:29:39 <tkajinam> * context
14:29:49 <rosmaita> thank you, go ahead
14:30:03 <tkajinam> Nova has maintained several virt drivers, but they are now removing unmaintained ones
14:30:23 <tkajinam> vmware driver was marked experimental and is being removed this cycle.
14:31:22 <tkajinam> there are some features for VMware platform in the other projects and I'm wondering if we can deprecate these all in this cycle and remove it after 2024.1 release
14:31:44 <eharney> for context, the vmware volume driver is only useful if using vmware compute, right?
14:32:19 <simondodsley> i think you are right - only used in VMware Integrated OpenStack (VIO)
14:32:28 <tkajinam> I believe so
14:32:34 <rosmaita> we should check with hemna
14:32:47 <rosmaita> i think he runs openstack on vmware?
14:33:06 <eharney> i think that is correct
14:33:43 <rosmaita> i have the same question as eharney, if the storage driver is only useful with the compute driver, and the compute driver is being removed, then this is a no-brainer
14:33:57 <rosmaita> but otherwise, this may need some brain work
14:34:04 <tkajinam> I already raised the same topic for glance during the previous PTG and we agreed to send an email to find anyone using it without VMWare. so far I've not heard any feedback to it.
14:34:32 <simondodsley> I beleive that VIO may be on the verge of demise anyway with the Broadcom buyout
14:34:40 <tkajinam> wondering if we can do the same, and wait for some time (like m-2) and then deprecate the driver if we hear no objections.
14:35:47 <tkajinam> I mean, I can send an email to ask if anyone needs the vmdk driver without vmware, and if we hear nothing then we can deprecate the driver.
14:35:58 <rosmaita> tkajinam: that would be great
14:36:05 <tkajinam> I believe the driver is useless without vmware virt driver but just in case I'm wrong...
14:36:10 <eharney> the driver requires a vcenter server to use
14:36:24 <tkajinam> yeah that's what I read
14:36:48 <rosmaita> i always thought of a "vcenter server" as being a kind of storage appliance
14:37:00 <rosmaita> but, i do not know what i am talking about
14:37:12 <simondodsley> VIO only officially supports that one driver if I read their docs correctly
14:37:13 <eharney> it's the vmware virt platform (which probably has a different name by now)
14:37:17 <rosmaita> i don't think Walt is here?  hemna??
14:37:30 <tkajinam> that's a kind of centralized endpoint managing multiple ESXi, afair > vCenter
14:37:52 <simondodsley> tkajinam: correct
14:38:05 <tkajinam> If anyone here knows someone familiar with this driver or VIO then that would be great, as I can double check my observation with him/her
14:38:23 <tkajinam> but anyway I'll send out an email and the bring this topic after some time, surely during this cycle.
14:38:26 <rosmaita> #action tkajinam to send an email to the ML similar to his glance_store email, but for cinder
14:38:50 <tkajinam> note that the feature in os-brick may be actually useless once we deprecate/remove vmdk driver so I don't feel like there may be any discussions needed for it.
14:39:35 <rosmaita> ok, thanks tkajinam
14:39:48 <rosmaita> maybe we'll know something in time for the first midcycle
14:39:56 <rosmaita> anything else?
14:40:11 <tkajinam> nothing from my end
14:40:56 <rosmaita> #topic Cinderlib 2023.2: Cycle trailing release deadline
14:41:08 <rosmaita> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/RPTPVHSFSK6PXJGRV775EFVZ4Y4DX2SM/
14:41:18 <rosmaita> release deadline is 7 December
14:42:01 <rosmaita> just a reminder, this version of cinderlib that will be released is the one that works with Bobcat (2023.2)
14:43:00 <rosmaita> the CI jobs are running against stable/2023.2, so hopefully we would pick up incompatibilities
14:43:41 <rosmaita> anyway, if you are a cinderlib user, it would be good to try out cinderlib master to make sure it works with Bobcat
14:44:05 <rosmaita> i will leave a marker here for geguileo ^^ because cinderlib is kind of his baby
14:44:33 <rosmaita> #topic SQLAlechemy 2.0
14:44:47 <rosmaita> jbernard has been tracking this one
14:45:05 <jbernard> i have put a list of the remaining patches in the etherpad
14:45:18 <rosmaita> this was a milestone-1 priority, so let's try to get this done in the next day or so!
14:45:34 <jbernard> but tldr; 1 is waiting on recheck, 5 could use a person to review
14:46:03 <rosmaita> ok thanks, and thanks for the list in the etherpad
14:46:07 <jbernard> i think 1 of those 5 i need to respond to, but if anyone has time or db knowledge, we could finish these up quickly
14:46:16 <rosmaita> line 147 in https://etherpad.opendev.org/p/cinder-caracal-meetings
14:46:28 <rosmaita> (though it may not stay at line 147 for long!)
14:47:05 <rosmaita> thanks jbernard ... like i said, it's a priority for M-1, so please make it a priority to review these
14:47:22 <rosmaita> #topic windows support deprecation
14:47:26 <rosmaita> tkajinam: that's you again!
14:47:52 <tkajinam> this is another "kill unmaintained item" topic but an easy one
14:48:47 <tkajinam> there are a few Windows related drivers in cinder, which are dependent on os-win. As you know Winstackers project who maintained os-win has been retired and these should be removed
14:49:10 <tkajinam> (another option is os-win should be replaced or picked up but I don't think anyone may do these
14:49:49 <tkajinam> I've proposed the patches to deprecate windows support in os-brick and cinder and would like to get these merged in 2024.1
14:49:50 <rosmaita> yeah, microsoft is involved with the Foundation, but apparently they have no interest in openstack running on windows
14:49:53 <tkajinam> so that we can drop these in 2024.2
14:50:33 <rosmaita> ok, thanks for posting those
14:50:45 <tkajinam> one note about my patch is that I didn't add warning for every single  os.name == 'nt'  to avoid showing multiple multiple warnings
14:51:26 <tkajinam> but I added warnings to core parts (I believe) so these would be enough
14:51:32 <tkajinam> along with the release note
14:51:44 <rosmaita> ok, that sounds reasonable
14:52:16 <geguileo> tkajinam: what's the patch?
14:52:29 <tkajinam> https://review.opendev.org/c/openstack/cinder/+/894237
14:52:29 <tkajinam> https://review.opendev.org/c/openstack/os-brick/+/900913
14:52:30 <tkajinam> these two
14:52:51 <tkajinam> (I added these to the etherpad as well
14:53:07 <eharney> there's some code in cinder/cmd/* to remove too
14:53:11 <geguileo> tkajinam: thanks
14:53:24 <geguileo> eharney: that's why I was asking, but I see the patch is not removing code
14:53:36 <geguileo> It's just giving warnings in preparation of removal
14:54:07 <tkajinam> yes. my intention is to only deprecate these during this cycle
14:54:15 <tkajinam> and then remove it after 2024.1 release
14:54:19 <tkajinam> to follow SLURP
14:54:37 <tkajinam> 2024.1 deprecation  2024.2 removal  I mean
14:55:59 <rosmaita> right, the deprecation must happen in a SLURP release
14:56:25 <geguileo> +1
14:57:06 <rosmaita> tkajinam: anything else?
14:57:51 <rosmaita> ok, next item, everyone's favorite
14:57:56 <rosmaita> #topic review requests
14:58:21 <rosmaita> 4 requests this week, looks like most have good feedback so far, so please put them on your list to review
14:58:36 <rosmaita> and don't forget about the Festival of Reviews on Friday, 1400 UTC
14:58:50 <rosmaita> #topic open discussion
14:58:55 <rosmaita> ok 90 seconds left
14:59:00 <rosmaita> anyone?
14:59:05 <inori> The primary patches under review are related to SQLAlchemy 2.0. Regarding to the structure of [Review Requests] section, it seems that patches related to new features can only be added after M2 is passed, right? I have quite a few feature-related patches waiting for review. Do you have any suggestions on how I can expedite this process?
15:00:12 <drencrom> Hi, forgot to add it to the doc, but please remember to send the mail about the metadata length rosmaita
15:00:27 <rosmaita> drencrom: thanks for the reminder
15:01:11 <rosmaita> inori: maybe attend the Festival on friday, traditionally each attendee can nominate a patch, so that can get one reviewed kind of quickly
15:01:24 <rosmaita> ok, we are out of time
15:01:28 <rosmaita> thanks everyone!
15:01:31 <rosmaita> #endmeeting