14:01:03 <jbernard> #startmeeting cinder
14:01:03 <opendevmeet> Meeting started Wed Apr 17 14:01:03 2024 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:03 <opendevmeet> The meeting name has been set to 'cinder'
14:01:21 <whoami-rajat> hi
14:01:22 <jbernard> #topic roll call
14:01:28 <simondodsley> o/
14:01:34 <rosmaita> o/
14:01:37 <wilkmar> o/
14:02:04 <zaitcev> o/
14:02:56 <tosky> o/
14:03:55 <jungleboyj> o/
14:04:10 <jbernard> #link https://etherpad.opendev.org/p/cinder-caracal-meetings
14:04:30 <jbernard> ^ i haven't copied over the boiler plate yet, so we'll use the carcal etherpad for this one
14:04:57 <jbernard> i think most are here, lets get started
14:05:08 <jbernard> this will probably be a quick one
14:05:17 <jbernard> #topic announcements
14:05:34 <jbernard> Thanks to all that attended the PTG
14:06:04 <jbernard> we covered a large number of topics and so far the feedback has indicated it was productive
14:06:34 <jbernard> I'm working on condensing the etherpad into a summary for the list, that will go out this week
14:06:50 <jbernard> jungleboyj: can you help me with the recording management?
14:07:02 <jbernard> we have a youtube channel, are you able to make those available there?
14:07:07 <jbernard> how does it work?
14:07:09 <jungleboyj> Yep.
14:07:26 <jungleboyj> I have continued to do that.  If you just get me links to the videos I can upload them.
14:07:46 <jungleboyj> I should probably figure out how to give you access as well.  :-)
14:07:50 <jbernard> ok, can i just share them out of google drive? is that sufficient?
14:08:00 <jungleboyj> jbernard:  Yep, that works just fine.
14:08:03 <jbernard> jungleboyj: only if you want less work :)
14:08:21 <jbernard> jungleboyj: ok great
14:08:39 <jbernard> jungleboyj: thanks
14:08:59 <jungleboyj> I can keep doing that, just thinking for future access we should add you.  smcginnis and I are the two with access currently.  :-)
14:09:12 <jbernard> #topic dalmatian development cycle
14:09:36 <jbernard> this is the link to the timeline: https://releases.openstack.org/dalmatian/schedule.html
14:09:42 <jbernard> #link https://releases.openstack.org/dalmatian/schedule.html
14:10:32 <simondodsley> are you going to be adding Cinder specific events, as Manila has done?
14:10:56 <jbernard> simondodsley: that's a good question
14:11:14 <jbernard> simondodsley: do you know what manilla is doing beyond the standard schedule?
14:11:33 <jbernard> the short anwser is yes - if it applies and is helpful to our team
14:11:40 <jungleboyj> In the past we have done that.
14:11:41 <simondodsley> I'm just thinking we should add Cinder events as in the Caracal schedule
14:11:50 <simondodsley> https://releases.openstack.org/caracal/schedule.html
14:11:58 <rosmaita> there should be an example patch around somewhere
14:12:09 <jungleboyj> rosmaita: ++
14:12:19 <jbernard> ok, definately
14:12:40 <jungleboyj> Just base it off the Caracal example.
14:12:41 <jbernard> i need to sort out how to post those events, ill figure that out this week
14:12:48 <rosmaita> https://review.opendev.org/c/openstack/releases/+/754484
14:12:55 <jbernard> #action jbernard to share recordings with jay
14:13:03 <jungleboyj> ++
14:13:15 <jbernard> #action jbernard submit cinder-specific events for dalmation cycle
14:13:40 <jbernard> this meeting may be mostly for my personal organization :P
14:13:50 <jbernard> simondodsley: thanks for raising that
14:14:16 <jbernard> i will include the results of our event (midcycle, etc) in next week's meeting
14:14:19 <jungleboyj> :-)  Welcome new PTL.
14:14:54 <jbernard> thanks :)
14:15:13 <jbernard> #topic update CI for dalmatian
14:15:15 <jbernard> rosmaita: ^
14:15:35 <jbernard> brian is asking for reviews here:
14:15:39 <jbernard> #link https://review.opendev.org/q/topic:%22dalmatian-ci-update%22
14:15:41 <rosmaita> just need to get these merged so we'll be running the correct stuff
14:15:59 <rosmaita> just a note
14:16:22 <rosmaita> even though we don't support python 3.8, i didn't change the python_requires in setup.cfg
14:16:37 <rosmaita> last time someone did that early in the cycle it broke a bunch of projects
14:17:16 <rosmaita> we cna update it later
14:18:14 <jbernard> thanks rosmaita
14:18:27 <jbernard> #topic tgtadm deprecation
14:18:34 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/915752
14:19:10 <rosmaita> just need some reviews to move those 3 patches along (that's the parent patch)
14:20:16 <rosmaita> they get the driver options cleaned up a bit to prepare for handling the tgtadm deprecatinos
14:20:32 <jbernard> if anyone has spare cycles, this is a good place to help
14:20:56 <jbernard> OR if you are looking to trade reviews for patches you have waiting, this might be a good place to focus effort
14:21:49 <jbernard> that's all of the prepared content
14:21:54 <jbernard> #topic open discussion
14:22:20 <zaitcev> Short and sweet!
14:22:37 <ccokeke[m]> Hi
14:23:20 <ccokeke[m]> O/
14:23:36 <jbernard> ccokeke[m]: hi, feel free to raise any issues or questions
14:24:12 <wilkmar> Hi, I would appreciate it if someone could review this patch https://review.opendev.org/c/openstack/cinder/+/913754 , thank you in advance
14:26:01 <jbernard> wilkmar: ive added it to the etherpad
14:26:24 <wilkmar> thank you
14:27:05 <whoami-rajat> jbernard, just in case you are looking for caracal specific events for schedule
14:27:06 <whoami-rajat> #link https://review.opendev.org/c/openstack/releases/+/899847
14:27:29 <jbernard> whoami-rajat: that's very helpful, thanks
14:28:15 <whoami-rajat> np, also i wanted to mention, we might need new bug deputy and release liaison
14:28:31 <ccokeke[m]> jbernard: jbernard: Thanks for the opportunity,
14:28:38 <whoami-rajat> since jbernard is now PTL, we can delegate those responsibilities
14:28:56 <jbernard> whoami-rajat: ok sounds good
14:30:56 <jbernard> ccokeke[m]: do you have something to add?
14:31:04 <Dessira> hi
14:31:53 <Dessira> i have a question regarding the document-drivers-interface
14:32:19 <ccokeke[m]> jbernard: No.The issue I encountered last time was addressed by Gouthamr so I am working on it presently.Thanks for the opportunity
14:32:48 <jbernard> ccokeke[m]: ok
14:32:56 <jbernard> Dessira: whatcha got?
14:34:31 <Dessira> which would be the appropriate file for the accept-transfer doc as there is no volume-transfer interface?
14:36:04 <jbernard> #link https://etherpad.opendev.org/p/document-driver-interface
14:36:35 <jbernard> whoami-rajat: this was your topic at the PTG, can you help with this one?
14:37:02 <whoami-rajat> jbernard, sure, checking
14:38:54 <whoami-rajat> Dessira, we might need to create a new interface for that ...
14:39:06 <whoami-rajat> Gorka and I checked that a lot of methods were missing
14:39:29 <whoami-rajat> and i think transfers is in the list because some drivers need to do custom things before accepting transfer
14:39:33 <Dessira> alright whoami-rajat. Thanks
14:39:52 <whoami-rajat> Dessira, maybe you can work on other resource first and we can figure out what to do about transfers?
14:40:25 <rosmaita> I wonder if we can add those functions to the main interface, like what we do with clone_image()
14:40:27 <rosmaita> #link https://opendev.org/openstack/cinder/src/branch/master/cinder/interface/volume_driver.py#L239-L242
14:40:55 <Dessira> Ok whoami-rajat. no probs :)
14:41:37 <eharney> how many drivers implement accept_transfer?
14:43:12 <jbernard> eharney: only solidfire and vmware from a git grep on volume/drivers/
14:45:05 <rosmaita> we should probably handle it like clone_image, say that the default implementation is fine unless the driver needs to do custom stuff
14:45:13 <rosmaita> https://opendev.org/openstack/cinder/commit/e071ee263201d5ed0689e0755cf06f0a8568d16c
14:46:15 <jungleboyj> That makes sense.
14:46:52 <jbernard> ok, any other topics?
14:47:49 <jbernard> ok, see you in the cinder channel
14:47:52 <jbernard> #endmeeting