14:00:43 <jbernard> #startmeeting cinder
14:00:43 <opendevmeet> Meeting started Wed May 15 14:00:43 2024 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:43 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:43 <opendevmeet> The meeting name has been set to 'cinder'
14:00:53 <jbernard> #topic roll call
14:01:02 <zaitcev> o/
14:01:19 <akawai> o/
14:01:26 <whoami-rajat> hi
14:01:32 <rosmaita> o/
14:01:47 <eharney> hi
14:02:58 <sp-bmilanov> hello
14:02:59 <crohmann> hi
14:05:07 <jbernard> welcome everyone
14:05:13 <jbernard> #topic annoucements
14:05:39 <jbernard> D-1 milestone is tomorrow
14:06:02 <jbernard> i dont think it means a lot for us, libraries will be released
14:06:14 <jbernard> but otherwise we just keep rolling
14:06:30 <jbernard> please correct me if im missing something
14:06:59 <jbernard> this friday is our festival of reviews
14:07:16 <jbernard> they have been piling up, so there appears to be quite a bit to do
14:07:26 <jbernard> if you can help out, that would great
14:07:33 <jbernard> would *be*, even
14:08:13 <jbernard> that's all ive got
14:08:16 <jbernard> for annoucements
14:08:23 <jbernard> moving onto topics
14:08:35 <jbernard> #topic project-specific milestone dates
14:08:54 <jbernard> I need to define specific dates for us for the following milestones
14:08:59 <jbernard> spec freeze
14:09:04 <jbernard> new driver merged deadline
14:09:06 <jbernard> and
14:09:10 <jbernard> new target driver merge deadline
14:09:41 <jbernard> in looking at last cycle's scheulde, I will likely pick dates consistent with what we've done in the past
14:10:06 <jbernard> does anyone have an specific concerns about deadlines?  do we think the default dates will work?
14:11:02 * jungleboyj sneaks in late
14:11:03 <whoami-rajat> it might also be worth looking into the Bobcat cycle deadlines since that aligns better with the release schedule of Dalmatian
14:11:20 <jbernard> whoami-rajat: that's a good idea
14:11:54 <jbernard> ok, i will propose those dates to the list soon and submit them for review if there are no objections
14:12:26 <jbernard> #topic antelope, patch to bump ceph to reef
14:12:39 <jbernard> #link https://review.opendev.org/c/openstack/devstack-plugin-ceph/+/915146
14:13:02 <jbernard> ^ this patch updates ceph from quincy to reef for 2024.1 (antelope) tests
14:13:18 <jbernard> it doesn't have input from us yet
14:13:59 <jbernard> the logic seems reasonable, but i wanted to raise it in case you have an objection
14:14:54 <jbernard> whoami-rajat: has this happened before? i think ideally we'd want to test on both
14:15:39 <rosmaita> well, reef was released in the fall, i think there should be an "s" release happening soon (unless they changed their release schedule)
14:16:33 <whoami-rajat> so this has already merged in Caracal and bobcat and now we are looking into merging it in antelope
14:16:35 <jbernard> i dont think anything has been announced yet
14:16:55 <whoami-rajat> i remember we used to have a compatibility doc between ceph and openstack releases
14:17:20 <rosmaita> ok, i am wrong there ... preliminary release of reef was in the fall, the official release was march 11
14:17:29 <rosmaita> so reef is the latest
14:17:55 <rosmaita> the compatibility doc is the rbd driver docs
14:18:00 <jbernard> i think the logic is that, as time goes on, more folks are likely to be deploying against reef than quincy
14:18:39 <rosmaita> "For a given OpenStack release, Cinder supports the current Ceph active stable releases plus the two prior releases."
14:18:39 <crohmann> yes. We run Reef with Zed
14:19:36 <whoami-rajat> i understand the reasoning of using the latest version in master, just trying to understand if it makes sense for stable branches and till how long we can backport it without causing a breaking change
14:20:00 <jbernard> this is my question as well
14:20:15 <crohmann> I doubt there were client affecting changes for RBD in a while.
14:20:56 <crohmann> The only thing really bugging me are the Ceph caps which are so poorly documented (https://bugs.launchpad.net/nova/+bug/2051244)
14:22:35 <rosmaita> crohmann: have we still not documented that from the cinder side?
14:22:50 <crohmann> nope, no movement to the whole issue.
14:23:27 <rosmaita> what do we still need on that?
14:24:22 <crohmann> We need to agree which caps are ACTUALLY required (which pool by which client with which access level) and also convert this to the profile style of caps that Ceph STRONGLY advises to use
14:27:00 <jbernard> #action movement on ceph caps
14:27:08 <rosmaita> i know you've been working on this for about a year or so
14:27:25 <rosmaita> not sure what we can do to speed things up
14:27:51 <whoami-rajat> can get ask the operators to provide recommended profiles that they are using in their deployment currently? we can make changes to it but at least it will be a good starting point
14:28:01 <whoami-rajat> s/get/we
14:28:03 <rosmaita> other than just post a doc with whatever you think is correct, and let people correct it if they run into a problem
14:28:27 <crohmann> It seems that things have changed at least to profiles in the Documentation at Ceph (https://docs.ceph.com/en/latest/rbd/rbd-openstack/#setup-ceph-client-authentication)
14:28:35 <eharney> i think it'd be useful to add this to devstack-plugin-ceph so we can test it
14:29:03 <crohmann> eharney: Yes, that is one of the raised issues in the referenced Launchpad bug ... that devstack does take shortcuts here
14:29:04 <rosmaita> eharney: ++
14:29:58 <crohmann> whoami-rajat: My launchpad bug (which I believe you asked me to open) actually DOES contain my own config
14:31:32 <rosmaita> crohmann: are you happy with your config, or do you hope to narrow it some more?
14:32:11 <whoami-rajat> crohmann, okay then as rosmaita said, we can use that as a starting point and review it
14:32:35 <eharney> it could potentially be narrowed more depending on things like whether glance is using ceph as a backend or not
14:32:42 <crohmann> I did not mean to hijack the topics section though. I'd appreciate if someone joins the conversation in the ticket. I also gladly push some changes to docs or otherwise if there is some aggreement on what is "correct"
14:33:30 <rosmaita> i think no one wants to commit to "correct", because it might not work!
14:33:39 <jbernard> crohmann: no worries, this is important
14:33:45 <eharney> this is why i think the most valuable next step is to implement it in the devstack plugin
14:34:39 <jungleboyj> ++
14:35:15 <crohmann> I'll push a change for devstack as a starting point then. Otherwise ... join the fun train at https://bugs.launchpad.net/nova/+bug/2051244
14:35:56 <rosmaita> that sounds like a good plan
14:36:16 <jungleboyj> Agreed.
14:36:28 <jbernard> excellent
14:36:34 <jbernard> #topic backup patches
14:37:11 <zaitcev> oh no
14:37:12 <jbernard> really quickly, as crohmann notes as well, there are several c-bak patches accumulating, I think we should try to review these as part of our festival efforts on friday
14:37:15 <zaitcev> what about them?
14:37:28 <zaitcev> Totally!
14:37:35 <jbernard> great ;)
14:38:05 <jbernard> that's all for topics I had
14:38:30 <jbernard> anything else from anyone? how are things going for everybody?
14:39:00 <zaitcev> Backup encryption is progressing. Just slowly.
14:40:03 <jbernard> progress is good!
14:40:20 <jbernard> I'll spin through the review requests today
14:40:31 <jbernard> #link https://etherpad.opendev.org/p/cinder-dalmatian-meetings#L104
14:40:46 <jbernard> if anyone would like to raise specific concerns, feel free
14:40:51 <jbernard> #topic open discussion
14:41:14 * sp-bmilanov is trying to figure out why the gate pipeline has failed, twice, on different jobs for 803823, and if he should re-run until all jobs pass
14:41:38 <crohmann> jbernard: I put my change (https://review.opendev.org/c/openstack/cinder/+/810457) in there ... as I have a specific question that I need answer to prior to pushing a hopefully final patchset. See https://review.opendev.org/c/openstack/cinder/+/810457/comment/31a6c2c2_4750ec07/
14:43:03 <eharney> there was a suggestion in this requirements change that we merge it at the beginning of this cycle:  https://review.opendev.org/c/openstack/cinder/+/908193
14:44:59 <jbernard> crohmann: ok
14:45:34 <crohmann> There also is another question about a (potentially broken) test failing in https://review.opendev.org/c/openstack/cinder/+/484729/comments/b6da8f16_5c9481e3?tab=comments, also keeping me from finishing this change for a final review
14:45:42 <rosmaita> sp-bmilanov: i just issued a recheck, looks like a random thing
14:46:42 <whoami-rajat> i see this issue in the ceph tempest job, could it be related to our recent RBD changes
14:46:44 <whoami-rajat> May 15 00:45:03.833658 np0037512504 cinder-volume[113176]: ERROR oslo_messaging.rpc.server rbd.ImageHasSnapshots: [errno 39] RBD image has snapshots (error removing image)
14:46:56 <jbernard> #action movement on crohmann blocking questions
14:47:03 <eharney> whoami-rajat: yeah i was looking at that one earlier.  first time i've seen it, not sure why yet -- i think it references a read only image
14:47:48 <whoami-rajat> yeah it could be
14:47:56 <whoami-rajat> May 15 00:45:03.833658 np0037512504 cinder-volume[113176]: ERROR oslo_messaging.rpc.server [req-e5453de1-89c1-41e7-9c97-12b3b82181d3 req-fe8a5e99-6bbe-4cbb-a4ba-ad8f0f86e574 tempest-TestVolumeBootPattern-189137301 None] Exception during message handling: rbd.ReadOnlyImage: [errno 30] RBD read-only image (error flattening b'volume-74ed150e-1809-41ad-a759-d388e5130a3e')
14:48:02 <sp-bmilanov> rosmaita: thanks!
14:49:23 <jbernard> eharney: the moto bump needs to merge nowish?
14:50:08 <eharney> jbernard: i don't know about "needs", but it was bumped out to not be at the end of the last cycle.  when is the right time?
14:51:29 <jbernard> eharney: if zuul posts updated results, i dont see why we couldn't get this in now
14:56:01 <jbernard> ok, if there's nothing else, i think we're done
14:57:06 <jbernard> thanks everyone
14:57:09 <jbernard> #endmeeting