14:00:17 <jbernard> #startmeeting cinder
14:00:17 <opendevmeet> Meeting started Wed Jun  5 14:00:17 2024 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <opendevmeet> The meeting name has been set to 'cinder'
14:00:21 <jbernard> #topic roll call
14:00:23 <jbernard> o/
14:00:28 <Luzi> o/
14:00:35 <ccokeke[m]> o/
14:00:36 <jbernard> good morning/afternoon/evening everyone!
14:00:37 <whoami-rajat> hi
14:00:54 <akawai> o/
14:00:57 <jungleboyj> o/
14:02:11 <rosmaita> o/
14:02:33 <jbernard> #link https://etherpad.opendev.org/p/cinder-dalmatian-meetings
14:02:52 <simondodsley> o/
14:03:49 <tosky> o/
14:05:59 <jbernard> ok, lets get started
14:06:13 <jbernard> #topic annoucements
14:06:32 <jbernard> our first midcycle is next wednesday (june 12)
14:06:51 <jbernard> ive created an etherpad to collect topics
14:07:02 <jbernard> #link https://etherpad.opendev.org/p/cinder-dalmatian-midcycles
14:07:30 <jbernard> feel free to add any topics or talking points there and we can organize them into a schedule for the session
14:08:33 <jbernard> I think the final cinder-specific schedule will merge shortly
14:08:36 <jbernard> #link https://review.opendev.org/c/openstack/releases/+/919908
14:08:54 <jbernard> a few minor tweaks (thanks rajat)
14:09:52 <zaitcev> Wow, running this show is no sinecure.
14:10:05 <jbernard> that's all i have for annoucements, things have been pretty steady in the last weeks
14:11:12 <jbernard> #topic docstrings!
14:11:33 <zaitcev> Oh, snap. I've only finished half of mine.
14:11:46 <jbernard> if we can, I'd like to get a collection of the docstring patches either merged or in progress in hopes of creating a reveiw dashboard for us
14:12:48 <jbernard> for context, in the PTG we agreed to consolidate our driver documentation into the cinder interface definition and references those from the driver declarations
14:13:03 <jbernard> #link https://etherpad.opendev.org/p/document-driver-interface
14:13:07 <rosmaita> probably the best thing would be to use a common topic for the reviews
14:13:30 <jbernard> im just going to spin through the assignments really quickly
14:13:32 <jbernard> rosmaita: +1
14:14:22 <jbernard> rosmaita: maybe just 'docstrings' would work
14:14:34 <rosmaita> sure
14:14:47 <jbernard> rosmaita: can i apply such a topic to the collection, or must that be done by each respective author?
14:15:23 <rosmaita> i think any core can set a topic on a review (though i'm not sure about that)
14:15:50 <jbernard> ok, ill try to to field that one and let everyone keep working :)
14:16:15 <jbernard> #action apply common topic to outstanding docstring patches for dashboard (jbernard)
14:16:27 <jbernard> the list as it is:
14:16:33 <whoami-rajat> 'docstrings' might be too generic and could be used by other projects (or probably already used?), maybe something more cinder specific?
14:16:42 <whoami-rajat> cinder-driver-docstrings
14:16:50 <zaitcev> I used "improve-driver-docstring" topic.
14:16:51 <jbernard> 'cinder-docstrings-dalmatian'
14:17:13 <jbernard> ok, ill pick something unique, no worries
14:17:13 <zaitcev> Too late, mine is merged. I'll do that next.
14:17:18 <jbernard> lol
14:17:25 <whoami-rajat> I've my patches under "document-driver-interface-image" https://review.opendev.org/q/topic:%22document-driver-interface-image%22
14:17:29 <whoami-rajat> but I'm fine with changing it
14:17:51 <jbernard> manage/unmanage still needs a volunteer
14:17:56 <jbernard> any takers on taht one?
14:18:07 <jbernard> #link https://etherpad.opendev.org/p/document-driver-interface#L32
14:18:35 <jbernard> the list contains several duplicates, probably not as bad as it initially looks
14:19:27 <jbernard> ok, ill nominate myself then
14:19:45 <jbernard> next is replication, still needs a volunteer
14:20:26 <jbernard> added to the list ;)
14:20:36 <jbernard> basic create/delete
14:20:45 <jbernard> whoami-rajat: you've posted a patch for those?
14:21:32 <whoami-rajat> jbernard, I've a patch up for create volume https://review.opendev.org/c/openstack/cinder/+/918336
14:22:10 <jbernard> whoami-rajat: does that include the snapshot and delete routines?
14:22:38 <whoami-rajat> jbernard, nope, i will propose separate patches for those, only done create_volume for now
14:23:04 <jbernard> ok
14:23:26 <jbernard> transer
14:23:36 <jbernard> Desire, are you here?
14:24:55 <jbernard> i don't see any posted patches from a quick scan, can revisit soon
14:25:13 <jbernard> attach/detach
14:25:15 <jbernard> this is gorka
14:25:27 <jbernard> he's not here today, do we know the status of those?
14:26:55 <jbernard> scheduler
14:27:06 <jbernard> rosmaita: ^
14:27:11 <jbernard> how are those going?
14:27:37 <rosmaita> well, i have some of the functions doc'd locally, need to finish
14:27:53 <jbernard> me too
14:28:05 <jbernard> you're also on the 'assorted' list as well
14:28:41 <jbernard> image
14:28:41 <rosmaita> that one i have not started
14:29:27 <jbernard> whoami-rajat: you've already posted patches in the etherpad for those
14:29:44 <whoami-rajat> yes, all patches are up for image
14:29:47 <jbernard> and that just leaves init and backup from pete
14:29:57 <jbernard> which are in progress
14:30:43 <jbernard> i'll ask gorka offline, im sure it wont take him long to get those posted
14:30:54 <jbernard> ok, that's all for docstring scraping
14:32:16 <jbernard> we can do review requests shortly, ill open for discussion now if anyone has concerns or general questions
14:32:22 <jbernard> #topic open discussion
14:35:06 <zaitcev> Looks like nobody has anything.
14:35:16 <jbernard> #topic review requests
14:35:39 <jbernard> antelope backport
14:35:46 <jbernard> #link https://review.opendev.org/c/openstack/os-brick/+/920232
14:35:59 <jbernard> ^ that's an easy one
14:36:25 <jbernard> akawai needs a review for Hitachi tests
14:36:32 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/916724
14:37:10 <jbernard> simondodsley needs a review for Pure API upgrade
14:37:18 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/903095
14:37:51 <simondodsley> Please
14:37:56 <jbernard> ^ this is blocking other patches, so needs to be reviewed
14:38:35 <jbernard> simondodsley: am i correct that your local CI is passing on that patch?
14:39:08 <simondodsley> Yes. I can provide tempest results if needed
14:39:18 <jbernard> ok, that's helpful to know
14:39:45 <jbernard> and Luzi needs reviews for image encryption spec and user visible info in volume types
14:39:51 <jbernard> #link https://review.opendev.org/c/openstack/cinder-specs/+/919499
14:39:53 <jbernard> and
14:39:59 <jbernard> #link https://review.opendev.org/c/openstack/cinder-specs/+/909195
14:40:15 <Luzi> yes please
14:41:25 <jbernard> will the review-priority flag cause patches like this to become more visible in dashboard listings?
14:41:30 <jbernard> whoami-rajat, rosmaita: ^
14:41:54 <rosmaita> well, it's supposed to
14:42:13 <rosmaita> but i don't think it's worked well in practice
14:43:26 <whoami-rajat> i think we can filter out patches which has RP set but we haven't gone through that list in a while
14:43:40 <jbernard> ok, lets try for an initial pass and any outstanding concerns can be worked through in the midcycle next week
14:44:29 <jbernard> that's all i have for today
14:44:40 <jbernard> anything else?
14:45:57 <jbernard> ok, thanks everyone!
14:46:00 <jbernard> #endmeeting