14:00:14 <jbernard> #startmeeting cinder
14:00:14 <opendevmeet> Meeting started Wed Jun 26 14:00:14 2024 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <opendevmeet> The meeting name has been set to 'cinder'
14:00:20 <jayaanand> hi
14:00:23 <jbernard> #topic roll call
14:00:25 <rosmaita> o/
14:00:31 <jbernard> o/
14:00:32 <eharney> hi
14:00:35 <akawai> o/
14:00:40 <whoami-rajat> Hi
14:00:54 <kpdev> o/
14:01:09 <ccokeke[m]> o/
14:02:21 <Luzi> o/
14:03:03 <jbernard> #link https://etherpad.opendev.org/p/cinder-dalmatian-meetings
14:03:35 <zaitcev> o/
14:04:37 <jbernard> welcome everyone
14:05:12 <jbernard> #topic annoucements
14:05:38 <jbernard> the naming vote for the 'E' release is happening
14:05:45 <jbernard> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/33F2I7NRUHGJ5L3A5D66COO26NRJSQJN/
14:06:06 <jbernard> also
14:06:18 <jbernard> PTG signup is open
14:06:23 <jbernard> (for Oct)
14:06:34 <jbernard> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/PCBOXDHRGOXIVG5DXNEIE2YDG47E6SQN/
14:06:49 <whoami-rajat> actually that's only for the PTL to do but i added it just for awareness
14:07:11 <jbernard> whoami-rajat: ahh, good to know, thank you
14:07:43 <whoami-rajat> wait
14:07:47 <whoami-rajat> i might be wrong
14:07:55 <rosmaita> those E release names are pretty rank, good thing we are doing ranked choice voting
14:08:06 <whoami-rajat> ok everyone can register in this, there will be a separate email for project signup, the subject is really confusing here
14:08:21 <whoami-rajat> sorry for the confusion, we can all register in this
14:09:49 <jbernard> we are now in R-14
14:10:07 <jbernard> which means, the dalmatian 2 milstone is coming up
14:11:01 <jbernard> the spec freeze was last week, but I think we have at least one or two that need exceptions
14:12:04 <whoami-rajat> yes, i added few topics about that
14:12:10 <jbernard> i think image encryption and user visible volume info are in good shape
14:12:40 <jbernard> whoami-rajat: ahh,
14:12:53 <whoami-rajat> but we can continue discussing, my intent was just to highlight them
14:13:16 <jbernard> yes, I think we have some good specs that are very close, I think extending the deadline is okay
14:14:23 <jbernard> we'll get to that in bit
14:14:41 <jbernard> for now, what's upcoing:
14:14:44 <jbernard> #link https://releases.openstack.org/dalmatian/schedule.html
14:15:06 <jbernard> dalmatian 2 milestone and driver and target-driver deadlines
14:15:54 <jbernard> that's all for announcements
14:16:13 <jbernard> im going to merge last week's content here so that we cover everything
14:17:01 <jbernard> well, there's actually not much
14:17:21 <jbernard> kgube reproposed extend volume completion spec
14:18:22 <jbernard> the api change merged last cycle, but patches are missing. do we need to repropose the spec to get them merged?
14:18:56 <jbernard> I don't think so, new patches can reference a spec, even if it's not in the current cycle, no?
14:19:22 <whoami-rajat> i think the spec was reproposed and merged
14:19:51 <jbernard> #link https://review.opendev.org/c/openstack/cinder-specs/+/896014
14:20:03 <whoami-rajat> #link https://review.opendev.org/c/openstack/cinder-specs/+/922374
14:20:24 <jbernard> ahh! im looking at the wrong one
14:20:28 <jbernard> ignore my link!
14:20:38 <jbernard> that makes much more sense
14:21:06 <jbernard> so this moves forward, i think kgube has a path forward
14:21:46 <jbernard> #topic volume type metadata
14:21:52 <jbernard> Luzi: that's you
14:22:07 <jbernard> #link https://review.opendev.org/c/openstack/cinder-specs/+/909195
14:22:17 <Luzi> the question i had is already obsolete
14:22:26 <Luzi> so I think the spec is in a good state
14:22:31 <jbernard> excellent
14:23:22 <jbernard> #topic need someone from dell/emc to review a particular patch
14:23:28 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/914992
14:23:38 <rosmaita> it's a real tiny patch
14:23:51 <jbernard> changes make sense, but if we have someone with specific knowledge - what would be nice
14:23:59 <rosmaita> Rajat made a good point that it would be good to have Dell ack that the change is ok
14:24:11 <jbernard> is anyone from Dell around today?
14:24:11 <rosmaita> since it was not proposed by a dell person
14:25:29 <rosmaita> well, so much for my brilliant plan to get some visibility on the patch
14:25:30 * jungleboyj sneaks in late
14:25:48 <whoami-rajat> ideally it shouldn't break anything since we are moving a variable to utils for common use but the author is from Mirantis and i wanted to avoid a scenario where Dell comes complaining about something :D
14:26:21 <whoami-rajat> but if we feel it's safe, we can go ahead with merging it
14:26:34 <jbernard> who are our dell people? maybe i can reach out directly
14:27:02 <whoami-rajat> happystacker doesn't seem to be around today
14:27:21 <jbernard> ok, ill ping happystacker offline
14:27:39 <jbernard> #action feedback from dell to merge https://review.opendev.org/c/openstack/cinder/+/914992
14:27:45 <whoami-rajat> sounds good, thanks
14:27:56 <jbernard> #topic spec freeze
14:28:11 <jbernard> we've a few in good shape, i think we should extend the deadline
14:28:19 <jbernard> what are thoughts?
14:29:15 <rosmaita> no objection from me
14:29:19 <whoami-rajat> +1 for extending it
14:30:12 <jbernard> ok, ill notify teh list
14:30:27 <jbernard> #action send mail to list extending spec freeze
14:30:51 <jbernard> #topic driver merge deadline
14:31:02 <jbernard> we have (as far as I know) one proposed new driver
14:31:09 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/921020
14:31:14 <jbernard> Ceastor driver
14:31:36 <whoami-rajat> another nvme driver, great!
14:31:45 <jbernard> yes
14:31:59 <jbernard> i don't belive there is any CI for this driver at the moment
14:32:19 <whoami-rajat> ah, i was trying to find it ...
14:32:26 <jbernard> would anyone like to volunteer to review this?
14:32:57 <jbernard> if it's close and the author is responsive, we could possibly land this
14:33:09 <whoami-rajat> we will need to add a comment stating that CI is a hard requirement for merging a new driver
14:33:13 <whoami-rajat> maybe they are not aware
14:34:59 <jbernard> is the entry point for new driver docs this: https://wiki.openstack.org/wiki/Cinder/how-to-contribute-a-driver
14:35:11 <jbernard> i know we have a checklist for reviewers
14:35:28 <whoami-rajat> #link https://docs.openstack.org/cinder/latest/contributor/new_driver_checklist.html
14:35:48 <whoami-rajat> not sure if the wiki is up to date, maybe a driver vendor can tell?
14:38:13 <jbernard> i added a link to the checklist and asked about CI in the review
14:38:14 <rosmaita> wiki says right at the beginning: "The deadline for new backend drivers is Milestone 2 of the current development cycle. By this deadline, your driver should have working third party CI and no code review issues."
14:40:22 <jbernard> i made mention of this on the patch
14:40:28 <jbernard> we'll see what comes back
14:40:51 <jbernard> #topic review requests
14:41:20 <jbernard> Fujitsu
14:41:29 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/901146/
14:41:53 <jbernard> HPE
14:42:02 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/921592
14:42:14 <jbernard> Hitachi
14:42:21 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/901318
14:42:35 <jbernard> and Storpool
14:42:37 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/843277
14:42:44 <jbernard> #link https://review.opendev.org/c/openstack/os-brick/+/887575
14:43:25 <whoami-rajat> I also wanted reviews on this patch, needed for SDK and OSC commands for default volume types
14:43:28 <whoami-rajat> #link https://review.opendev.org/c/openstack/cinder/+/920308
14:43:53 <whoami-rajat> it's making the default type APIs compatible with other APIs
14:44:11 <whoami-rajat> i mean making the format compatible
14:45:08 <zaitcev> So, how do we make Hitachi to answer Brian's question in https://review.opendev.org/c/openstack/cinder/+/901318
14:47:29 <eharney> https://review.opendev.org/c/openstack/cinder/+/921864   gets our pylint job to stop failing on all runs
14:49:03 <rosmaita> zaitcev: looks like the last actual hitachi action on that patch was the may 21 rebase
14:52:28 <jbernard> that's all for the adgenda today
14:52:36 <jbernard> #topic open discussion
14:55:07 <jbernard> ok, thanks everyone!
14:55:10 <jbernard> #endmeeting