14:01:13 <jbernard> #startmeeting cinder
14:01:13 <opendevmeet> Meeting started Wed Oct 16 14:01:13 2024 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:13 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:13 <opendevmeet> The meeting name has been set to 'cinder'
14:01:24 <jbernard> #link https://etherpad.opendev.org/p/cinder-epoxy-meetings
14:01:26 <whoami-rajat> Hi
14:01:28 <jbernard> #topic roll call
14:01:30 <jayaanand> Hi
14:01:30 <jbernard> o/
14:01:35 <gireesh> hi
14:01:36 <rosmaita> o/
14:01:39 <jhorstmann> o/
14:01:39 <akawai> o/
14:04:23 <jbernard> im seeing etherpad updates, ill wait a bit for those to settle
14:04:29 <rosmaita> :D
14:05:14 <jungleboyj> o/
14:06:05 <jbernard> ok
14:06:12 <jbernard> #topic annoucements
14:06:18 <jbernard> welcome everyone
14:06:33 <jbernard> the PTG is next week
14:06:46 <jbernard> for us, we have 3 days:
14:06:52 <jbernard> wed, thu, and fri
14:07:19 <jbernard> that is what I've booked and I think it will be sufficient based on the proposed topics
14:07:31 <jbernard> friday will likely be a code review collaborative
14:07:44 <jbernard> but we could repurpose it if needed
14:07:53 <jbernard> that "room" will be Ocata
14:08:13 <jbernard> #link https://ptg.opendev.org/ptg.html
14:08:19 <jbernard> from 14 to 17 UTC
14:09:12 <jbernard> we'll likely use the google meet link as before, i think i remember there being issues with meetpad
14:09:40 <jbernard> but in general, it will be very much like our past virtual ptgs
14:09:46 <jbernard> things to note:
14:09:55 <jbernard> on monday, there is the TC track
14:10:08 <jbernard> they will have a session for eventlet removal
14:10:40 <jbernard> this is relevant for me at least, I'm hoping to make some headway on that this cycle
14:11:19 <jbernard> unlike glance (which mostly uses eventlet for their wsgi service), we use eventlet directly, so our transition is likely to look different
14:11:38 <jbernard> if you have interest in that topic, the TC track on monday will be helpful
14:11:40 <jbernard> also
14:11:41 <rosmaita> there's more info about eventlet removal at the top of  https://etherpad.opendev.org/p/epoxy-ptg-cinder
14:11:56 <jbernard> yup, thank rosmaita
14:12:25 <jbernard> the horizon team has asked us to participate in a 'feature gap' meeting on wednesday
14:12:35 <jbernard> they expect it will take ~30 minutes
14:13:08 <jbernard> i proposed a start time of 14:30 - which gives us 30 minutes to say hello and get settled before we jump into that
14:13:35 <jbernard> i will be sending out a mail with all of this information later today
14:14:20 <jbernard> otherwise, what is in the etherpad is what we're working with
14:14:30 <jbernard> ah, i still need to merge them
14:14:40 <jbernard> that should all be fixed up today before I send the mail
14:14:50 <jbernard> any questions or concerns about the PTG?
14:14:59 <jbernard> anything i might have missed?
14:15:17 <whoami-rajat> glance team is also planning a cross project
14:15:25 <whoami-rajat> for the new location API adoption they merged last cycle
14:15:33 <whoami-rajat> it should be between nova-cinder-glance
14:15:48 <jbernard> whoami-rajat: yes, that's important. do we have a day/time for that?
14:16:05 <whoami-rajat> I'm not sure, maybe we can sync with Pranali to coordinate
14:16:32 <jbernard> #action reach out to glance about cross project coordination at ptg
14:17:29 <rosmaita> https://etherpad.opendev.org/p/oct2024-ptg-glance
14:17:50 <rosmaita> looks like thursday, both image encryption and location API
14:17:55 <jbernard> perfect
14:18:13 <whoami-rajat> also we need to update the etherpad, the ptg page still points to the old one
14:18:15 <whoami-rajat> cinder: https://etherpad.opendev.org/p/oct2024-ptg-cinder
14:18:22 <jbernard> yup, ill fix that today
14:18:27 <whoami-rajat> thanks!
14:20:45 <jbernard> im also working on the cinder-specific milestones for the general release calendar
14:21:31 <jbernard> im likely to follow close to what we had in the dalmatian cycle, but ill post what I'm thinking before anything is confirmed
14:21:51 <jbernard> in case we want something different
14:22:10 <jbernard> that all from me
14:22:15 <jbernard> next on the list is rosmaita
14:22:29 <jbernard> non wsgi deprecations
14:22:32 <jbernard> rosmaita: take it away
14:22:37 <rosmaita> yeah, this just came in on the mailing list this morning
14:22:46 <rosmaita> not sure it's a big deal for us
14:22:55 <rosmaita> but, please read the email
14:23:05 <rosmaita> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/EBV4PAMFUZCL72KC2HP7W4P47L6RYU2H/
14:23:14 <rosmaita> and then review the patches
14:23:25 <rosmaita> #link https://review.opendev.org/c/openstack/devstack/+/932193
14:23:32 <rosmaita> #link https://review.opendev.org/c/openstack/devstack/+/932196
14:23:46 <rosmaita> if anyone sees a problem or has questions, we can discuss next week
14:23:57 <rosmaita> that's all
14:25:07 <jbernard> antelope is become unmaintained
14:25:33 <rosmaita> yeah, projected date for the end-of-maintenance tag is oct 30
14:25:52 <rosmaita> so, if there's anything we want in there, it needs to be merged as soon as possible
14:25:58 <jbernard> yes
14:26:06 <rosmaita> you can use this handy dashboard to help in reviewing:
14:26:16 <rosmaita> #link http://tiny.cc/cinder-maintained
14:26:30 <rosmaita> just keep in mind that patches can't be merged into Antelope unless they are in all more recent branches
14:27:07 <rosmaita> any questions?
14:27:26 <jbernard> in wondering about the rbd flattening results
14:27:42 <jbernard> i don't think ganso is around at the moment
14:30:04 <rosmaita> i think that one merged into master when it was 2024.1 (Caracal) development
14:30:13 <rosmaita> so it has never actually been backported
14:30:30 <jbernard> true, i see proposals for A and B
14:31:08 <jbernard> i think we were hoping https://review.opendev.org/c/openstack/devstack-plugin-ceph/+/919539 could be fixed up to depend on those backports so there would be better test coverage to review
14:33:07 <rosmaita> https://review.opendev.org/c/openstack/cinder/+/931976 is kind of a big patch, which would argue against backporting
14:33:07 <rosmaita> but on the other hand, it only affects a single driver, so it's kind of low risk
14:33:46 <jbernard> eharney: are you willing to weigh in on those backports?
14:34:07 <rosmaita> maybe if ganso could give us more info about how it's working -- i think he has applied the patch in his cloud
14:34:28 <jbernard> we have about 2 weeks before final release, but that time is going to fly, especially with the ptg next week
14:38:29 <jbernard> i think this all for the adgenda today
14:38:34 <jbernard> #topic open discussion
14:39:40 * sp-bmilanov is trying to find any follow-ups on https://etherpad.opendev.org/p/cinder-drivers-documentation
14:40:58 <whoami-rajat> yeah we should rediscuss the driver documentation
14:41:14 <sp-bmilanov> as I understand it, sometimes an entry point to OpenStack is starting work on a Cinder backend driver, and an overview article focused on this with pointers to the other relevant documentation might be useful
14:41:17 <rosmaita> sp-bmilanov: don't think there has been any action on that, i think all our efforts were devoted to the driver-interface-docstring update
14:41:21 <whoami-rajat> with new expected driver proposals next cycle, this will be very useful
14:42:34 <jbernard> i know several patches ot the interface docstrings landed
14:42:48 <jbernard> but there are still a few gaps remaining
14:43:07 <jbernard> that's not an overview though
14:43:19 <jbernard> sp-bmilanov: is anyone working on this?
14:44:10 <sp-bmilanov> no, I read through the drivers doc etherpad just now, with the feedback from yuval
14:44:36 <sp-bmilanov> s/no/I don't know/
14:45:07 <whoami-rajat> I remember Gorka and I created an etherpad that had all work items
14:45:12 <whoami-rajat> let me try to find it
14:48:07 <whoami-rajat> #link https://etherpad.opendev.org/p/document-driver-interface
14:48:17 <whoami-rajat> here it is, took an eternity to find
14:49:01 <jbernard> yep, we started the dalmatian cycle with that if i recall
14:49:11 <rosmaita> thanks for finding that, i added it to the "spotlight links" at the top of the meeting agenda
14:50:31 <jbernard> sp-bmilanov: is that helpful?
14:50:44 <whoami-rajat> thanks rosmaita , that would be easier to find next time
14:52:37 <whoami-rajat> we also have lesser owners now with Pete and Gorka not around
14:53:12 <jbernard> true
14:53:26 <sp-bmilanov> jbernard: not sure, it seems too low-levew, my impression is that yuval is looking for a single overview that introduces OpenStack to a person just now starting with Cinder backend driver development
14:54:02 <jbernard> sp-bmilanov: ahh, i understand.  i don't think we currently have such a thing
14:54:22 <jbernard> sp-bmilanov: are you and/or yuval interested in driving that effort?
14:55:46 <sp-bmilanov> I might give it some thought, I will get back to you with a draft if I can write something up
14:56:58 <jbernard> sound good
14:57:01 <jbernard> sounds, even
14:57:51 <jbernard> ok, last call
14:58:35 <jbernard> thanks everyone, i look forward to next week's dicussions
14:58:40 <jbernard> #endmeeting