15:00:31 <jbernard> #startmeeting cinder
15:00:31 <opendevmeet> Meeting started Wed Nov  6 15:00:31 2024 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:31 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:31 <opendevmeet> The meeting name has been set to 'cinder'
15:00:35 <jbernard> #topic roll call
15:00:37 <jbernard> o/
15:00:39 <Luzi> o/
15:01:00 <jbernard> #link https://etherpad.opendev.org/p/cinder-epoxy-meetings
15:01:06 <msaravan> Hi
15:01:17 <rosmaita> o/
15:01:49 <jungleboyj> o/
15:02:00 <Sai> o/
15:02:51 <sp-bmilanov> o/
15:03:36 <gireesh> hi
15:03:58 <jbernard> welcome everyone, just a couple more minutes to collect everyone
15:04:10 <jbernard> (sorry for the time mistake)
15:07:48 <jbernard> ok
15:07:54 <jbernard> #topic announcements
15:08:09 <jbernard> first, i appologize for the time issue
15:08:29 <jbernard> im curious if anyone objects to moving it to 15UTC
15:08:36 <whoami-rajat> hi
15:08:54 <jbernard> if there is a conflict, i can try to make a few changes on my side
15:09:04 <sp-bmilanov> no worries jbernard! so that would be +1 from what we have right now in the calendar?
15:09:13 <jbernard> exactly
15:09:47 <jbernard> my time moved back 1 hour last weekend and i failed to realize the rest of the world isn't on my schedule ;)
15:10:11 <Luzi> moving it is unfortunate for us from europe
15:10:21 <jbernard> Luzi: ack
15:10:32 <jbernard> ok, let me try to make some adjustments here
15:10:46 <manudinesh> Hi All,  I had requested for comments on this bug# https://bugs.launchpad.net/cinder/+bug/2084117  and had added it in cinder_bs agenda link https://etherpad.opendev.org/p/cinder-bug-squad-meeting [on Oct 16th]  Guess that etherpad is no more actively used.  Request you to please take it on priority and share your comments, Thanks
15:10:48 <jbernard> it's certainly easier for me to do that and to impose a time change on everyone else
15:11:04 <jbernard> manudinesh: hold onto that until the open discussion section
15:11:10 <jbernard> manudinesh: we're in the annoucments at the moment
15:11:28 <manudinesh> sorry...
15:11:33 <jbernard> manudinesh: no worries
15:11:49 <jbernard> so, for clarity, we're keeping the 14:00 UTC meeting time on wednesdays
15:12:03 <jbernard> continuing next week
15:12:13 <jbernard> time issue resolved
15:12:58 <jbernard> moving one
15:13:03 <jbernard> s/one/on
15:13:16 <jbernard> i posted a summary of our ptg content to the list
15:13:19 <jbernard> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/G4DMPLHQFCI4K2HMYAIMCL7DF3TMX7B6/
15:13:36 <jbernard> i think that captures most of it, without details, just an overview
15:14:01 <jbernard> i need to fix the wiki version, if you think i've missed something let me know
15:14:15 <jbernard> next, we have a release update
15:14:20 <jbernard> rosmaita: do you want to take this one?
15:14:31 <rosmaita> sure
15:14:48 <jungleboyj> jbernard: Do you have videos for me to post?
15:14:56 <jbernard> jungleboyj: yes!
15:15:01 <rosmaita> not much to say ... we're releasing a final cinder and os-brick from Antelope (probably tomorrow)
15:15:10 <jbernard> #action jbernard to get videos to jay for posting
15:15:38 <rosmaita> and Antelope will go to Unmaintained and stable/2023.1 will be deleted shortly after
15:16:20 <rosmaita> last thing: i'm willing to continue as release person for epoxy, but will be happy to teach anyone else who's interested how to do it and take ove
15:16:27 <rosmaita> *over
15:16:38 <rosmaita> that's all from me
15:16:39 <jungleboyj> jbernard:  ++
15:16:41 <jbernard> would anyone like to volunteer to be release liason?
15:17:33 <jbernard> there is virtually zero prestige or recognition, however you /will/ have my eternal gratitude :)
15:18:02 <jbernard> *crickets*
15:18:06 <jbernard> :)
15:18:28 <jungleboyj> :-)
15:18:40 <jbernard> rosmaita: looks like you're our release liason!
15:18:45 <jbernard> rosmaita: congrats!
15:18:56 <jungleboyj> Can't even offer beers at the next event as we don't get together anymore.
15:18:56 <rosmaita> :D
15:19:15 <jbernard> one day...
15:19:15 <jungleboyj> rosmaita: Thank you for your compliance.  ;-)
15:19:37 <rosmaita> i will celebrate with a virtual beer
15:19:41 <jbernard> lol
15:19:55 <jbernard> just make sure you get the hashes right first ;)
15:19:56 <jungleboyj> lol
15:20:42 <jbernard> id like to quickly hijack topics and ask a related question:
15:20:58 <jbernard> do we want to consider merging the unmaintained cores with cinder cores, as I belive Ironic has done?
15:21:46 <jbernard> i would still be very reluctant to make use of that power, as I don't want to make a mistake, but it's not fun redirecting folks the way we do
15:22:02 <jbernard> does anyone have a opinion on this?
15:22:46 <jbernard> does anyone have any, even mild, objections?
15:23:06 <rosmaita> well, the point of unmaintained was that the project has no responsibility
15:23:07 <jungleboyj> I think we already have a notable about of overlap there.
15:23:22 <jungleboyj> Oh, unmaintained, not stable.
15:23:24 <jungleboyj> Nevermind.
15:24:36 <rosmaita> my objection was that i don't know that we want to be responsible for reviewing victoria through antelope, in addition to the stuff we're actually supposed to be reviewing
15:25:14 <rosmaita> but any cinder core could volunteer to be an unmaintained core, if they would like to
15:25:19 <jbernard> that's a very fair point, especially considering our current review bandwidth
15:25:34 <rosmaita> and any cinder community member could volunteer as well
15:26:03 <rosmaita> i think the requirements to be an unmaintained core are still being developed
15:26:32 <jbernard> ok, lets leave it then, we can always revisit if the situation changes
15:26:57 <jbernard> #topic volume backup bug
15:27:05 <jbernard> mhen, Luzi: that's you
15:27:15 <jbernard> #link https://bugs.launchpad.net/cinder/+bug/2086683
15:27:43 <Luzi> yeah mhen found this bug
15:27:55 <jbernard> oy, that's not awesome :/
15:28:11 <Luzi> when there is no volume backup service configured, it is still possible to create a volume backup
15:28:20 <Luzi> that will end up in error state of course
15:28:33 <Luzi> and non-admin users are not able to delete this resource
15:29:12 <Luzi> we wanted to make you aware of this.
15:29:18 <jbernard> thanks
15:29:47 <Luzi> unfortunately i cannot tell any more than that - mhen should be there soon, but he has a conflicting meeting
15:30:05 <Luzi> it would be nice to catch this on API level
15:30:25 <jbernard> whoami-rajat: ^ i would think the api should fail if the necessary service is non-existant
15:30:52 <rosmaita> looks like we don't do any kind of testing of backups when the service is disabled or absent
15:31:52 <jbernard> our voting jobs have it enabled, i guess it makes some sense that we haven't seen this
15:32:33 <Luzi> mhen is now here, and i need to go - if there are any questions
15:32:47 <mhen> o/
15:32:53 <jbernard> mhen: heya
15:33:12 <jbernard> we need a sanity check in the api logic
15:35:17 <jbernard> i think the report is clear, so everything needed to work on this one is present
15:35:44 <jbernard> #topic multi-transport protocol volume driver support
15:35:47 <jbernard> sp-bmilanov:
15:35:57 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/847536
15:35:59 <mhen> I think checks like these need to be used in more places: https://github.com/openstack/cinder/blob/75b478b7819168a301ec8927a4a4113b000587de/cinder/backup/api.py#L155-L167
15:36:44 <sp-bmilanov> ah, hi, was just going to say that I have to go soon, but the short version is that there are cases where we would like to handle both iSCSI and the StorPool block protocol with one driver
15:37:02 <jbernard> mhen: i made a note in the etherpad
15:37:08 <jbernard> mhen: agree
15:37:31 <sp-bmilanov> in setups where there are hypervisors connect by different protocols, but they'd want the same volume
15:38:31 <sp-bmilanov> there might be a way to do this currently, but I couldn't figure it out, and I suspect that would be a change in the core to allow drivers to do this properly
15:39:49 <jbernard> sp-bmilanov: in the call to attach(), is the metadata needed to determine which of possible protocols to use present?
15:40:44 <sp-bmilanov> I need to double check, but it should
15:41:23 <sp-bmilanov> (for reference, the proposed change currently does this in cinder, not os-brick: https://review.opendev.org/c/openstack/cinder/+/847536)
15:41:40 <sp-bmilanov> sorry, I have to go, can I add this topic for next week as well?
15:41:50 <jbernard> sure
15:42:07 <sp-bmilanov> thanks!
15:43:07 <jbernard> #topic review requests
15:43:22 <jbernard> Luzi has a cople for volume type metadata
15:43:29 <jbernard> this is important for epoxy:
15:43:38 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/918316
15:43:40 <jbernard> and
15:43:45 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/928794
15:44:38 <rosmaita> btw, epoxy milestone 1 is next week
15:44:57 <jbernard> good grief
15:45:33 <jbernard> hitachi has one
15:45:41 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/892616
15:45:48 <jbernard> we agreed at the ptg to pin mypy
15:45:54 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/932636
15:46:05 <jbernard> and there's a netapp bug
15:46:12 <jbernard> #link https://bugs.launchpad.net/cinder/+bug/2084117
15:46:28 <jbernard> which isn't a code review, but rather a bug comment request
15:46:45 <jbernard> manudinesh: ^ do you have more to add for that one?
15:48:44 <jbernard> #topic open discussion
15:48:44 <manudinesh> We downloaded it from official site and tested and faced this error...wanted to know from NetApp Cinder team if there is fix coming on these lines
15:50:13 <jbernard> im not sure if anyone is watching from netapp, but im reasonably certain they will see and respond to this one
15:50:24 <manudinesh> VM deployment fails if it is vSCSI based connectivity group but VM deploys are successful for NPIV based connection ...
15:50:46 <manudinesh> sure jbernard, Thank you ..
15:51:21 <jbernard> manudinesh: ill add it to next week's agenda too
15:51:31 <manudinesh> Thank you
15:52:35 <jbernard> anything else?
15:53:11 <rosmaita> looks like the requirements-check job is suddenly failing on all patches
15:53:17 <jbernard> fun
15:53:24 <rosmaita> not our fault ... looks like an issue with ubuntu-noble
15:54:00 <jbernard> ok
15:54:20 <jbernard> thanks everyone, see you next week at the normal 14:00 time
15:54:24 <jbernard> #endmeeting