14:01:12 <jbernard> #startmeeting cinder
14:01:12 <opendevmeet> Meeting started Wed Mar  5 14:01:12 2025 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:12 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:12 <opendevmeet> The meeting name has been set to 'cinder'
14:01:16 <jbernard> #topic roll call
14:01:18 <jbernard> o/
14:01:20 <sfernand> hi
14:01:20 <msaravan> Hi
14:01:25 <jbernard> #link https://etherpad.opendev.org/p/cinder-epoxy-meetings
14:01:28 <rosmaita> o/
14:01:29 <jungleboyj> o/
14:01:33 <simondodsley> o/
14:01:35 <akawai> o/
14:02:24 <Luzi> o/
14:02:27 <tosky> o/
14:05:09 <jbernard> welcome everyone
14:05:37 <jbernard> we are fast approaching the release of epoxy
14:05:53 <jbernard> many patches have merged, but there is still quite a bit to do
14:06:08 <jbernard> if you have review cycles, that is definately the best way to help out this week
14:06:44 <jbernard> i think it's possible for a freeze exception for the image encryption patch
14:06:46 <jbernard> #link https://review.opendev.org/c/openstack/cinder/+/926298
14:06:55 <jbernard> but additional reviews are needed
14:07:55 <jbernard> #topic state of os-brick ci
14:08:05 <jbernard> i think rajat is away right now
14:08:38 <jbernard> but he raises a valid point on the state of CI for os-brick (and likely the others, including cinder)
14:09:08 <simondodsley> We discussed os-brick on 3rd party about a year ago and we made it mandatory for new drivers to check os-brick, but we didn't mandate it for existing CIs
14:09:22 <simondodsley> maybe that mandate should be issued
14:10:29 <jbernard> yeah, i think that it's important to push for healthy CI reporting
14:10:42 <rosmaita> yes, it's really a self-protection thing, because the cinder CIs only use released os-brick ... if you want to know if something will break you early, you need to check brick pre-release
14:10:55 <jbernard> it's an important way for use to have confidence in the quality of our patches taken as a whole
14:11:59 <jbernard> so i think we (mostly likely me :) ) need some kind of audit to determine the current state of CIs, which ones are reporting and not, and which ones are providing results that can be trusted
14:12:42 <jbernard> once we have that understanding, the next question would be how to address the deficit
14:12:52 <simondodsley> related to this the Pure CI is struggling to report the location of the logs since we upgraded to SoftwareFactory and a newer version of Zuul. Does anyone who maintains a CI that is reporting the URL correctly have time to discuss, offline, your Zuul config?
14:16:12 <rosmaita> simondodsley: is it a consistent incorrectness, i.e., can you leave a note on the meeting agenda telling reviewers how to find the log from the incorrect url?
14:17:31 <simondodsley> rosmaita: it is cnsisttent. The incorrect URL points to our internal log location, rather than the uploaded public location. They are very different
14:17:46 <rosmaita> ok
14:20:27 <jbernard> #action jbernard to do (or coordinate) a CI audit to determine current state
14:20:41 <jbernard> #topic open discussion
14:21:05 <jbernard> that's all for defined topics, we can use the remaining time for whatever is needed
14:21:23 <jbernard> Simon has several patches up that need another core review
14:21:28 <rosmaita> jbernard: i don't know if jungleboyj has any time, but he was always the best at doing the CI audits
14:22:00 <jungleboyj> Lol.
14:22:04 <rosmaita> maybe he can help you out
14:22:09 <simondodsley> isn't there a report that runs to show CI status? Seem to remember that
14:22:16 <jungleboyj> simondodsley:  Yes.
14:22:19 <jbernard> #action jungleboyj to do a full and comprehensive audit of CIs, including TPS reports.
14:22:28 <jungleboyj> Let me see if that is still out there.
14:22:30 <jbernard> :)
14:22:41 <rosmaita> yes, the can't have it both ways thing
14:23:05 <jungleboyj> http://cinderstats.ivehearditbothways.com/cireport.txt
14:23:07 <jbernard> wasn't that a sean thing?
14:23:18 <jungleboyj> Yeah, Sean's system looks like it is still running.
14:23:21 <simondodsley> yes - but it only covers cinder, not os-brick
14:23:38 <rosmaita> i wonder how smcginnis is set for free time?
14:24:09 <jungleboyj> I can say that my free time is extremely limited right now.
14:24:37 <simondodsley> that report fails to show Pure even though it is reporting well. Must be a confg thing
14:25:00 <jbernard> for the F release cycle, i plan to spend some time cleaning out the set of oldest reviews lingering in gerrit, i can add this to that set
14:32:44 <jbernard> im back, my machine crashed
14:33:24 <jbernard> i dont see anything in my backlog, should we end things for today?
14:34:29 <jungleboyj> Works for me.  It went quiet when you dropped.
14:34:43 <jbernard> ok, sounds good to me
14:34:46 <jbernard> thank you everyone
14:34:50 <jbernard> #endmeeting