14:01:54 <jbernard> #startmeeting cinder
14:01:54 <opendevmeet> Meeting started Wed Apr  2 14:01:54 2025 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:54 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:54 <opendevmeet> The meeting name has been set to 'cinder'
14:02:01 <msaravan> hi
14:02:03 <jbernard> #topic roll call
14:02:04 <jungleboyj> o/
14:02:05 <jbernard> o/
14:02:05 <simondodsley> o/
14:02:06 <rosmaita> o/
14:02:08 <agalica> hi
14:02:09 <keerthivasansuresh> o/
14:02:12 <jbernard> #link https://etherpad.opendev.org/p/cinder-flamingo-meetings
14:02:15 <agalica> o/
14:02:18 <jbernard> ^ new etherpad for this cycle
14:02:29 <hvlcchao1> o/
14:02:36 <sfernand> hi
14:02:38 <whoami-rajat_> Hi
14:02:43 <hvlcchao1> hi
14:02:54 <tosky_> hi
14:05:04 <eharney> o/
14:07:30 <jbernard> welcome everyone
14:07:40 <jbernard> #topic annoucements
14:07:56 <jbernard> 2025.1 epoxy is done
14:08:08 <jbernard> i would like to thank everyone that contributed
14:08:26 <jbernard> and helped make it a good release
14:08:43 <jbernard> special thanks to rosmaita, our release liason, for managing all of the hashes
14:08:50 <whoami-rajat> \o/
14:09:01 <rosmaita> almost messed up the last one!
14:09:07 <jungleboyj> ++
14:09:39 <sfernand> rosmaita: ++
14:11:30 <jbernard> as a quick aside, i really enjoy working with everyone on this team, it's been a great experience
14:11:50 <jbernard> we now begin the 2025.2 (Flamingo) cycle
14:12:00 <jbernard> the PTG is next week
14:12:00 <simondodsley> thanks for your leadership over this past cycle as well
14:12:42 <jungleboyj> Agreed.  Thank you jbernard !
14:12:57 <jbernard> re the PTG, we have one pressing item:
14:13:04 <whoami-rajat> thanks jbernard, great to have you as PTL!
14:13:13 <jbernard> nova and neutron would like to have a cross-project discussion
14:13:19 <jbernard> #link https://bugs.launchpad.net/neutron/+bug/2102184
14:15:14 <simondodsley> i'm all for dynamic storage QoS changes on frontend QoS
14:15:45 <jbernard> currently, there is a 1h slot on wednesday at 1400
14:15:56 <jbernard> for glance/cinder/nova
14:16:10 <jbernard> and another on Thursday, 1300 (1h)
14:16:19 <jbernard> for neutron/cinder/nova
14:16:28 <jbernard> i just want to make sure that works for everyone
14:16:36 <simondodsley> what TZ is that?
14:16:41 <jbernard> those are UTC
14:17:00 <jbernard> 1300 is 9am EDT (for reference)
14:17:37 <simondodsley> Wednesady is OK for me
14:17:41 <jbernard> ack
14:18:07 <simondodsley> is there a link to the Cinder PTG schedule?
14:18:11 <jbernard> does anyone need/want to be present for those discussion that has a conflict?
14:19:02 <jbernard> #link https://etherpad.opendev.org/p/apr2025-ptg-cinder
14:19:04 <jbernard> simondodsley: ^
14:19:49 <jbernard> last call for cross-project conflicts
14:20:25 <jbernard> ok
14:20:32 <whoami-rajat> i remember there was going to be a cross project for new location APIs
14:20:36 <whoami-rajat> need to check the date/time for that
14:20:57 <jbernard> that may be a topic for the already scheduled slot, i need to check on that
14:21:11 <jbernard> #action check on location API cross-project topic
14:22:22 <whoami-rajat> thanks
14:22:38 <jbernard> ok, great
14:23:05 <jbernard> ill send a mail this week with finalized time slots for us, but I expect it to match previous years
14:23:48 <jbernard> #topic cli coverage (simon)
14:24:10 <simondodsley> ok - this may be covered in the upcoming PTG topic.
14:24:40 <simondodsley> I was wondering specifically about cinder manage and unmange which don't seem to have an openstack cli equivalent
14:24:48 <jbernard> rosmaita: i have another meeting in 6 minutes, can you wrap us up when the discussion concludes?
14:24:55 <whoami-rajat> simondodsley, i remember adding them
14:25:03 <simondodsley> what are they then?
14:25:08 <rosmaita> jbernard: will do
14:25:14 <jbernard> rosmaita: thanks
14:26:03 <whoami-rajat> manage: https://review.opendev.org/c/openstack/python-openstackclient/+/895214/9
14:26:06 <whoami-rajat> unmanage: https://review.opendev.org/c/openstack/python-openstackclient/+/919820/5
14:26:52 <whoami-rajat> the convention is pretty odd but that's how OSC team wants it to be
14:26:59 <rosmaita> jbernard: i think you may need to #chair me or i won't be able to end the meeting
14:27:16 <simondodsley> ok - that's why i couldn't find them...
14:27:18 <jbernard> #chair
14:27:18 <opendevmeet> Current chairs: jbernard
14:27:23 <jbernard> #chair rosmaita
14:27:23 <opendevmeet> Current chairs: jbernard rosmaita
14:27:30 <rosmaita> \o/
14:28:32 <simondodsley> thanks whoami-rajat
14:29:12 <simondodsley> I guess I can move on to the second topic which is also mine...
14:29:16 <whoami-rajat> simondodsley, np, last i checked, OSC should be in parity with cinderclient but do let me know if we missed any commands
14:29:42 <simondodsley> so the second topic is more of a question....
14:30:43 <simondodsley> has anyone seen strange behavioural differences between caracal and epoxy with multipath not connecting to all targets on a backend (iSCSI specifically) even though os-brick isbeing passed multiple targets but only connects to 1?
14:31:21 <simondodsley> i've had a couple of anecdotal reports of this
14:31:52 <simondodsley> config files are the same for both nova and cinder in both versions
14:32:20 <simondodsley> if this is true, it is a worrying potential os-brick regression
14:35:04 <msaravan> Yes, we saw that when there are multiple targets, they are not connecting to all.
14:35:05 <whoami-rajat> simondodsley, do you mean in epoxy deployment, multipathing is enabled with multiple targets but there is only single path visible under the mpath device?
14:35:48 <simondodsley> correct
14:36:27 <simondodsley> it looks like os-brick stops connecting after the fist target connects
14:36:40 <simondodsley> i haven't seen it myself, so this is all second-hand
14:37:33 <simondodsley> the logs show 4 ip addresses being sent to os-brick but it only connects to one of them
14:37:47 <whoami-rajat> ack, would be good to have it reported in a bug with debug logs, as i remember, the iSCSI portals are connected in parallel in different threads
14:37:58 <simondodsley> i'm asking for that bug report to be raised
14:38:16 <whoami-rajat> so even though if one connection is made, other connect calls still execute
14:38:53 <simondodsley> is that parallelism new or was it always like that?
14:38:54 <whoami-rajat> https://github.com/openstack/os-brick/blob/master/os_brick/initiator/connectors/iscsi.py#L751-L754
14:39:01 <whoami-rajat> always like this
14:40:28 <simondodsley> i'll make sure the bug report is filed.
14:40:32 <simondodsley> Subject over - thanks
14:41:08 <whoami-rajat> thanks for raising this -- sounds pretty bad if it turns out to be an actual issue
14:43:33 <rosmaita> ok, that's all that was on the agenda
14:43:38 <rosmaita> #topic open discussion
14:44:33 <rosmaita> watch for jbernard's email about PTG scheduling
14:45:21 <rosmaita> he said it will be similar to previous PTGs, so probably tuesday-thursday with friday open for followup topics
14:45:45 <rosmaita> but make sure you check your email monday morning in case i'm wrong about that and we are meeting on monday
14:46:52 <rosmaita> anyone else have anything to say?
14:47:18 <jungleboyj> Sounds good.
14:48:15 <rosmaita> ok, let's close this up ... happy Epoxy day everyone!
14:48:23 <rosmaita> #endmeeting