14:08:18 <jbernard> #startmeeting cinder
14:08:18 <opendevmeet> Meeting started Wed Jun 25 14:08:18 2025 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:18 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:08:18 <opendevmeet> The meeting name has been set to 'cinder'
14:08:24 <jbernard> #topic roll call
14:08:26 <jbernard> o/
14:08:31 <hvlcchao1> o/
14:08:38 <raghavendrat> hi
14:08:40 <gireesh> hi
14:08:43 <rosmaita> 0/
14:08:43 <sfernand> hi
14:08:55 * fungi added something to the agenda a few moments ago
14:09:08 <tosky> o/
14:09:26 <skryhin_> o/
14:09:35 <agamboa> o/
14:09:52 <sp-bmilanov> o/
14:11:36 <jbernard> ok, welcome everyone
14:11:47 <jayaanand_> o/
14:12:08 <jbernard> #topic followup / barbican patches blocking stable/2025.1
14:12:42 <jbernard> raghavendrat, rosmaita: ^ it looks like we're still waiting for them to merge the requisite patches
14:13:06 <raghavendrat> yes, second +2 is required
14:13:27 <Sai> o/
14:13:49 <rosmaita> i pinged doug, he is going to follow up on getting someone else to review those patches
14:14:46 <jbernard> is there anything we can do, or just wait for them to follow up?
14:14:56 <jbernard> rosmaita: thanks
14:16:32 <raghavendrat> couple of days ago, i requested for review on the same in IRC chat barbican channel. mharley did acknowledge it
14:17:57 <jbernard> we could mark the job as non-voting if this doesn't get resolved soon
14:18:13 <gireesh> hi core reviews, I also need +2 for my patch https://review.opendev.org/c/openstack/cinder/+/951485
14:18:15 <jbernard> that would be an alternative, i realize it's less desirable
14:20:20 <jbernard> rosmaita: ^ what are your thoughts? is it resonable to set a deadline? i don't want this to be out there indefinately
14:21:03 <jayaanand_> i have multiple PRs need your attention https://review.opendev.org/c/openstack/cinder/+/928486
14:21:12 <jayaanand_> https://review.opendev.org/c/openstack/cinder/+/944964
14:21:19 <jayaanand_> https://review.opendev.org/c/openstack/cinder/+/952900
14:21:46 <rosmaita> jbernard: well, we'd only have to make it non-voting for stable/2025.1 , so maybe that wouldn't be too bad
14:21:58 <rosmaita> gireesh: jayaanand_: please stay on topic
14:22:12 <gireesh> sure
14:22:36 <jayaanand_> ok
14:22:37 <rosmaita> i think we give them a day or so, and then go to the mailing list saying we're making the job non-voting
14:22:53 <rosmaita> to hopefully shame them into action
14:22:54 <jbernard> gireesh, jayaanand_: ack, if you can put them on the etherpad, that would help, htey're on my list but im completey swamped with downstream tasks this week, so my responses will be delayed quyite a bit i expect
14:23:16 <jbernard> rosmaita: agree
14:23:34 <raghavendrat> thanks Brian & Jon. that would help
14:24:25 <jbernard> #action consider marking barbican job non-voting if no progress this week
14:24:55 <Sai> Sorry to pitch in, I also need reviews for this patch Jon: https://review.opendev.org/c/openstack/cinder/+/952904
14:25:11 <jbernard> Sai: yes, see my reponse above
14:25:57 <jbernard> #topic pep8 tests are failing stable/2025.1
14:26:02 <jbernard> raghavendrat: ^
14:26:13 <Sai> > Sai: yes, see my reponse above
14:26:13 <Sai> Sure Jon, I am looking for the etherpad to update. Thanks.
14:26:26 <jbernard> np
14:26:43 <jbernard> rosmaita: it looks like eric agreed with your comment on that patch
14:26:45 <jbernard> https://review.opendev.org/c/openstack/cinder/+/952862
14:27:55 <raghavendrat> It looks like this patch 952862 is also dependent on barbican patch in Epoxy
14:29:09 <rosmaita> everything is!
14:29:33 <rosmaita> nothing can merge to stable/2025.1 until the barbican thing is resolved
14:31:26 <jbernard> oy
14:31:34 <jbernard> ok, 24 hours then
14:35:36 <sp-bmilanov> did I disconnect or did it get a bit quiet? :)
14:36:04 <jbernard> #topic listing volumes via poilcy adjustments
14:36:07 <jbernard> skryhin_: ^
14:37:16 <skryhin_> hi, I previously mentioned this request in mailing list. we need to provide 3rd party tools/cmdb access to list all volumes using non-admin user.
14:39:41 <jbernard> skryhin_: ok, can you provide more context? how can we help?
14:41:40 <jbernard> while we're waiting, fungi, what are teh struggles?
14:41:44 <fungi> just a quick revisit of something i mentioned in #openstack-cinder earlier today, the macrosan ci operator seems like they could use some guidance on adding their system's details to the wiki, they keep replacing the template and index on the main page rather than creating a new page and adding it to the index table
14:42:10 <fungi> i've had to roll back their wiki edits tice in recent months to restore the page
14:42:16 <fungi> er, twice
14:42:23 <jbernard> ok, are they present now?
14:42:37 <fungi> i have no idea, probably not
14:42:50 <jbernard> fungi: how big are the changes? they know there's a preview before publish, right?
14:43:12 <jbernard> fungi: also, thanks for the rollbacks
14:43:18 <fungi> i'd just rather not block their account, if someone on the cinder team has time to help them out instead
14:44:07 <fungi> there is a preview feature, i think they're just misunderstanding/misreading the instructions since they've done it twice now
14:44:19 <jbernard> fungi: sure, can they send me the changes?
14:44:56 <jbernard> fungi: if i can get a diff, it shouldn't be too hard to do it once
14:44:58 <skryhin_> currently, when a user with the SystemReader role attempts to use the all_tenants filter (e.g., via openstack volume list --all-projects), the request is blocked. we observe this occurring at the Cinder API layer, specifically within the remove_invalid_filter_options logic (reference: https://github.com/openstack/cinder/blob/stable/2024.1/cinder/volume/api.py#L667-L674). this prevents SystemReader from obtaining a system-wide view of vol
14:44:58 <skryhin_> umes. Other OpenStack services, such as Nova, Keystone, and Neutron, have successfully implemented mechanisms or policy adjustments to allow a SystemReader role (when appropriately scoped) to access system-wide lists of resources without requiring full administrative privileges. for instance, Nova enables this for servers via the `os_compute_api:servers:index:get_all_tenants` policy for the SystemReader role. it would be highly beneficia
14:44:58 <skryhin_> l if Cinder could adopt a similar logic or adapt its policy for `volume:get_all_tenants_filter`
14:45:13 <fungi> jbernard: the changes can be found in the wiki page history, or the link of their edits list i included in the agenda
14:45:59 <skryhin_> jbernard: ok, can you provide more context? how can we help? - yes, please see above. thank you
14:47:11 <skryhin_> in short: we want to provide access to read the info about all volumes on the cloud for non-admin role by adjusting policy.
14:48:00 <jbernard> fungi: ok
14:48:28 <jbernard> #action macrosan wiki update
14:49:37 <fungi> thanks!
14:51:04 <rosmaita> skryhin_: have you looked at https://docs.openstack.org/cinder/latest/configuration/block-storage/policy-config-HOWTO.html#example-configuring-a-read-only-administrator
14:53:44 <agamboa> Hey rosmaita, could you take another look at this patch: https://review.opendev.org/c/openstack/cinder/+/901318 ? We updated the release notes with your improvements
14:54:36 <skryhin_> rosmaita: hm, sorry, not yet. I'll check it. thank you
14:55:52 <rosmaita> skryhin_: np ... i know we have too much reliance on admin context in our db layer, but i'm personally afraid to refactor it out of there until we have better test coverage
14:57:05 <harsh> Hi.. Sorry for jumping in but we only have 4 mins left here. I have a doubt regarding the patch : [IBM SVf driver] Adding support for callhome plugin | https://review.opendev.org/c/openstack/cinder/+/951829 . We enabled the feature of callhome on the IBM SVf driver to know how many customers are using the IBM storage with openstack.
14:57:09 <harsh> But as this is a feature, we can't backport it to the older release. So we are wondering if there is something that can be done to backport this patch to atleast Antelope release ?
14:57:18 <rosmaita> agamboa: i think i already have a +2 on https://review.opendev.org/c/openstack/cinder/+/901318 ... were you thinking of a different patch
14:57:33 <skryhin_> rosmaita: I understand that this is quite a sensitive topic. thanks again
14:59:21 <rosmaita> harsh: Antelope is in 'unmaintained' status, so we (the cinder team) doesn't do any backports to it ... but there is an unmaintained core team, you could ask them if they would be more lenient
15:00:01 <agamboa> rosmaita: oh, got it, thanks. Can I mark the comment resolved? Sorry, still new to gerrit, wasn't sure if I should let you resolve it
15:00:09 <harsh> Can we backport a feature ?
15:01:03 <harsh> if the unmaintanied core team won't allow, can we backport it to Bobcat realease ?
15:01:04 <rosmaita> harsh: usually not, unless it's security related
15:01:37 <rosmaita> harsh: stable/bobcat was deleted a month or so ago, the farthest you can backport is caracal
15:01:59 <harsh> ok thanks rosmaita :)
15:02:37 <harsh> I will let my team know and see if caracal is okay or not. if not, will get in touch with the unmaintained core team.
15:03:02 <jbernard> ok, we're over time, last call everyone
15:03:26 <rosmaita> well, the unmaintained policy is that it's got to be in all the more recent branches before it will be accepted into unmaintained
15:04:41 <jbernard> #endmeeting