14:04:06 <jbernard> #startmeeting cinder
14:04:06 <opendevmeet> Meeting started Wed Jul  2 14:04:06 2025 UTC and is due to finish in 60 minutes.  The chair is jbernard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:06 <opendevmeet> The meeting name has been set to 'cinder'
14:04:12 <simondodsley> o/
14:04:13 <jbernard> #topic roll call
14:04:15 <jbernard> o/
14:04:17 <hvlcchao1> o/
14:04:18 <rosmaita> o/
14:04:20 <jbernard> #link https://etherpad.opendev.org/p/cinder-flamingo-meetings
14:04:34 <sp-bmilanov> o/
14:05:21 <sfernand> hi
14:05:49 <Sai> o/
14:09:44 <jbernard> welcome everyone
14:10:16 <jbernard> #annoucements
14:10:35 <jbernard> all new commits need a 'signed-off-by' field in teh commit message
14:10:45 <jbernard> this is done by adding the '-s' flag to git-commit
14:11:00 <jbernard> #link https://docs.openstack.org/contributors/common/dco.html
14:11:05 <jbernard> rosmaita: ^ anything to add
14:11:54 <rosmaita> not really, i am not sure about the status of automated checking, so core reviewers may need to check for a while
14:12:27 <simondodsley> i just used it this morning
14:12:34 <gireesh> hi
14:13:22 <jbernard> rosmaita: do we know if patches will fail gate if it's not present?
14:13:51 <rosmaita> not sure, because it is only required for changes after 30 June
14:14:13 <rosmaita> so a June patch with no changes that is approved today doesn't need to have it
14:14:32 <jbernard> ok
14:15:07 <sp-bmilanov1> I seem to have been disconnected for ~10 minutes, are we still on the "Signed-off-by" topic? I just hit something that might be of interest
14:15:22 <jbernard> sp-bmilanov1: yep
14:15:22 <rosmaita> we are, go ahead
14:16:15 <sp-bmilanov1> nice, so, I wanted to cherry-pick some changes to stable/2024.1 and I can't do it from the Gerrit UI because of this new requirement.. I can do it via git's CLI though
14:16:36 <jbernard> fun
14:17:00 <sp-bmilanov1> but it seems better to do it via Gerrit's UI since it tracks it a bit more with the "cherry pick of" row in the UI
14:17:45 <jbernard> sp-bmilanov1: you could raise this issue with the infra team, maybe they're aware already
14:18:09 <sp-bmilanov1> will do, thanks
14:18:24 <rosmaita> but also, if you 'git cherry-pick -x <hash>' locally, you get the cherry-picked-from line in the commit message
14:18:58 * sp-bmilanov1 is testing it out right now
14:21:02 <sp-bmilanov1> https://review.opendev.org/c/openstack/cinder/+/953958 I guess that's good enough until infra figure it out
14:23:05 <jbernard> #topic followup
14:23:22 <jbernard> we have had some gate issues in recent weeks
14:23:33 <jbernard> i /think/ most of those issues have been resolved
14:23:40 <jbernard> rosmaita: ^ can you confirm?
14:23:54 <jbernard> pep8 and barbican patches have landed
14:24:49 <hemna> mep
14:24:50 <rosmaita> i need to check
14:26:15 <rosmaita> looks like pep8 is back in shape through 2024.1 (Caracal): https://zuul.opendev.org/t/openstack/builds?job_name=openstack-tox-pep8&project=openstack/cinder
14:26:34 <hemna> rosmaita something else seems busted though ? https://zuul.opendev.org/t/openstack/build/d65450201076455dab6328c4125af6ec
14:27:17 <rosmaita> and barbican seems ok through caracal, also: https://zuul.opendev.org/t/openstack/builds?job_name=cinder-tempest-plugin-lvm-lio-barbican&project=openstack/cinder
14:27:21 <rosmaita> hemna: looking
14:27:56 <rosmaita> hemna: i think there was some discussion about that in the glance channel recently
14:28:27 <hemna> ok.  any ideas / resolution yet?
14:29:03 <rosmaita> not sure, reading now: https://meetings.opendev.org/irclogs/%23openstack-glance/%23openstack-glance.2025-07-01.log.html#openstack-glance.2025-07-01.log.html#t2025-07-01T17:37:07
14:29:09 <hemna> ok ty
14:31:59 <rosmaita> hemna: sounds like it may be fixed now? go ahead and give your patch a recheck and let's see what happens
14:32:11 <hemna> ok will do
14:33:44 <jbernard> #topic sdk, missing cinder/volume commands
14:33:46 <jbernard> simondodsley: ^
14:33:54 <simondodsley> whilst working on some openstack ansible modules i noticed a bunch of cinder/volume commands do not seem to be represented in the SDK. Who can look at getting these added? Mainly around qos specs, but a few other as well. I have a link to an etherpad with a list in the meeting etherpad.
14:35:47 <jbernard> simondodsley: is that list comprehensive, or just the one's you noticed?
14:36:16 <jbernard> i know rajat has spent time on the sdk/client
14:36:24 <simondodsley> just what ive noticed, although i think i t is pretty comprehensive
14:36:38 <jbernard> #link https://etherpad.opendev.org/p/cinder-openstacksdk-gaps
14:37:25 <simondodsley> i'm stuck creating new cinder ansible modules without these SDK entries. I can use http methods to do it but that is very untidy
14:37:38 <jbernard> yeah..
14:37:57 <jbernard> #action current sdk state, what to do about missing commands
14:38:35 <jbernard> simondodsley: i dont have a quick answer, but i should have a better understanding before next meeting
14:38:44 <simondodsley> ok- thanks
14:38:51 <jbernard> are you volunteering? :)
14:39:14 <simondodsley> not really - i took a look at the sdk code and didn't understand it
14:40:14 <jbernard> ill try to have a better answer by next meeting
14:41:18 <simondodsley> 👌
14:41:20 <jbernard> unrelated, i did reach out to macrosan about their wiki updates, haven't gotten a response yet (related to fungi's topic last meeting)
14:41:47 <jbernard> #topic open discussion
14:42:03 <simondodsley> what is the state of reviews from cores?
14:43:25 * sp-bmilanov1 just got back from #openstack-infra, the Signed-off-by issue with backporting is known and present in the announcement in the ML -- https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/KGEKDH3AKRM3CKQW7SEVVVQFV2X6OCF6/
14:45:44 <jbernard> simondodsley: we need more
14:46:06 <simondodsley> cores or reviews???
14:46:10 <jbernard> yes
14:46:20 <simondodsley> there are a lot of patches out there outstanding for some time
14:46:26 <rosmaita> sp-bmilanov1: ok, so you *can* use the gerrit web UI to backport, but you need to manually add the signed-off-by line to the commit message
14:47:46 <fungi> i haven't tested that, but does it give you a chance to use the webui editor between starting the backport and creating the change?
14:48:03 <fungi> i guess it pulls up a commit message editor at the time you click the backport button?
14:49:45 <rosmaita> yes, there is a "cherry pick change to another branch" dialog box
14:49:55 <rosmaita> it has a "cherry pick commit message"
14:50:26 <rosmaita> so you could add the signed-off-by line in there if needed
14:56:35 <jbernard> ok, last call
14:56:45 <sp-bmilanov1> ugh, I completely missed that, thanks all!
14:58:31 <jbernard> alright, thank you everyone
14:58:35 <jbernard> #endmeeting